Службы Reporting Services в SQL Server Data Tools (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) — это среда MicrosoftMicrosoft Visual StudioVisual Studio для создания решений бизнес-аналитики.is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. SSDT содержит среду разработки, (конструктор отчетов), в которой можно открывать, изменять, просматривать, сохранять и развертывать определения отчетов Службы Reporting ServicesReporting Services с разбивкой на страницы, общие источники данных, общие наборы данных и элементы отчетов.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Службы Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) не входит в SQL Server.is not included with SQL Server. Скачать SQL Server Data Tools.Download SQL Server Data Tools.

В этом разделе описываются решения, проекты, шаблоны проектов и конфигурации служб SQL Server Data ToolsSQL Server Data Tools для Службы Reporting ServicesReporting Services, а также представления, меню, панели инструментов и сочетания клавиш, которые можно использовать в конструкторе отчетов.This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Службы Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

Чтобы приступить к разработке отчетов, см. раздел Разработка отчетов с использованием конструктора отчетов (SSRS).To get started designing reports, see Design Reports with Report Designer (SSRS).

Решения и проектыSolutions and Projects

Проект отчета выступает в качестве контейнера для определений отчета и ресурсов.A report project acts as a container for report definitions and resources. Когда проект развернут, каждый файл проекта отчета публикуется на сервере отчетов.Every file in the report project is published to the report server when the project is deployed. При первом создании проекта также создается решение в качестве контейнера для проекта.When you create a project for the first time, a solution is also created as a container for the project. К одному решению можно добавить несколько проектов.You can add multiple projects to a single solution.

КонфигурацииConfigurations

Чтобы создать несколько наборов свойств проекта для различных вариантов развертывания, например для тестового и рабочего серверов отчетов предприятия, следует использовать диспетчер конфигурации.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. Дополнительные сведения см. в разделе Развертывание и поддержка версий в SQL Server Data Tools (службы SSRS).For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

Проекты «Сервер отчетов»Report Server Projects

После установки служб Службы Reporting ServicesReporting Servicesв среде SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)становятся доступны следующие шаблоны проектов.When you install Службы Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):

  • Проект сервера отчетов.Report Server Project. При выборе проекта сервера отчетов открывается конструктор отчетов.When you select a Report Server Project, Report Designer opens. Проект сервера отчетов — это шаблон проекта бизнес-аналитики, установленный в среде Visual StudioVisual Studio и доступный в диалоговом окне Создание проекта .A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. Дополнительные сведения см. в разделе Добавление в проект отчета нового или существующего отчета (службы SSRS). Свойства проекта сервера отчетов относятся ко всем отчетам и общим источникам данных проекта среды SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) project. В число этих свойств входит URL-адрес сервера отчетов и имена папок для отчетов и общих источников данных.These properties include the URL for the report server and the folder names for reports and shared data sources. Текущие значения свойств можно просмотреть с помощью диалогового окна Страницы свойств проекта .Use the Project Property Pages dialog box to view the current property values. Чтобы открыть это диалоговое окно, в меню Проект выберите Свойства.To open this dialog box, on the Project menu, click Properties.

  • Мастер проекта сервера отчетов.Report Server Project Wizard. При выборе проекта мастера сервера отчетов автоматически создается проект сервера отчетов и открывается мастер отчетов.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. Отчеты можно создавать с помощью мастера. Для этого необходимо выполнять инструкции на каждой странице: создается строка подключения с источником данных, указываются учетные данные для соединения с ним, создается запрос, добавляются области данных таблицы или матрицы, задаются данные отчета и групп, выбирается цвет шрифта и стиля, отчет публикуется на сервере отчетов и просматривается в локальном режиме.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. После создания отчета с помощью мастера можно изменить данные и структуру отчета с помощью конструктора отчетов в проекте сервера отчетов.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

Новые шаблоны проекта в SSDTNew Project templates in SSDT

Окна и панели конструктора отчетовReport Designer Windows and Panes

Конструктор отчетов поддерживает два представления: Конструктор, в котором задаются данные и макет отчета, и Просмотр, позволяющее просмотреть подготовленный отчет.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the report. В каждом представлении можно вывести несколько окон для удобства конструирования или просмотра отчета.In each view, you can display multiple windows to help you design or view a rendered report.

Область данных отчетаReport Data Pane

В области данных отчета отображаются встроенные поля, источники данных, наборы данных, коллекции полей, параметры отчетов и изображения.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

Область данных отчета используется для просмотра следующих элементов.Use the Report Data pane to view:

  • Встроенные поля . Стандартные данные отчета, например имя отчета и время его обработки.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • Источники данных . Источник данных — это имя источника данных и подключение к нему.Data sources A data source represents a name and connection to a source of data.

  • Наборы данных . Каждый набор данных включает запрос, указывающий, какие данные нужно получить из источника данных.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. Раскройте набор данных, чтобы просмотреть коллекции полей, определенные запросом к набору данных.Expand the dataset to view the collection of fields specified by the dataset query.

    В некоторых конструкторах запросов для многомерных наборов данных на панели «Фильтры» можно задать фильтры и указать, следует ли создавать параметры отчета.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. Если указать параметр отчета, автоматически создается специальный набор данных для заполнения списка допустимых значений параметра.If you specify the report parameter option, a special dataset is automatically created to populate the parameter's valid values list. По умолчанию этот набор данных не отображается в области данных отчета.By default, the dataset does not appear in the Report Data Pane. Дополнительные сведения см. в разделе Отображение скрытых наборов данных для значений параметра в многомерных данных (построитель отчетов и службы SSRS).For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • Параметры отчета . Список параметров отчета.Report parameters The list of report parameters. Параметры могут быть созданы вручную или автоматически, если запрос к набору данных включает параметры запроса.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • Изображения . Список доступных изображений, которые можно включать в отчет в качестве элементов отчета.Images The list of images that are available to include as an Image report item in a report.

Источники и наборы данных в области данных отчета представляют элементы в определении отчета.Data sources and datasets in the Report Data pane represent the elements in the report definition. Область данных отчета — это функция, поддерживаемая многими средами создания отчетов.The Report Data pane is a feature supported by multiple report authoring environments. В построителе отчетов это единственная доступная панель для управления источниками и наборами данных.In Report Builder, it is the only pane available for managing data sources and datasets. В конструкторе отчетов область данных отчета работает вместе с обозревателем решений, в котором общие источники и наборы данных отображаются в виде файлов.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. Общие источники и наборы данных в области данных отчета должны указывать на соответствующие общие источники данных и общие наборы данных в обозревателе решений.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. Элементы в области данных отчета содержат ссылки на файлы данных в обозревателе решений.The Report Data pane elements then contain a reference to the data files in Solution Explorer. Свойства проекта определяют, должны ли общие источники и наборы данных развертываться на сервере отчетов или на сайте SharePoint.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. Дополнительные сведения см. в разделе Преобразование источников данных (построитель отчетов и службы SSRS).For more information, see Convert Data Sources (Report Builder and SSRS).

Примечание

Если область данных отчета не видна, щелкните область конструирования и выберите в меню Вид пункт Данные отчета.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. Если область данных отчета открывается как плавающее окно, его можно закрепить.If the Report Data pane is floating, you can anchor it. Дополнительные сведения см. в разделе Закрепление области данных отчета в конструкторе отчетов (службы SSRS).For more information, see Dock the Report Data Pane in Report Designer (SSRS).

Панель группировкиGrouping Pane

На панели группирования определяются группы для области данных табликса.Use the Grouping pane to define groups for a tablix data region. Для таблиц можно задавать группы строк и сведений, а для матриц — группы строк и столбцов.You can define row groups and detail groups for tables and row and column groups for matrices. Панель группирования нельзя использовать для определения групп для диаграмм или других областей данных.You cannot use the Grouping pane to define groups for Charts or other data regions. Дополнительные сведения см. в разделе Основные сведения о группах (построитель отчетов и службы SSRS).For more information, see Understanding Groups (Report Builder and SSRS).

Панель группирования имеет два режима:The Grouping pane has two modes:

  • По умолчанию.Default. Текущие значения свойств можно просмотреть с помощью диалогового окна По умолчанию используется для отображения всех групп строк и столбцов в иерархическом формате, показывающем связи между родительскими группами, дочерними группами, смежными группами и группами сведений.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. Дочерняя группа выводится ниже родительской группы и на один уровень отступа правее.A child group appears under and at the next indent level compared to its parent group. Смежная группа выводится на том же уровне отступа, что и группы одного с ней уровня.An adjacent group appears at the same indent level as its peer or sibling groups.

    Добавление, удаление и изменение групп происходит в режиме по умолчанию.Use default mode to add, edit, or delete groups. Если группа создана на основе одного поля набора данных, то это поле можно перетащить на панель «Группы строк» или «Группы столбцов».For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. Группу можно вставить выше или ниже существующей группы.You can insert the group above or below an existing group. Для добавления смежной группы щелкните правой кнопкой мыши одноуровневую группу и воспользуйтесь функциями контекстного меню.To add an adjacent group, right-click the sibling group, and use the shortcut menu. Чтобы отобразить ячейки табликса, принадлежащие к группе, выделите группу на панели группирования.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • РасширенныйAdvanced. Текущие значения свойств можно просмотреть с помощью диалогового окна Расширенный используется для отображения элементов статических и динамических групп строк и столбцов выбранной области данных табликса.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. Элементы групп используются для настройки свойств, управляющих отображением строк и столбцов, связанных с группой или элементом группы, а также для настройки правил, согласно которым модули подготовки отчетов пытаются выводить группы вместе на одной странице.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. В области конструктора отобразятся элементы группы в виде ячеек в областях групп строк и групп столбцов.Group members appear on the design surface as cells in the row group and column group areas.

Примечание

Для переключения между режимом По умолчанию и Расширенный щелкните правой кнопкой мыши стрелку вниз, расположенную справа от значка Группы столбцов .To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

Дополнительные сведения см. в разделе Grouping Pane.For more information, see Grouping Pane.

Область элементовToolbox

Панель элементов содержит элементы отчета, которые можно перетащить в область конструктора.The Toolbox contains report items that you can drag to the design surface. Области данных — это элементы отчета, с помощью которых упорядочиваются данные отчета.Data regions are report items that you use to organize data on the report. Таблица, матрица, список, диаграмма, датчик, гистограмма, спарклайн и индикатор являются областями данных.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. К другим элементам отчета относятся карта, текстовое поле, прямоугольник, линия, изображение и вложенный отчет.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. Пользовательские элементы отчета тоже могут входить в этот список, если они установлены и зарегистрированы системным администратором.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

Панель «Свойства»Properties Pane

Панель свойств представляет собой стандартное окно среды Visual StudioVisual Studio , в котором отображаются имена и значения свойств элемента отчета, выбранного в данный момент в области конструктора.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. В большинстве случаев имена свойств соответствуют элементам и атрибутам, которые хранятся в файле на языке определения отчетов (RDL).In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. Наиболее часто используемые свойства можно установить с помощью диалогового окна «Свойства» выбранного элемента.The most commonly used properties can be set by using the Properties dialog box for the selected item. Чтобы открыть нужное диалоговое окно, нажмите кнопку Страницы свойств на панели инструментов на панели свойств.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. Опытные пользователи могут задавать значения свойств непосредственно на панели свойств.Advanced users can set property values directly in the Properties pane.

Панель свойств используется для следующих действий.Use the Properties pane to:

  • Задание свойств для текущего выбранного элемента в области конструктора.Set properties for the currently selected item on the design surface. Некоторые свойства имеют раскрывающийся список значений.Some properties provide a drop-down list of values. Кроме того, можно ввести значение непосредственно в ячейку.You can also type the value directly in the cell. Некоторые свойства содержат коллекцию значений, что обозначается как (Коллекция) .Some properties contain a collection of values, indicated by the value (Collection). Большинство свойств принимает в качестве значения выражение; сложные выражения обозначаются как <Выражение> .Most properties can accept an expression; complex expressions are indicated by the value <Expression>. Чтобы открыть диалоговое окно Выражение, нажмите кнопку <Выражение> .Click <Expression> to open the Expression dialog box. Дополнительные сведения см. в разделе Expression Dialog Box.For more information, see Expression Dialog Box.

  • С помощью кнопок панели инструментов на панели свойств можно переключать сетку с вида по категориям на вид в алфавитном порядке.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. В представлении по категориям можно развернуть ту или иную категорию, чтобы увидеть все принадлежащие к ней свойства.In category view, you may need to expand a category to see all the properties under it. Чтобы открыть диалоговое окно свойств элемента, нажмите кнопку Страницы свойств на панели инструментов или щелкните элемент правой кнопкой мыши и выберите Свойства.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • Задание свойств для элемента группы, выбранного в данный момент на панели группирования.Set properties for the currently selected group member in the Grouping pane. Свойства элементов групп помогают управлять повторением статических строк заголовков и нижних колонтитулов для каждого экземпляра группы.Group member properties help control how static group header and footer rows repeat for each group instance. Дополнительные сведения см. в разделе Отображение верхних и нижних колонтитулов в группе (построитель отчетов и службы SSRS).For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

Для вывода панели свойств выберите пункт Окно свойств в меню Вид.To display the Properties pane, from the View menu, click Properties Window. Можно отменить закрепление этой панели и переместить ее в другую часть окна среды SQL Server Data ToolsSQL Server Data Toolsлибо вывести как представление со вкладками в области конструктора.You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

Обозреватель решенийSolution Explorer

Обозреватель решений представляет собой стандартный компонент среды Visual StudioVisual Studio , в котором отображаются все элементы проекта.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. Для проекта сервера отчетов сюда входят папки, позволяющие упорядочить общие источники данных, общие наборы данных, отчеты и ресурсы.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. Элементы в папках автоматически упорядочиваются по алфавиту при открытии файла решения.Folder items are automatically alphabetized when you open the solution file. Чтобы просмотреть свойства элемента на панели "Свойства", выделите этот элемент.To view item properties in the Properties pane, select the item.

ВыводOutput

В окне «Вывод» отображаются ошибки обработки при предварительном просмотре отчета и ошибки публикации — при развертывании отчета или общего источника данных.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

Окна «Вывод» и «Структура документа» можно использовать для отладки ошибок в выражениях.Use the Output and the Document Outline windows to help debug errors in expressions.

Структура документаDocument Outline

Окно «Структура документа» предназначено для просмотра иерархии всех элементов отчета в определении отчета.The Document Outline window displays a hierarchical list of all report items in the report definition. Чтобы открыть панель структуры документа, в меню Вид укажите Другие окна и щелкните Окно документа.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

Панель «Структура документа» используется для идентификации текстовых полей и других элементов отчета по именам.Use the Document Outline pane to help identify text boxes and other report items by name. При выборе элемента на панели структуры документа соответствующий элемент также выбирается в области конструктора.When you select an item in the Document Outline, the item is also selected on the Design Surface.

Список задачTask List

В окне «Список задач» отображаются ошибки сборки для неподдерживаемых функций, если отчет импортирован из другого приложения, например MicrosoftMicrosoft Access.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

Представление конструктора в конструкторе отчетовReport Designer Design View

По умолчанию при создании проекта сервера отчетов конструктор отчетов открывается в представлении конструктора с открытой областью конструктора.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. По умолчанию в области конструктора отображается текст отчета и фон.By default, the design surface displays the report body and the report background.

Контекстное меню фона содержит функции добавления верхнего и нижнего колонтитула отчета, а с помощью меню «Вид» можно отобразить линейку и панель группирования.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

С помощью элемента управления масштабированием можно уменьшать и увеличивать масштаб, в котором выводится отчет.Use the zoom control to increase or decrease the magnification of the report.

Для конструирования отчета элементы отчета можно перетаскивать с панели элементов в область конструктора, чтобы затем настраивать их свойства и менять их расположение в отчете.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

Средство предварительного просмотра в конструкторе отчетовReport Designer Preview

Предварительный просмотр используется для запуска отчета и просмотра подготовленного отчета с помощью средства просмотра отчетов.Use Preview to run the report and view the rendered report in the report viewer. При предварительном просмотре данные отчета сохраняются в локальном кэше.Preview caches report data locally. Кроме того, можно настроить конфигурацию для запуска отчета в представлении отладки с помощью браузера.You can also set configuration properties to run the report in debug view, using a browser.

При предварительном просмотре отчета конструктор отчетов подключается к источникам данных отчета, запускает запросы наборов данных, кэширует данные на локальном компьютере, обрабатывает отчет (в ходе обработки данные и макет объединяются) и подготавливает его к просмотру.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. Отчет можно просмотреть на вкладке «Предварительный просмотр» или настроить свойства проекта для просмотра отчета в режиме отладки или непосредственно в браузере.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • Просмотр параметризованных отчетов.Previewing Parameterized Reports. При предварительном просмотре отчеты обрабатываются автоматически, если все параметры отчета имеют допустимые значения по умолчанию.When you preview a report, the report is processed automatically if all report parameters have valid default values. Если у одного или нескольких параметров отчета нет допустимых значений по умолчанию, то нужно выбрать значение для каждого такого параметра, затем нажать кнопку Просмотреть отчетна панели инструментов отчета.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • Основные сведения о локальном кэше данных . При предварительном просмотре отчета обработчик запускает все его запросы к наборам данных с текущими значениями параметров по умолчанию, затем сохраняет результаты в файле локального кэша данных (.rdl.data).Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. Если запросы набора данных отчета и параметры отчета не изменились, то можно воспользоваться уже полученными данными из кэша и продолжать конструирование отчета без дополнительной нагрузки на ресурсы для их повторного получения.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • Предварительный просмотр отчета с помощью диспетчера конфигурации и отладки.Previewing the Report using Configuration Manager and Debug. Свойства проекта в среде SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)определяют, каким образом будут развертываться и отлаживаться отчеты.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. Эти свойства относятся ко всем отчетам и общим источникам данных проекта.These properties apply to all reports and shared data sources in the project. Чтобы настроить свойства проекта, щелкните в меню Проект пункт Свойства.To set the project properties, from the Project menu, click Properties. С помощью этих параметров можно тестировать отчеты и публиковать их на сервере отчетов.Use these settings to test your reports and publish them to the report server.

  • Наблюдение за сообщениями об ошибках на панели вывода.Monitoring the Output Pane for Error Messages. Если при предварительном просмотре отчета обработчик обнаруживает проблему, он выводит сообщения об ошибках на панель вывода.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

Меню конструктора отчетовReport Designer Menus

Если проект конструктора отчетов активен в среде SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), то на главную панель инструментов добавляются следующие панели инструментов.When a Report Designer project is active in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. Меню конструктора отчетов видны только в режиме конструктора.The Report Designer menus are visible only when in Design view.

Меню «Формат»Format Menu

При выборе элемента в области конструктора меню Формат содержит следующие команды.When you select an item on the design surface, the Format menu contains the following options:

  • Цвет переднего плана . Выбор цвета текста.Foreground Color Select a text color. Цвет по умолчанию — черный.Black is the default text color.

  • Цвет фона . Выбор цвета фона в текстовых полях и областях данных.Background Color Select a background color for your text boxes and data regions.

  • Шрифт . Выбор шрифта: полужирный, курсив, подчеркнутый.Font Specify whether the text is bold, italic, or underlined.

  • Выравнивание по ширине . Выравнивание текста: по левому краю, по правому краю, по центру.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • Выравнивание . Расположение выделенных объектов относительно друг друга в отчете.Align Specify how the selected objects are aligned in relation to one another within the report.

  • Установить тот же размер . Выравнивание размеров выделенных объектов в отчете.Make Same Size Adjust the size of the selected objects within the report.

  • Интервал по горизонтали . Выравнивание интервала по горизонтали между выделенными объектами отчета.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • Интервал по вертикали . Выравнивание интервала по вертикали между выделенными объектами отчета.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • Расположить по центру формы . Центрирование выделенного объекта в окне конструктора отчетов по вертикали и по горизонтали.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • Порядок . Перемещение выделенного объекта на передний или на задний план.Order Move selected objects into the background or foreground.

Меню «Отчет»Report Menu

Когда область конструктора отчетов находится в фокусе, меню Отчет содержит следующие команды.When the report design surface has focus, the Report menu contains the following options:

  • Свойства отчета . Открытие диалогового окна Свойства отчета .Report Properties Select to open the Report Properties dialog box. В этом диалоговом окне задаются общие свойства отчета, например имя автора, размер шага сетки, а также такие свойства макета отчета, как число столбцов и размеры страниц.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. Можно также указать пользовательский код, ссылки на сборки и классы, имена выходных элементов, преобразований и схем данных.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • Вид. Переключение между двумя вкладками конструктора отчетов: "Конструктор" и "Просмотр".View Switch between the two Report Designer tabs: Design and Preview.

  • Верхний колонтитул страницы . Добавление или удаление верхнего колонтитула страницы.Page Header Add or delete a page header to the report. При удалении верхнего колонтитула страницы удаляются также все его элементы.When you delete a page header, all items in the page header are deleted.

  • Нижний колонтитул страницы . Добавление или удаление нижнего колонтитула страницы.Page Footer Add or delete a page footer to the report. При удалении нижнего колонтитула страницы удаляются также все его элементы.When you delete a page footer, all items in the page footer are deleted.

  • Панель группирования . Отображение или скрытие панели группирования.Grouping Pane Show or hide the Grouping pane.

Представление менюView Menu

С помощью меню Вид можно отобразить следующие окна и панели инструментов конструктора отчетов.Use the View menu to display Report Designer windows and toolbars

  • Список ошибок . Используется для вывода ошибок, обнаруженных при публикации или предварительном просмотре отчета.Error List Use this option to display errors detected when publishing or previewing a report.

  • Вывод . Используется для отображения ошибок, обнаруженных при публикации или обработке отчета, а также для получения дополнительных сведений об ошибках в выражениях, если в отчете выводится текст "#Error".Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • Окно свойств . Используется для отображения значений свойств элемента отчета, выбранного в данный момент в области конструктора.Properties Window Use this option to display the property values for the currently selected report item on the design surface. Чтобы увидеть свойства вложенных элементов отчета, щелкните элемент отчета несколько раз для перемещения по иерархии элементов отчета и всех его вложенных элементов.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. Проверьте имя элемента, показанное в верхней части панели свойств, чтобы узнать, свойства какого элемента отчета отображены в настоящий момент.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • Область элементов . Используется для вывода области элементов.Toolbox Use this option to display the Toolbox.

  • Другие окна . Используется для вывода следующей панели:Other Windows Use this option to display the following pane:

    • Структура документа . Используется для вывода иерархического представления элементов отчета и их коллекций текстовых полей в отчете.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • Панели инструментов . Используется для отображения панелей инструментов, поддерживающих функции конструктора отчетов, в том числе панелей Границы отчета и Форматирование отчета.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. Дополнительные сведения см. в разделе Панели инструментов конструктора отчетов.For more information, see Report Designer Toolbars.

  • Данные отчета . Используется для отображения панели данных отчета, куда можно добавлять параметры отчета, источники данных, наборы данных и изображения.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

Меню «Проект»Project Menu

Меню Проект используется для управления общими источниками данных и отчетами проекта.Use the Project menu to manage shared data sources and reports in a project. При добавлении и удалении элементов отчета иерархическое представление элементов отчета в обозревателе решений обновляется автоматически.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • Добавить элемент . Добавление к проекту нового общего источника данных или нового отчета.Add New Item Add a new shared data source or new report to the project.

  • Добавить существующий элемент . Добавление к проекту существующего общего источника данных или существующего отчета.Add Existing Item Add an existing shared data source or an existing report to the project.

  • Импортировать отчеты . Импорт отчетов из другого приложения, например из Microsoft Access.Import Reports Import reports from another application, for example, Microsoft Access.

  • Исключить из проекта . Исключение элементов из проекта.Exclude from Project Exclude items from the project. Этот параметр не удаляет файлы из файловой системы.This option does not delete the item from your file system.

  • Показать все файлы . Отображение всех файлов проекта.Show All Files Show all files in a project.

  • Обновить элементы области элементов проекта . Обновление кэша области элементов после добавления в проект новых пользовательских элементов отчета.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • Свойства . Открытие диалогового окна Страницы свойств для данного проекта.Properties Open the Property Pages dialog box for this project. Дополнительные сведения см. в разделе Диалоговое окно страниц свойств проекта.For more information, see Project Property Pages Dialog Box.

Панели инструментов конструктора отчетовReport Designer Toolbars

В конструкторе отчетов предусмотрены следующие специализированные панели инструментов для построения отчетов.Report Designer provides the following specialized toolbars to use when designing reports:

  • Отчет . Добавление верхнего или нижнего колонтитула, переключение режимов отображения линейки и панели группирования, изменение масштаба вывода отчета.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • Границы отчета . Настройка стиля, ширины и цвета выбранных границ и линий для выбранных элементов отчета.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • Форматирование отчета . Установка формата выбранных элементов отчета.Report Formatting Set the format of selected report items. Для текстовых полей с помощью этой панели инструментов можно изменить следующие виды форматирования: свойства шрифта, цвет текста, цвет фона, выравнивание текста.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • Макет . Указание порядка вывода элементов отчета и слияния ячеек в области данных.Layout Set the drawing order of report items and merging cells within a data region.

  • Стандартная . Открытие и закрытие проектов, вывод окон, выбор конфигурации отладки.Standard Open or save projects, display windows, and select the Debug configuration.

С помощью меню Вид можно управлять отображением этих панелей инструментов.Use the View menu to control whether to display these toolbars. Другие панели инструментов Visual StudioVisual Studio могут быть отключены, если их возможности неприменимы к функциям конструктора отчетов.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

Система управления версиямиSource Control

SQL Server Data ToolsSQL Server Data Tools может интегрироваться с подключаемыми модулями источников данных. На страницах "Проекты" и "Решения" диалогового окна Параметры можно указать подключаемые модули и настроить свойства.can integrate with source plug-ins. Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

Пользовательские шаблоны отчетовCustom Report Templates

Чтобы использовать пользовательские отчеты в качестве шаблонов для создания новых отчетов просто скопируйте их в папку ReportProject на том компьютере, где установлена среда SQL Server Data ToolsSQL Server Data Tools .To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. По умолчанию эта папка находится в следующем расположении: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. Когда в проект отчета добавляется новый элемент, пользовательский отчет отображается на панели «Шаблоны».When you add a new item to the report project, your custom report appears in the Templates pane.

Можно также добавить пользовательские стили в мастер отчета.You can also add custom styles to the report wizard.

Поддержка командной строки для SQL Server Data ToolsCommand Line Support for SQL Server Data Tools

Инструменты SQL Server Data ToolsSQL Server Data Tools созданы на основе MicrosoftMicrosoft Visual StudioVisual Studio и базового приложения devenv.exe.SQL Server Data ToolsSQL Server Data Tools is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. Прежде чем использовать эти параметры, необходимо задать верное значение для следующих двух элементов.Before you can use these options, you must set valid values for following two items:

  • Свойства проекта для OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder и TargetServerURL.Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • Как минимум один набор свойств конфигурации, например, Debug или Release.At least one set of configuration properties, for example, Debug or Release.

Дополнительные сведения см. в разделе Publishing Data Sources and Reports.For more information, see Publishing Data Sources and Reports.

Для проекта сервера отчетов необходимо задать следующие параметры в командной строке.For a report server project, you can specify the following options from the command line:

  • /deploy . Выполняет развертывание отчетов на основе свойств проекта, указанных в файле конфигурации./deploy Deploy reports by using the project properties specified in a configuration file. Например, следующие команды выполняют развертывание отчетов, указанных в файле решения Reports.sln с использованием параметров конфигурации Release, которые заданы в свойствах проекта.For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build . Создает файл решения, но не развертывает его./build Build the solution file, but do not deploy it. Например, следующие команды создают отчеты, указанные в файле решения Reports.sln, с использованием параметров конфигурации Debug, которые заданы в свойствах проекта.For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out . Перенаправляет вывод, сформированный в ходе построения решения, в указанный файл./out Redirect the output generated by building a solution to the specified file. Например, следующая команда перенаправляет вывод из сборки, созданной в предыдущем примере, в файл mybuildlog.txt.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Сочетания клавиш в службах Reporting ServicesKeyboard Shortcuts in Reporting Services

Сочетания клавиш можно использовать для следующих действий.Use keyboard shortcuts to:

  • Управление окнами и режимами в среде SQL Server Data ToolsSQL Server Data Tools.Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    ОписаниеDescription Сочетание клавишKey Combination
    Выполнить сборку выбранного проектаBuild the selected project CTRL + SHIFT + BCTRL+SHIFT+B
    Открыть окно «Свойства»Display Properties window F4F4
    Открыть окно «Данные»Display Data window CTRL + Alt + DCTRL+Alt+D
    Начать отладкуStart debugging F5F5
    Переместиться от одного открытого окна к следующемуMove from one open window to the next F6F6
  • Управление элементами в области конструктора отчета.Control items on the report design surface:

    ОписаниеDescription Сочетание клавишKey Combination
    Переместить фокус с элемента отчета на следующий элемент отчетаMove focus from one report item to the next report item TABTAB
    Переместить выбранный элемент отчетаMove selected report item Клавиши со стрелкамиArrow keys
    Сдвинуть выбранный элемент отчетаNudge selected report item CTRL + клавиши со стрелкамиCTRL+Arrow keys
    Увеличить или уменьшить размер выбранного элемента отчетаIncrease or decrease the size of the selected report item CTRL + SHIFT + клавиши со стрелкамиCTRL+SHIFT+Arrow keys
    В текстовом поле переместить курсор в начало отображаемого текста, который является видимымIn a text box, move cursor to the beginning of the display text that is visible CTRL + HOMECTRL+HOME
    В текстовом поле переместить курсор в конец отображаемого текста, который является видимымIn a text box, move cursor to the end of the display text that is visible CTRL + ENDCTRL+END
    В текстовом поле выбрать текст от текущей позиции курсора до начала отображаемого текста, который является видимымIn a text box, select text from the current cursor position to the beginning of the display text that is visible SHIFT + HOMESHIFT+HOME
    В текстовом поле выбрать текст от текущей позиции курсора до конца отображаемого текста, который является видимымIn a text box, select text from the current cursor position to the end of the display text that is visible SHIFT + ENDSHIFT+END
    В текстовом поле выбрать текст от текущей позиции курсора до начала выраженияIn a text box, select text from the current cursor position to the beginning of the expression CTRL + SHIFT + HOMECTRL+SHIFT+HOME
    В текстовом поле выбрать текст от текущей позиции курсора до конца выраженияIn a text box, select text from the current cursor position to the end of the expression CTRL + SHIFT + ENDCTRL+SHIFT+END
    Открыть контекстное меню для выбранного элемента отчетаOpen the shortcut menu for the selected report item SHIFT + F10 + клавиша свойств на новых клавиатурахSHIFT+F10+Property Key on newer keyboards

Дальнейшие действияNext steps

Скачать SQL Server Data Tools Обозреватель решений Download SQL Server Data Tools Solution Explorer
Reporting Services, отчеты служб Reporting Services Reports
Язык определения отчетов Report Definition Language
Развертывание и поддержка версий в SQL Server Data ToolsDeployment and Version Support in SQL Server Data Tools

Остались вопросы?More questions? Посетите форум служб Reporting Services.Try asking the Reporting Services forum