Руководство по Создание отчета в свободной форме (построитель отчетов)

В этом учебнике вы создадите отчет с разбивкой на страницы в качестве информационного бюллетеня. На каждой странице выводится статический текст, сводные визуальные элементы и образец подробных данных по продажам.

Снимок экрана отчета в свободной форме построителя отчетов.

Отчет группирует сведения по территории и отображает имя менеджера по продажам на данной территории, а также подробные и сводные сведения о продажах. Вы начнете с создания области списка данных, которая используется как основа отчета в свободной форме, затем добавите декоративную панель с изображением, статический текст со вставленными данными, таблицу для отображения подробной информации и при необходимости круговые диаграммы и гистограммы со сводными данными.

На изучение этого руководства потребуется примерно 20 минут.

Требования

Дополнительные сведения о требованиях см. в разделе Предварительные условия для использования учебников (построитель отчетов).

1. Создание пустого отчета, источника данных и набора данных

Примечание

В этом учебнике запрос уже содержит значения данных, поэтому внешний источник данных не требуется. В связи с этим запрос получается весьма длинным. В рабочей среде запрос не будет содержать данные. Этот запрос содержит данные только в учебных целях.

Создание пустого отчета

  1. Запустите построитель отчетов с компьютера, веб-портала Службы Reporting Services или сервера в режиме интеграции с SharePoint.

    Откроется диалоговое окно Создать отчет или набор данных .

    Если диалоговое окно Новый отчет или набор данных не появилось, в меню Файл выберите команду Создать.

  2. Убедитесь в том, что на левой панели выбран Новый отчет .

  3. На правой панели щелкните Пустой отчет.

Создание нового источника данных

  1. В области данных отчета нажмите кнопку Создать > Источник данных.

  2. В поле Имя введите ListDataSource

  3. Нажмите кнопку Использовать соединение, внедренное в отчет.

  4. Убедитесь в том, что выбран тип соединения Microsoft SQL Server, а затем в поле Строка подключения введите: Источник данных = <servername>

    Значение <servername> , например Report001, указывает компьютер, на котором установлен экземпляр яда СУБД SQL Server. Так как данные для этого отчета не извлекаются из базы данных SQL Server, не нужно указывать имя базы данных. База данных по умолчанию на указанном сервере используется только для синтаксического анализа запроса.

  5. Нажмите Учетные данные и введите учетные данные, необходимые для подключения к экземпляру ядра СУБД SQL Server.

  6. Нажмите кнопку ОК.

Создание нового набора данных

  1. В области данных отчета щелкните Создать > Набор данных.

  2. В поле Имя введите ListDataset.

  3. Нажмите Использовать включенный в мой отчет набор данных , проверьте, что в качестве источника данных указан ListDataSource.

  4. Убедитесь, что выбран тип запроса Текст , и нажмите кнопку Конструктор запросов.

  5. Нажмите кнопку Изменить как текст.

  6. Скопируйте и вставьте на панели запросов следующий запрос:

    SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(16996.60 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13747.25 AS money) AS Sales, 55 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(9248.15 AS money) As Sales, 37 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1350.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1800.00 AS money) AS Sales, 24 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1125.00 AS money) AS Sales, 15 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1147.50 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,  'Lens Adapter' as Product, CAST(742.50 AS money) AS Sales, 11 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1417.50 AS money) AS Sales, 21 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13497.30 AS money) AS Sales, 54 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(11997.60 AS money) AS Sales, 48 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(10247.95 AS money) As Sales, 41 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Tripod' as Product, CAST(1200.00 AS money) AS Sales, 16 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(2025.00 AS money) AS Sales, 27 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1425.00 AS money) AS Sales, 19 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(887.50 AS money) AS Sales, 13 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Lens Adapter' as Product, CAST(607.50 AS money) AS Sales, 9 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1215.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(10191.00 AS money) AS Sales, 79 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8772.00 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(10578.00 AS money) AS Sales, 82 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(7218.10 AS money) AS Sales, 38 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(8357.80 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory,'Digital' as Subcategory,'Slim Digital' as Product, CAST(9307.55 AS money) AS Sales, 49 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(3870.00 AS money) AS Sales, 30 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(5805.00 AS money) AS Sales, 45 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8643.00 AS money) AS Sales, 67 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(9877.40 AS money) AS Sales, 52 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(12536.70 AS money) AS Sales, 66 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(6648.25 AS money) AS Sales, 35 as Quantity  
    
  7. Щелкните значок Запуск (!), чтобы запустить запрос.

    Результаты запроса — это данные, доступные для отображения в отчете.

    Снимок экрана: конструктор запросов, отображающий данные, доступные для отображения в отчете в свободной форме построителя отчетов.

  8. Нажмите кнопку ОК.

2. Добавление и настройка списка

В Службы Reporting Services область списка данных идеально подходит для создания отчетов произвольной формы. Она основана на области данных tablix , так же как таблицы и матрицы. Дополнительные сведения см. в разделе Создание счета-фактуры и формы со списками.

Список будет использоваться для отображения сведений о территориальных продажах в отчете, отформатированном как информационный бюллетень. Сведения группируются по территориям. Добавьте новую группу строк, в которой данные группируются по территориям, а затем удалите встроенную группу строк подробностей.

Добавление списка

  1. На вкладке Вставка щелкните Области данных > Список.

  2. Щелкните в области текста отчета (между заголовком и областью нижнего колонтитула) и перетащите указатель, чтобы создать поле со списком. Установите для списка высоту в 7 дюймов и ширину в 6,25 дюйма. Чтобы задать точный размер, в области Свойства в разделе Положение введите значения свойств Ширина и Высота .

    Примечание

    Для отчета используются размер бумаги Letter (8,5 X11) и поля шириной 1 дюйм. Поле со списком высотой более 9 дюймов или шириной более 6,5 дюймов может привести к формированию пустых страниц.

  3. Щелкните внутри поля со списком, щелкните правой кнопкой мыши панель вверху списка и выберите пункт Свойства табликса.

    Снимок экрана, показывающий параметр свойств табликса для отчета в свободной форме построителя отчетов.

  4. В раскрывающемся списке Имя набора данных выберите пункт ListDataset.

  5. Нажмите кнопку ОК.

  6. Щелкните правой кнопкой мыши внутри списка и выберите пункт Свойства прямоугольной области.

  7. На вкладке Общие установите флажок Вставить разрыв страницы после .

  8. Нажмите кнопку ОК.

Добавление новой группы строк и удаление группы подробностей

  1. На панели "Группы строк" щелкните правой кнопкой мыши группу подробностей, выберите пункт Добавить группу , а затем пункт Родительская группа.

    Снимок экрана, показывающий, как добавить родительскую группу в отчет в свободной форме построителя отчетов.

  2. В списке Группировать по выберите [Territory].

  3. Нажмите кнопку ОК.

    Столбец, содержащий ячейку [Territory] , будет добавлен в список.

  4. Щелкните правой кнопкой мыши столбец "Территория" в списке и выберите команду Удалить столбцы.

    Снимок экрана, показывающий, как удалить столбец из отчета в свободной форме построителя отчетов.

  5. Выберите Удалить только столбцы.

  6. На панели "Группы строк" щелкните правой кнопкой мыши группу Подробности и выберите пункт Удалить группу.

  7. Выберите Удалить только группу.

  8. Нажмите кнопку ОК.

3. Добавление графических элементов

Одно из преимуществ области списка данных заключается в возможности добавлять в любом месте такие элементы отчета, как прямоугольники и текстовые поля, не ограничиваясь табличным макетом. Внешний вид отчета улучшается благодаря добавлению графических элементов (прямоугольника с цветной заливкой).

Добавление графических элементов в отчет

  1. На вкладке Вставка выберите Прямоугольник.

  2. Щелкните в левом верхнем углу списка и перетащите указатель, чтобы создать прямоугольник с длиной в 17,78 см и шириной 8,89 см. Чтобы задать точный размер, в области Свойства в разделе Положение введите значения свойств Ширина и Высота.

  3. Щелкните правой кнопкой мыши прямоугольник и выберите пункт Свойства прямоугольника.

  4. Перейдите на вкладку Заливка .

  5. В поле Цвет заливки выберите значение Светло-серый.

  6. Нажмите кнопку ОК.

  7. Нажмите кнопку Выполнить для предварительного просмотра отчета.

В левой стороне отчета теперь находится вертикальный графический элемент, состоящий из светло-серого прямоугольника, как показано на рисунке ниже.

Снимок экрана: построитель отчетов покажет вертикальный рисунок, состоящий из светло-серого прямоугольника.

4. Добавление произвольного текста

Вы можете добавлять текстовые поля, которые содержат статический текст, повторяемый на каждой странице отчета, а также поля данных.

Добавление текста в отчет

  1. Щелкните Конструктор для возврата в режим конструктора.

  2. На вкладке Вставка щелкните Текстовое поле. Щелкните в левом верхнем углу списка внутри ранее добавленного прямоугольника и перетащите указатель, чтобы создать текстовое поле шириной приблизительно 3,45 дюйма и высотой приблизительно 5 дюймов.

  3. Поместите курсор в текстовое поле и введите Информационный бюллетень для. После слова "для" поставьте пробел, отделяющий этот текст от поля, которое вы добавите в следующем шаге.

    Добавление текста заголовка бюллетеня

  4. Перетащите поле [Territory] из ListDataSet в области "Данные отчета" в текстовое поле и поместите его после надписи "Информационный бюллетень для ".

    Снимок экрана, показывающий, как перетащить поле «Территория» в отчет в свободной форме построителя отчетов.

  5. Выделите текст и поле [Territory] .

  6. На вкладке Главная в разделе Шрифт выберите следующие значения:

    • Segoe Semibold.
    • 20 пт.
    • Томатный.
  7. Поместите курсор ниже текста, введенного в шаге 3, и введите Здравствуйте, , поставив после запятой пробел, отделяющий этот текст от поля, которое вы добавите в следующем шаге.

  8. Перетащите поле [FullName] из ListDataSet в области "Данные отчета" в текстовое поле и поместите его после надписи "Здравствуйте, ", а затем введите восклицательный знак (!).

  9. Выделите текст, добавленный в предыдущем шаге.

  10. На вкладке Главная в разделе Шрифт выберите следующие значения:

    • Segoe Semibold.
    • 16 пт.
    • Черный.
  11. Разместите курсор ниже текста, добавленного в шагах с 9 по 13, а затем скопируйте и вставьте следующий текст-заполнитель:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin sed dolor in ipsum pulvinar egestas. Sed sed lacus at leo ornare ultricies. Vivamus velit risus, euismod nec sodales gravida, gravida in dui. Etiam ullamcorper elit vitae justo fermentum ut ullamcorper augue sodales. 
    Ut placerat, nisl quis feugiat adipiscing, nibh est aliquet est, mollis faucibus mauris lectus quis arcu. In mollis tincidunt lacinia. In vitae erat ut lorem tincidunt luctus. Curabitur et magna nunc, sit amet adipiscing nisi. Nulla rhoncus elementum orci nec tincidunt. 
    Aliquam imperdiet cursus erat vel tincidunt. Donec et neque ac urna rutrum sodales. In id purus et nisl dignissim dapibus. Sed rhoncus metus at felis feugiat eu tempor dolor vehicula. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nullam faucibus consectetur diam eu pellentesque.   
    
    
  12. Выделите добавленный текст.

  13. На вкладке Главная в разделе Шрифт выберите следующие значения:

    • Segoe UI.
    • 10 пт.
    • Черный.
  14. Поместите курсор в текстовом поле ниже текста-заполнителя и введите Поздравляем с общим объемом продаж , поставив в конце пробел, отделяющий этот текст от поля, которое вы добавите в следующем шаге.

  15. Перетащите поле Sales в текстовое поле, поместите его после текста, введенного в предыдущем шаге, а затем поставьте восклицательный знак (!).

  16. Выделите текст и только что добавленное поле.

  17. На вкладке Главная в разделе Шрифт выберите следующие значения:

    • Segoe Semibold.
    • 16 пт.
    • Черный.
  18. Выделите только поле [Sales], щелкните его правой кнопкой мыши и выберите пункт Выражение.

  19. В поле Выражение измените выражение, включив функцию Sum следующим образом:

    =Sum(Fields!Sales.value)  
    
  20. Нажмите кнопку ОК.

    Снимок экрана, показывающий текстовое поле в отчете в свободной форме построителя отчетов.

  21. Не снимая выделение с поля [Sum(Sales)], на вкладке Главная в группе Число нажмите кнопку Денежный.

  22. Щелкните правой кнопкой текстовое поле с текстом "Щелкните, чтобы добавить заголовок", а затем нажмите кнопку Удалить.

  23. Выберите поле со списком. Выделите две двусторонние стрелки и переместите их в верхнюю часть страницы.

    Снимок экрана, показывающий, как перетащить список в отчете в свободной форме построителя отчетов.

  24. Нажмите кнопку Выполнить для предварительного просмотра отчета.

В отчете отображается статический текст, и каждая страница отчета содержит данные для определенной территории. Данные о продажах форматируются как денежные значения.

Снимок экрана, показывающий предварительный просмотр страницы бюллетеня из отчета в свободной форме построителя отчетов.

5. Добавление таблицы для показа подробностей о продажах

Используйте мастер создания новой таблицы или матрицы, чтобы добавить таблицу в отчет произвольной формы. После завершения работы мастера добавьте вручную строку для итогов.

Добавление таблицы

  1. На вкладке Вставка в области Области данных щелкните Таблица > Мастер таблиц.

  2. На странице Выбор набора данных выберите ListDataset > Далее.

  3. На странице Выравнивание полей перетащите поле Product из раздела Доступные поля в Значения.

  4. Повторите шаг 3 для полей SalesDate, Quantity и Sales. Поместите SalesDate ниже Product, Quantity ниже SalesDate, а Sales ниже SalesDate.

  5. Щелкните Далее.

  6. На странице Выбор макета можно просмотреть макет таблицы.

    Таблица очень проста: пять столбцов без строк или групп столбцов. Поскольку группы отсутствуют, недоступны варианты макета, связанные с группами. Далее в учебнике таблица будет обновлена вручную для добавления итога.

  7. Щелкните Далее.

  8. Нажмите кнопку Готово.

  9. Перетащите таблицу ниже текстового поля, добавленного в занятии 4.

    Примечание

    Убедитесь в том, что таблица находится внутри поля со списком и серого прямоугольника.

  10. Выбрав таблицу, в области Группа строк щелкните правой кнопкой мыши элемент Сведения > Добавить итог > После.

    Снимок экрана, показывающий, как добавить итоги в отчете в свободной форме построителя отчетов.

  11. Выделите ячейку в столбце Product и введите Итого.

    Снимок экрана: ячейка в столбце Product с итогом, введенным в него.

  12. Выберите поле [SalesDate]. На вкладке Главная в разделе Число измените значение По умолчанию на Дата.

  13. Выберите поля [Sum(Sales)]. На вкладке Главная в разделе Число измените значение По умолчанию на Денежный.

Нажмите кнопку Выполнить для предварительного просмотра отчета.

Отчет отображает таблицу со сведениями о продажах и итогами.

Снимок экрана, показывающий предварительный просмотр таблицы из отчета в свободной форме построителя отчетов.

6. Сохранение отчета

Отчеты можно сохранять на сервере отчетов, в библиотеке SharePoint или на компьютере.

В данном учебнике предусмотрено сохранение отчета на сервере отчетов. Если нет доступа к серверу отчетов, сохраните отчет на компьютере.

Сохранение отчета на сервере отчетов

  1. Нажмите кнопку Построитель отчетов и выберите Сохранить как.

  2. Нажмите кнопку Последние сайты и серверы.

  3. Выберите или введите имя сервера отчетов, для которого существует разрешение на сохранение отчетов.

    Появится сообщение «Соединение с сервером отчетов». После того как соединение установлено, пользователю представляется содержимое папки, заданной администратором сервера отчетов как место по умолчанию для отчетов.

  4. В поле Имя замените имя по умолчанию на SalesInformationByTerritory.

  5. Выберите команду Сохранить.

Отчет будет сохранен на сервере отчетов. Имя сервера отчетов, с которым установлено соединение, будет отображено в строке состояния в нижней части окна.

Сохранение отчета на компьютере

  1. Нажмите кнопку Построитель отчетов и выберите Сохранить как.

  2. Перейдите на Рабочий стол , откройте папку Мои документы или Мой компьютер и перейдите в папку, в которую нужно сохранить отчет.

  3. В поле Имя замените имя по умолчанию на SalesInformationByTerritory.

  4. Выберите команду Сохранить.

7. Добавление строки в отдельные области отчета (необязательно)

Добавление строки в отдельные области редактирования и подробностей отчета.

Добавление линии

  1. Щелкните Конструктор для возврата в режим конструктора.

  2. На вкладке Вставка выберите Элементы отчета > Линия.

  3. Проведите линию ниже текстового поля, добавленного на занятии 4.

  4. Щелкните линию, а затем на вкладке Главная в разделе Граница выберите следующие значения:

    • Для параметра Ширина выберите значение 3 пт .
    • Для параметра Цвет выберите значение Томатный.

8. Добавление представлений сводных данных (необязательно)

С помощью прямоугольников можно управлять подготовкой отчетов к просмотру. Поместите круговую диаграмму и гистограмму в прямоугольник, чтобы отчет был правильно подготовлен к просмотру.

Добавление прямоугольника

  1. Щелкните Конструктор для возврата в режим конструктора.

  2. На вкладке Вставка выберите Элементы отчета > Прямоугольник. Путем перетаскивания создайте в поле со списком справа от таблицы прямоугольник шириной приблизительно 2,25 дюйма и высотой приблизительно 7,9 дюйма.

  3. Выделите новый прямоугольник, а затем в области "Свойства" установите значения BorderColor — LightGrey , BorderStyle — Solid и BorderWidth — 2 pt.

  4. Выровняйте верхний край прямоугольника с верхним краем таблицы.

Добавление круговой диаграммы

  1. На вкладке Вставка выберите Визуализации данных > Диаграмма > Мастер диаграмм.

  2. На странице Выбор набора данных выберите ListDataset > Далее.

  3. Щелкните Круговая > Далее.

  4. На странице "Размещение полей диаграммы" перетащите поле Product в Категории.

  5. Перетащите поле Quantity в Значения , а затем нажмите кнопку Далее.

  6. Нажмите кнопку Готово.

  7. Измените размеры диаграммы, показанной в левом верхнем углу отчета, установив ширину 2,25 дюйма и высоту 3,6 дюйма.

  8. Перетащите диаграмму в прямоугольник.

  9. Выделите заголовок диаграммы и введите Проданные объемы товаров.

  10. На вкладке Главная в разделе Шрифт установите следующие значения для заголовка:

    • Шрифт Segoe UI Semibold.
    • Размер 12 пт.
    • Цвет черный.
  11. Щелкните правой кнопкой мыши условные обозначения и выберите пункт Свойства условных обозначений.

  12. На вкладке Общие в разделе Местоположение условных обозначений выберите центральную точку внизу.

  13. Нажмите кнопку ОК.

  14. При необходимости сделайте область диаграммы выше путем перетаскивания.

    Снимок экрана, показывающий круговую диаграмму для добавления к отчету в свободной форме построителя отчетов.

Добавление гистограммы

  1. На вкладке Вставка выберите Визуализации данных > Диаграмма > Мастер диаграмм.

  2. На странице Выбор набора данных нажмите ListDataset , а затем нажмите кнопку Далее.

  3. Выберите Столбец , а затем нажмите кнопку Далее.

  4. На странице Размещение полей диаграммы перетащите поле Product на панель Категории.

  5. Перетащите поле Sales в Значения , а затем нажмите кнопку Далее.

    Значения отображаются по вертикальной оси.

  6. Нажмите кнопку Готово.

    Гистограмма добавляется в верхний левый угол отчета.

  7. Измените размер диаграммы, установив ширину 2,25 дюйма и высоту почти 4 дюйма.

  8. Перетащите диаграмму внутрь прямоугольника ниже круговой диаграммы.

  9. Выделите заголовок диаграммы и введите Продажи товаров.

  10. На вкладке Главная в разделе Шрифт установите следующие значения для заголовка:

    • Шрифт Segoe UI Semibold.
    • Размер 12 пт.
    • Цвет черный.
  11. Щелкните правой кнопкой мыши условные обозначения и выберите команду Удалить условные обозначения.

    Примечание

    Если удалить условные обозначения, диаграмма небольшого размера станет удобнее для восприятия.

    Снимок экрана, показывающий гистограмму для добавления к отчету в свободной форме построителя отчетов.

  12. Выделите ось диаграммы, а затем на вкладке Главная выберите Число > Денежный.

  13. Два раза нажмите кнопку Уменьшить разрядность , чтобы отображались только рубли, но не копейки.

Проверка местонахождения диаграмм внутри прямоугольника

Прямоугольники можно использовать как контейнеры для других элементов на странице отчета. Дополнительные сведения см. в этом разделе.

  1. Выделите прямоугольник, который вы создали и в который добавили диаграммы ранее на этом занятии.

    Свойство Name на панели «Свойства» показывает имя прямоугольника.

    Снимок экрана, показывающий, как просмотреть свойство Name в отчете в свободной форме построителя отчетов.

  2. Щелкните круговую диаграмму.

  3. Проверьте, что свойство Parent на панели Свойства показывает имя прямоугольника.

    Снимок экрана, показывающий, как просмотреть свойство Parent в отчете в свободной форме построителя отчетов.

  4. Щелкните гистограмму и повторите шаг 3.

    Примечание

    Если диаграммы не находятся внутри прямоугольника, то не отображаются вместе в подготовленном к просмотру отчете.

Придание одинаковых размеров диаграммам

  1. Выделите круговую диаграмму, нажмите клавишу CTRL, а затем выделите гистограмму.

  2. Выделив обе диаграммы, щелкните их правой кнопкой мыши и выберите пункты Макет > Установить ту же ширину.

    Примечание

    Элемент, который вы щелкнули сначала, задает ширину для всех выбранных элементов.

  3. Нажмите кнопку Выполнить для предварительного просмотра отчета.

Теперь отчет содержит сводные данные о продажах в круговых диаграммах и гистограммах.

Next Steps

На этом работа с учебником по созданию отчета произвольной формы закончена.

Дополнительные сведения о списках см. в следующих разделах:

См. подробнее о конструкторах запросов в руководствах по средствам проектирования запросов (SSRS) и пользовательскому интерфейсу текстового конструктора запросов (построитель отчетов).

См. также:

Учебники по построителю отчетов