Работа с проектами SSMA (OracleToSQL)Working with SSMA Projects (OracleToSQL)

Чтобы перенести базы данных Oracle в SQL ServerSQL Server , сначала необходимо создать проект SSMA.To migrate Oracle databases to SQL ServerSQL Server, you first create an SSMA project. Проект представляет собой файл, содержащий следующие сведения:The project is a file that contains the following information:

  • Метаданные о базах данных Oracle, на которые необходимо выполнить миграцию SQL ServerSQL Server .Metadata about the Oracle databases you want to migrate to SQL ServerSQL Server.

  • Метаданные о целевом экземпляре SQL ServerSQL Server , который будет принимать перенесенные объекты и данные.Metadata about the target instance of SQL ServerSQL Server that will receive the migrated objects and data.

  • SQL ServerSQL Server сведения о соединении.connection information.

  • Параметры проекта.Project settings.

При открытии проекта он отключается от Oracle и SQL ServerSQL Server .When you open a project, it is disconnected from Oracle and SQL ServerSQL Server. Это позволяет работать в автономном режиме.That lets you work offline. Сведения о повторном подключении к см SQL ServerSQL Server . в разделе подключение к SQL Server (OracleToSQL).For information about reconnecting to SQL ServerSQL Server, see Connecting to SQL Server (OracleToSQL).

Просмотр параметров проекта по умолчаниюReviewing Default Project Settings

SSMA содержит несколько параметров для преобразования и загрузки объектов базы данных, переноса данных и синхронизации SSMA с Oracle и SQL ServerSQL Server .SSMA contains several settings for converting and loading database objects, migrating data, and synchronizing SSMA with Oracle and SQL ServerSQL Server. Параметры по умолчанию подходят для многих пользователей.The default settings are appropriate for many users. Однако перед созданием нового проекта SSMA необходимо проверить параметры.However, before you create a new SSMA project, you should review the settings. При необходимости можно изменить параметры по умолчанию, которые будут использоваться для всех новых проектов.If you want to, you can change the default settings that will be used for all your new projects.

Проверка параметров проекта по умолчаниюTo review default project settings

  1. В меню Сервис выберите пункт Параметры проекта по умолчанию.On the Tools menu, click Default Project Settings.

  2. Выберите тип проекта в раскрывающемся списке версия целевого объекта миграции , для которого необходимо просмотреть или изменить параметры, а затем щелкните вкладку Общие .Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. На левой панели щелкните Преобразование.In the left pane, click Conversion.

  4. В области справа проверьте и при необходимости измените параметры.In the right pane, review and change the settings as necessary. Дополнительные сведения об этих параметрах см. в разделе Project settings (Conversion) (OracleToSQL).For more information about these settings, see Project Settings (Conversion) (OracleToSQL).

  5. Повторите шаги 1-3 для миграции, синхронизации, загрузки системных объектов, графического пользовательского интерфейса и сопоставления типов.Repeat Steps 1-3 for the Migration, Synchronization, Loading System Objects, GUI, and Type Mapping pages.

Создание новых проектовCreating New Projects

Чтобы перенести данные из баз данных Oracle в SQL ServerSQL Server , необходимо сначала создать проект.To migrate data from Oracle databases to SQL ServerSQL Server, you must first create a project.

Создание проектаTo create a project

  1. В меню Файл выберите пункт Создать проект.On the File menu, click New Project.

    Откроется диалоговое окно Создание проекта .The New Project dialog box appears.

  2. В поле Name введите имя проекта.In the Name box, enter a name for your project.

  3. В поле Расположение введите или выберите папку для проекта, а затем нажмите кнопку ОК.In the Location box, enter or select a folder for the project, and then click OK.

  4. В раскрывающемся списке Миграция выберите версию целевого объекта, SQL ServerSQL Server используемую для миграции.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. Доступны следующие варианты.The options available are:

    • SQL ServerSQL Server 20052005

    • SQL ServerSQL Server 20082008

    • SQL ServerSQL Server 20142014

    • SQL ServerSQL Server 20162016

    • База данных SQL AzureAzure SQL Database

Настройка параметров проектаCustomizing Project Settings

Помимо определения параметров проекта по умолчанию, которые применяются ко всем новым проектам SSMA, можно настроить параметры для каждого проекта.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. Дополнительные сведения см. в разделе Установка параметров проекта (OracleToSQL).For more information, see Setting Project Options (OracleToSQL).

При настройке сопоставления типов данных между исходной и целевой базами данных можно определить сопоставления на уровне проекта, базы данных или объекта.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Дополнительные сведения см. в разделе Сопоставление типов данных Oracle и SQL Server (OracleToSQL).For more information, see Mapping Oracle and SQL Server Data Types (OracleToSQL).

Сохранение проектовSaving Projects

При сохранении проекта SSMA сохраняет параметры проекта и при необходимости метаданные базы данных в файле проекта.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

Сохранение проектаTo save a project

  • В меню файл выберите команду сохранить проект.On the File menu, click Save Project.

    Если схемы в проекте были изменены или не были преобразованы, SSMA предложит загрузить и сохранить метаданные.If schemas in the project have changed or have not been converted, SSMA will prompt you to load and save metadata. Загрузка и сохранение метаданных позволит работать в автономном режиме.Loading and saving metadata will let you work offline. Она также позволяет отправить полный файл проекта другим пользователям, например техническому персоналу службы технической поддержки.It also lets you send a complete project file to other people, such as technical support personnel. Если будет предложено сохранить метаданные, выполните следующие действия.If you are prompted to save metadata, do the following:

    1. Для каждой схемы, отображающей состояние метаданных, установите флажок рядом с именем базы данных.For each schema that shows a status of Metadata missing, select the check box next to the database name.

      Сохранение метаданных может занять несколько минут.Saving metadata might take several minutes. Если вы не хотите сохранять метаданные, не выбирайте никакие флажки.If you do not want to save metadata yet, do not select any check boxes.

    2. Нажмите кнопку Сохранить .Click the Save button.

      SSMA будет анализировать схемы Oracle и сохранять метаданные в файл проекта.SSMA will parse the Oracle schemas and save the metadata to the project file.

Открытие проектовOpening Projects

При открытии проекта он отключается от Oracle и из SQL ServerSQL Server .When you open a project, it is disconnected from Oracle and from SQL ServerSQL Server. Это позволяет работать в автономном режиме.That lets you work offline. Чтобы обновить метаданные, загрузите объекты базы данных в SQL ServerSQL Server .To update metadata, load database objects into SQL ServerSQL Server. Для переноса данных необходимо повторно подключиться к Oracle и SQL ServerSQL Server .To migrate data, you must reconnect to Oracle and SQL ServerSQL Server.

Открытие проектаTo open a project

  1. Используйте одну из следующих процедур.Use one of the following procedures:

    • В меню файл укажите последние проекты, а затем щелкните проект, который нужно открыть.On the File menu, point to Recent Projects, and then click the project you want to open.

    • В меню файл выберите Открыть проект, найдите файл проекта. o2ssproj, выберите файл и нажмите кнопку Открыть.On the File menu, select Open Project, locate the .o2ssproj project file, select the file, and then click Open.

  2. Чтобы повторно подключиться к Oracle, в меню файл выберите команду Повторное подключение к Oracle.To reconnect to Oracle, on the File menu, click Reconnect to Oracle.

  3. Чтобы повторно подключиться к SQL ServerSQL Server , в меню файл выберите команду повторное подключение к SQL Server.To reconnect to SQL ServerSQL Server, on the File menu, click Reconnect to SQL Server.

Следующий шагNext Step

Следующим шагом процесса миграции является Подключение к Oracle Database (OracleToSQL).The next step in the migration process is to Connecting to Oracle Database (OracleToSQL).

См. также:See Also

Перенос баз данных Oracle в SQL Server (OracleToSQL)Migrating Oracle Databases to SQL Server (OracleToSQL)
Подключение к Oracle Database (OracleToSQL)Connecting to Oracle Database (OracleToSQL)
Подключение к SQL Server (OracleToSQL)Connecting to SQL Server (OracleToSQL)