Настройка меню и сочетаний клавишCustomize Menus and Shortcut Keys

ОБЛАСТЬ ПРИМЕНЕНИЯ ЭТОЙ СТАТЬИ: даSQL ServerдаБаза данных SQL AzureдаХранилище данных SQL AzureдаParallel Data WarehouseTHIS TOPIC APPLIES TO: yesSQL ServeryesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse

Сочетания клавиш позволяют выбрать команду меню или нажать кнопку путем нажатия клавиш ALT+.A keyboard accelerator allows you to select a menu command or button by pressing ALT+. Например, чтобы открыть меню Правка , нажмите клавиши ALT+E.For example, to open the Edit menu, press ALT+E. В диалоговом окне Настройка можно переставить и изменить кнопки панели инструментов, меню и команды меню.You can rearrange and modify toolbar buttons, menus, and menu commands by using the Customize dialog box. Имеются инструкции по изменению настроек с помощью мыши или только с помощью клавиатуры.Instructions are provided for changing the settings using the mouse and using only the keyboard.

Сочетания клавиш для хранимых процедур с использованием клавиши CTRL можно создать на странице Клавиатура диалогового окна Сервис/Параметры .Keyboard accelerators for stored procedures using the Ctrl key can be created from the Keyboard page of the Tools/Options dialog box.

Примечание

Для отображения только заголовков нажмите кнопку Свернуть все в верхней части этой страницы.Click Collapse All at the top of this page to show only the headings.

Открытие диалогового окна «Сочетания клавиш» с помощью мышиOpening the Keyboard Accelerator Dialog Box Using the Mouse

Открытие диалогового окна для назначения и изменения назначенных сочетаний клавиш (используя мышь)To access the dialog box for assigning or changing a keyboard accelerator (using the mouse)

  1. В меню Сервис выберите команду Настройка.On the Tools menu, click Customize.

  2. Убедитесь, что панель инструментов, которую хотите изменить, видима.Make sure the toolbar you want to change is visible.

    1. В диалоговом окне Настройка перейдите на вкладку Панели инструментов .In the Customize dialog box, click the Toolbars tab.

    2. Отметьте панель инструментов, которую хотите отобразить.Select the check box for the toolbar you want to display.

  3. В диалоговом окне Настройка выберите вкладку Команды .In the Customize dialog box, click the Commands tab.

Изменение сочетаний клавиш для кнопок панели инструментов с помощью мышиChanging a Toolbar Buttons Accelerator Key Using the Mouse

Назначение или изменение сочетания клавиш для кнопки панели инструментов (с помощью мыши)To assign or change a toolbar button's keyboard accelerator (using the mouse)

  1. Нажмите кнопку панели инструментов.Click the button on the toolbar.

  2. В диалоговом окне Настройка на вкладке Команды щелкните Изменить выбор.In the Customize dialog box, on the Commands tab, click Modify Selection.

  3. В поле Имя контекстного меню введите имя кнопки панели инструментов, поставив амперсанд (&) перед буквой, которую вы хотите назначить как клавишу быстрого выбора.In the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  4. Нажмите клавишу ВВОД.Press ENTER.

  5. В диалоговом окне Настройка нажмите Закрыть.In the Customize dialog box, click Close.

Изменение сочетаний клавиш для команд меню с помощью мышиChanging a Menu Commands Accelerator Key Using the Mouse

Назначение или изменение сочетания клавиш для команды меню (с помощью мыши)To assign or change a menu command's keyboard accelerator (using the mouse)

  1. Щелкните имя меню на панели меню или панели инструментов.Click the menu name on the menu bar or toolbar.

  2. Выберите команду меню.Click the menu command.

  3. В диалоговом окне Настройка нажмите кнопку Изменить выбор.In the Customize dialog box, click Modify Selection.

  4. В поле Имя контекстного меню введите имя команды меню, поставив амперсанд (&) перед буквой, которую вы хотите назначить как клавишу быстрого выбора.In the Name box on the shortcut menu, type a name for the menu command with an ampersand (&) before the letter that you want as the keyboard accelerator.

  5. Нажмите клавишу ВВОД.Press ENTER.

  6. В диалоговом окне Настройка нажмите Закрыть.In the Customize dialog box, click Close.

Открытие диалогового окна «Сочетания клавиш» с помощью клавиатурыOpening the Keyboard Accelerator Dialog Box Using the Keyboard

Открытие диалогового окна для назначения и изменения сочетаний клавиш (с помощью клавиатуры)To access the dialog box for assigning or changing a keyboard accelerator (using the keyboard)

  1. Нажмите клавиши ALT+T, затем введите "н", чтобы открыть диалоговое окно Настройка .Press ALT+T, then type C, to open the Customize dialog box.

  2. Убедитесь, что панель инструментов, которую хотите изменить, видима.Make sure the toolbar you want to change is visible.

    1. В диалоговом окне Настройка нажмите клавиши ALT+B, чтобы открыть вкладку Панели инструментов .In the Customize dialog box, press ALT+B to show the Toolbars tab.

    2. Используйте кнопки со стрелками для выбора отображаемой панели инструментов, затем нажмите клавишу ПРОБЕЛ , чтобы выбрать панель инструментов.Use the arrow keys to select the toolbar you want to display, then SPACE to select the check box.

  3. В диалоговом окне Настройка нажмите клавиши ALT+C, чтобы открыть вкладку Команды .In the Customize dialog box, press ALT+C to display the Commands tab.

Изменение сочетаний клавиш для кнопок панели инструментов с помощью клавиатурыChanging a Toolbar Buttons Accelerator Key Using the Keyboard

Назначение или изменение сочетания клавиш для кнопок панели инструментов (с помощью клавиатуры)To assign or change a toolbar button's keyboard accelerator (using the keyboard)

  1. Чтобы открыть диалоговое окно Изменение порядка команд , нажмите клавиши ALT+R.Press ALT+R to display the Rearrange Commands dialog box.

  2. В диалоговом окне Изменение порядка команд используйте клавиши со стрелками для выбора элемента Панель инструментов.In the Rearrange Commands dialog box, use the arrow keys to select Toolbar.

  3. Нажатием клавиши TAB переместитесь к списку Панель инструментов , затем используйте клавиши со стрелками для выбора кнопки, которую хотите изменить, и нажмите клавишу ВВОД.Tab to the Toolbar list, and use the arrow keys to select the toolbar that contains the button you want to change, and then press ENTER.

  4. Нажатием клавиши TAB переместитесь к списку Элементы управления и с помощью клавиш со стрелками выберите кнопку, которую хотите изменить.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  5. Нажмите клавиши ALT+M, чтобы выбрать элемент Изменить выделенный объект.Press ALT+M, to select Modify Selection.

  6. Нажатием клавиши TAB переместитесь к полю Имя контекстного меню выбранного объекта и введите имя кнопки панели инструментов, поставив амперсанд (&) перед буквой, которую вы хотите назначить как клавишу быстрого выбора.Tab to the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  7. Нажмите клавишу ВВОД.Press ENTER.

  8. Нажатием клавиши TAB переместитесь к кнопке Закрыть , затем нажмите клавишу ВВОД.Tab to the Close button, and then press ENTER.

Изменение сочетаний клавиш для команд меню с помощью клавиатурыChanging a Menu Commands Accelerator Key Using the Keyboard

Назначение или изменение сочетания клавиш для команды меню (с помощью клавиатуры)To assign or change a menu command's keyboard accelerator (using the keyboard)

  1. Чтобы открыть диалоговое окно Изменение порядка команд , нажмите клавиши ALT+R.Press ALT+R to display the Rearrange Commands dialog box.

  2. Нажатием клавиши TAB переместитесь к списку Строка меню , затем с помощью клавиш со стрелками выберите нужное меню в списке Строка меню и нажмите клавишу ВВОД.Tab to Menu Bar and then use the arrow keys to click the menu you want in the Menu Bar list, and then press ENTER.

  3. Нажатием клавиши TAB переместитесь к списку Элементы управления и с помощью клавиш со стрелками выберите кнопку, которую хотите изменить.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  4. Нажмите клавиши ALT+M, чтобы выбрать элемент Изменить выделенный объект.Press ALT+M, to select Modify Selection.

  5. Нажатием клавиши TAB переместитесь к полю Имя контекстного меню выбранного объекта и введите имя кнопки панели инструментов, поставив амперсанд (&) перед буквой, которую вы хотите назначить как клавишу быстрого выбора.Tab to the Name box on the shortcut menu, and type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  6. Нажмите клавишу ВВОД.Press ENTER.

  7. В диалоговом окне Настройка нажмите Закрыть.In the Customize dialog box, click Close.

Создание сочетания клавиш для хранимой процедурыCreating a Keyboard Accelerator for a Stored Procedure

Создание сочетания клавиш для хранимой процедурыTo create a keyboard accelerator for a stored procedure

  1. В меню Сервис выберите команду Параметры.On the Tools menu, click Options.

  2. На странице Клавиатура выберите неиспользуемое сочетание клавиш в списке Сочетания клавиш .On the Keyboard page, select an unused keyboard combination in the Shortcut list.

  3. В поле Хранимая процедура введите имя хранимой процедуры и затем нажмите кнопку ОК.In the Stored Procedure box, type the stored procedure name, and then click OK.

Добавление нового элемента к менюAdding a New Item to the Menu

Добавление нового элемента к менюTo add a new item to the menu

  1. В меню Сервис выберите команду Параметры.On the Tools menu, click Options.

  2. В диалоговом окне Настройка на вкладке Команды щелкните Создать меню.In the Customize dialog box, on the Commands tab, click New Menu.

  3. В поле Команды перетащите пункт Создать меню на панель меню и поместите его туда, где должно отображаться новое меню.On the Commands box, drag New Menu to the menu bar and drop it where you want the new menu to appear.

  4. В меню щелкните правой кнопкой пункт Создать менюи в поле Имя введите имя нового меню.On the menu, right-click New Menu, and in the Name box, type a name for the new menu.

  5. В диалоговом окне Настройка выберите категорию, например Файл, и выберите команду, например Открыть файл.In the Customize dialog box, select category such as File, and select a command such as Open File. Перетащите команду в новое меню.Drag the command to the new menu. При подведении курсора к новому меню оно будет развернуто.As you point to the new menu, the menu will expand. Поместите команду в развернутое меню.Drop the command onto the expanded menu.

  6. В диалоговом окне Настройка нажмите Закрыть.In the Customize dialog box, click Close.

Примечание

Некоторые команды доступны только при отображении в среде SQL Server Management Studio соответствующего содержимого.Some commands are available only when SQL Server Management Studio is displaying relevant content. Если команды в меню недоступны, элемент меню будет также недоступен.If no commands on the menu are available, the menu item will not be available.

См. также:See Also

Возможности среды SQL Server Management StudioFeatures in SQL Server Management Studio