Не удалось подключиться к Dynamics 365 версии 9.0 с помощью средств пакета SDK

В этой статье описывается решение проблемы, из-за которой не удается подключиться к Dynamics 365 версии 9.0 с помощью средств пакета SDK.

Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4077479

Симптомы

Не удается подключиться к Dynamics 365 версии 9.0 с помощью средств пакета SDK, таких как средство регистрации подключаемого модуля или средство миграции конфигурации. После указания сведений о подключении и нажатия кнопки Войти вы вернелись в диалоговое окно входа.

Причина

Это может произойти, если вы не используете последнюю версию средств пакета SDK, использующих TLS 1.2. Dynamics 365 (в сети) версии 9.0 требуется ПРОТОКОЛ TLS 1.2 или более поздней версии. TLS 1.0 и 1.1 больше не поддерживаются.

Решение

Скачайте последнюю версию средств пакета SDK из Nuget.

Дополнительная информация

Дополнительные сведения об изменении требования TLS 1.2 см. в статье Microsoft Dynamics 365 Customer Engagement (в сети) для требования TLS 1.2 для подключения.