Ошибка "Не удается подключиться к серверу Microsoft Dynamics CRM при попытке подключения Microsoft Dynamics CRM 2013 для Microsoft Office Outlook к CRM Online

В этой статье описано, как устранить ошибку, возникающую при попытке подключения Microsoft Dynamics CRM 2013 для Microsoft Office Outlook к CRM Online.

Область применения: Microsoft Dynamics CRM Online
Исходный номер базы знаний: 3089686

Симптомы

При попытке подключить Microsoft Dynamics CRM 2013 для Microsoft Office Outlook (клиент Outlook) к организации CRM Online возникает следующая ошибка:

"Не удается подключиться к серверу Microsoft Dynamics CRM, так как не удается проверить подлинность учетных данных. Проверьте подключение или обратитесь к администратору за дополнительной помощью".

При выборе пункта Сведения отображаются следующие дополнительные сведения:

Значение не может иметь значение NULL.
Имя параметра: path1
в System.IO.Path.Combine(String path1, String path2)
в Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(String environment)
в Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.GetLogonManager()
в Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
в Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
в Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, form parentWindow, Credential credentials)
в Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Причина

Помощник по входу в Microsoft Online Services не установлен или не указаны правильные имя пользователя и пароль. Если проблема вызвана неправильным именем пользователя или паролем, это могут быть учетные данные, которые кэшируются в диспетчере учетных данных Windows.

Разрешение

Если помощник по входу в Microsoft Online Services не установлен, установите его, используя соответствующую ссылку ниже. После установки закройте и снова откройте мастер настройки Microsoft Dynamics CRM для Microsoft Office Outlook.

Если помощник по входу в Microsoft Online Services уже установлен и вы по-прежнему получаете сообщение об ошибке, нажмите кнопку ОК , и появится запрос на ввод имени пользователя и пароля. Если имя пользователя и пароль уже заполнены, это означает, что учетные данные были кэшированы. Повторно введите правильное имя пользователя и пароль, чтобы убедиться, что неверные учетные данные не используются.

Примечание.

Чтобы узнать, хранятся ли учетные данные в диспетчере учетных данных Windows, выберите меню Пуск в Windows и введите Диспетчер учетных данных. В области Универсальные учетные данные могут отображаться учетные данные, которые начинаются с Microsoft_CRM. Если вы изменили пароль или используете другую учетную запись пользователя, эти сохраненные учетные данные могут быть неправильными. Эти учетные данные можно удалить, что не позволит Microsoft Dynamics CRM для Microsoft Office Outlook использовать их при попытке подключения.

Если ваша организация CRM Online уже обновлена до обновления 2015 (7.0 или более поздней версии), вы можете использовать Microsoft Dynamics CRM 2015 для Microsoft Office Outlook, который не использует помощник по входу в Microsoft Online Services.

Дополнительная информация

Если помощник по входу в Microsoft Online Services не установлен, файл журнала содержит следующую ошибку:

19:23:00| Ошибка| Ошибка при подключении к URL-адресу. https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc Исключение: System.DllNotFoundException: Помощник по входу в Microsoft Online Services не установлен. 32-разрядная: https://g.microsoftonline.com/0BX00en/500 64-разрядная: https://g.microsoftonline.com/0BX00en/501