Microsoft Dynamics CRM области предварительного просмотра и формы не отображаются данные в Outlook

В этой статье описывается решение проблемы, из-за чего Microsoft Dynamics CRM области предварительного просмотра или формы в нижней части окна не отображается никаких сведений.

Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 2617456

Симптомы

Если вы используете Microsoft Office Outlook и у вас установлен клиент Microsoft Dynamics CRM для Outlook, в области предварительного просмотра Microsoft Dynamics CRM или области формы в нижней части окна не отображается никаких сведений.

Причина

Эта проблема может быть вызвана одним из следующих условий.

Причина 1

Более ранняя версия Microsoft Office оставила ссылки на более старый файл библиотеки объектов (OLB). Обычно сюда входят более ранние версии основных сборок взаимодействия.

Причина 2

Временный каталог профиля пользователя содержит более 65 535 файлов. Outlook использует временные файлы для хранения области формы. Однако если временный каталог пользователя содержит более 65 535 файлов, Outlook не может инициализировать область формы.

Решение для причины 1

Важно!

В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому следует в точности выполнять приведенные инструкции. Для дополнительной защиты создайте резервную копию реестра, прежде чем редактировать его. Так вы сможете восстановить реестр, если возникнет проблема. Дополнительные сведения о резервном копировании и восстановлении реестра см. в статье Резервное копирование и восстановление реестра в Windows.

  1. Выберите Пуск, Все программы, Стандартные и Запустить.

  2. В диалоговом окне Выполнить введите regedit и нажмите кнопку ОК.

  3. В редакторе реестра найдите следующий куст:

    HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.3

  4. Найдите строковое значение PrimaryInteropAssemblyName , а затем определите версию, как показано в полужирном элементе в следующем примере:

    PrimaryInteropAssemblyName"="Microsoft.Office.Interop.Outlook, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C

Если версия — 12.0.0.0, необходимо удалить куст папки 9.3, так как это соответствует системе Microsoft Office 2007.

Решение для причины 2

  1. Выберите Пуск, Все программы, Стандартные и Запустить.
  2. В диалоговом окне Выполнить введите %localappdata%, а затем нажмите кнопку ОК.
  3. Откройте папку Temp.
  4. Удалите все файлы .tmp, начинающиеся с Olk.