При отправке сообщения электронной почты произошла неизвестная ошибка при тестировании и включении почтового ящика в Microsoft Dynamics 365

В этой статье описывается решение ошибки, возникающей при попытке протестировать и включить почтовый ящик в Microsoft Dynamics 365.

Применимо к: Microsoft Dynamics 365
Исходный номер базы знаний: 4092733

Симптомы

При попытке протестировать и включить почтовый ящик в Microsoft Dynamics 365 возникает следующая ошибка:

"При отправке сообщения электронной почты "Ваш почтовый ящик подключен к Dynamics 365 произошла неизвестная ошибка". <Имя> почтового ящика не синхронизировано. Владелец связанного профиля сервера <> электронной почты был уведомлен".

Если выбрать раздел Сведения , вы также можете увидеть дополнительные сведения, например следующий текст:

"Ошибка: System.Net.Mail.SmtpException: синтаксическая ошибка, команда не обнаружена. Ответ сервера:
в System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(результат IAsyncResult)
в System.Net.Mail.SmtpTransport.EndGetConnection(результат IAsyncResult)
в System.Net.Mail.SmtpClient.ConnectCallback(результат IAsyncResult)"

Причина

Эта ошибка может возникнуть, если значение исходящего порта в разделе Дополнительно профиля сервера электронной почты неправильно.

Решение

Для устранения данной проблемы выполните следующие действия.

  1. Перейдите в раздел Параметры, Email Конфигурация, а затем выберите Email Профили сервера.

  2. Откройте профиль сервера Email, используемый почтовым ящиком с этой ошибкой.

    Примечание.

    Вы также можете выбрать имя профиля сервера Email в сообщении об ошибке. Он отображается в виде гиперссылки, которая открывает правильную запись профиля сервера Email.

  3. Выберите Дополнительно.

  4. Исправьте значение исходящего порта и нажмите кнопку Сохранить.

    Примечание.

    Сведения о правильных портах, используемых при подключении к службе SMTP, см. в документации от поставщика электронной почты. Для Gmail порт равен 587.

  5. Выберите Почтовые ящики , а затем выберите почтовый ящик, в который поступила ошибка.

  6. Нажмите кнопку Тестировать & включить почтовые ящики .

  7. После завершения тестов откройте запись почтового ящика и просмотрите раздел Оповещения , если результаты не отображаются как Успешно.