Ошибки возникают при отправке от имени или от имени другого пользователя при использовании маршрутизатора Dynamics CRM Email с Exchange Online

В этой статье описывается решение проблемы, из-за чего при использовании маршрутизатора Microsoft Dynamics CRM Email с Microsoft Office 365 Exchange Online могут возникать сообщения об ошибках.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 2708727

Симптомы

При использовании маршрутизатора Microsoft Dynamics CRM Email с Microsoft Office 365 Exchange Online могут возникнуть следующие ошибки:

Учетная запись пользователя, которая использовалась для отправки этого запроса, не имеет права отправлять почту от имени указанной учетной записи отправки.

Указанные учетные данные доступа имеют недостаточные разрешения делегата для отправки сообщения электронной почты. Обратитесь к администратору Microsoft Exchange, чтобы предоставить необходимые разрешения.

Причина

Эти ошибки возникают, если у пользователя администратора, настроенного в профиле исходящей почты маршрутизатора Microsoft Dynamics CRM Email, отсутствуют разрешения "Отправить как" или "Делегировать" в почтовом ящике, используемом для отправки электронной почты. Администраторы и пользователи в Office 365 Exchange Online по умолчанию не имеют разрешений на отправку как или делегирование доступа.

Решение

Чтобы устранить эту проблему, настройка администратора в профиле исходящих Microsoft Dynamics CRM Email маршрутизатора должна быть предоставлена разрешение "Отправить как", если разрешение "Отправить как" отмечено. Если делегированный доступ помечен в профиле исходящей почты, пользователю должны быть предоставлены разрешения на полный доступ для почтового ящика, так как делегирование доступа не может быть явно определено с помощью Exchange Online. Они добавляются с Windows PowerShell. Дополнительные сведения см. в разделе: