В почтовом ящике Microsoft Dynamics 365 появляется ошибка "Http-сервер вернул запрещено исключение"

В этой статье описано, как устранить ошибку, возникающую при нажатии кнопки Проверить & включить почтовый ящик в записи почтового ящика в Dynamics 365.

Применимо к: Microsoft Dynamics 365
Исходный номер базы знаний: 4483440

Симптомы

При нажатии кнопки Тест & Включить почтовый ящик для записи почтового ящика в Dynamics 365 в разделе результатов теста отображается сбой и регистрируется следующее оповещение:

Сообщение электронной почты "Ваш почтовый ящик теперь подключен к Dynamics 365" не может быть отправлено, так как произошла ошибка при установке безопасного подключения к серверу электронной почты. Почтовый ящик [имя почтового ящика] не синхронизирован. Владелец профиля сервера электронной почты Microsoft Exchange Online уведомлен.
код ошибки сервера Email: http-сервер вернул исключение Запрещено.

При выборе пункта Сведения отображаются следующие другие сведения:

"Ошибка: System.Net.WebException: запрос завершился ошибкой с состоянием HTTP 403: Запрещено.
в system.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, boolean asyncCall)
в System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
в Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
в Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()"

Причина

Dynamics 365 взаимодействует с Microsoft Exchange с помощью запросов веб-служб Exchange (EWS). Если служба EWS отключена, возникнет эта ошибка. Ниже приведены некоторые возможные способы отключения или ограничения EWS в Exchange.

  1. EWS отключен для почтового ящика
  2. EWS отключен для всей организации
  3. Параметр EwsApplicationAccessPolicy имеет значение EnforceAllowList и the EwsAllowList не разрешает доступ из Dynamics 365 (CRM).
  4. Параметр EwsApplicationAccessPolicy имеет значение EnforceBlockList и the EwsBlockList включает Dynamics 365 (CRM).

Разрешение

Если проблема возникает только для некоторых почтовых ящиков, проверка, если EWS отключен для почтового ящика:

  1. Сначала проверка, чтобы узнать, отключен ли EWS для почтового ящика. Используйте следующую команду PowerShell:

    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. Если для EwsEnabled задано значение False, используйте следующую команду PowerShell, чтобы включить веб-службы Exchange (EWS) для почтового ящика:

    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    Важно!

    После выполнения этой команды может потребоваться до 120 минут, прежде чем изменение параметра вступит в силу.

Если проблема возникает для всех почтовых ящиков, проверка, отключен ли EWS на уровне организации или используется ли EwsAllowList для ограничения разрешенного трафика EWS.

  1. Используйте следующую команду PowerShell, чтобы узнать, настроены ли какие-либо параметры EWS:

    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. Убедитесь, что для EwsEnabled не задано значение False. Следующую команду можно использовать, чтобы задать для EwsEnabledзначение True , если в настоящее время задано значение False:

    Set-OrganizationConfig -EwsEnabled $True
    

    Важно!

    После выполнения этой команды может потребоваться до 120 минут, прежде чем изменение параметра вступит в силу.

  3. Если EwsApplicationAccessPolicy задано значение EnforceAllowList и EwsAllowList не содержит значения для CRM (пример: CRM/*), что не позволит Dynamics 365 (CRM) взаимодействовать с Exchange. Используйте следующую команду, чтобы обновить список, чтобы включить CRM/* и любые другие приложения, которые вы хотите разрешить (<PreviousAllowList> в следующем примере):

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    Важно!

    После выполнения этой команды может потребоваться до 120 минут, прежде чем изменение параметра вступит в силу.

  4. Если EwsApplicationAccessPolicy задано значение EnforceBlockList и EwsAllowList содержит значение crm (пример: CRM/*), которое не позволит Dynamics 365 (CRM) взаимодействовать с Exchange. Используйте следующую команду, чтобы обновить список, чтобы больше не включать CRM:

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    Важно!

    После выполнения этой команды может потребоваться до 120 минут, прежде чем изменение параметра вступит в силу.

Дополнительная информация

Дополнительные сведения об изменении параметров Exchange с помощью PowerShell и управлении доступом к EWS см. в следующих статьях: