Вы получаете сообщения о сбое состояния задания в Data Protection Manager

Эта статья поможет устранить проблему, при которой возникают сообщения о сбое состояния задания, если компонент мониторинга в реальном времени антивирусной программы настроен для мониторинга реплик и передачи файлов журналов для защищенных томов Data Protection Manager.

Исходная версия продукта: System Center Data Protection Manager
Оригинальный номер базы знаний: 928840

Симптомы

После настройки Microsoft System Center Data Protection Manager для защиты данных на одном или нескольких файловом сервере возникают следующие симптомы:

  • Файловые серверы содержат несогласованные реплики.

  • При использовании консоли администрирования Data Protection Manager вы заметили, что скорость передачи данных может случайным образом замедляться.

  • Задания репликации данных могут завершиться сбоем на одном или нескольких файловом сервере. В этом случае на затронутых файловых серверах создаются сведения о состоянии задания, похожие на следующее:

    Сообщение о состоянии 1

    Тип: проверка согласованности
    Состояние: сбой
    Описание. Службе DPM не удалось связаться с агентом файлов DPM на локальном узле сервера. (Id 52 Details: указанное сетевое имя больше не доступно (0x80070040))
    Время начала: <startTime>
    Затраченное время: <затраченное время>
    Переданные данные: 118,51 ГБ (127253828784 байт)
    Скорость передачи данных: 464 КБ/с
    Сведения об источнике: <Volume> on <ServerName>
    Члены группы защиты: 7
    Подробно
    Группа защиты: <ProtectionGroup>

    Сообщение о состоянии 2

    Тип: Синхронизация
    Состояние: сбой
    Описание: реплика на сервере DPM для <параметра Volume> on <ServerName> является несогласованным. Изменения не могут быть применены к filePath><. (Идентификатор 109 Подробности. Процесс не может получить доступ к файлу, так как он используется другим процессом (0x80070020))
    Время начала: <startTime>
    Затраченное время: <затраченное время>
    Переданные данные: 1,79 ГБ (1916715024 байт)
    Скорость передачи данных: 100 КБ/с
    Сведения об источнике: <Volume> on <ServerName>
    Члены группы защиты: 7
    Подробно
    Группа защиты: <ProtectionGroup>

    Сообщение о состоянии 3

    Тип: Синхронизация
    Состояние: сбой
    Описание: реплика на сервере DPM для <параметра Volume> on <ServerName> является несогласованным. Изменения не могут быть применены к filePath><. (Идентификатор 109. Сведения: доступ запрещен (0x80070005))
    Время начала: <startTime>
    Затраченное время: <затраченное время>
    Переданные данные: 1,57 ГБ (1691028040 байт)
    Скорость передачи данных: 207 КБ/с
    Сведения об источнике: <Volume> on <ServerName>
    Члены группы защиты: 2
    Подробно
    Группа защиты: <ProtectionGroup>

    Сообщение о состоянии 4

    Тип: Синхронизация
    Состояние: сбой
    Описание: реплика на сервере DPM для <параметра Volume> on <ServerName> является несогласованным. Изменения не могут быть применены к filePath><. (Идентификатор 109 Details. Система не может найти указанный путь (0x80070003))
    Время начала: <startTime>
    Затраченное время: <затраченное время>
    Переданные данные: 116,74 МБ (122411432 байтов)
    Скорость передачи данных: 221 КБ/с
    Сведения об источнике: <Volume> on <ServerName>
    Члены группы защиты: 2
    Группа защиты сведений: <ProtectionGroup>

    Примечание.

    Вы также можете получать другие сообщения о сбое состояния задания.

  • Синхронизация Data Protection Manager может завершиться ошибкой. В этом случае вы получаете сообщения о состоянии, похожие на одно из следующих:

    Сообщение о состоянии 1

    Описание. Начиная с <даты и времени> задания синхронизации для <пути> на <сервере ServerName> завершаются сбоем. Общее число неудачных заданий = 4. Последнее задание завершилось сбоем по следующей причине: (идентификатор 3115) DPM не удалось завершить это задание в течение времени, выделенного для набора заданий, связанных с этой группой защиты. (идентификатор 3151).

    Сообщение о состоянии 2

    Тип: Синхронизация
    Состояние: сбой
    Описание. Реплика на сервере DPM для <пути> в <serverName> не является. Изменения не могут быть применены к пути к файлу< и имени >файла. (Идентификатор 109 Подробности: доступ запрещен (0x80070005)
    Время начала: <дата и время>
    Затраченное время: <затраченное время>
    Переданные данные: 18,75 МБ (19662648 байт)
    Скорость передачи данных: 83 КБ/с
    Сведения об источнике: <путь> к <serverName>
    Группа защиты: <ProtectionGroup>

Причина

Эта проблема может возникнуть, если компонент мониторинга в реальном времени антивирусной программы настроен для мониторинга реплик и передачи файлов журналов для защищенных томов Data Protection Manager. Эта проблема может возникнуть, если компонент мониторинга в реальном времени антивирусной программы отслеживает программу Msdpmfsagent.exe на сервере Data Protection Manager.

Разрешение

Чтобы устранить эту проблему, см. статью Запуск антивирусной программы на сервере DPM.

Дополнительная информация

Мониторинг реплик и файлов журнала передачи антивирусной программы в режиме реального времени снижает производительность в Data Protection Manager. Это происходит из-за того, что процесс мониторинга в режиме реального времени заставляет антивирусную программу сканировать журналы передачи каждый раз, когда Data Protection Manager синхронизируется с файловый сервер. Кроме того, процесс мониторинга в режиме реального времени заставляет антивирусную программу сканировать все затронутые файлы каждый раз, когда Data Protection Manager применяет изменения к репликам.

Рекомендуется настроить антивирусную программу для удаления зараженных файлов с файловых серверов и сервера Data Protection Manager, а не использовать функцию карантина для архивации зараженных файлов. Это помогает предотвратить повреждение данных реплик и теневых копий.

Если антивирусная программа настроена для автоматической очистки и карантина зараженного файла, антивирусная программа изменяет файл. Однако Data Protection Manager не может обнаружить эти изменения в файле. Когда Data Protection Manager пытается синхронизировать реплика, измененный другой программой, реплика и теневые копии файла могут быть повреждены. Дополнительные сведения о настройке антивирусной программы для удаления зараженных файлов см. в документации по программе или обратитесь к производителю антивирусной программы.