Начало работы с инструментами Visual Studio для UnityGet started with Visual Studio Tools for Unity

Установка Visual StudioInstall Visual Studio

Пакетная установка UnityUnity bundled installation

Начиная с Unity 2018.1, Visual Studio по умолчанию является редактором скриптов на C# для Unity и входит в помощник по загрузке Unity, а также в средство установки Unity Hub.Starting with Unity 2018.1, Visual Studio is the default C# script editor for Unity, and is included in the Unity Download Assistant, as well as the Unity Hub installation tool.

Во время установки убедитесь, что Visual Studio отмечена в списке компонентов, устанавливаемых с Unity:During installation, ensure that Visual Studio is checked in the list of components to install with Unity:

Unity HubUnity Hub

установка unity hub

установка unity hub

Помощник по загрузке UnityUnity Download Assistant

установка помощника по загрузке Unity

Версия Visual Studio, которая входит в установку Unity, может не быть последней.The version of Visual Studio included with your Unity installation may not be the latest. Например, если вас просят установить Visual Studio 2017, рекомендуется вручную установить более новую версию Visual Studio.If you are asked to install Visual Studio 2017, then we recommend manually installing a newer version of Visual Studio.

Установка вручнуюManual installation

Если у вас уже установлено решение Visual Studio или вы предпочитаете выполнить установку вручную, запустите установщик Visual Studio.If you already have Visual Studio installed, or prefer to manually install, run the Visual Studio installer.

  1. Загрузите установщик Visual Studio или запустите его (если он был ранее установлен).Download the Visual Studio installer, or open it if already installed.

  2. Щелкните Изменить (если установлено) или Установка (для новой установки) для требуемой версии Visual Studio.Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. На вкладке Рабочие нагрузки прокрутите до раздела Mobile & Gaming (Мобильные приложения и игры) и выберите рабочую нагрузку Game development with Unity (Разработка игр с помощью Unity).On the Workloads tab, scroll to the Mobile & Gaming section and select the Game development with Unity workload.

    Рабочая нагрузка Unity

    Рабочая нагрузка Unity

  4. Щелкните Изменить (если установлено) или Установка (для новой установки) в правом нижнем углу окна установки.Click Modify (if already installed) or Install (for new installations) in the bottom-right corner of the installer window.

Проверка обновления Visual StudioCheck for updates to Visual Studio

Рекомендуется проверить наличие обновлений из Visual Studio, чтобы использовать новейшие функции и инструменты.It is recommended to check for updates within Visual Studio to ensure you have access to the latest tools and features. Это не приведет к повреждению вашего проекта Unity.This will not break your Unity project.

Настройка Unity для работы с Visual StudioConfigure Unity for use with Visual Studio

Начиная с Unity 2018.1 Visual Studio будет внешним редактором скриптов по умолчанию для Unity.Starting with Unity 2018.1, Visual Studio should be the default external script editor in Unity. Вы можете подтвердить это или изменить внешний редактор скриптов на определенную версию Visual Studio.You can confirm this or change the external script editor to a specific version of Visual Studio:

  1. Выберите Параметры в меню Изменить.Select Preferences from the Edit menu.

    Выберите "Параметры"

    Выберите "Параметры"

  2. В диалоговом окне параметров откройте вкладку Внешние инструменты.In the Preferences dialog, select the External Tools tab.

  3. В раскрывающемся списке внешнего редактора скриптов выберите необходимую версию элемента Visual Studio, если она присутствует, в противном случае нажмите кнопку Обзор... .From the External Script Editor dropdown list, choose your desired version of Visual Studio if it is listed, otherwise select Browse....

    Выберите Visual Studio

    Выберите Visual Studio

  4. Если было выбрано Обзор... , необходимо перейти в каталог Common7/IDE, находящийся в каталоге установки Visual Studio, и выбрать файл devenv.exe.If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. Затем щелкните Открыть.Then click Open.

    Выберите "Открыть"

    Выберите "Открыть"

  5. После выбора Visual Studio из списка внешнего редактора скриптов, убедитесь, что флажок Editor Attaching (Присоединение редактора) установлен.Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. Чтобы завершить процесс настройки, закройте диалоговое окно Параметры.Close the Preferences dialog to complete the configuration process.

Поддержка устаревших версийSupport for older versions

Загрузите и установите Инструменты Visual Studio для Unity из Visual Studio Marketplace.Download and install Visual Studio Tools for Unity from the Visual Studio Marketplace. Необходимо установить нужный пакет для вашей версии Visual Studio.You'll need to install the right package for your version of Visual Studio.

Примечание

Для инструментов Visual Studio для Unity требуется Unity версии не ниже чем 5.2, а также версия Visual Studio, поддерживающая расширения, например Visual Studio Community, Professional, Premium или Enterprise.Visual Studio Tools for Unity requires Unity 5.2 and above, as well as a version of Visual Studio that supports extensions, such as Visual Studio Community, Professional, Premium, or Enterprise. Чтобы убедиться, что Инструменты Visual Studio для Unity включены в вашу версию Unity, выберите About Unity (О программе Unity) в меню Справка и найдите текст "Microsoft Visual Studio Tools for Unity enabled" (Инструменты Microsoft Visual Studio для Unity включены) в левом нижнем углу диалогового окна.To verify that Visual Studio Tools for Unity are enabled in your installation of Unity, select About Unity from the Help menu and look for the text "Microsoft Visual Studio Tools for Unity enabled" in the bottom-left of the dialog. О программе Unityabout Unity

Следующие шагиNext steps

Сведения о работе с проектом Unity и его отладке в Visual Studio см. в статье Инструменты Visual Studio для Unity.To learn how to work with and debug your Unity project in Visual Studio, see Visual Studio Tools for Unity.