Создание базы данных и добавление таблиц в Visual StudioCreate a database and add tables in Visual Studio

Visual Studio можно использовать для создания и обновления файла локальной базы данных в SQL Server Express LocalDB.You can use Visual Studio to create and update a local database file in SQL Server Express LocalDB. Можно также создать базу данных, выполнив инструкции Transact-SQL в окне Обозреватель объектов SQL Server инструментов в Visual Studio.You can also create a database by executing Transact-SQL statements in the SQL Server Object Explorer tool window in Visual Studio. В этом разделе мы создадим MDF файл и добавим таблицы и ключи с помощью Конструктор таблиц.In this topic, we'll create an .mdf file and add tables and keys by using the Table Designer.

PrerequisitesPrerequisites

Для выполнения этого пошагового руководства вам потребуются рабочие нагрузки .NET для настольных приложений и хранения и обработки данных , установленные в Visual Studio.To complete this walkthrough, you'll need the .NET desktop development and Data storage and processing workloads installed in Visual Studio. Чтобы установить их, откройте Visual Studio Installer и выберите изменить (или несколько > изменить) рядом с версией Visual Studio, которую необходимо изменить.To install them, open Visual Studio Installer and choose Modify (or More > Modify) next to the version of Visual Studio you want to modify.

Создание проекта и файла локальной базы данныхCreate a project and a local database file

  1. Создайте новый проект приложения Windows Forms и назовите его сампледатабасевалксраугх.Create a new Windows Forms App project and name it SampleDatabaseWalkthrough.

  2. В строке меню выберите проект > Добавить новый элемент.On the menu bar, select Project > Add New Item.

  3. В списке шаблонов элементов прокрутите вниз и выберите база данных на основе службы.In the list of item templates, scroll down and select Service-based Database.

    Диалоговое окно ''Шаблоны элементов''

  4. Присвойте базе данных имя сампледатабасеи нажмите кнопку Добавить.Name the database SampleDatabase, and then click Add.

Добавление источника данныхAdd a data source

  1. Если окно Источники данных не открыто, откройте его, нажав клавиши Shift+ALT+D или выбрав View > другие окна > Источники данных в строке меню.If the Data Sources window isn't open, open it by pressing Shift+Alt+D or selecting View > Other Windows > Data Sources on the menu bar.

  2. В окне Источники данных выберите Добавить новый источник данных.In the Data Sources window, select Add New Data Source.

    Добавление нового источника данных в Visual Studio

    Открывается мастер настройки источника данных.The Data Source Configuration Wizard opens.

  3. На странице Выбор типа источника данных выберите база данных , а затем нажмите кнопку Далее.On the Choose a Data Source Type page, choose Database and then choose Next.

  4. На странице Выбор модели базы данных нажмите кнопку Далее , чтобы принять значение по умолчанию (набор данных).On the Choose a Database Model page, choose Next to accept the default (Dataset).

  5. На странице Выбор подключения к данным выберите файл сампледатабасе. mdf в раскрывающемся списке и нажмите кнопку Далее.On the Choose Your Data Connection page, select the SampleDatabase.mdf file in the drop-down list, and then choose Next.

  6. На странице сохранить строку подключения в файле конфигурации приложения нажмите кнопку Далее.On the Save the Connection String to the Application Configuration File page, choose Next.

  7. На странице Выбор объектов базы данных появится сообщение о том, что база данных не содержит объектов.On the Choose your Database Objects page, you'll see a message that says the database doesn't contain any objects. Нажмите кнопку Готово.Choose Finish.

Просмотр свойств подключения к даннымView properties of the data connection

Чтобы просмотреть строку подключения для файла сампледатабасе. mdf , откройте окно свойств подключения к данным:You can view the connection string for the SampleDatabase.mdf file by opening the Properties window of the data connection:

  • Выберите View > Обозреватель объектов SQL Server , чтобы открыть окно Обозреватель объектов SQL Server .Select View > SQL Server Object Explorer to open the SQL Server Object Explorer window. Разверните узел (LocalDB) \MSSQLLocalDB > базы данных, а затем щелкните правой кнопкой мыши сампледатабасе. mdf и выберите пункт Свойства.Expand (localdb)\MSSQLLocalDB > Databases, and then right-click on SampleDatabase.mdf and select Properties.

  • Кроме того, можно выбрать представление > Обозреватель сервера, если это окно еще не открыто.Alternatively, you can select View > Server Explorer, if that window isn't already open. Откройте окно свойств, развернув узел подключения к данным , щелкнув правой кнопкой мыши сампледатабасе. mdfи выбрав пункт Свойства.Open the Properties window by expanding the Data Connections node, right-clicking on SampleDatabase.mdf, and then selecting Properties.

    Tip

    Если вы не можете развернуть узел подключения к данным или подключение Сампледатабасе. mdf отсутствует в списке, нажмите кнопку подключиться к базе данных на панели инструментов Обозреватель сервера.If you can't expand the Data Connections node, or the SampleDatabase.mdf connection is not listed, select the Connect to Database button in the Server Explorer toolbar. В диалоговом окне Добавление соединения убедитесь, что в поле источник данныхвыбран Microsoft SQL Server файл базы данных , а затем найдите и выберите файл сампледатабасе. mdf.In the Add Connection dialog box, make sure that Microsoft SQL Server Database File is selected under Data source, and then browse to and select the SampleDatabase.mdf file. Завершите добавление подключения, нажав кнопку ОК.Finish adding the connection by selecting OK.

Создание таблиц и ключей с помощью конструктор таблицCreate tables and keys by using Table Designer

В этом разделе вы создадите две таблицы, первичный ключ в каждой таблице и несколько строк образца данных.In this section, you'll create two tables, a primary key in each table, and a few rows of sample data. Вы также создадите внешний ключ, чтобы указать, как записи в одной таблице соответствуют записям в другой таблице.You'll also create a foreign key to specify how records in one table correspond to records in the other table.

Создание таблицы CustomersCreate the Customers table

  1. В Обозреватель сервераразверните узел подключения к данным , а затем узел сампледатабасе. mdf .In Server Explorer, expand the Data Connections node, and then expand the SampleDatabase.mdf node.

    Если вы не можете развернуть узел подключения к данным или подключение Сампледатабасе. mdf отсутствует в списке, нажмите кнопку подключиться к базе данных на панели инструментов Обозреватель сервера.If you can't expand the Data Connections node, or the SampleDatabase.mdf connection is not listed, select the Connect to Database button in the Server Explorer toolbar. В диалоговом окне Добавление соединения убедитесь, что в поле источник данныхвыбран Microsoft SQL Server файл базы данных , а затем найдите и выберите файл сампледатабасе. mdf.In the Add Connection dialog box, make sure that Microsoft SQL Server Database File is selected under Data source, and then browse to and select the SampleDatabase.mdf file. Завершите добавление подключения, нажав кнопку ОК.Finish adding the connection by selecting OK.

  2. Щелкните правой кнопкой мыши таблицы и выберите команду Добавить новую таблицу.Right-click on Tables and select Add New Table.

    Будет открыт Конструктор таблиц, отобразится сетка с одной строкой по умолчанию, которая представляет один столбец в создаваемой таблице.The Table Designer opens and shows a grid with one default row, which represents a single column in the table that you're creating. Путем добавления строк в сетку будут добавлены столбцы в таблицу.By adding rows to the grid, you'll add columns in the table.

  3. В сетке добавьте строку для каждой из следующих записей.In the grid, add a row for each of the following entries:

    Имя столбцаColumn name Тип данныхData type Разрешить значения nullAllow nulls
    CustomerID nchar(5) False (не установлен)False (cleared)
    CompanyName nvarchar(50) False (не установлен)False (cleared)
    ContactName nvarchar (50) True (установлен)True (selected)
    Phone nvarchar (24) True (установлен)True (selected)
  4. Щелкните правой кнопкой мыши CustomerID строку и выберите Задать первичный ключ.Right-click on the CustomerID row, and then select Set Primary Key.

  5. Щелкните правой кнопкой мыши строку по умолчанию (Id), а затем выберите Удалить.Right-click on the default row (Id), and then select Delete.

  6. Назовите таблицу "Клиенты" путем обновления первой строки в области скриптов, как показано в следующем примере:Name the Customers table by updating the first line in the script pane to match the following sample:

    CREATE TABLE [dbo].[Customers]
    

    Результат должен быть примерно таким:You should see something like this:

    конструктор таблиц

  7. В левом верхнем углу Конструктор таблицвыберите Обновить.In the upper-left corner of Table Designer, select Update.

  8. В диалоговом окне Предварительный просмотр обновлений базы данных выберите обновить базу данных.In the Preview Database Updates dialog box, select Update Database.

    Таблица Customers создается в файле локальной базы данных.The Customers table is created in the local database file.

Создание таблицы OrdersCreate the Orders table

  1. Создайте еще одну таблицу, а затем добавьте строку для каждой записи следующей таблицы.Add another table, and then add a row for each entry in the following table:

    Имя столбцаColumn name Тип данныхData type Разрешить значения nullAllow nulls
    OrderID int False (не установлен)False (cleared)
    CustomerID nchar(5) False (не установлен)False (cleared)
    OrderDate datetime True (установлен)True (selected)
    OrderQuantity int True (установлен)True (selected)
  2. Задайте OrderID в качестве первичного ключа, а затем удалите строку по умолчанию.Set OrderID as the primary key, and then delete the default row.

  3. Назовите таблицу "Заказы" путем обновления первой строки в области скриптов, как показано в следующем примере:Name the Orders table by updating the first line in the script pane to match the following sample:

    CREATE TABLE [dbo].[Orders]
    
  4. В левом верхнем углу Конструктор таблицвыберите Обновить.In the upper-left corner of the Table Designer, select Update.

  5. В диалоговом окне Предварительный просмотр обновлений базы данных выберите обновить базу данных.In the Preview Database Updates dialog box, select Update Database.

    Таблица Orders создается в файле локальной базы данных.The Orders table is created in the local database file. Если развернуть узел таблицы в обозреватель сервера, отобразятся две таблицы:If you expand the Tables node in Server Explorer, you see the two tables:

    Узел таблиц, развернутый в обозреватель сервера

Создание внешнего ключаCreate a foreign key

  1. В контекстной области в правой части сетки конструктор таблиц для таблицы Orders щелкните правой кнопкой мыши внешние ключи и выберите Добавить новый внешний ключ.In the context pane on the right side of the Table Designer grid for the Orders table, right-click on Foreign Keys and select Add New Foreign Key.

    Добавление внешнего ключа в конструктор таблиц в Visual Studio

  2. В появившемся текстовом поле замените текст ToTable на Customers.In the text box that appears, replace the text ToTable with Customers.

  3. На панели T-SQL обновите последнюю строку, чтобы она соответствовала следующему примеру:In the T-SQL pane, update the last line to match the following sample:

    CONSTRAINT [FK_Orders_Customers] FOREIGN KEY ([CustomerID]) REFERENCES [Customers]([CustomerID])
    
  4. В левом верхнем углу Конструктор таблицвыберите Обновить.In the upper-left corner of the Table Designer, select Update.

  5. В диалоговом окне Предварительный просмотр обновлений базы данных выберите обновить базу данных.In the Preview Database Updates dialog box, select Update Database.

    Создается внешний ключ.The foreign key is created.

Заполнение таблиц даннымиPopulate the tables with data

  1. В Обозреватель сервера или Обозреватель объектов SQL Serverразверните узел образца базы данных.In Server Explorer or SQL Server Object Explorer, expand the node for the sample database.

  2. Откройте контекстное меню для узла таблицы , выберите Обновить, а затем разверните узел таблицы .Open the shortcut menu for the Tables node, select Refresh, and then expand the Tables node.

  3. Откройте контекстное меню таблицы Customers и выберите команду отобразить данные таблицы.Open the shortcut menu for the Customers table, and then select Show Table Data.

  4. Добавьте необходимые данные для некоторых клиентов.Add whatever data you want for some customers.

    Можно указать любые пять символов как ИД клиентов, но хотя бы один нужно выбрать и запомнить для дальнейшего использования в этой процедуре.You can specify any five characters you want as the customer IDs, but choose at least one that you can remember for use later in this procedure.

  5. Откройте контекстное меню таблицы Orders и выберите пункт отобразить данные таблицы.Open the shortcut menu for the Orders table, and then select Show Table Data.

  6. Добавление данных для некоторых заказов.Add data for some orders.

    Important

    Убедитесь, что все идентификаторы заказов и количества заказов — целые числа, и каждый идентификатор клиента соответствует значению, указанному в столбце CustomerID таблицы клиентов.Make sure that all order IDs and order quantities are integers and that each customer ID matches a value that you specified in the CustomerID column of the Customers table.

  7. В строке меню выберите файл > сохранить все.On the menu bar, select File > Save All.

См. также:See also