Удаленная отладкаRemote Debugging

Вы можете отладить приложение Visual Studio, развернутое на другом компьютере.You can debug a Visual Studio application that has been deployed on a different computer. Для этого используется удаленный отладчик Visual Studio.To do so, you use the Visual Studio remote debugger.

Для углубленных инструкций по удаленной отладке см.For in-depth instructions on remote debugging, see these topics.

СценарийScenario СсылкаLink
Служба приложений AzureAzure App Service Снимок отладчик или удаленная отладка ASP.NET на AzureSnapshot Debugger or Remote debug ASP.NET on Azure
AzureAzure VM Удаленная отладка ASP.NET в AzureRemote debug ASP.NET on Azure
Azure Service FabricAzure Service Fabric Отчерепное приложение Azure Service FabricDebug an Azure Service Fabric application
ASP.NETASP.NET Дистанционная отладка ASP.NET ядра или ASP.NET удаленного отладкиRemote debug ASP.NET Core or Remote Debug ASP.NET
C# или Visual BasicC# or Visual Basic Удаленная отладка проекта C# или Visual BasicRemote debug a C# or Visual Basic project
C++C++ Дистанционное отладка проекта СЗЗRemote debug a C++ project
Универсальные приложения для Windows (UWP)Universal Windows Apps (UWP) Запуск приложений UWP на удаленной машине или отожоблить установленный пакет приложенийRun UWP apps on a remote machine or Debug an installed app package

Если вы просто хотите загрузить и установить удаленный отладчик и не нуждаетесь в дополнительных инструкциях для вашего сценария, выполните последующие шаги в этой статье.If you just want to download and install the remote debugger and don't need any additional instructions for your scenario, follow the steps in this article.

Скачивание и установка инструментов удаленной отладкиDownload and Install the remote tools

На удаленном устройстве или сервер, который требуется отладить на, а не компьютера с Visual Studio Загрузите и установите правильную версию инструментов удаленной отладки по ссылкам в следующей таблице.On the remote device or server that you want to debug on, rather than the Visual Studio machine, download and install the correct version of the remote tools from the links in the following table.

  • Скачайте последние инструменты удаленной отладки для вашей версии Visual Studio.Download the most recent remote tools for your version of Visual Studio. Последнюю версию инструментов удаленной отладки совместим с более ранними версиями Visual Studio, но более ранние версии инструментов удаленной отладки не совместимы с более поздними версиями Visual Studio.The latest remote tools version is compatible with earlier Visual Studio versions, but earlier remote tools versions aren't compatible with later Visual Studio versions. (Например, если вы используете Visual Studio 2017, скачайте последнее обновление инструментов удаленной отладки для Visual Studio 2017.(For example, if you are using Visual Studio 2017, download the latest update of the remote tools for Visual Studio 2017. В этом случае не загружайте инструменты удаленной отладки для Visual Studio 2019 г.)In this scenario, do not download the remote tools for Visual Studio 2019.)
  • Загрузите инструменты удаленной отладки с ту же архитектуру, что и их установке на.Download the remote tools with the same architecture as the machine you're installing them on. Например если необходимо выполнить отладку 32-разрядное приложение на удаленном компьютере под управлением 64-разрядной операционной системы, установите средства удаленного 64-разрядной.For example, if you want to debug a 32-bit app on a remote computer running a 64-bit operating system, install the 64-bit remote tools.
ВерсияVersion СсылкаLink ПримечанияNotes
Visual Studio 2019Visual Studio 2019 Инструменты удаленной отладкиRemote tools Совместимость со всеми версиями Visual Studio 2019.Compatible with all Visual Studio 2019 versions. Скачайте версию, которая соответствует операционной системе устройства (x 86, x64 или ARM64).Download the version matching your device operating system (x86, x64, or ARM64). В Windows Server, см. в разделе разблокировать на загрузку файла загрузить инструменты удаленной отладки.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2017Visual Studio 2017 Инструменты удаленной отладкиRemote tools Совместимость со всеми версиями Visual Studio 2017.Compatible with all Visual Studio 2017 versions. Скачайте версию, которая соответствует операционной системе устройства (x 86, x64 или ARM64).Download the version matching your device operating system (x86, x64, or ARM64). В Windows Server, см. в разделе разблокировать на загрузку файла загрузить инструменты удаленной отладки.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2015Visual Studio 2015 Инструменты удаленной отладкиRemote tools Инструменты удаленной отладки для Visual Studio 2015 доступны из My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. При появлении присоединиться к бесплатным Visual Studio Dev Essentials программы или войдите с помощью идентификатор вашей подписки Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. В Windows Server, см. в разделе разблокировать на загрузку файла загрузить инструменты удаленной отладки.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 Инструменты удаленной отладкиRemote tools Загрузить страницу в документации по Visual Studio 2013Download page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 Инструменты удаленной отладкиRemote tools Загрузить страницу в документации по Visual Studio 2012Download page in Visual Studio 2012 documentation
ВерсияVersion СсылкаLink ПримечанияNotes
Visual Studio 2017Visual Studio 2017 Инструменты удаленной отладкиRemote tools Совместимость со всеми версиями Visual Studio 2017.Compatible with all Visual Studio 2017 versions. Скачайте версию, которая соответствует операционной системе устройства (x 86, x64 или ARM64).Download the version matching your device operating system (x86, x64, or ARM64). В Windows Server, см. в разделе разблокировать на загрузку файла загрузить инструменты удаленной отладки.On Windows Server, see Unblock the file download for help downloading the remote tools. Последнюю версию инструментов удаленной отладки, откройте документа Visual Studio 2019.For the most recent version of the remote tools, open the Visual Studio 2019 doc.
Visual Studio 2015Visual Studio 2015 Инструменты удаленной отладкиRemote tools Инструменты удаленной отладки для Visual Studio 2015 доступны из My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. При появлении присоединиться к бесплатным Visual Studio Dev Essentials программы или войдите с помощью идентификатор вашей подписки Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. В Windows Server, см. в разделе разблокировать на загрузку файла загрузить инструменты удаленной отладки.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 Инструменты удаленной отладкиRemote tools Загрузить страницу в документации по Visual Studio 2013Download page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 Инструменты удаленной отладкиRemote tools Загрузить страницу в документации по Visual Studio 2012Download page in Visual Studio 2012 documentation

Можно запускать удаленный отладчик, скопировав msvsmon.exe для удаленного компьютера, а не выполнять установку инструментов удаленной отладки.You can run the remote debugger by copying msvsmon.exe to the remote computer, rather than installing the remote tools. Тем не менее мастер настройки удаленного отладчика (rdbgwiz.exe) доступен только при установке инструментов удаленной отладки.However, the Remote Debugger Configuration Wizard (rdbgwiz.exe) is available only when you install the remote tools. Необходимо использовать мастер для конфигурации, если вы хотите запустить удаленный отладчик как службу.You may need to use the wizard for configuration if you want to run the remote debugger as a service. Дополнительные сведения см. в разделе (необязательно) Настройка удаленного отладчика как службы.For more information, see (Optional) Configure the remote debugger as a service.

Примечание

  • Чтобы выполнить отладку приложений Windows 10 на устройствах ARM, используйте ARM64, которая доступна в последнюю версию инструментов удаленной отладки.To debug Windows 10 apps on ARM devices, use ARM64, which is available with the latest version of the remote tools.
  • Для отладки приложений Windows 10 в Windows RT используйте ARM, который доступен только в Visual Studio 2015, скачайте инструменты удаленной отладки.To debug Windows 10 apps on Windows RT devices, use ARM, which is available only in the Visual Studio 2015 remote tools download.

ТребованияRequirements

Supported Operating SystemsSupported Operating Systems

Удаленный компьютер должен работать под управлением одной из следующих операционных систем:The remote computer must be running one of the following operating systems:

  • Windows 10 (не phone)Windows 10 (not phone)

  • Windows 8 или 8.1 (не phone)Windows 8 or 8.1 (not phone)

  • Windows 7 с пакетом обновления 1 (SP1)Windows 7 Service Pack 1

  • Windows Server 2016Windows Server 2016

  • Windows Server 2012 или Windows Server 2012 R2Windows Server 2012 or Windows Server 2012 R2

  • Windows Server 2008 с пакетом обновления 2 (SP2), Windows Server 2008 R2 с пакетом обновления 1 (SP1)Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1

Примечание

Windows Phone требуется USB-подключение для отладки (Инструменты удаленной отладки не требуется).Windows Phone requires a USB connection to debug (it does not require the remote tools).

Поддерживаемые конфигурации оборудованияSupported Hardware Configurations

  • Процессор с тактовой частотой 1,6 ГГц или большей1.6 GHz or faster processor

  • 1 ГБ ОЗУ (1,5 ГБ при выполнении в виртуальной машине)1 GB of RAM (1.5 GB if running on a virtual machine)

  • 1 ГБ доступного пространства на жестком диске1 GB of available hard disk space

  • Жесткий диск 5400 об/мин5400-RPM hard drive

  • Видеоадаптер с поддержкой DirectX 9 и разрешением экрана 1024x768 или вышеDirectX 9-capable video card running at 1024 x 768 or higher display resolution

Конфигурация сетиNetwork configuration

Удаленный компьютер и компьютер Visual Studio должны быть подключены по сети, объединены в рабочую или домашнюю группу либо соединены напрямую с помощью кабеля Ethernet.The remote computer and the Visual Studio computer must be connected over a network, workgroup, or homegroup, or else connected directly through an Ethernet cable. Отладка между двумя компьютерами, подключенными через прокси-сервер не поддерживается.Debugging between two computers connected through a proxy is not supported. Отладка в различных странах высокой задержкой или низкой пропускной способностью, таких как удаленный доступ к Интернету, или через Интернет не рекомендуется и может произойти сбой или неприемлемо медленно.Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow.

(Необязательно) Запуск удаленного отладчика из общего файла(Optional) To run the remote debugger from a file share

Вы можете найти удаленный отладчик (msvsmon.exe) на компьютере с Visual Studio сообщества, профессиональные, или предприятие уже установлен.You can find the remote debugger (msvsmon.exe) on a computer with Visual Studio Community, Professional, or Enterprise already installed. Для некоторых сценариев самый простой способ настройки удаленной отладки — запустить удаленный отладчик (msvsmon.exe) из общего файла.For some scenarios, the easiest way to set up remote debugging is to run the remote debugger (msvsmon.exe) from a file share. Для ограничений использования см. страницу справки удаленного отладчика (Help > Use in the remote debugger).For usage limitations, see the remote debugger's Help page (Help > Usage in the remote debugger).

  1. Найти msvsmon.exe в каталоге, соответствующем вашей версии Visual Studio:Find msvsmon.exe in the directory matching your version of Visual Studio:

    Программные файлы (x86)»Microsoft Visual Studio»2019-Enterprise-Common7-IDE-Remote Debugger-x86-msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Программные файлы (x86)»Microsoft Visual Studio»2019-Enterprise-Common7-IDE-Remote Debugger-x64-msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

    Программные файлы (x86)»Microsoft Visual Studio-2017Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Программные файлы (x86)»Microsoft Visual Studio-2017Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

  2. Поделитесь папкой Remote Debugger на компьютере Visual Studio.Share the Remote Debugger folder on the Visual Studio computer.

  3. На удаленном компьютере выполнить msvsmon.exe из общей папки.On the remote computer, run msvsmon.exe from the shared folder. Следуйте инструкциям по настройке.Follow the setup instructions.

Совет

Для установки командной строки и ссылки на строку команд msvsmon.exe /? см. страницу справки для msvsmon.exe, введя командную строку на компьютере с установленным Visual Studio (или перейдите на справку > использование в удаленном отладчике).For command line installation and command line reference, see the Help page for msvsmon.exe by typing msvsmon.exe /? in the command line on the computer with Visual Studio installed (or go to Help > Usage in the remote debugger).

Настройка удаленного отладчикаSet up the remote debugger

  1. На удаленном компьютере, поиска и запуска удаленный отладчик из запустить меню.On the remote computer, find and start the Remote Debugger from the Start menu.

    Если у вас нет административных разрешений на удаленном компьютере, щелкните правой кнопкой мыши удаленный отладчик приложении и выберите Запуск от имени администратора.If you don't have administrative permissions on the remote computer, right-click the Remote Debugger app and select Run as administrator. В противном случае просто запустите его обычным образом.Otherwise, just start it normally.

    Если вы планируете присоединить к процессу, который выполняется с правами администратора, или выполняется от имени другого пользователя учетной записи (например, IIS), щелкните правой кнопкой мыши удаленный отладчик приложении и выберите Запуск от имени администратора.If you are planning to attach to a process which is running as an administrator, or is running under a different user account (such as IIS), right-click the Remote Debugger app and select Run as administrator. Дополнительные сведения см. в разделе запускать удаленный отладчик с правами администратора.For more information, see Run the remote debugger as an administrator.

  2. Первый раз при запуске удаленного отладчика (или до его настройки), конфигурация удаленной отладки откроется диалоговое окно.The first time you start the remote debugger (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    Настройки удаленного отладчикаRemote Debugger configuration

  3. Если API веб-служб Windows не установлен, что возможно только в Windows Server 2008 R2, выберите установить кнопки.If the Windows Web Services API is not installed, which happens only on Windows Server 2008 R2, select the Install button.

  4. Выберите по крайней мере один тип сети вы хотите использовать инструменты удаленной отладки на.Select at least one network type you want to use the remote tools on. Если компьютеры соединены через домен, необходимо выбрать первый пункт.If the computers are connected through a domain, you must choose the first item. Если компьютеры соединены посредством рабочей или домашней группы, выберите второй или третий пункт соответствующим образом.If the computers are connected through a workgroup or homegroup, choose the second or third item as appropriate.

  5. Выберите настроить удаленную отладку настроить брандмауэр и запустить удаленный отладчик.Select Configure remote debugging to configure the firewall and start the remote debugger.

  6. Когда настройка будет завершена, удаленный отладчик появится окно.When configuration is complete, the Remote Debugger window appears.

    Окно удаленного отладчикаRemote Debugger window

    Удаленный отладчик теперь Ожидание подключения.The remote debugger is now waiting for a connection. Используйте имя сервера и порта номер, чтобы задать конфигурацию удаленного подключения в Visual Studio.Use the server name and port number shown to set the remote connection configuration in Visual Studio.

Чтобы остановить работу удаленного отладчика, выберите файл > выхода.To stop the remote debugger, select File > Exit. Его можно перезапустить из запустить меню или из командной строки:You can restart it from the Start menu, or from the command line:

<Remote debugger installation directory>\msvsmon.exe

Настройка удаленного отладчикаConfigure the remote debugger

После первого запуска удаленного отладчика можно изменить некоторые аспекты его конфигурации.You can change some aspects of the configuration of the remote debugger after you have started it for the first time.

  • Если вам нужно добавить разрешения для подключения других пользователей к удаленному отладчику, выберите Инструменты > разрешения.If you need to add permissions for other users to connect to the remote debugger, choose Tools > Permissions. Для предоставления разрешений или отказа в предоставлении необходимо обладать правами администратора.You must have administrator privileges to grant or deny permissions.

    Важно!

    Вы можете запустить удаленный отладчик под учетной записью пользователя, которая отличается от учетной записи пользователя, которую вы используете на компьютере Visual Studio, но вы должны добавить другую учетную запись пользователя к разрешениям удаленного отладчика.You can run the remote debugger under a user account that differs from the user account you are using on the Visual Studio computer, but you must add the different user account to the remote debugger's permissions.

    Кроме того, можно запустить удаленный отладчик от командной строки с ** </разрешить имя пользователя>** параметр: ** < username@computer msvsmon/позволяет>. **Alternatively, you can start the remote debugger from the command line with the /allow <username> parameter: msvsmon /allow <username@computer>.

  • Если вам необходимо изменить режим аутентификации или номер порта, или указать значение тайм-аута для удаленных инструментов: выберите Инструменты > варианты.If you need to change the Authentication mode or the port number, or specify a timeout value for the remote tools: choose Tools > Options.

    Для перечисления номеров портов, используемых по умолчанию, см.For a listing of the port numbers used by default, see Remote Debugger Port Assignments.

    Предупреждение

    Вы можете запускать инструменты удаленной отладки в режиме "без аутентификации", однако настоятельно рекомендуется не использовать этот режим.You can choose to run the remote tools in No Authentication mode, but this mode is strongly discouraged. При работе в этом режиме сетевая безопасность не обеспечивается.There is no network security when you run in this mode. Режим без аутентификации можно выбрать, только если вы уверены в отсутствии вредоносного или опасного трафика.Choose the No Authentication mode only if you are sure that the network is not at risk from malicious or hostile traffic.

(Необязательно) Настройка удаленного отладчика как услуги(Optional) Configure the remote debugger as a service

Для отладки в ASP.NET и других серверных средах необходимо либо запустить удаленный отладчик в качестве администратора, либо, если вы хотите, чтобы он всегда работал, запустить удаленный отладчик как службу.For debugging in ASP.NET and other server environments, you must either run the remote debugger as an Administrator or, if you want it always running, run the remote debugger as a service.

Если вы хотите настроить удаленный отладчик в качестве службы, выполните следующие действия.If you want to configure the remote debugger as a service, follow these steps.

  1. Найдите мастер настройки удаленного отладчика (rdbgwiz.exe).Find the Remote Debugger Configuration Wizard (rdbgwiz.exe). (Это отдельное приложение от удаленного debugger.) Он доступен только при установке удаленных инструментов.(This is a separate application from the Remote Debugger.) It is available only when you install the remote tools. Вместе с Visual Studio он не устанавливается.It is not installed with Visual Studio.

  2. Запустите мастер настройки.Start running the configuration wizard. Когда появится первая страница, нажмите кнопку Далее.When the first page comes up, click Next.

  3. Установите флажок Запускать удаленный отладчик Visual Studio 2015 как службу .Check the Run the Visual Studio 2015 Remote Debugger as a service checkbox.

  4. Добавьте имя учетной записи пользователя и пароль.Add the name of the user account and password.

    Возможно, вам придется добавить журнал в качестве пользователя службы прямо на эту учетную запись (Найдите местную политику безопасности (secpol.msc) на странице или окне старта (или введите секпол в запросе команды).You may need to add the Log on as a service user right to this account (Find Local Security Policy (secpol.msc) in the Start page or window (or type secpol at a command prompt). В открывшемся окне дважды щелкните элемент Назначение прав пользователя, а затем в области справа найдите элемент Вход в качестве службы .When the window appears, double-click User Rights Assignment, then find Log on as a service in the right pane. Дважды щелкните его.Double-click it. Добавьте учетную запись пользователя в окно Свойства и нажмите кнопку ОК.)Add the user account to the Properties window and click OK). Нажмите кнопку Далее.Click Next.

  5. Выберите тип сети, с которой должны взаимодействовать инструменты удаленной отладки.Select the type of network that you want the remote tools to communicate with. Должен быть выбран по крайней мере один тип сети.At least one network type must be selected. Если компьютеры соединены через домен, необходимо выбрать первый пункт.If the computers are connected through a domain, you should choose the first item. Если компьютеры соединены посредством рабочей или домашней группы, необходимо выбрать второй или третий пункт.If the computers are connected through a workgroup or homegroup, you should choose the second or third items. Нажмите кнопку Далее.Click Next.

  6. Если службу удается запустить, вы увидите сообщение Вы успешно завершили работу мастера настройки удаленного отладчика Visual Studio.If the service can be started, you will see You have successfully completed the Visual Studio Remote Debugger Configuration Wizard. Если службу не удается запустить, вы увидите сообщение Не удалось завершить мастер настройки удаленного отладчика Visual Studio.If the service cannot be started, you will see Failed to complete the Visual Studio Remote Debugger Configuration Wizard. На странице также приводится ряд советов по запуску службы.The page also gives some tips to follow to get the service to start.

  7. Нажмите кнопку Готово.Click Finish.

    Теперь удаленный отладчик должен работать как служба.At this point the remote debugger is running as a service. Чтобы проверить, так ли это, выберите Панель управления > Службы и найдите службу Удаленный отладчик Visual Studio 2015.You can verify this by going to Control Panel > Services and looking for Visual Studio 2015 Remote Debugger.

    Останавливать и запускать службу удаленного отладчика можно с помощью компонента Панель управления > Службы.You can stop and start the remote debugger service from Control Panel > Services.

Настройка отладки с удаленными символамиSet up debugging with remote symbols

Вы можете отлаживать код с использованием символов, созданных на компьютере Visual Studio.You should be able to debug your code with the symbols you generate on the Visual Studio computer. Производительность удаленного отладчика гораздо выше при использовании локальных символов.The performance of the remote debugger is much better when you use local symbols. Если необходимо использовать удаленные символы, укажите, что монитор удаленной отладки должен искать символы на удаленном компьютере.If you must use remote symbols, you need to tell the remote debugging monitor to look for symbols on the remote machine.

Начиная с версии Visual Studio 2013 с обновлением 2 можно использовать следующий параметр командной строки msvsmon для использования удаленных символов для управляемого кода: Msvsmon /FallbackLoadRemoteManagedPdbsStarting in Visual Studio 2013 Update 2, you can use the following msvsmon command-line switch to use remote symbols for managed code: Msvsmon /FallbackLoadRemoteManagedPdbs

Дополнительные сведения см. в справке по удаленной отладке (нажмите клавишу F1 в окне удаленного отладчика или щелкните Справка > Использование).For more information, please see the remote debugging help (press F1 in the remote debugger window, or click Help > Usage). Также см. запись блога с описанием изменений, связанных с удаленной загрузкой символов .NET в Visual Studio 2012 и 2013.You can find more information at .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013

См. также разделSee also