Персонализация интегрированной среды разработки Visual StudioPersonalize the Visual Studio IDE

Доступны разные способы индивидуальной настройки Visual Studio в соответствии с личным стилем и требованиями к разработке.You can personalize Visual Studio in various ways to best support your own development style and requirements. Целый ряд параметров можно использовать в разных экземплярах Visual Studio — см. статью Синхронизация параметров в Visual Studio.Many of your settings roam with you across Visual Studio instances—see Synchronized settings. В этой статье кратко описываются эти способы, а также приводятся ссылки на ресурсы с дополнительными сведениями.This article briefly describes different personalizations and where you can find more information.

Note

Этот раздел относится к Visual Studio в Windows.This topic applies to Visual Studio on Windows. Информацию о Visual Studio для Mac см. в статье Настройка интегрированной среды разработки Visual Studio для Mac.For Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

Параметры по умолчаниюDefault settings

Можно выбрать заданную по умолчанию коллекцию параметров, которая оптимизирует Visual Studio для вашего типа разработки.You can choose a default collection of settings that optimizes Visual Studio for your type of development. Дополнительные сведения см. в статье Параметры среды.For more information, see Environment settings.

Общие параметры средыGeneral environment options

Доступ ко многим персонализированным параметрам можно также получить в диалоговом окне Параметры среды.Many personalization options are exposed through the Environment Options dialog box. Открыть это диалоговое окно можно двумя способами:There are two ways to access this dialog box:

  • В строке меню выберите Сервис > Параметры и при необходимости разверните узел Среда.On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • Нажмите клавиши CTRL+Q, введите среда в поле поиска, а затем выберите Среда > Общие из результатов.Press Ctrl+Q, type environment in the search box, and then choose Environment > General from the results.

Tip

В открывшемся диалоговом окне "Параметры" нажмите клавишу F1 для получения справочных сведений о различных параметрах на этой странице.When the Options dialog box appears, you can press F1 for help on the various settings on that page.

Цветовые темы средыEnvironment color themes

Чтобы изменить цветовую тему на светлую, темную или синюю, введите среда в поле поиска и выберите Среда > Общие.To change the color theme between light, dark and blue, type environment in the search box, and then choose Environment > General. В диалоговом окне Параметры измените значение настройки Цветовая тема.In the Options dialog box, change the Color theme option.

Чтобы изменить параметры раскраски в редакторе, введите среда в поле поиска и выберите Среда > Шрифты и цвета.To change colorization options in the editor, type environment in the search box, and then choose Environment > Fonts and Colors. См. практическое руководство по Изменение шрифтов и цветов.See How to: Change fonts and colors.

Вы можете изменить регистр главного меню, выбрав вариант Заглавные буквы (например, "Файл") и ВСЕ ПРОПИСНЫЕ (например, "ФАЙЛ").You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). Введите среда в поле поиска, выберите Среда > Общие, а затем измените параметр Применить регистр заголовка к строке меню.Type environment in the search box, select Environment > General, and then change the Apply title case styling to menu bar option.

Настройка меню и панелей инструментовCustomize menus and toolbars

Сведения о добавлении или удалении элементов меню или панели инструментов см. в разделе Практическое руководство. Настройка меню и панелей инструментов.To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

Начальная страницаStart page

Сведения о создании настраиваемой начальной страницы для пользователя и команды см. в разделе Настройка начальной страницы.To create a custom start page for you and your team, see Customize the Start page.

Макеты оконWindow layouts

Можно определить и сохранить несколько макетов окон и переключаться между ними.You can define and save multiple window layouts and switch between them. Например, можно определить один макет для написания кода, а другой — для отладки.For example, you can define one layout for coding and one for debugging. Сведения о расположении окон и упорядочивании их поведения, а также о сохранении пользовательских макетов см. в статье Настройка макетов окон.To arrange window positions and behavior and save custom layouts, see Customize window layouts.

Внешние инструментыExternal tools

Вы можете настроить меню Сервис и запускать внешние средства.You can customize the Tools menu to launch external tools. Дополнительные сведения см. в разделе Управление внешними инструментами.For more information, see Manage external tools.

См. такжеSee also