Шаг 1. Создание проекта приложения Windows FormsStep 1: Create a Windows Forms App project

Первый шаг в создании программы для просмотра изображений — это создание проекта приложения Windows Forms.When you create a picture viewer, the first step is to create a Windows Forms App project.

Откройте Visual Studio 2017.Open Visual Studio 2017

  1. В строке меню выберите Файл  > Создать  > Проект.On the menu bar, choose File > New > Project. Диалоговое окно должно выглядеть так же, как на следующем снимке экрана.The dialog box should look similar to the following screenshot.

    Диалоговое окно "Новый проект"New project dialog
    Диалоговое окно Новый проектNew project dialog box

  2. В левой части диалогового окна Новый проект выберите Visual C# или Visual Basic, а затем — Классическое приложение Windows.On the left side of the New Project dialog box, choose either Visual C# or Visual Basic, and then choose Windows Desktop.

  3. В списке шаблонов проектов выберите Приложение Windows Forms (.NET Framework) .In the project templates list, choose Windows Forms App (.NET Framework). Назовите новую форму PictureViewer и нажмите кнопку ОК.Name the new form PictureViewer, and then choose the OK button.

    Примечание

    Если вы не видите шаблон Приложение Windows Forms (.NET Framework) , используйте Visual Studio Installer, чтобы установить рабочую нагрузку Разработка классических приложений .NET.If you don't see the Windows Forms App (.NET Framework) template, use the Visual Studio Installer to install the .NET desktop development workload.

    Рабочая нагрузка разработки классических приложений .NET в Visual Studio Installer.NET desktop development workload in the Visual Studio Installer

    Дополнительные сведения см. в разделе Установка Visual Studio.For more information, see the Install Visual Studio page.

Запустите Visual Studio 2019.Open Visual Studio 2019

  1. На начальном экране выберите Создать проект.On the start window, choose Create a new project.

    Просмотр окна "Создание проекта"

  2. В поле поиска окна Создание проекта введите Windows Forms.On the Create a new project window, enter or type Windows Forms in the search box. Затем в списке Тип проекта выберите Рабочий стол.Next, choose Desktop from the Project type list.

    Применив фильтр Тип проекта, выберите шаблон Приложение Windows Forms (.NET Framework) для C# или Visual Basic и нажмите кнопку Далее.After you apply the Project type filter, choose the Windows Forms App (.NET Framework) template for either C# or Visual Basic, and then choose Next.

    Выбор шаблона Visual Basic или C#для приложения Windows Forms (.NET Framework)

    Примечание

    Если шаблон Приложение Windows Forms (.NET Framework) отсутствует, его можно установить из окна Создание проекта.If you don't see the Windows Forms App (.NET Framework) template, you can install it from the Create a new project window. В сообщении Не нашли то, что искали? выберите ссылку Установка других средств и компонентов.In the Not finding what you're looking for? message, choose the Install more tools and features link.

    Ссылка "Установка других средств и компонентов" из сообщения "Не нашли то, что искали?" в окне "Создание проекта"

    После этого в Visual Studio Installer выберите рабочую нагрузку Разработка классических приложений .NET.Next, in the Visual Studio Installer, choose the Choose the .NET desktop development workload.

    Рабочая нагрузка .NET Core в Visual Studio Installer

    Затем нажмите кнопку Изменить в Visual Studio Installer.After that, choose the Modify button in the Visual Studio Installer. Вам может быть предложено сохранить результаты работы; в таком случае сделайте это.You might be prompted to save your work; if so, do so. Выберите Продолжить, чтобы установить рабочую нагрузку.Next, choose Continue to install the workload.

  3. В поле Имя проекта окна Настроить новый проект введите PictureViewer.In the Configure your new project window, type or enter PictureViewer in the Project name box. Затем нажмите Создать.Then, choose Create.

Visual Studio создает решение для приложения.Visual Studio creates a solution for your app. Решение играет роль контейнера для всех проектов и файлов, необходимых приложению.A solution acts as a container for all of the projects and files needed by your app. Более подробно эти термины поясняются далее в этом учебнике.These terms will be explained in more detail later in this tutorial.

Сведения о проекте приложения Windows FormsAbout the Windows Forms App project

  1. Среда разработки содержит три окна: главное окно, Обозреватель решений и окно Свойства.The development environment contains three windows: a main window, Solution Explorer, and the Properties window.

    Если какое-либо из этих окон отсутствует, можно восстановить макет окон по умолчанию.If any of these windows are missing, you can restore the default window layout. В строке меню выберите Окно > Сброс макета окна.On the menu bar, choose Window > Reset Window Layout.

    Можно также отобразить окна с помощью команд меню.You can also display windows by using menu commands. В строке меню выберите Вид > Окно "Свойства" или Обозреватель решений.On the menu bar, choose View > Properties Window or Solution Explorer.

    Если открыты какие-либо другие окна, закройте их с помощью кнопки Закрыть (x) в верхнем правом углу.If any other windows are open, close them by choosing the Close (x) button in their upper-right corners.

    • Главное окно. В этом окне выполняется основная часть работы, например работа с формами и редактирование кода.Main window In this window, you'll do most of your work, such as working with forms and editing code. В окне показана форма в редакторе форм.The window shows a form in the Form Editor. В верхней части окна находятся две вкладки — вкладка Начальная страница и вкладка Form1.cs [Design] .At the top of the window, the Start Page tab and the Form1.cs [Design] tab appear. (В Visual Basic имя вкладки заканчивается на .vb, а не на .cs.)(In Visual Basic, the tab name ends with .vb instead of .cs.)
    • Главное окно. В этом окне выполняется основная часть работы, например работа с формами и редактирование кода.Main window In this window, you'll do most of your work, such as working with forms and editing code. В окне показана форма в редакторе форм.The window shows a form in the Form Editor.
    • Окно "Обозреватель решений" . В этом окне можно просматривать все элементы, входящие в решение, и переходить к ним.Solution Explorer window In this window, you can view and navigate to all items in your solution.

    Если выбрать файл, содержимое в окне Свойства изменится.If you choose a file, the contents of the Properties window changes. Если открыть файл кода (с расширением .cs в C# и .vb в Visual Basic), откроется сам файл кода или конструктор для него.If you open a code file (which ends in .cs in C# and .vb in Visual Basic), the code file or a designer for the code file appears. Конструктор — это визуальная поверхность, на которую можно добавлять элементы управления, такие как кнопки и списки.A designer is a visual surface onto which you can add controls such as buttons and lists. При работе с формами Visual Studio такая поверхность называется конструктор Windows Forms.For Visual Studio forms, the designer is called the Windows Forms Designer.

    • Окно "Свойства" . В этом окне производится изменение свойств элементов, выбранных в других окнах.Properties window In this window, you can change the properties of items that you choose in the other windows. Например, выбрав форму Form1, можно изменить ее название путем задания свойства Text, а также изменить цвет фона путем задания свойства Backcolor.For example, if you choose Form1, you can change its title by setting the Text property, and you can change the background color by setting the Backcolor property.

      Примечание

      В верхней строке в обозревателе решений отображается текст Решение "PictureViewer" (1 проект) . Это означает, что Visual Studio автоматически создала для вас решение.The top line in Solution Explorer shows Solution 'PictureViewer' (1 project), which means that Visual Studio created a solution for you. Решение может содержать несколько проектов, но пока что вы будете работать с решениями, которые содержат только один проект.A solution can contain more than one project, but for now, you'll work with solutions that contain only one project.

  2. В строке меню выберите Файл > Сохранить все.On the menu bar, choose File > Save All.

    Другой вариант — нажать кнопку Сохранить все на панели инструментов, как показано на рисунке ниже.As an alternative, choose the Save All button on the toolbar, which the following image shows.

    Кнопка "Сохранить все" на панели инструментовSave All toolbar button
    Кнопка Сохранить все на панели инструментовSave All toolbar button

    Visual Studio автоматически заполняет имя папки и имя проекта, а затем сохраняет проект в папке проектов.Visual Studio automatically fills in the folder name and the project name and then saves the project in your projects folder.

Следующие шагиNext steps

См. такжеSee also