Обновление Visual Studio

Применимо к:yes Visual Studio noVisual Studio для Mac noVisual Studio Code

В этом разделе описывается обновление клиентской установки Visual Studio в Windows. Для Visual Studio для Mac см. раздел Обновление Visual Studio для Mac.

Если вы являетесь ИТ-администратором и хотите настроить обновление клиентов организации с помощью сетевого макета, обратитесь к руководству администраторов Visual Studio, в частности к разделу об управлении сетевыми установками и их обновлении.

Перед обновлением

Чтобы установить, обновить или изменить Visual Studio, учетная запись, с которой выполняется обновление, должна иметь административные права как на компьютере, так и в том месте, где находятся обновления продукта (интернет-ресурс или сетевая папка). Если вы вошли в систему как обычный пользователь и пытаетесь выполнить одну из этих команд, то получите уведомление системы контроля учетных записей о запросе учетных данных администратора. Дополнительные сведения см. в разделе Разрешения пользователей и Visual Studio.

Перед выполнением обновления Visual Studio необходимо закрыть. Мы настоятельно рекомендуем сохранить работу перед выполнением обновления.

Перед обновлением на компьютере необходимо сначала установить Visual Studio. Чтобы установить текущую версию Visual Studio с серверов, размещенных Майкрософт, перейдите на страницу скачиваемых материалов Visual Studio. Если в данный момент используется другой экземпляр Visual Studio, можно установить новый экземпляр одновременно с ним или удалить его перед установкой нового.

Мы рекомендуем выполнить обновление до последнего выпуска Visual Studio 2019, чтобы вы всегда имели доступ к новым функциям, улучшениям и исправлениям безопасности. А если вы хотите протестировать самую свежую версию, попробуйте скачать и установить Visual Studio 2022.

Существует несколько различных способов установить обновления Visual Studio. Можно сделать это с помощью Visual Studio Installer, проверить наличие обновлений, воспользоваться центром уведомлений среды IDE или запустить конкретную версию начального загрузчика. Вот как обновить Visual Studio 2019 с помощью этих различных методов.

Использование Visual Studio Installer

  1. Найдите Visual Studio Installer на своем компьютере.

    В меню "Пуск" Windows можно выполнить поиск по слову "установщик".

    Screenshot showing the result of a Start menu search for the Visual Studio Installer.

    Для продолжения работы может потребоваться обновление самого установщика. Если это так, следуйте инструкциям на экране.

  2. Найдите в установщике экземпляр Visual Studio, который хотите обновить.

    Например, если вы ранее установили Visual Studio Community 2019 и для него есть обновление, в установщике появится доступное сообщение об обновлении .

    Screenshot showing a Visual Studio 2019 installation with an available update.

  3. Чтобы установить обновления, нажмите кнопку Обновить.

    Screenshot showing the Update button in the Visual Studio installer that can be used to update to a Visual Studio 2019 installation.

  4. Когда обновление завершится, может появиться запрос на перезагрузку компьютера. В таком случае перезагрузите компьютер, а затем запустите Visual Studio, как обычно.

    Если вам не будет предложено перезагрузить компьютер, выберите Запуск, чтобы запустить Visual Studio из установщика.

    Screenshot showing the Launch button in the Visual Studio installer that can be used to start Visual Studio 2019.

Использование окна сообщений в среде IDE

  1. IDE проверяет наличие доступных обновлений при запуске Visual Studio. В некоторых случаях появляется краткое сообщение об обновлении Visual Studio 2019. Если вы хотите установить его сейчас, выберите Просмотреть сведения. Если вы хотите отложить обновление до окончания работы в Visual Studio, выберите Обновить при закрытии.

    Screenshot showing the 'Visual Studio 2019 update' message in the IDE.

  2. Если вы выбрали Просмотреть сведения, в появившемся диалоговом окне Обновление скачано и готово к установке нажмите кнопку Обновить, чтобы выполнить обновление сейчас.

    Screenshot showing the Update button in the 'Update downloaded and ready to install' dialog box.

Проверка обновлений вручную

  1. Чтобы проверить доступные обновления, в строке меню выберите Справка, затем Проверить наличие обновлений. Также можно воспользоваться полем поиска, для этого нажмите клавиши CTRL+Q, введите "Проверить обновления" и выберите соответствующий результат поиска.

    Screenshot showing the 'Check for Updates' from the Help menu.

  2. В диалоговом окне Доступно обновление нажмите кнопку Обновить.

    Screenshot showing the Update button in the 'Update available' dialog box.

Использование центра уведомлений

  1. Чтобы открыть центр Уведомления, выберите значок уведомления в правом нижнем углу IDE Visual Studio.

    Screenshot showing the notification icon in the Visual Studio IDE.

  2. Выберите обновление, которое хотите установить, в центре уведомлений. Если вы хотите установить его сейчас, выберите Просмотреть сведения. Если вы хотите отложить обновление до окончания работы в Visual Studio, выберите Обновить при закрытии.

    Screenshot showing the Notification hub in Visual Studio 2019.

  3. Если вы выбрали Просмотреть сведения, в появившемся диалоговом окне Доступно обновление нажмите кнопку Обновить.

Запуск конкретного начального загрузчика

Если вы являетесь клиентом выпуска Enterprise или Professional, то можете обновить экземпляр Visual Studio 2019 до любой версии, выпущенной позже установленной в данный момент. Чтобы обновить экземпляр Visual Studio 2019 при помощи этого метода, перейдите на страницу журнала выпусков Visual Studio 2019, скачайте начальный загрузчик нужной версии обновления в каталог установки продукта, а затем дважды щелкните его, чтобы запустить обновление.

Настройка параметров обновления

Существует несколько различных параметров, которые можно настроить для управления поведением обновления. Некоторые из них являются собственными параметрами Visual Studio 2019 и управляют тем, как и когда скачиваются и устанавливаются элементы продукта. Другие, такие как возможность настроить источник обновлений, требуют наличия последней версии установщика Visual Studio 2022.

Поведение установки и скачивания

  1. В строке меню выберите Сервис>Параметры.

  2. Разверните пункт Среда и выберите элемент Обновления продукта.

    Screenshot showing the updates settings in Visual Studio.

  3. Просмотрите параметры конфигурации, которые можно задать в этом диалоговом окне. Можно настроить автоматическое скачивание обновлений, позволяющее загружать обновления, когда компьютер находится в состоянии бездействия. Также можно выбрать один из двух режимов установки: Установить при скачивании или Скачать все и установить. Выберите нужные режим установки и параметры автоматического скачивания для обновлений Visual Studio.

Настройка исходного расположения обновлений

Если вы находитесь в корпоративной среде, можно настроить расположение, в котором экземпляры клиента будут искать обновления. Это полезно в случаях, когда клиент был установлен из одного сетевого макета, а в дальнейшем требуется, чтобы обновления скачивались из другого сетевого макета. Возможность настроить расположения обновлений требует наличия последней версии установщика Visual Studio 2022. Его можно получить с помощью установки Visual Studio 2022 на клиентском компьютере или от администратора через сетевой макет. Дополнительные сведения об использовании этой функции см. в документации Visual Studio 2022 по настройке исходного расположения обновлений. Ознакомьтесь также со сведениями о том, как настроить макеты Visual Studio 2019 для использования последней версии Visual Studio 2022 Installer.

Обновление при закрытии

В Visual Studio 2019 версии 16.9 мы представили концепцию обновления при закрытии. При доступном обновлении интерфейс уведомлений об обновлениях в IDE предоставляет возможность отложить его до момента намеренного закрытия Visual Studio. Кнопка Обновить при закрытии появляется в окне уведомления об обновлении, а также в центре уведомлений. Команда Обновить при закрытии не является постоянным параметром и применяется только к текущему обновлению. Другими словами, отложенное обновление при закрытии необходимо выбирать каждый раз, когда вы принимаете или закрываете уведомление о доступном обновлении.

Screenshot showing the Update on Close option in the update notification message box.

Мы рекомендуем выполнить обновление до последнего выпуска Visual Studio 2022, чтобы вы всегда имели доступ к новым функциям, улучшениям и исправлениям безопасности.

Существует несколько различных способов установить обновления Visual Studio. Можно сделать это с помощью Visual Studio Installer, проверить наличие обновлений, воспользоваться центром уведомлений среды IDE или запустить конкретную версию начального загрузчика. Вот как обновить Visual Studio 2022 с помощью этих различных методов.

Использование Visual Studio Installer

  1. Найдите Visual Studio Installer на своем компьютере.

    В меню "Пуск" в Windows выполните поиск по запросу "installer" и выберите Visual Studio Installer в результатах.

    Screenshot showing the result of a Start menu search for the Visual Studio Installer.

    Если вам будет предложено обновить Visual Studio Installer, прежде чем продолжить, сделайте это, следуя инструкциям.

  2. В Visual Studio Installer найдите установку Visual Studio, которую требуется обновить.

    Например, если вы ранее установили Visual Studio Community 2022 и для него есть обновление, в Visual Studio Installer появится сообщение Доступно обновление.

    Screenshot showing the Update button and message in the Visual Studio Installer when a new update is available.

  3. Чтобы установить обновления, нажмите кнопку Обновить.

    Screenshot showing the Update button that you can select to install the new update.

  4. После завершения обновления Visual Studio Installer может предложить перезагрузить компьютер. В таком случае перезагрузите компьютер, а затем запустите Visual Studio, как обычно.

    Если вам не будет предложено перезагрузить компьютер, выберите Запуск, чтобы запустить Visual Studio из Visual Studio Installer.

    Screenshot showing the Launch button that you can select to start Visual Studio.

Использование окна сообщений в среде IDE

  1. IDE проверяет наличие доступных обновлений при запуске Visual Studio. В некоторых случаях появляется краткое сообщение об обновлении Visual Studio 2022. Если вы хотите установить его сейчас, выберите Просмотреть сведения. Если вы хотите отложить обновление до окончания работы в Visual Studio, выберите Обновить при закрытии.

    Screenshot showing an update message for Visual Studio 2022 in the lower-right corner of the Visual Studio IDE.

  2. Если вы выбрали Просмотреть сведения, в появившемся диалоговом окне Доступно обновление нажмите кнопку Обновить, чтобы выполнить обновление сейчас.

    Screenshot showing the Update button in the 'Update available' dialog box in Visual Studio 2022.

Проверка обновлений вручную

  1. Чтобы проверить доступные обновления, в строке меню выберите Справка, затем Проверить наличие обновлений. Также можно воспользоваться полем поиска, для этого нажмите клавиши CTRL+Q, введите "Проверить обновления" и выберите соответствующий результат поиска.

    Screenshot showing the 'Check for Updates' option in the Help menu.

  2. В диалоговом окне Доступно обновление нажмите кнопку Обновить.

    Screenshot showing the Update button in the 'Update available' dialog box.

Использование центра уведомлений

  1. Чтобы открыть центр уведомлений, выберите значок уведомления в правом нижнем углу Visual Studio IDE.

    Screenshot showing the notification icon in the Visual Studio IDE.

  2. Выберите обновление, которое хотите установить, в центре уведомлений. Если вы хотите установить его сейчас, выберите Просмотреть сведения. Если вы хотите отложить обновление до окончания работы в Visual Studio, выберите Обновить при закрытии.

    Screenshot showing the Notifications hub in the Visual Studio IDE.

  3. Если вы выбрали Просмотреть сведения, в появившемся диалоговом окне Доступно обновление нажмите кнопку Обновить.

Запуск конкретного начального загрузчика

Если вы являетесь клиентом выпуска Enterprise или Professional, то можете обновить экземпляр Visual Studio 2022 до любой версии, выпущенной позже установленной в данный момент. Чтобы обновить экземпляр Visual Studio 2022 при помощи этого метода, перейдите на страницу журнала выпусков Visual Studio 2022, скачайте начальный загрузчик нужной версии обновления в каталог установки продукта, а затем дважды щелкните его, чтобы запустить обновление.

Настройка параметров обновления

Существует несколько различных параметров, которые можно настроить для управления поведением обновления, например, как и когда скачиваются и устанавливаются элементы продукта или где располагается источник обновлений.

Поведение установки и скачивания

  1. В строке меню выберите Сервис>Параметры.

  2. Разверните пункт Среда и выберите элемент Обновления продукта.

    Screenshot showing the Updates settings in the Options window of the Visual Studio IDE.

  3. Просмотрите параметры конфигурации, которые можно задать в этом диалоговом окне. Можно настроить автоматическое скачивание обновлений, позволяющее загружать обновления, когда компьютер находится в состоянии бездействия. Также можно выбрать один из двух режимов установки: Установить при скачивании или Скачать все и установить. Выберите нужные режим установки и параметры автоматического скачивания для обновлений Visual Studio.

Настройка исходного расположения обновлений

В Visual Studio 2022 теперь можно настроить, откуда клиенты будут получать обновления. Эти исходные расположения обновлений называются "каналы". Дополнительные сведения о назначении и доступности каналов см. в документации по циклу выпуска Visual Studio. Корпорация Майкрософт предоставляет всем пользователям доступ к текущему каналу и каналу предварительного просмотра, а клиентам выпусков Enterprise и Professional — доступ к каналам долгосрочного обслуживания (LTSC). ИТ-администраторы также могут настраивать исходные расположения обновлений, например сетевые макеты, к которым у клиентов должен быть доступ. Дополнительные параметры и сведения о настройке см. в руководстве администраторов Visual Studio.

Существует два способа открыть диалоговое окно "Параметры обновления", позволяющее изменить канал, из которого экземпляр Visual Studio должен получать обновления.

  1. Откройте Visual Studio Installer, выберите экземпляр, который хотите настроить, нажмите кнопку "Дополнительные параметры" , а затем выберите пункт меню Параметры обновления. Дополнительные сведения о том, как найти Visual Studio Installer, см. в предыдущих инструкциях.

Screenshot showing the Updates settings in the Installer.

  1. Диалоговое окно "Параметры обновления" также можно вызвать другим способом. Для этого откройте Visual Studio IDE, вызовите диалоговое окно "Доступно обновление" (нажав Просмотреть сведения в уведомлении об обновлении или Проверить наличие обновлений в меню "Справка"), а затем щелкните ссылку "Изменить параметры обновления".

Screenshot showing the Updates settings in the Update available dialog in the IDE.

Диалоговое окно Параметры обновления будет выглядеть следующим образом. В этом примере экземпляр Visual Studio использует канал LTSC 17.0.

Screenshot showing the Updates settings dialog in the Visual Studio 2022 IDE.

Выбрав необходимое значение в раскрывающемся списке Канал обновления, вы можете управлять исходным расположением будущих обновлений для этого экземпляра Visual Studio. Следует учитывать следующие особенности:

  • Канал предварительного просмотра и текущий канал доступны для всех выпусков Visual Studio, а каналы LTSC — только для клиентов выпусков Professional и Enterprise.
  • Можно обновить экземпляр Visual Studio сразу после настройки расположения канала обновления. Или отложить фактическое обновление продукта на более позднее время. Настройка канала обновления и обновление продукта — это два независимых события. Сведения о программном управлении каналом обновления см. в разделе Использование команды modifySettings.
  • Канал обновления можно изменить только в том случае, если последняя версия продукта, доступная на этом канале, новее установленной. Например, всегда можно перейти с текущего канала на канал предварительного просмотра, но перейти с канала предварительного просмотра на текущий можно, только если последний выпуск на текущем канале является более поздним, чем установленный выпуск из канала предварительного просмотра.
  • При обновлении канала будет установлен последний выпуск, находящийся на нем. Если вы являетесь корпоративным клиентом и хотите установить определенную версию продукта из этого канала, следуйте приведенным выше инструкциям Запуск конкретного начального загрузчика.
  • Все каналы LTSC имеют даты истечения срока действия, как показано на рисунке выше. После его окончания LTSC нельзя будет использовать в качестве источника обновлений, и этот канал исчезнет из списка.
  • Все каналы Майкрософт размещаются на серверах Майкрософт, и для них требуется доступ к Интернету.
  • Для каждого экземпляра Visual Studio независимо можно настроить источник обновлений. Если у вас установлено два экземпляра Visual Studio 2022, их можно обновлять из разных каналов.
  • ИТ-администраторы могут управлять этим текстом в раскрывающемся списке Канал обновления. Например, они могут добавлять расположения сетевых макетов в качестве источников обновлений. Также они могут сделать расположения, размещенные Майкрософт, недоступными в качестве источников обновлений. Эта функция также работает в установках Visual Studio 2019. Сведения о настройке этих расположений обновлений см. на странице Установка значений по умолчанию для корпоративных развертываний.

Обновление при закрытии

При доступном обновлении интерфейс уведомлений об обновлениях в IDE предоставляет возможность отложить его до момента намеренного закрытия Visual Studio. Кнопка Обновить при закрытии появляется в окне уведомления об обновлении, а также в центре уведомлений. Команда Обновить при закрытии не является постоянным параметром и применяется только к текущему обновлению. Другими словами, отложенное обновление при закрытии необходимо выбирать каждый раз, когда вы принимаете или закрываете уведомление о доступном обновлении.

Screenshot showing the Update on Close option in the update notification message box.

Обновления администратора

Если вы входите в организацию с централизованным управлением установленными версиями программного обеспечения, администратор предприятия может управлять обновлениями Visual Studio на вашем компьютере. Дополнительные сведения о том, как администрировать и настраивать типы обновлений, которые поддерживаются на компьютере, см. в разделе Использование Configuration Manager для развертывания обновлений Visual Studio.

Поддержка или устранение неполадок

Иногда возникают проблемы. Если установить Visual Studio не удается, воспользуйтесь пошаговыми указаниями в статье Устранение неполадок при установке и обновлении Visual Studio.

Ниже приведены несколько дополнительных вариантов:

См. также раздел