Предупреждение MSBuild MSB8030

MSB8030: для параметра компоновщика "Минимальная требуемая версия" требуется параметр "Подсистема". Без параметра "Подсистема" минимальная требуемая версия не передается компоновщику и может препятствовать запуску выходного двоичного кода в более старых операционных системах.

Для разрешения этой проблемы:

  • Задайте свойство /SUBSYSTEM для проекта. Чтобы задать это значение в свойствах проекта, выберите проект в Обозревателе решений, а затем щелкните правой кнопкой мыши, чтобы открыть контекстное меню. Выберите пункт Свойства, чтобы открыть диалоговое окно Страницы свойств для проекта. Перейдите на страницу свойств Свойства конфигурации > Компоновщик > Система. Для каждой конфигурации в проекте задайте свойство Подсистема.