Visual Studio 2017 для Mac, версия 7.4 Visual Studio 2017 for Mac version 7.4


Сообщество разработчиков | Требования к системе | Совместимость | Распространяемый код | Xamarin | Блоги | ОбслуживаниеDeveloper Community | System Requirements | Compatibility | Distributable Code | Xamarin | Blogs | Servicing


Примечание

Если вы открываете локализованную версию этой страницы и хотите просмотреть актуальные материалы, посетите страницу "Заметки о выпуске" на английском языке.If you are accessing this page from a non-English language version, and want to see the most up-to-date content, please visit this Release Notes page in English.

Совет

Язык страницы можно переключить в ее нижней части.You can switch the page language at the bottom of this page. Нажмите кнопкуClick the значок , найдите свой язык или выберите его в списке доступных языков. icon, search for your language, or select from the list of available languages.


Используйте Visual Studio 2017 для Mac для создания мобильных, облачных и веб-приложений с помощью Xamarin и .NET Core, а также для создания игр с помощью Unity.Use Visual Studio 2017 for Mac to build apps for mobile, web, and the cloud with Xamarin and .NET Core, as well as games with Unity.

Скачать последнюю версию Visual Studio для Mac 2017Download the Current Release of Visual Studio for Mac 2017

Download Visual Studio 2017 for Mac

Дополнительные сведения о Visual Studio 2017 для Mac см. в статьях Требования к системе Mac и Целевая платформа и совместимость для Mac.To learn more about Visual Studio 2017 for Mac, see Mac System Requirements and Mac Platform Targeting and Compatibility.

Для получения дополнительных сведений о связанных скачиваемых файлах обратитесь к странице Загрузки.To learn more about other related downloads, see the Downloads page.

ОтзывыFeedback

Мы будем рады узнать ваше мнение!We’d love to hear from you! Вы можете сообщить о проблеме с помощью параметра интегрированной среды разработки Visual Studio для Mac, а затем отслеживать свой отзыв на портале сообщества разработчиков.You can report a problem via the Report a Problem option the Visual Studio for Mac IDE and track your feedback in the Developer Community portal. Свои предложения отправляйте через UserVoice.For suggestions, let us know through UserVoice.

История выпусковRelease History


5 марта 2018 г. — Visual Studio 2017 для Mac версии 7.4 (7.4.0.1033)March 5, 2018 - Visual Studio 2017 for Mac 7.4 (7.4.0.1033)

В выпуске Visual Studio для Mac версии 7.4 мы постарались уделить внимание основным проблемам с утечкой памяти, производительностью и стабильностью, о которых нам сообщали пользователи.For the Visual Studio for Mac 7.4 release, we've taken time to focus on fixing some of the top memory leaks, performance problems, and stability issues that have been reported to us. В этот выпуск также добавлены поддержка функций разработки Android Oreo 8.1 и несколько улучшений для разработчиков Xamarin.This release also brings support for Android Oreo 8.1 development and several productivity enhancements for Xamarin developers.

Основные сведения о выпускеRelease Highlights

  • Теперь официально поддерживается macOS High Sierra.macOS High Sierra is now officially supported.
  • Поддержка Xcode 9.3.Support for Xcode 9.3.
  • Теперь поддерживается C# версии 7.1 (см. статью о новых возможностях C# 7.1).C# 7.1 is now supported (see what's new in C# 7.1).
  • Поддержка Android 8.1 Oreo.Support for Android 8.1 Oreo.
  • Беспроводное развертывание и отладка для Xamarin.iOS.Wireless deployment and debugging for Xamarin.iOS.
  • Внесены основные архитектурные изменения в редактор C#. В результате в IntelliSense улучшены производительность, надежность и скорость отклика при вводе.Core architectural changes were made to the C# editor; both IntelliSense performance/reliability and typing responsiveness are improved as a result.

Исправленные ошибки в этом выпускеIssues fixed in this release

Подробные сведения о выпускеRelease in Detail

  • Добавлено меню Правка > Переключиться в режим предложений, чтобы можно было переключаться между режимами предложения и завершения IntelliSense.Added an Edit > Switch to Suggestion Mode menu, to toggle between IntelliSense suggestion mode and completion mode. В этом режиме предложения автозаполнения IntelliSense не перезаписывают текст, который вы написали, если вы вручную не выберете их из списка предложений IntelliSense.In suggestion mode, IntelliSense auto-complete suggestions will not override the text you've written unless you manually choose them from the IntelliSense suggestion list. Чтобы вернуться в режим завершения, выберите меню "Правка" > "Переключиться в режим завершения".To switch back to Completion Mode you can choose the Edit | Switch to Completion Mode menu. Доступно стандартное сочетание клавиш CTRL+ALT+ПРОБЕЛ, если вы используете схемы настраиваемого сочетания клавиш Visual Studio (смешанная версия) или Visual Studio (Windows).A default keyboard shortcut of Ctrl+Alt+Space is provided if you're using Visual Studio (Mixed) or Visual Studio (Windows) key binding schemes.

  • Добавлен ярлык CMD+SHIFT+P, который открывает отфильтрованное поле поиска "Перейти к", чтобы вы могли искать доступные команды с учетом текущего контекста.Added a Cmd+Shift+P shortcut that will open the Navigate To search box, filtered so you can search for available commands based on your current context.

Debug source files option
Рис. 1. Фильтрация команд(Figure 1) Command Filtering
  • Поиск исходных файлов отладчика.Debugger source lookup.

    • Добавлена поддержка вкладки Исходные файлы отладки в параметрах решения (рис. 2).Added support for the Debug Source Files tab in solution options (Figure 2). Чтобы не загромождать пользовательский интерфейс, это меню отобразится, только когда вы добавите первую папку.To keep the UI clean, this menu appears only after you add the first folder.

      Debug source files option
      Рис. 2. Параметр исходных файлов отладки(Figure 2) Debug source files option
    • Если вы пытаетесь перейти к кадру стека или методу и отладчик не может найти исходные файлы, отображается новый диалоговое окно Исходный код не найден (рис. 3).If you try to navigate to a stack frame or step into a method and the debugger doesn't find source files, a new Source Not Found document (Figure 3) is shown. В нем предоставлены некоторые параметры для поиска существующих исходных файлов.This document helps to provide some options to locate source files if you have them. Он может пригодиться при отладке сборок, которые скомпилированы в ходе непрерывной интеграции, если у пользователя есть доступ к исходным файлам и PDB-файлам.This is useful when debugging assemblies that were compiled on CI and user has access to source files and .pdb file.

      New 'source not found' dialog
      Рис. 3. Новое диалоговое окно "Исходный код не найден"(Figure 3) New "source not found" dialog
  • В проект добавлен наблюдатель файлов для обнаружения файлов.File watcher to detect files added to the project.

    Теперь Visual Studio для Mac будет обнаруживать файлы, добавленные в проект .NET Core или удаленные из него, и будет динамически обновлять окно "Решение" в соответствии с изменениями.Visual Studio for Mac will now detect files added to or removed from a .NET Core project and update the Solution window with the changes dynamically. Это улучшение решает проблему выгрузки и перезагрузки после миграции EF, о которой сообщалось в сообществе разработчиков.This improvement addressed the unload/reload required after EF migrations issue reported in the Developer Community.

  • Использование каталога VS для USERPREFS-файлаUse .vs directory for .userprefs

    • Чтобы улучшить совместимость с Visual Studio в Windows, файл параметров пользователя, созданный средой Visual Studio для Mac, больше не хранится в каталоге решения. Вместо этого он хранится в каталоге .vs/SolutionName/xs/UserPrefs.xml.To improve compatibility with Visual Studio on Windows the user preferences file generated by Visual Studio for Mac are no longer stored in the solution directory but are now stored in .vs/SolutionName/xs/UserPrefs.xml.

XamarinXamarin

  • Больше не поддерживается функция "Upload to Xamarin Test Cloud" (Отправить в Xamarin Test Cloud) в среде Visual Studio для Mac (она вызывалась при щелчке правой кнопкой мыши дерева модульного теста).We no longer support the “Upload to Xamarin Test Cloud” function in Visual Studio for Mac (invoked by right-clicking the Unit test tree). Тесты переадресации можно отправлять с помощью CLI Центра приложений Visual Studio.Moving forwards tests can be submitted through the Visual Studio App Center CLI.

  • Мы удалили поддержку компонентов в интегрированной среде разработки.We have removed the support for components in IDE. Если вы откроете проект с компонентами, на которые существуют ссылки, вы увидите ошибку.If you open a project that has components already referenced, you will be met with an error. Чтобы исправить эту ошибку, необходимо вручную изменить CSPROJ-файл и удалить все сведения в тегах <XamarinComponentReference/>.The fix this error, you must edit the .csproj file manually and remove all information in the <XamarinComponentReference/> tags. Дополнительные сведения см. в руководстве по миграции компонентов.For more information see the Components migration guide.

iOSiOS

  • Мы добавили поддержку для беспроводного развертывания и отладки устройств AppleTV и iOS.We've added support for wireless deployment and debugging for iOS or AppleTV devices. Когда подключенное через сеть устройство готово для развертывания, оно отображается в списке целевых устройств, как если бы оно было подключено через USB.When a device is connected via a network and ready to be used for deployment, it now shows up in the device target list, as if the device were connected through USB. Рис. 4.(Figure 4):

    Apple device connected over Wi-Fi selected in device list
    Рис. 4. Устройство Apple, подключенное по сети, отображается в списке устройств(Figure 4) Apple device connected over a network is displayed in device list

    См. дополнительные сведения в руководстве по беспроводному развертыванию.For more information on this feature, see the Wireless Deployment guide.

  • Теперь среда Visual Studio для Mac предлагает разблокировать устройство развертывания перед запуском приложения (рис. 5) и не прерывает сеанс отладки:Visual Studio for Mac now asks to unlock the deployment device before launching the app (Figure 5) and does not interrupt the debugging session:

    Alert advising user to unlock iOS device
    Рис. 5. Оповещение, предлагающее пользователю разблокировать устройство iOS(Figure 5) Alert advising user to unlock iOS device
  • Теперь Visual Studio для Mac автоматически создает привязки C# для моделей CoreML, когда они добавляются в проект. Это обновление позволяет быстро и легко использовать модели CoreML.Visual Studio for Mac now auto-generates C# bindings for CoreML models when they are added to a project allowing for quick and easy usage of CoreML models.

  • Улучшения подготовкиProvisioning Improvements:

    • В этой версии улучшен рабочий процесс установки fastlane.This release introduces a better fastlane installation workflow. Если fastlane отсутствует, вместо отображения диалогового окна об ошибке с предложением ознакомиться с документацией по подготовке и установке fastlane мы предоставляем возможность установить fastlane в среде IDE.If fastlane is not installed, instead of showing an error dialog asking you to read the provisioning documentation and install fastlane, we provide a way to do it within the IDE.
    • В зависимости от скорости Интернета и параметров компьютера, установка может длиться до двух минут.Depending on the internet speed and computer parameters the installation can take up to two minutes. Поэтому для вашего удобства fastlane загружается в фоновом режиме.For this reason, fastlane will be downloaded in the background for your convenience.
    • Мы внесли ряд улучшений пользовательского интерфейса в мини-приложение автоматической подготовки в редакторе Info.plist.We made a number of UI improvements to the automatic provisioning widget in Info.plist editor. Новое мини-приложение разделяет ручной и автоматический режимы подготовки и сообщает пользователю состояние подготовки.The new widget draws a definite distinction between manual and automatic provisioning modes and communicates provisioning status to the user.

AndroidAndroid

Android 8.1 Oreo — это последняя версия Android, доступная в Google.Android 8.1 Oreo is the latest version of Android available from Google. В Android 8.1 Oreo доступно множество новых компонентов для разработчиков Xamarin.Android, например Android Go, API Neural Networks, обновления Autofill Framework, API SharedMemory и т. д.Android 8.1 Oreo offers many new features of interest to Xamarin.Android developers such as Android Go, Neural Networks API, Autofill Framework updates, SharedMemory API, and many more. Эти API доступны для приложений Xamarin.Android при использовании Xamarin.Android 8.2 и более поздних версий.These APIs are available to Xamarin.Android apps when you use Xamarin.Android 8.2 and later.

  • Мы добавили интеграцию с диспетчером устройств Xamarin Android (предварительная версия) для пользователей, которые установили пакет SDK Tools 26.We've added integration for the Xamarin Android Device Manager (preview) for users with SDK Tools 26 installed. Дополнительные сведения см. в документации.For more information, refer to the documentation.

  • Вы получите предупреждение, если эмулятор Android не использует HAXM.You'll now be warned if the Android emulator is not using HAXM.

Визуальные конструкторыVisual Designers

Конструктор iOSiOS Designer
  • Настраиваемые сочетания клавиш режима ограниченийConstraints Mode Key Bindings:

    Новые настраиваемые сочетания клавиш упрощают работу в новом режиме ограничений (доступно в версии 15.5).New key bindings make it easier to work with the new constraints mode (introduced in 15.5). Пример:For example:

    • Переключение в режим ограничений: ⌘+E.Toggle constraints mode: ⌘ E
    • Временное включение режима ограничений: удержание клавиши ⌃.Temporarily enable constraints mode: Hold ⌃
    • Обновление ограничений или обновление фреймов в режиме ограничений: ⇧+⌘+R.In constraints mode, update constraints; else update frames: ⇧ ⌘ R
  • Теперь для tvOS можно включить варианты признаковTrait Variations can now be enabled for tvOS :

    Теперь для раскадровок tvOS и XIB можно включить варианты признаков, что позволяет изменять стиль со светлого на темный.Trait variations can now be enabled for tvOS storyboards and XIBs, which enables variation by light style or dark style.

  • Автоматическое уменьшение масштаба при перетаскивании больших элементов из панели элементовAutomatic Zoom Out when dragging large items from the Toolbox:

    Поверхность конструктора теперь автоматически уменьшает свой масштаб при перетаскивании большого элемента из панели элементов.The design surface now automatically zooms out when you drag a large item from the toolbox. Это упрощает размещение крупных элементов в файле XIB или раскадровке.This makes it easier to place large items on your XIB or storyboard.

  • Индикатор и селектор увеличенияZoom Indicator and Selector:

    Указывает текущий процент увеличения и позволяет выбирать уровни увеличения в всплывающем списке.Indicates current zoom level percentage and enables selecting zoom levels from a pop up list.

Конструктор AndroidAndroid Designer
  • Синтаксический разбор и обработка ресурса Android значительно изменена в этом выпуске, что увеличило производительность и точность на доске.Android resource parsing and processing has been vastly revamped in this release resulting in increased performance and accuracy across the board.
  • Добавлена поддержка отрисовки Android Oreo (API 26).Added Android Oreo (API 26) rendering support.
  • Теперь поддерживаются такие компоненты Oreo, как настраиваемые шрифты и адаптивные значки.Oreo features like custom fonts and adaptive icons are now supported.
  • Увеличение скорости отрисовки.Rendering speed improvements.
  • Улучшен режим завершения IntelliSense.Improved IntelliSense completion experience.

Xamarin.FormsXamarin.Forms

Мы исправили несколько ошибок для улучшения редактирования XAML:We fixed a number of bugs to improve XAML editing:

  • [ИСПРАВЛЕНО] Непредсказуемое поведение в редакторе XML или XAML для vsmac и vs при нажатии клавиши ВВОД для добавления нового атрибута в элемент.[FIXED] Inconsistent behavior in XML/XAML editor between vs/vsmac when hitting "ENTER" in to add a new attribute to an element.
  • [ИСПРАВЛЕНО] Для завершения отсутствуют многие элементы: ResourceDictionary, x:Double, x:Key и т. д.[FIXED] Many elements are missing from completion: ResourceDictionary, x:Double, x:Key etc.
  • [ИСПРАВЛЕНО] После ввода точки в имени функция IntelliSense недоступна.[FIXED] No IntelliSense after typing period in name.
  • [ИСПРАВЛЕНО] В IntelliSense отсутствует одна платформа.[FIXED] One Platform is missing from IntelliSense.
  • [ИСПРАВЛЕНО] Клавиша TAB вставляет пробелы, клавиша отступа вставляет символы табуляции.[FIXED] Tab key inserts spaces, indenter inserts tabs.
  • [ИСПРАВЛЕНО] XAML IntelliSense отображает свойства элементов, отсортированные по длине имени.[FIXED] XAML IntelliSense lists element properties sorted by length of name.

Xamarin Workbooks и установщикXamarin Workbooks and Installer

Мы полностью отделили Xamarin Inspector от Xamarin Workbooks.We have fully split Xamarin Inspector from Xamarin Workbooks. Для работы расширения Inspector больше не требуется устанавливать расширение Workbooks.The Inspector extension no longer requires a Workbooks installation to function.

Все заметки о выпуске продукта XamarinAll Xamarin Product release notes


26 марта 2018 г. — Visual Studio 2017 для Mac версии 7.4.1 (7.4.1.48)March 26, 2018 - Visual Studio 2017 for Mac 7.4.1 (7.4.1.48)


3 апреля 2018 г. — Visual Studio 2017 для Mac версии 7.4.2 (7.4.2.12)April 3, 2018 - Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)

Этот выпуск включает поддержку Xcode 9.3. В нем реализовано решение следующих проблем:This release includes support for Xcode 9.3 and addresses the following issues:


Известные проблемыKnown Issues


Журнал заметок о выпуске Visual Studio 2017 для MacVisual Studio 2017 for Mac Release Notes History

Заметки о выпуске Visual Studio 2017 для Mac версии 7.3Visual Studio 2017 for Mac version 7.3 Release Notes

Заметки о выпуске Visual Studio 2017 для Mac версии 7.2Visual Studio 2017 for Mac version 7.2 Release Notes

Заметки о выпуске Visual Studio 2017 для Mac версии 7.1Visual Studio 2017 for Mac version 7.1 Release Notes

Заметки о выпуске Visual Studio 2017 для Mac версии 7.0Visual Studio 2017 for Mac version 7.0 Release Notes


К началу страницы
Top of Page