Развертывание решения Office с помощью установщик WindowsDeploy an Office solution by using Windows Installer

Узнайте, как создать файл установщика Windows для решения Office при помощи Visual Studio 2013Visual Studio 2013.Learn how to create a Windows Installer for your Office solution by using Visual Studio 2013Visual Studio 2013.

Благодаря созданию установщика Windows при помощи Visual Studio можно развернуть решение Office, для которого требуется административный доступ на компьютере конечного пользователя.By using Visual Studio to create a Windows Installer, you can deploy an Office solution that requires administrative access on the end user's computer. Например, файл установщика можно использовать для одновременной установки решения для всех пользователей компьютера.For example, you can use such a file to install a solution only once for all users of a computer. Решение Office можно также развернуть с помощью ClickOnce, но в таком случае решение придется установить отдельно для каждого пользователя компьютера.You can also deploy an Office solution by using ClickOnce, but that solution must be installed separately for each user of the computer.

Note

Интересуетесь разработкой решений, расширяющих возможности Office на нескольких платформах?Interested in developing solutions that extend the Office experience across multiple platforms? Ознакомьтесь с новой моделью надстроек Office.Check out the new Office Add-ins model. Надстройки Office имеют небольшой объем по сравнению с надстройками и решениями VSTO, и их можно создавать с помощью практически любой технологии веб-программирования, такой как HTML5, JavaScript, CSS3 и XML.Office Add-ins have a small footprint compared to VSTO Add-ins and solutions, and you can build them by using almost any web programming technology, such as HTML5, JavaScript, CSS3, and XML.

Содержание разделаIn this topic

Дополнительные сведения о развертывании решения Office с помощью ClickOnce см. в статье развертывание решения Office с помощью ClickOnce.For more information about how to deploy an Office solution by using ClickOnce, see Deploy an Office solution by using ClickOnce.

Сведения о создании файла установщик Windows с помощью Visual Studio 2010Visual Studio 2010см. в разделе развертывание решения Visual Studio 2010 Tools for Office с помощью установщик Windows.For information about how to create a Windows Installer file by using Visual Studio 2010Visual Studio 2010, see Deploy a Visual Studio 2010 Tools for Office solution using Windows Installer.

Загружаемые примерыDownload samples

Этот раздел ссылается на следующие загружаемые примеры.This topic refers to the following downloadable samples.

ПримерSample

ОписаниеDescription

ExcelAddInExcelAddIn

Надстройка VSTO Excel, которую можно установить на компьютере, на котором запущена 32-разрядная или 64-разрядная версия Office.An Excel VSTO Add-in that you can install on a computer that runs a 32-bit or 64-bit version of Office.

ExcelWorkbookExcelWorkbook

Настройка уровня документа Excel, которую можно установить на компьютере, на котором запущена 32-разрядная или 64-разрядная версия Office.An Excel document-level customization that you can install on a computer that runs a 32-bit or 64-bit version of Office.

Выбор способа предоставления доверия решениюDecide how to grant trust to the solution

Прежде чем решение можно будет запускать на компьютерах пользователей, необходимо предоставить доверие одним из следующих способов. В противном случае пользователи должны будут ответить на запрос о доверии при установке решения.Before a solution can run on user computers, you must grant trust in either of the following ways, or users must respond to a trust prompt when they install the solution.

Note

Для настроек уровня документа расположение документа также должно быть доверенным.For document-level customizations, the location of the document must also be trusted. Дополнительные сведения см. в разделе Предоставление доверия документам.For more information, see Grant trust to documents.

Получение InstallShield Limited EditionGet InstallShield Limited Edition

Можно создать файл установщика Windows с помощью выпуска InstallShield Limited Edition (ISLE), который предоставляется бесплатно, если установлена система Visual Studio.You can create a Windows Installer file by using InstallShield Limited Edition (ISLE), which is free if you've installed Visual Studio. ISLE заменяет функциональность шаблонов проектов для установки и развертывания, которые предлагались в предыдущих версиях Visual Studio.ISLE replaces the functionality of the project templates for setup and deployment that previous versions of Visual Studio offered.

Получение InstallShield Limited EditionTo get InstallShield Limited Edition

  1. В строке меню выберите Файл > Создать > Проект.On the menu bar, choose File > New > Project.

    Откроется диалоговое окно Новый проект .The New Project dialog box opens.

  2. В области шаблонов разверните узел Другие типы проектови выберите шаблон Установка и развертывание .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  3. В списке типов проекта для шаблона Установка и развертываниевыберите Включение InstallShield Limited Edition, а затем нажмите кнопку ОК .In the list of project types for Setup and Deployment, choose Enable InstallShield Limited Edition, and then choose the OK button.

    Откроется страница, которая содержит сведения о получении InstallShield Limited Edition.A page appears that provides information about how to get InstallShield Limited Edition.

  4. На этой странице щелкните ссылку Перейдите на веб-сайт загрузки .On that page, choose the Go to the download web site link.

  5. На странице загрузки выпуска InstallShield Limited Edition введите необходимые сведения в соответствующие поля, а затем щелкните ссылку Загрузить сейчас .On the download page for InstallShield Limited Edition, enter the required information into the appropriate fields, and then choose the Download Now link.

    После загрузки, установки и активации продукта в Visual Studio появляется шаблон Проект InstallShield Limited Edition .After you download, install, and activate the product, the InstallShield Limited Edition Project template appears in Visual Studio.

Создание проекта установкиCreate a setup project

  1. В Visual StudioVisual Studioоткройте развертываемый проект Office.In Visual StudioVisual Studio, open the Office project that you want to deploy.

    Примеры надстройки VSTO, связанные с этим разделом, содержат проект с именем ExcelAddIn.The VSTO Add-in samples that are associated with this topic contain a project that's named ExcelAddIn. Примеры настройки уровня документа содержат проект с именем ExcelWorkbook.The document-level customization samples contain a project that's named ExcelWorkbook. Этом раздел будет ссылаться на проект Office в решении с помощью одного из этих двух имен.This topic will refer to the Office project in your solution by using one of those two names.

  2. В строке меню выберите файл > Добавить > Новый проект.On the menu bar, choose File > Add > New Project.

    Откроется диалоговое окно Добавить новый проект .The Add New Project dialog box opens.

  3. В области шаблонов разверните узел Другие типы проектови выберите шаблон Установка и развертывание .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  4. В списке типов проекта для шаблона Установка и развертываниевыберите Проект InstallShield Limited Edition, присвойте имя проекту и нажмите кнопку ОК .In the list of project types for Setup and Deployment, choose InstallShield Limited Edition Project, name the project, and then choose the OK button.

    Созданный проект установки InstallShield появится в решении.The InstallShield setup project that you created appears in your solution.

    Примеры этого раздела содержат проект установки с именем OfficeAddInSetup.The samples for this topic contain a setup project that's named OfficeAddInSetup. Этот раздел будет ссылаться на проект установки в решении с помощью того же имени.This topic will refer to the setup project in your solution by using the same name.

Добавление выходного элемента проектаAdd the project output

Настройте проект OfficeAddInSetup для включения вывода проекта Office.You configure the OfficeAddInSetup project to include the output of your Office project. Для проектов надстроек VSTO выходными данными является только сборка решения.For VSTO Add-in projects, the project output is the solution assembly only. Для проектов настройки уровня документа выходной элемент проекта содержит не только сборку решения, но также сам документ.For document-level customization projects, the project output includes not only the solution assembly but also the document itself.

Добавление выходного элемента проектаTo add the project output

  1. В обозревателе решенийразверните узел проекта OfficeAddInSetup и выберите файл Project Assistant , как показано на следующем рисунке.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Файл помощника по проекту в Обозреватель решенийProject Assistant File in Solution Explorer

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

  3. В нижней части страницы Project assistant , нажмите кнопку Файлы приложения , как показано на следующем рисунке.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    Кнопка файлы приложения.The Application Files button.

  4. На странице Файлы приложения нажмите кнопку Добавление выходных элементов проекта .In the Application Files page, choose the Add Project Outputs button.

  5. В диалоговом окне Селектор вывода Visual Studio установите флажок Основные выходные файлы , а затем нажмите кнопку ОК .In the Visual Studio Output Selector dialog box, select the Primary Output check box, and then choose the OK button.

Добавление манифестов развертывания и приложенияAdd the deployment and application manifests

  1. На странице Файлы приложения нажмите кнопку Добавить файлы .In the Application Files page, choose the Add Files button.

  2. В диалоговом окне Открыть откройте папку выходных файлов проекта ExcelAddIn .In the Open dialog box, browse to the output directory of the ExcelAddIn project.

    Как правило, каталогом выходных файлов является подпапка bin\release корневого каталога проекта, в зависимости от выбранной конфигурации сборки.Usually, the output directory is the bin\release subfolder of the project root directory, depending on the build configuration that you choose.

  3. В каталоге выходных файлов выберите файлы ExcelAddIn.vsto и ExcelAddIn.dll.manifest , а затем нажмите кнопку Открыть .In the output directory, choose the ExcelAddIn.vsto and ExcelAddIn.dll.manifest files, and then choose the Open button.

    Страница Файлы приложения теперь содержит выходной файл проекта, манифест развертывания и манифест приложения, как показано на следующем рисунке.The Application Files page now contains the project output file, the deployment manifest, and the application manifest, as the following illustration shows.

    Выходные файлы проекта установки.The output files of your setup project.

Настройка зависимых компонентов в качестве необходимых компонентовConfigure the dependent components as prerequisites

В приложение установки необходимо включить не только следующие компоненты, но и все другие компоненты, необходимые для запуска решения.In your setup application, you must include not only the following components but also any other components that are required for your solution to run.

  • Версия платформы .NET Framework, для которой предназначено решение Office.The version of the .NET Framework that your Office solution targets.

  • Среда выполнения средств Microsoft Visual Studio 2010 для Office.The Microsoft Visual Studio 2010 Tools for Office Runtime.

Добавьте .NET Framework 4 или .NET Framework 4,5 в качестве необходимого компонента.Add the .NET Framework 4 or the .NET Framework 4.5 as a prerequisite

  1. В обозревателе решенийпоследовательно разверните узел проекта OfficeAddInSetup и узел Specify Application Data и выберите файл Redistributables , как показано на следующем рисунке.In Solution Explorer, expand the OfficeAddInSetup project node, expand the Specify Application Data node, and then choose the Redistributables file, which the following illustration shows.

    Распространяемый файл в Обозреватель решенийThe Redistributables file in Solution Explorer

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

    Откроется страница Redistributables .The Redistributables page opens.

  3. В списке распространяемых компонентов установите соответствующий флажок для версии платформы .NET Framework, для которой предназначено решение.In the list of redistributable components, select appropriate the check box for the version of the .NET Framework that your solution targets.

    Например, если решение предназначено для .NET Framework 4.5.NET Framework 4.5, установите флажок Microsoft .NET Framework 4.5 Full .For example, if your solution targets the .NET Framework 4.5.NET Framework 4.5, select the Microsoft .NET Framework 4.5 Full check box. Может появиться диалоговое окно с запросом на подтверждение установки распространяемого компонента, которое требуется системе InstallShield, прежде чем можно будет добавить этот компонент в качестве необходимого компонента.A dialog box might appear asking whether you want to install the redistributable component, which InstallShield requires before you can add the component as a prerequisite. Если это диалоговое окно не отображается, компонент уже существует на компьютере.If this dialog box doesn't appear, the component already exists on your computer.

  4. Если это диалоговое окно отображается, нажмите кнопку Нет .If this dialog box appears, choose the No button.

Добавление среды выполнения средств Visual Studio 2010 для OfficeAdd the Visual Studio 2010 Tools for Office Runtime

Страница Redistributables содержит элемент с именем Microsoft VSTO 2010 Runtime, но он ссылается на более старую версию среды выполнения.The Redistributables page contains an item that's named Microsoft VSTO 2010 Runtime, but it refers to an older version of the runtime. Поэтому можно вручную создать файл конфигурации, который ссылается на самую последнюю версию.Therefore, you could manually create a configuration file that refers to the most recent version. Затем необходимо поместить этот файл в один каталог с файлами конфигурации для всех других элементов, отображаемых на странице Redistributables .You must then put that file into the same directory as the configuration files for all of the other items that appear in the Redistributables page.

Добавление среды выполнения Visual Studio 2010 Tools for Office в качестве необходимого компонентаTo add the Visual Studio 2010 Tools for Office runtime as a prerequisite

  1. Откройте Блокнот и вставьте следующий XML-код в текстовый файл.Open Notepad, and then paste the following XML into a text file.

    <?xml version="1.0" encoding="UTF-8"?>
    <SetupPrereq>
    <conditions>
        <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    </conditions>
    <files>
        <file LocalFile="<ISProductFolder>\SetupPrerequisites\VSTOR\vstor_redist.exe" URL="http://download.microsoft.com/download/C/0/0/C001737F-822B-48C2-8F6A-CDE13B4B9E9C/vstor_redist.exe" CheckSum="88b8aa9e8c90818f98c80ac4dd998b88" FileSize=" 0,40117912"></file>
    </files>
    <execute file="vstor_redist.exe" returncodetoreboot="1641,3010" requiresmsiengine="1">
    </execute>
    <properties Id="{15965040-56BB-49B8-A88F-3525C48D9BA8}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
    </SetupPrereq>
    
  2. Создайте идентификатор GUID в Visual Studio.Generate a GUID in Visual Studio. В меню Сервис выберите пункт Создать GUID.On the Tools menu, choose Create GUID.

  3. В программе Генератор GUID выберите переключатель Формат реестра , нажмите кнопку Копировать , а затем кнопку Выход .In the GUID generator program, choose the Registry Format option button, choose the Copy button, and then choose the Exit button.

  4. В Блокноте замените текст Your GUID goes here , вставив на его место идентификатор GUID.In Notepad, replace the text Your GUID goes here by pasting the GUID in its place.

    Откроется диалоговое окно <properties> файла будет выглядеть следующим образом.The <properties> element of your file resembles the following.

    <properties Id="{87989B73-21DC-4403-8FD1-0C68A41A6D8C}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
  5. В строке меню в блокноте выберите файл > сохранить.On the menu bar in Notepad, choose File > Save.

  6. В диалоговом окне Сохранить как перейдите в папку Рабочий стол .In the Save As dialog box, browse to your Desktop folder.

  7. В списке Тип файла выберите все файлы*(.*) .In the Save as type list, choose All Files (*.*).

  8. В поле Имя файла введите Visual Studio 2010 Tools for Office Runtime.prq, а затем нажмите кнопку Сохранить .In the File name box, enter Visual Studio 2010 Tools for Office Runtime.prq, and then choose the Save button.

    Note

    Убедитесь, что вы добавили расширение .prq в конце имени файла, чтобы определить этот файл как необходимый компонент.Make sure that you add .prq at the end of the file name to identify this file as a prerequisite file.

  9. Закройте блокнот.Close Notepad.

  10. В папке Desktop скопируйте файл Visual Studio 2010 Tools для Office Runtime. prQ в один из следующих каталогов на компьютере.From your Desktop folder, copy the Visual Studio 2010 Tools for Office Runtime.prq file to one of the following directories on your computer.

Для 32-разрядных операционных систем :\ %ProgramFiles%\InstallShield\2013LE\SetupPrerequisitesFor 32-bit operating systems: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\

Для 64-разрядных операционных систем: % ProgramFiles (x86)% \ 2013LE \\ сетуппререкуиситесFor 64-bit operating systems: %ProgramFiles(x86)%\2013LE\SetupPrerequisites\

  1. На странице Redistributables проекта InstallShield, нажмите кнопку Обновить , чтобы обновить список распространяемых компонентов, как показано на следующем рисунке.In the Redistributable page of the InstallShield project, choose the Refresh button to refresh the list of redistributable components, as the following illustration shows.

Кнопка "Обновить".The refresh button.

  1. В списке распространяемых компонентов установите флажок Среда выполнения средств Visual Studio 2010 для Office .In the list of redistributable components, select the Visual Studio 2010 Tools for Office Runtime check box.

Может появиться диалоговое окно с запросом на подтверждение установки распространяемого компонента.A dialog box might appear asking whether you want to install the redistributable component. Если это диалоговое окно не отображается, можно перейти к разделу Укажите, где вы хотите развернуть решение на компьютере пользователя этого раздела.If this dialog box doesn't appear, you can skip to the Specify where you want to deploy the solution on the user's computer section of this topic.

  1. Если это диалоговое окно отображается, нажмите кнопку Нет .If this dialog box appears, choose the No button.

Указание места развертывания решения на компьютере пользователяSpecify where to install the solution on the user's computer

  1. В обозревателе решенийпоследовательно разверните узлы OfficeAddInSetup и Организация настройки , а затем выберите файл Общие сведения .In Solution Explorer, expand the OfficeAddInSetup node, expand the Organize your Setup node, and then choose the General Information file.

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

  3. В списке свойств, нажмите кнопку Обзор рядом с свойством INSTALLDIR .In the list of properties, choose the Browse button next to the INSTALLDIR property.

  4. В диалоговом окне Задание INSTALLDIR выберите папку на компьютере пользователя, на котором нужно установить решение.In the Set INSTALLDIR dialog box, choose a folder on the user's computer where you want to install the solution.

    Note

    В диалоговом окне Задать INSTALLDIR можно также создать подкаталоги, открыв контекстное меню для любой папки в списке.You can also create subdirectories in the Set INSTALLDIR dialog box by opening the shortcut menu for any folder in the list.

Настройка надстройки VSTOConfigure a VSTO Add-in

Вы можете указать, следует ли установить надстройку VSTO для всех пользователей компьютера (для компьютера) или только для пользователя, выполняющего установку (для пользователя).You can specify whether you want your VSTO Add-in to be installed for all users of the computer (per-computer), or only for the user performing the installation (per-user).

Если необходимо обеспечить поддержку установки для компьютера, создайте два отдельных установщика.If you want to support per-computer installations, create two separate installers. Разделение установщиков можно выполнить на основе версии Office (32-разрядная и 64-разрядная) или версии Windows (32-разрядная и 64-разрядная), в которой работает пользователь.You can split installers based on the Office version (32-bit and 64-bit) or on the Windows version (32-bit and 64-bit) that the user is running.

Для установки для отдельных пользователей требуется только один установщик независимо от версии Office или Windows.Per-user installations require only one installer regardless of Office or Windows version.

Note

Этот раздел применим только при развертывании надстройки VSTO.This section applies only if you're deploying a VSTO Add-in. Если вы развертываете настройку на уровне документа, можно сразу переходить к разделу Настройка настройки уровня документа .If you're deploying a document-level customization, you can immediately go to the Configure a document-level customization section.

Указание поддерживаемого типа установки: для пользователя или для компьютераTo specify whether you want to support per-user or per-computer installations

  1. В обозревателе решенийпоследовательно разверните узел проекта OfficeAddInSetup и узел Organize Your Setup , а затем выберите файл Общие сведения .In Solution Explorer, expand the OfficeAddInSetup project node, expand the Organize Your Setup node, and then choose the General Information file.

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

    Откроются свойства проекта установки.The properties of the setup project appear.

  3. В списке для свойства AllUSERS укажите, следует ли установить это решение для всех пользователей компьютера или только для пользователя, устанавливающего решение.In the list for the AllUSERS property, specify whether you want this solution to be installed for all users of the computer or for only the user who installs the solution.

    Чтобы установить надстройку VSTO для текущего пользователя, выберите ALLUSERS = "" (установка на пользователя) .To install the VSTO Add-in for the current user, choose ALLUSERS="" (Per-user installation). Чтобы установить надстройку VSTO для всех пользователей компьютера, выберите ALLUSERS=1 (установка для компьютера) .To install the VSTO Add-in for all users of the computer, choose ALLUSERS=1 (Per-machine installation)

    В следующей процедуре будут созданы разделы реестра, позволяющие приложению Office обнаруживать и загружать надстройку VSTO.In the next procedure, you'll create registry keys to enable the Office application to discover and load the VSTO Add-in. См. раздел записи реестра для надстроек VSTO.See Registry entries for VSTO Add-ins.

Создание разделов реестраTo create registry keys

  1. В обозревателе решенийвыберите узел Project Assistant .In Solution Explorer, choose the Project Assistant node.

    В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

  2. В нижней части страницы Project Assistant , нажмите кнопку Application Registry , как показано на следующем рисунке.At the bottom of the Project assistant page, choose the Application Registry button, which the following illustration shows.

    Кнопка реестра приложения.The Application Registry button.

    Откроется страница Application Registry .The Application Registry page appears.

  3. В разделе Do you want to configure the registry data that your application will install? (Вы хотите настроить данные реестра, которые будут установлены приложением?) выберите переключатель Да .Under Do you want to configure the registry data that your application will install?, choose the Yes option button.

  4. В списке представление реестра конечного компьютера Добавьте иерархию ключей, включающую тип создаваемого установщика.In the Destination computer's Registry view list, add the key hierarchy that enables the type of installer you want to create.

    Путь, который настраивается в этом разделе, зависит от того, какой установщик необходимо создать: для отдельного пользователя или для компьютера.The path that you configure in this section depends on whether you create a per-user installer or a per-computer installer.

    Установщик для отдельного пользователяPer-user installer

    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

    Установщики для компьютера на основе версии OfficePer-computer installers based on Office version

Версия OfficeOffice version

Путь конфигурации InstallShieldInstallShield Configuration Path

32-разрядная версия32-bit

HKEY_LOCAL_MACHINE\SOFTWARE (32-разрядная версия) \Микрософт\оффице\ексцел\аддинс\самплекомпани.ексцеладдинHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64-разрядная версия64-bit

\Микрософт\оффице\ексцел\аддинс\самплекомпани.ексцеладдин HKEY_LOCAL_MACHINE\SOFTWARE (64-разрядная версия)HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Установщики для компьютера на основе версии WindowsPer-computer installers based on Windows version

Версия WindowsWindows version

Путь конфигурации InstallShieldInstallShield Configuration Path

32-разрядная версия32-bit

HKEY_LOCAL_MACHINE\SOFTWARE (32-разрядная версия) \Микрософт\оффице\ексцел\аддинс\самплекомпани.ексцеладдинHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64-разрядная версия64-bit

HKEY_LOCAL_MACHINE\SOFTWARE (32-разрядная версия) \Микрософт\оффице\ексцел\аддинс\самплекомпани.ексцеладдинHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

\Микрософт\оффице\ексцел\аддинс\самплекомпани.ексцеладдин HKEY_LOCAL_MACHINE\SOFTWARE (64-разрядная версия)HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Note

Установщик для 64-разрядной ОС Windows требует наличия двух путей реестра, поскольку пользователи могут запускать 32-и 64-разрядные версии Office на компьютере под управлением 64-bit Windows.An installer for 64-bit Windows requires two registry paths because it's possible for users to run 32-bit and 64-bit versions of Office on a computer that runs 64-bit Windows.

Note

Рекомендуется, чтобы имя вашей надстройки VSTO начиналось с имени вашей компании.As a best practice, start the name of your VSTO Add-in with the name of your company. Это соглашение увеличивает вероятность того, что ключ будет уникальным и снизить вероятность конфликта с надстройкой VSTO от другого поставщика.This convention increases the chance that the key will be unique and decreases the chance of conflict with a VSTO Add-in from another supplier. Надстройки, имеющие одинаковые имена, могут, например, перезаписывать разделы реестра друг друга.Add-ins that have the same name can, for example, overwrite each other's registration keys. Такой подход не может гарантировать, что раздел будет уникальным, но может уменьшить потенциальные конфликты имен.This approach can't guarantee that the key will be unique but can reduce potential name collisions.

  1. После создания иерархии ключей откройте контекстное меню для ключа самплекомпани. ExcelAddIn , выберите создать, а затем выберите строковое значение.After you've created the hierarchy of keys, open the shortcut menu for the SampleCompany.ExcelAddIn key, choose New, and then choose String Value.

    Новое строковое значение появится в списке данных реестра конечного компьютера .The new string value appears in the Destination computer's Registry data list. Имя строкового параметра выделяется, чтобы его можно было изменить.The name of the string value is highlighted so that you can rename it.

  2. Задайте параметру имя Description.Rename the value to Description.

  3. Повторите эту процедуру, чтобы создать следующие параметры.Repeat this process to create the following values.

Тип значенияValue Type

nameName

Строковый параметрString Value

FriendlyNameFriendlyName

Параметр DWORDDWORD Value

LoadBehaviorLoadBehavior

Строковый параметрString Value

ManifestManifest

  1. Откройте контекстное меню для значения Description и выберите команду Изменить.Open the shortcut menu for the Description value, and then choose Modify.

    Откроется диалоговое окно Изменить данные .The Edit Data dialog box appears.

  2. В текстовом поле Значение введите Демонстрационная надстройка Excelи нажмите кнопку ОК .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

    Это описание отображается, когда пользователь запускает приложение Office, открывает диалоговое окно Параметры и затем выбирает надстройку VSTO в области Надстройки .This description appears when the user opens the Office application, opens the Options dialog box, and then, in the Add-Ins pane, chooses the VSTO Add-in.

  3. Откройте контекстное меню для параметра FriendlyName и выберите команду Изменить.Open the shortcut menu for the FriendlyName value, and then choose Modify.

Откроется диалоговое окно Изменить данные .The Edit Data dialog box appears.

  1. В текстовом поле Значение введите Демонстрационная надстройка Excelи нажмите кнопку ОК .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

Эта строка отображается в диалоговом окне Надстройки COM в приложении Office.This string appears in the COM Add-Ins dialog box in the Office application. По умолчанию значение строки представляет собой идентификатор надстройки VSTO.By default, the value of the string is the VSTO Add-in ID.

  1. Откройте контекстное меню для параметра LoadBehavior и выберите команду Изменить.Open the shortcut menu for the LoadBehavior value, and then choose Modify.

Откроется диалоговое окно Изменить данные .The Edit Data dialog box appears.

  1. В текстовом поле Значение введите 3и нажмите кнопку ОК .In the Value data text box, enter 3, and then choose the OK button.

Значение 3 загружает надстройку VSTO при запуске приложения.A value of 3 loads the VSTO Add-in when the application starts. Дополнительные сведения о значениях LoadBehavior см. в разделе записи реестра для надстроек VSTO.For more information about LoadBehavior values, see Registry entries for VSTO Add-ins.

  1. Откройте контекстное меню для параметра Manifest и выберите команду Изменить.Open the shortcut menu for the Manifest value, and then choose Modify.

Откроется диалоговое окно Изменить данные .The Edit Data dialog box appears.

  1. В текстовом поле Значение введите file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocalи нажмите кнопку ОК .In the Value data text box, enter file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal, and then choose the OK button.

Среда выполнения средств Visual Studio 2010 для Office использует этот путь для поиска манифеста развертывания.The Visual Studio 2010 Tools for Office Runtime uses this path to locate the deployment manifest. Часть [INSTALLDIR] этого пути представляет собой макрос, который сопоставлен свойству INSTALLDIR на странице свойств Общие сведения проекта установки InstallShield.The [INSTALLDIR] portion of this path is a macro that maps to the INSTALLDIR property in the General Information property page of your InstallShield setup project. Это свойство определяет расположение на целевом компьютере для установки надстройки VSTO.This property specifies the location on the target computer to install the VSTO Add-in. Суффикс |vstolocal гарантирует загрузку решения из папки установки, а не кэша ClickOnce.The |vstolocal suffix ensures that your solution is loaded from the installation folder, not the ClickOnce cache.

Important

При создании пользовательской области формы в надстройке VSTO для Outlook необходимо создать дополнительные записи реестра для регистрации региона в Outlook.If you create a custom form region in a VSTO Add-in for Outlook, you must create more registry entries to register the region with Outlook. Дополнительные сведения см. в разделе записи реестра для областей формы Outlook.For more information, see Registry entries for Outlook form regions.

Configure a document-level customizationConfigure a document-level customization

Этот раздел применим только в том случае, если выполняется развертывание настройки на уровне документа.This section applies only if you're deploying a document-level customization. Если вы развертываете надстройку VSTO, можно сразу же вернуться к разделу Построение проекта установки .If you're deploying a VSTO Add-in, you can go immediately to the Build the setup project section.

Настройки на уровне документа не используют разделы реестра.Document-level customizations don't use registry keys. Вместо этого расположение манифеста развертывания хранится в настраиваемых свойствах документа.Instead, custom document properties contain the location of the deployment manifest.

Для изменения пользовательских свойств создается программа, которая удаляет из документа настройку на уровне документа, изменяет соответствующие свойства, а затем повторно Прикрепляет настройку к документу.To modify custom properties, you create a program that removes the document-level customization from the document, modifies the appropriate properties, and then reattaches customization to the document. Затем нужно создать настраиваемое действие, которое запускает программу, и добавить это действие в проект установки.You then create a custom action that runs the program, and you add that action to your setup project.

Создание программы, изменяющей свойства документаTo create a program that modifies document properties

  1. В строке меню выберите файл > Добавить > Новый проект.On the menu bar, choose File > Add > New Project.

    Откроется диалоговое окно Добавление нового проекта .The Add New Project dialog box appears.

  2. В области шаблонов в узле используемого языка выберите папку Windows .In the templates pane, under the node for the language that you want to use, choose the Windows folder.

  3. В списке типов проекта для шаблона Windowsвыберите шаблон Консольное приложение .In the list of project types for Windows, choose the Console Application template.

  4. Присвойте проекту имя SetExcelDocumentPropertiesи нажмите кнопку ОК .Name the project SetExcelDocumentProperties, and then choose the OK button.

  5. В обозревателе решенийнажмите кнопку Показать все файлы , откройте контекстное меню для узла проекта SetExcelDocumentProperties и выберите пункт Добавить ссылку.In Solution Explorer, choose the Show All Files button, open the shortcut menu for the SetExcelDocumentProperties project node, and then choose Add Reference.

  6. В диалоговом окне Диспетчер ссылок перейдите на вкладку Расширения , а затем установите флажки рядом со следующими сборками и нажмите кнопку ОК .In the Reference Manager dialog box, choose the Extensions tab, and then select the check box next to the following assemblies, and then choose the OK button.

    • Microsoft.VisualStudio.Tools.Applications.RuntimeMicrosoft.VisualStudio.Tools.Applications.Runtime

    • Microsoft.VisualStudio.Tools.Applications.ServerDocumentMicrosoft.VisualStudio.Tools.Applications.ServerDocument

  7. В обозревателе решенийвыберите файл Program.cs (для приложений C#) или файл Module1.vb (для приложений Visual Basic).In Solution Explorer, choose the Program.cs file (for C# applications) or the Module1.vb file (for Visual Basic applications).

  8. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

  9. Замените все содержимое этого файла следующим кодом.Replace the contents of the entire file with the following code.

Imports Microsoft.VisualStudio.Tools.Applications.Runtime
Imports Microsoft.VisualStudio.Tools.Applications

Module Module1

    Sub Main()

        Dim assemblyLocation As String = ""
        Dim solutionID As Guid
        Dim deploymentManifestLocation As Uri = Nothing
        Dim documentLocation As String = ""
        Dim nonpublicCachedDataMembers As String() = Nothing

        Dim CommandLineArgs As  _
            System.Collections.ObjectModel.ReadOnlyCollection(Of String) = _
            My.Application.CommandLineArgs

        For i As Integer = 0 To CommandLineArgs.Count - 1

            Console.WriteLine(CommandLineArgs(i))
            Dim oArugment As String() = CommandLineArgs(i).Split("=")

            Select Case oArugment(0)

                Case "/assemblyLocation"
                    assemblyLocation = oArugment(1)

                Case "/deploymentManifestLocation"
                    If Not Uri.TryCreate(oArugment(1), UriKind.Absolute, _
                                         deploymentManifestLocation) Then
                        MsgBox("Error creating URI")
                    End If

                Case "/documentLocation"
                    documentLocation = oArugment(1)

                Case "/solutionID"
                    solutionID = Guid.Parse(oArugment(1))
            End Select
        Next
        Try
            ServerDocument.RemoveCustomization(documentLocation)
            ServerDocument.AddCustomization(documentLocation, assemblyLocation, _
                                            solutionID, deploymentManifestLocation, _
                                            True, nonpublicCachedDataMembers)

            Console.WriteLine("Insallation Location Modified Successfully")

        Catch ex As System.IO.FileNotFoundException
            Console.WriteLine("The specified document does not exist.")
            Console.ReadLine()


        Catch ex As System.IO.IOException
            Console.WriteLine("The specified document is read-only.")
            Console.ReadLine()


        Catch ex As InvalidOperationException

            Console.WriteLine("The customization could not be removed.\n" &
                ex.Message)
            Console.ReadLine()


        Catch ex As DocumentNotCustomizedException
            Console.WriteLine("The document could not be customized.\n" &
                ex.Message)
            Console.ReadLine()

        End Try
    End Sub

End Module
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Microsoft.VisualStudio.Tools.Applications.Runtime;
using Microsoft.VisualStudio.Tools.Applications;

namespace SetExcelDocumentProperties
{
    class Program
    {
        static void Main(string[] args)
        {
            string assemblyLocation = "";
            Guid solutionID = new Guid();
            Uri deploymentManifestLocation = null;
            string documentLocation = "";
            string[] nonpublicCachedDataMembers = null;

            for (int i = 0; i <= args.Count() - 1; i++)
            {
                Console.WriteLine(args[i]);
                string[] oArugment = args[i].Split('=');

                switch (oArugment[0])
                {
                    case "/assemblyLocation":
                        assemblyLocation = oArugment[1];
                        break;
                    case "/deploymentManifestLocation":
                        if (!Uri.TryCreate(oArugment[1], UriKind.Absolute, out deploymentManifestLocation))
                        {
                            Console.WriteLine("Error creating URI");
                        }
                        break;
                    case "/documentLocation":
                        documentLocation = oArugment[1];
                        break;
                    case "/solutionID":
                        solutionID = Guid.Parse(oArugment[1]);
                        break;
                }
            }
            try
            {
                ServerDocument.RemoveCustomization(documentLocation);
                ServerDocument.AddCustomization(documentLocation, assemblyLocation,
                                            solutionID, deploymentManifestLocation,
                                            true, out nonpublicCachedDataMembers);

            }
            catch (System.IO.FileNotFoundException)
            {
                Console.WriteLine("The specified document does not exist.");
            }
            catch (System.IO.IOException)
            {
                Console.WriteLine("The specified document is read-only.");
            }
            catch (InvalidOperationException ex)
            {
                Console.WriteLine("The customization could not be removed.\n" +
                    ex.Message);
            }
            catch (DocumentNotCustomizedException ex)
            {
                Console.WriteLine("The document could not be customized.\n" +
                    ex.Message);
            }
        }
    }
}
  1. Скомпилируйте проект.Compile the project.

Добавление настраиваемого действия, которое запускает программуTo add a custom action that runs your program

  1. В обозревателе решенийразверните узел проекта OfficeAddInSetup и выберите файл Project Assistant , как показано на следующем рисунке.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Файл помощника по проекту в Обозреватель решенийProject Assistant File in Solution Explorer

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

  3. В нижней части страницы Project assistant , нажмите кнопку Файлы приложения , как показано на следующем рисунке.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    Кнопка файлы приложения.The Application Files button.

  4. На странице Файлы приложения нажмите кнопку Добавление выходных элементов проекта .In the Application Files page, choose the Add Project Outputs button.

    Откроется диалоговое окно Селектор вывода Visual Studio .The Visual Studio Output Selector dialog box appears.

  5. В узле SetExcelDocumentProperties установите флажок Основные выходные файлы и нажмите кнопку ОК .Under the SetExcelDocumentProperties node, select the Primary Output check box, and then choose the OK button.

  6. В обозревателе решенийв узле OfficeAddInSetup разверните узел Define Setup Requirements and Actions (Определите требования и действия установки), а затем выберите папку Настраиваемые действия .In Solution Explorer, under the OfficeAddInSetup node, expand the Define Setup Requirements and Actions node, and then choose the Custom Actions folder.

  7. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

    В боковой области экрана открывается список событий.A list of events appear in a pane to the side of the screen.

    Note

    В выпуске InstallShield Limited Edition доступно только несколько событий, отображаемых в этом списке.Only a few events that appear in this list are available in InstallShield Limited Edition. В этой процедуре программа запускается с помощью события диалога после завершения установки .In this procedure, you'll run the program by using the After Setup Complete Success dialog event.

  8. В списке событий в разделе Custom Actions During Installation(Настраиваемые действия в процессе установки) откройте контекстное меню для события After Setup Complete Success dialog и выберите пункт New EXE(Новый EXE-файл).In the list of events, under Custom Actions During Installation, open the shortcut menu for the After Setup Complete Success dialog event, and then choose New EXE.

    Под событием After Setup Complete Success dialog появится настраиваемое действие с именем NewCustomAction1 .A custom action that's named NewCustomAction1 appears under the After Setup Complete Success dialog event. Набор свойств для настраиваемого действия отображается в области рядом с событиями.A set of properties for the custom action appears in a pane next to the events.

    Important

    В списке событий отображаются два события After Setup Complete Success dialog .Two After Setup Complete Success dialog events appear in the list of events. Убедитесь, что выбран экземпляр события After Setup Complete Success dialog , который отображается в узле Custom Actions During Installation .Make sure that you choose the instance of the After Setup Complete Success dialog event that appears under the Custom Actions During Installation node.

  9. В списке для свойства Source Location (Исходное расположение) выберите пункт Installed with the Product(Установлено вместе с продуктом).In the list for the Source Location property, choose Installed with the Product.

  10. Нажмите кнопку Обзор рядом с свойством File Name .Choose the Browse button next to the File Name property.

  11. В диалоговом окне Browse for a Destination File (Поиск целевого файла) перейдите к файлу SetExcelDocumentProperties.Primary.output и нажмите кнопку Открыть .In the Browse for a Destination File dialog box, browse to the SetExcelDocumentProperties.Primary.output file, and then choose the Open button.

    Расположение этого файла зависит от папки, указанной для свойства INSTALLDIR проекта установки.The location of this file depends on the folder that you specified for the INSTALLDIR property of the setup project. Например, если для этого свойства задана папка с именем [PersonalFolder]DemoWorkbookApp, файл SetExcelDocumentProperties.Primary.output можно найти, перейдя в папку [ProgramFilesFolder]\DemoWorkbookApp.For example, if you set that property to a folder that's named [PersonalFolder]DemoWorkbookApp, you can find the SetExcelDocumentProperties.Primary.output file by browsing to [ProgramFilesFolder]\DemoWorkbookApp.

    В следующих шагах вы получите идентификатор решения для документа, а затем передадите этот идентификатор в качестве параметра консольному приложению.In the next few steps, you'll get the solution ID of the document and then pass that ID as a parameter to the console application. Вы также передадите расположение документа, манифест развертывания и сборку документа.You'll also pass the location of the document, the deployment manifest, and the document assembly.

  12. Откройте контекстное меню для проекта ExcelWorkbook и выберите команду Открыть папку в проводнике Windows или Открыть папку в проводнике в зависимости от вашей операционной системы.Open the shortcut menu for the ExcelWorkbook project, and then choose Open Folder in Windows Explorer or Open Folder in File Explorer depending on your operating system.

    Откроется папка, содержащая решение.The folder that contains your solution opens.

  13. Откройте файл проекта решения в Блокноте.Open the project file of your solution in Notepad. Для проектов Visual Basic имя файла — ExcelWorkbook. vbproj.For Visual Basic projects, the name of the file is ExcelWorkbook.vbproj. Для C# проектов имя файла — ExcelWorkbook. csproj.For C# projects, the name of the file is ExcelWorkbook.csproj.

  14. В файле проекта найдите <элемент SolutionId> , скопируйте его значение в буфер обмена и закройте Блокнот.In the project file, search for the <SolutionID> element, copy its value to the Clipboard, and then close Notepad.

    Это значение передается в консольное приложение как параметр.You pass this value into the console app as a parameter.

  15. На странице свойств NewCustomAction1задайте для свойства Командная строка значение следующей строки текста.In the properties page of NewCustomAction1, set the Command Line property to the following line of text.

/assemblyLocation="[INSTALLDIR]ExcelWorkbook.dll" /deploymentManifestLocation="[INSTALLDIR]ExcelWorkbook.vsto" /documentLocation="[INSTALLDIR]ExcelWorkbook.xlsx" /solutionID="Your Solution ID"
  1. Замените Your Solution ID идентификатором решения, копированным в буфер обмена.Replace Your Solution ID with the solution ID that you copied to the Clipboard.

Important

Проверьте установщик, чтобы убедиться, что консольное приложение, запускаемое этим пользовательским действием, имеет доступ к документам в каталоге [INSTALLDIR].Test your installer to verify that the console application that this custom action runs can access documents in the [INSTALLDIR] directory. Для некоторых каталогов на компьютере пользователя может потребоваться административный доступ (например, каталог Program Files).Some directories on the user's computer might require administrative access (for example, the Program Files directory). При развертывании решения в каталоге, для которого требуется административный доступ, следует открыть диалоговое окно Свойства файла Setup. exe , перейти на вкладку Совместимость и выбрать команду запустить эту программу как. Администратор перед распространением установщика.If you're deploying your solution to a directory that requires administrative access, you should open the Properties dialog box of the setup.exe file, choose the Compatibility tab, and then select the Run this program as administrator check box before you distribute the installer. Если вы не хотите, чтобы пользователи запускают программу установки с правами администратора, задайте для свойства [INSTALLDIR] каталог, к которому пользователь, вероятно, уже имеет доступ, например каталог документы .If you don't want users to run the setup program with administrative permissions, set the [INSTALLDIR] property to a directory to which the user probably has access already, such as the Documents directory. Дополнительные сведения см. в разделе Указание места установки решения на компьютере пользователя этого раздела.For more information, see the Specify Where You Want to Install the Solution on the user's computer section of this topic.

Build the setup projectBuild the setup project

  1. В обозревателе решенийразверните узел Подготовка для выпуска и выберите файл Выпуски .In Solution Explorer, expand the Prepare for Release node, and then choose the Releases file.

  2. В строке меню выберите вид > Открыть.On the menu bar, choose View > Open.

    В боковой области открывается обозреватель Сборки для выбора типа создаваемого выпуска.The Builds explorer opens in a side pane so that you can choose the type of release that you want to create.

  3. В обозревателе Сборки выберите папку SingleImage .In the Builds explorer, choose the SingleImage folder.

  4. В области рядом с обозревателем Сборки перейдите на вкладку Setup.exe .In the pane next to the Builds explorer, choose the Setup.exe tab.

  5. На странице свойств Setup.exe в списке Местоположение необходимых компонентов InstallShield выберите Загрузить из Интернета.In the Setup.exe property page, from the InstallShield Prerequisites Location list, choose Download From The Web.

  6. В строке меню последовательно выберите пункты Сборка > Диспетчер конфигураций.On the menu bar, choose Build > Configuration Manager.

  7. В списке Активная конфигурация решения выберите SingleImage.In the Active solution configuration list, choose SingleImage.

  8. В таблице Конфигурации проектов в столбце Конфигурация проекта OfficeAddInSetup и выберите SingleImage, а затем нажмите кнопку Закрыть .In the Project contexts table, in the Configuration column of the OfficeAddInSetup project, choose SingleImage, and then choose the Close button.

  9. В строке меню выберите Сборка > сборкаOfficeAddInSetup.On the menu bar, choose Build > Build OfficeAddInSetup.

    После завершения сборки вы можете разместить файл Setup. exe проекта OfficeAddInSetup по следующему адресу: Оффицеаддинсетуппрожектрут \OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\After the build completes, you can locate the setup.exe file of the OfficeAddInSetup project at the following location: OfficeAddInSetupProjectRoot\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\

См. такжеSee also