Обзор удаленного голографического взаимодействия

Вы можете использовать голографическое удаленное взаимодействие для потоковой передачи голографического содержимого в HoloLens в режиме реального времени. Существует два основных способа использования голографического удаленного взаимодействия, и важно понимать разницу:

  1. (Unity или Unreal): вы хотите предварительно просмотреть и отладить приложение во время процесса разработки: вы можете запустить приложение локально в редакторе Unity на компьютере в режиме воспроизведения и выполнить потоковую передачу в HoloLens. Голографическое удаленное взаимодействие позволяет быстро отлаживать приложение без создания и развертывания полного проекта. Мы называем это приложение голографическим приложением проигрывателя удаленного взаимодействия.

  2. (Unity, Unreal или C++): вы хотите, чтобы ресурсы компьютера могли работать с приложением вместо использования HoloLens локальных ресурсов: вы можете создать и создать приложение с возможностью голографического удаленного взаимодействия. Пользователь работает с приложением в HoloLens, но приложение на самом деле выполняется на компьютере, что позволяет ему использовать все преимущества более мощных ресурсов компьютера. Голографическое удаленное взаимодействие может быть особенно полезным, если в вашем приложении есть ресурсы с высоким разрешением или модели, и вы не хотите, чтобы частота кадров страдала. Мы называем это приложение голографическим удаленным взаимодействием.

В любом случае входные данные из HoloLens-взгляда, жеста, голоса и пространственного сопоставления отправляются на компьютер, содержимое отображается в виртуальном иммерсивном представлении, а затем отрисовываются в HoloLens.

Примечание

При разработке удаленного приложения необходимо использовать API Windows Mixed Reality или API OpenXR. Сочетание обоих API в одном приложении не поддерживается.

Важно!

Голографическое удаленное взаимодействие для HoloLens 2 является основным изменением версии. Удаленные приложения для HoloLens (1-го поколения) должны использовать пакет NuGet версии 1.x.x иудаленные приложения для HoloLens 2 должны использовать версию 2.x.x. Это означает, что удаленные приложения, написанные для HoloLens 2, несовместимы с HoloLens (1-го поколения) и наоборот.

См. также: