2. Настройка Photon Unity Networking2. Setting up Photon Unity Networking

В этом учебнике показано, как подготовиться к созданию совместного взаимодействия с помощью Photon Unity Networking (PUN).In this tutorial, you will prepare for creating a shared experience using Photon Unity Networking (PUN). Вы узнаете, как создать приложение PUN, импортировать активы PUN в проект Unity и подключить проект Unity к приложению PUN.You will learn how to create a PUN app, import PUN assets into your Unity project, and connect your Unity project to the PUN app.

ЗадачиObjectives

  • Узнать, как создать приложение PUN.Learn how to create a PUN app
  • Узнать, как найти и импортировать активы PUN.Learn how to find and import the PUN assets
  • Узнать, как подключить проект Unity к приложению PUN.Learn how to connect your Unity project to the PUN app

Создание и подготовка проекта UnityCreating and preparing the Unity project

В рамках этого раздела вы создадите новый проект Unity и подготовите его к разработке MRTK.In this section, you will create a new Unity project and get it ready for MRTK development.

Для этого сначала выполните инструкции из руководства Инициализация проекта и развертывание первого приложения (исключая раздел Разработка приложения для устройства), в том числе следующие действия:First, follow the Initializing your project and deploying your first application, excluding the Build your application to your device instructions, which includes the following steps:

  1. Создание проекта Unity и присвоение ему подходящего имени, например MRTK Tutorials.Creating the Unity project and give it a suitable name, for example, MRTK Tutorials
  2. Переключение платформы сборки.Switching the build platform
  3. Импорт требуемых ресурсов TextMeshPro.Importing the TextMeshPro Essential Resources
  4. Импорт набора средств для Смешанной реальности (MRTK).Importing the Mixed Reality Toolkit
  5. Настройка проекта Unity.Configuring the Unity project
  6. Создание и настройка сцены и присвоение ей понятного имени, например MultiUserCapabilities.Creating and configuring the scene and give the scene a suitable name, for example, MultiUserCapabilities

Затем выполните инструкции из раздела Изменение параметра отображения отслеживания пространственного положения:Then follow the Changing the Spatial Awareness Display Option instructions to:

  1. Измените профиль конфигурации MRTK на DefaultHoloLens2ConfigurationProfile.Change the MRTK configuration profile for to the DefaultHoloLens2ConfigurationProfile
  2. Измените параметры отображения сетки отслеживания пространственного положения на Occlusion (Загораживание).Change the spatial awareness mesh display options to Occlusion.

Включение дополнительных возможностейEnabling additional capabilities

В меню Unity щелкните Edit > Project Settings... (Правка > Параметры проекта...), чтобы открыть окно параметров проигрывателя, а затем найдите раздел Player > Publishing Settings (Проигрыватель > Параметры публикации).In the Unity menu, select Edit > Project Settings... to open the Player Settings window, then locate the Player > Publishing Settings section:

Параметры проигрывателя Unity

В окне Publishing Settings (Параметры публикации) прокрутите содержимое вниз до раздела Capabilities (Возможности) и убедитесь, что здесь включены возможности InternetClient, Microphone, SpatialPerception и GazeInput, которые вы включили при выполнении шага Настройка проекта Unity ранее.In the Publishing Settings, scroll down to the Capabilities section and double-check that the InternetClient, Microphone, SpatialPerception, and GazeInput capabilities, which you enabled during the Configuring the Unity project step above, are enabled.

Затем включите следующие дополнительные возможности:Then enable the following additional capabilities:

  • возможность InternetClientServer;InternetClientServer capability
  • возможность PrivateNetworkClientServer.PrivateNetworkClientServer capability

Настройки возможностей Unity

Установка встроенных пакетов UnityInstalling inbuilt Unity packages

В меню Unity выберите Window > Package Manager (Окно > Диспетчер пакетов), чтобы открыть окно диспетчера пакетов, а затем щелкните AR Foundation и нажмите кнопку Install (Установить) для установки пакета.In the Unity menu, select Window > Package Manager to open the Package Manager window, then select AR Foundation and click the Install button to install the package:

Диспетчер пакетов Unity с выбранным пакетом AR Foundation

Примечание

Пакет AR Foundation необходимо установить, так как он требуется для пакета SDK Пространственных привязок Azure, который вы будете импортировать при работе со следующим разделом.You are installing the AR Foundation package because it is required by the Azure Spatial Anchors SDK you will import in the next section.

Импорт активов для руководстваImporting the tutorial assets

Скачайте и импортируйте следующие пользовательские пакеты Unity в указанном здесь порядке:Download and import the following Unity custom packages in the order they are listed:

Когда вы завершите импорт активов для руководства, окно проекта должно выглядеть примерно так:After you have imported the tutorial assets your Project window should look similar to this:

Unity с окнами Hierarchy (Иерархия), Scene (Сцена) и Project (Проект) после импорта ресурсов для руководства

Совет

Сведения о том, как правильно импортировать пользовательский пакет Unity, см. в разделе Импорт набора средств для Смешанной реальности.For a reminder on how to import a Unity custom package, you can refer to the Importing the Mixed Reality Toolkit instructions.

Примечание

После импорта пакета учебных активов MultiUserCapabilities в окне консоли появятся несколько ошибок CS0246. Они указывают на отсутствие типа или пространства имен.After importing the MultiUserCapabilities tutorial assets package, you will see several CS0246 errors in the Console window stating that the type or namespace is missing. Это ожидаемое поведение, и ошибки будут устранены при работе со следующим разделом при импорте активов PUN.This is expected and will be resolved in the next section when you import the PUN assets.

Импорт активов PUNImporting the PUN assets

В меню Unity последовательно выберите Window > Asset Store (Окно > Asset Store), чтобы открыть окно Asset Store. Найдите и выберите актив PUN 2 — FREE от Exit Games, а затем нажмите кнопку Download (Скачать), чтобы скачать пакет активов в учетную запись Unity.In the Unity menu, select Window > Asset Store to open the Asset Store window, search for and select PUN 2 - FREE from Exit Games, click the Download button to download the asset package to your Unity account.

После скачивания нажмите кнопку Импорт, чтобы открыть окно Import Unity Package (Импорт пакета Unity).When the download is complete, click the Import button to open the Import Unity Package window:

Хранилище Unity Asset Store с PUN 2 (бесплатно)

В окне импорта пакета Unity нажмите кнопку All (Все), чтобы выбрать все ресурсы, а затем нажмите кнопку Import (Импорт), чтобы импортировать их.In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

Unity с окном импорта PUN 2

Когда в Unity завершится процесс импорта, появится окно мастера PUN с открытым меню PUN Setup (Настройка PUN). На данный момент вы можете проигнорировать или закрыть это окно.Once Unity has completed the import process, the Pun Wizard window will appear with the PUN Setup menu loaded, you can ignore or close this window for now:

Unity с окном настройки PUN

Создание приложения PUNCreating the PUN application

В этом разделе показано, как создать учетную запись Photon, если у вас ее еще нет, а также приложение PUN.In this section, you will create a Photon account, if you don't already have one, and create a new PUN app.

Перейдите на панель мониторинга Photon и войдите в систему, если у вас уже есть учетная запись, которую вы хотите использовать. В противном случае щелкните ссылку Создать и следуйте инструкциям, чтобы зарегистрировать новую учетную запись.Navigate to the Photon dashboard and sign in if you already have an account you want to use, otherwise, click the Create One link and follow the instructions to register a new account:

Страница входа в Photon

После входа нажмите кнопку Создать приложение.Once signed in, click the Create a New App button:

Страница приветствия панели мониторинга Photon

На странице создания приложения введите приведенные ниже значения.On the Create a New Application page, enter the following values:

  • В раскрывающемся списке Photon Type (Тип Photon) выберите PUN.For Photon Type, select PUN
  • В поле "Имя" введите подходящее имя, например MRTK Tutorials.For Name, enter a suitable name, for example, MRTK Tutorials
  • В поле "Описание" можно ввести описание (необязательно).For Description, optionally enter a suitable description
  • Поле "URL-адрес" оставьте пустым.For Url, leave the field empty

Затем нажмите кнопку Create (Создать), чтобы создать приложение.Then click the Create button to create the new app:

Страница создания приложения Photon

Когда Photon завершит процесс создания, на панели мониторинга появится новое приложение PUN.Once Photon has finished the creation process, the new PUN app will appear on your dashboard:

Страница приложения Photon

Подключение проекта Unity к приложению PUNConnecting the Unity project to the PUN application

В этом разделе показано, как подключить проект Unity к приложению PUN, которое вы создали при работе с предыдущим разделом.In this section, you will connect your Unity project to the PUN app you created in the previous section.

На панели мониторинга Photon щелкните поле ИД приложения, чтобы отобразить идентификатор приложения, а затем скопируйте его в буфер обмена.On the Photon dashboard, click the App ID field to reveal the app ID, then copy it to your clipboard:

Страница приложения Photon с выбранным идентификатором приложения

В меню Unity последовательно выберите Window > Photon Unity Networking > PUN Wizard (Окно > Photon Unity Networking > Мастер PUN), чтобы открыть окно мастера PUN. Затем нажмите кнопку Проект установки, чтобы открыть меню PUN Setup (Настройка PUN), и настройте его, как описано ниже.In the Unity menu, select Window > Photon Unity Networking > PUN Wizard to open the Pun Wizard window, click the Setup Project button to open the PUN Setup menu, and configure it as follows:

  • В поле AppId or Email (Идентификатор приложения или адрес электронной почты) вставьте идентификатор приложения PUN, скопированный на предыдущем шаге.In the AppId or Email field, paste the PUN app ID you copied in the previous step

Затем нажмите кнопку Проект установки, чтобы применить идентификатор приложения.Then click the Setup Project button to apply the app ID:

Окно настройки PUN в Unity с заполненным идентификатором приложения

Когда в Unity завершится процесс настройки PUN, в меню PUN Setup (Настройка PUN) появится сообщение Готово!Once Unity has finished the PUN setup process, the PUN Setup menu will display the message Done! В окне Project (Проект) будет автоматически выбран актив PhotonServerSettings, чтобы в окне Inspector (Инспектор) отображались его свойства.and automatically select the PhotonServerSettings asset in the Project window, so its properties are displayed in the Inspector window:

Окно настройки PUN в Unity с примененным проектом установки

Поздравляем!Congratulations

Вы успешно создали приложение PUN и подключили его к проекту Unity.You have successfully created a PUN app and connected it to your Unity project. Следующим шагом будет разрешение подключений для других пользователей, чтобы несколько пользователей могли видеть работу друг друга.Your next step is to allow connections with other users so that multiple users can see each other.