Участие в работе с графическими инструментами — MRTK3

Обновление пакета

  1. Разветвление репозитория и создание ветви. Рекомендуется user/username/featureименование ветви.
  2. Клонируйте и откройте GraphicsToolsUnityProject пример проекта в Unity.
  3. Внесите необходимые изменения. По умолчанию все изменения в пакете MRTK Graphics Tools будут опубликованы в пакете средств графики. (Если вы хотите обновить примеры, см. приведенный ниже раздел.)
  4. Отправьте ветвь в вилку и создайте запрос на вытягивание. Добавьте описание изменений в запрос на вытягивание. Изображения и GIF всегда ценятся.

Обновление примеров пакетов

Примеры существуют в подпапке Samples~ , как описано в примерах рекомендаций Unity. Символ ~ не позволяет импортировать папку Samples~ в Unity. Это идеальный вариант для добавления пакета через диспетчер пакетов. Но если вы не хотите обновлять примеры в пакете.

Если вы хотите внести изменения в примеры, необходимо внести временное локальное изменение в структуру каталогов проекта Unity.

  1. Откройте Приложение GraphicsToolsUnityProject в Unity. По умолчанию папка Samples не отображается в пакете MRTK Graphics Tools. Чтобы отобразить примеры, в строке меню "Файл" выберите Окно > Graphics Tools > Показать примеры.
  2. Внесите необходимые изменения в примеры.
  3. Важно. По завершении и перед фиксацией изменений не забудьте скрыть примеры. Выберите "Средства > графики окна>" скрыть примеры в строке меню файла.

Совет

Не удается вызвать пункт меню "Скрыть образцы" инструментов > графики окна > после редактирования примеров, git будет думать, что все примеры файлов были изменены. После скрытия примеров фактически измененные файлы должны быть очевидны в Git.