Инструменты в редакторе — MRTK3

В Graphics Tools в редакторе Unity имеется множество инструментов для разработки смешанной реальности. Некоторые из них описаны ниже. Остальные можно найти в соответствующих разделах, таких как специальные возможности и измерительный инструмент.

Описание пунктов меню находится в разделе меню Окно > Graphics Tools

Снимки экрана

Если вы часто создаете снимки экрана в Unity для документации и рекламных материалов, этот процесс может быть очень трудоемким и не давать желаемых результатов. Класс ScreenshotUtilities позволяет создавать снимки экрана через пункты меню и общедоступные API в редакторе Unity. Снимки экрана можно создавать с разным разрешением и прозрачными цветами для последующего простого наложения изображений.

Примечание

Это средство не поддерживает создание снимков экрана из изолированной сборки.

Создавать снимки экрана очень легко: выберите в редакторе Окно > Graphics Tools > Сделать снимок экрана и выберите нужный вариант.

Совет

Если вы создаете снимок экрана не во время игры, убедитесь, что вкладка с окном игры отображается. В противном случае снимок экрана не будет сохранен.

По умолчанию все снимки экрана сохраняются по пути временного кэша, а путь к самому снимку экрана отобразится в консоли Unity.

Screenshot example with transparent background

Приведенный выше снимок экрана был создан с использованием варианта "Четырехкратное разрешение (прозрачный фон). (Масштаб уменьшен для удобства скачивания.) При этом создается изображение с высоким разрешением и преобразованием пикселей с удаленным цветом в прозрачные пиксели. Это позволяет разработчикам продемонстрировать использование своего приложения в магазине или других на других медиаплощадках, наложив это изображение поверх других изображений.

Аниматоры материалов холста

Аниматоры материалов холста позволяют разработчикам анимировать свойства материала в графических компонентах UnityUI (дополнительные сведения см. в документации по анимации). Эти скрипты аниматора автоматически создаются из файлов шейдеров. Если файл шейдера изменяется, также изменяется и скрипт аниматора. Обычно это выполняется щелчком правой кнопкой мыши на шейдере и выбором пункта Graphics Tools > Сгенерировать аниматор материала холста.

При выборе пункта меню Окно > Graphics Tools > Аниматоры материалов холста > Сгенерировать все будут повторно сгенерированы все скрипты аниматоров для шейдеров при соблюдении следующих условий:

  • Наличие в каталоге Runtime/Shaders пакета Graphics Tools
  • Отсутствие "Non-Canvas" в имени шейдера.

Совет

Разработчикам следует использовать этот пункт меню при изменении шейдеров в пакете Graphics Tools. У настраиваемых шейдеров могут быть аниматоры, созданные по отдельности или с помощью метода ShaderUtilities.GenerateCanvasMaterialAnimator.

Отладка MIP-карты

Функция отладки карты MIP, включенная в режимы отладочной отрисовки представления сцены встроенного конвейера отрисовки, не существует в универсальном конвейере отрисовки (URP). Эта функция полезна при уменьшении размеров текстуры.

В Graphics Tools аналогичный инструмент был снова добавлен для URP. Этот инструмент можно включить с помощью пункта меню Окно > Graphics Tools > Режимы отрисовки > MIP-карты — Включить, а отключить — с помощью пункта меню Окно > Graphics Tools > Режимы отрисовки > MIP-карты — Отключить. Если этот параметр включен, представление сцены будет окрашено в оттенок на основе соотношения текселя к пикселю.

Цвет Значение
Исходный цвет Это идеальное соотношение (тексели и пиксели с соотношением 1:1 с текущим расстоянием и разрешением).
Красный Указывает, что текстура больше, чем необходимо.
Синий Указывает, что текстура может быть больше.

Примечание

Идеальный размер текстуры зависит от разрешения, при котором приложение будет работать, и от того, насколько близко камера может приблизиться к поверхности.

Например, на этом расстоянии плотность текселей слишком высокая на кубе слева и слишком мала на кубе справа:

Texel density comparison

Отображение и скрытие примеров

При открытии MRGTUnityProject в Unity. По умолчанию папка Samples не отображается в пакете MRTK Graphics Tools. Чтобы отобразить примеры, в строке меню "Файл" выберите Окно > Graphics Tools > Показать примеры.

Чтобы скрыть примеры, например, перед фиксацией своих примеров в пакете Graphics Tools, выберите в строке меню "Файл" выберите Окно > Graphics Tools > Скрыть примеры.

Примечание

Эти пункты меню станут неактивны, если Graphics Tools является неизменяемым пакетом.

См. также раздел