Где я могу найти информацию о версии и журналыWhere can I find my version information and logs?

КонтурOutline

Сведения о версииVersion information

Обычно лучше всего для отправки обратно все сведения из сведения о копировании кнопки.It's usually best to send back all of the information from the Copy Information buttons. В противном случае мы зачастую требуются для запроса дополнительной информации.Otherwise we will often need to request additional information. К примеру, версий операционной системы, версии Xcode, установлен уровнях Android API, и версии платформы .NET можно все быть важные при помощи в устранении проблемы.For example, operating system versions, Xcode version, installed Android API levels, and .NET version can all be important when helping to troubleshoot a problem.

Сведения о версии WindowsWindows version information

Xamarin StudioXamarin Studio

Справка > о > Показать подробности > сведения о копировании [Кнопка]Help > About > Show Details > Copy Information [button]

Visual StudioVisual Studio

Справка > о Microsoft Visual Studio > Info копирования [Кнопка]Help > About Microsoft Visual Studio > Copy Info [button]

Сведения о версии MacMac version information

Visual Studio для MacVisual Studio for Mac

Visual Studio > о программе Visual Studio > Показать подробности > сведения о копировании [Кнопка]Visual Studio > About Visual Studio > Show Details > Copy Information [button]

Platform-tools, Android SDK Tools Build-toolsAndroid SDK Tools, Platform-tools, Build-tools

Откройте диспетчер пакетов SDK для Android и снимки экрана верхней средства раздел.Open the Android SDK Manager, and take a screenshot of the top Tools section.

Visual Studio для MacVisual Studio for Mac

Сервис > Диспетчер пакетов SDK для AndroidTools > Open Android SDK Manager

Visual StudioVisual Studio

Сервис > Android > Диспетчер пакетов SDK для Android...Tools > Android > Open Android SDK Manager...

Журналы интегрированной среды разработки и установщикIDE and installer logs

Для каждого расположения журнала не забудьте заархивировать и присоединить папке всего журнала.For each log location, be sure to zip up and attach the entire log folder.

Журналы WindowsWindows logs

Инструменты Visual Studio для Xamarin Visual Studio Tools for Xamarin

%LOCALAPPDATA%\Xamarin\Logs

Visual Studio 2017 Visual Studio 2017

Как получить журналы установки Visual StudioHow to get the Visual Studio installation logs

Visual Studio 2015 Visual Studio 2015

«Универсальный» установщик Xamarin Xamarin "Universal" installer

%LOCALAPPDATA%\Xamarin\Universal

Это журналы из XamarinInstaller.exe установщика.These are the logs from the XamarinInstaller.exe installer.

Отдельные .msi установщики, подробных журналовIndividual .msi installers, verbose logs

msiexec /i Xamarin.msi /l*vx "%USERPROFILE%\Desktop\Xamarin.log"

Справочные материалы. Параметры командной строкиReference: Command-Line Options

Запуск Visual Studio, подробных журналовVisual Studio startup, verbose logs

devenv.exe /log "%USERPROFILE%\Desktop\VisualStudio.log"

Ссылка: /log (devenv.exe)Reference: /Log (devenv.exe)

Журналы MacMac logs

Можно выбрать перейти > Перейти к папке меню элемента в Finder, а затем скопируйте и вставьте любой из этих путей в диалоговом окне.You can select the Go > Go to Folder menu item in Finder, and then copy and paste any of these paths into the dialog.

Visual Studio для MacVisual Studio for Mac

~/Library/Logs/VisualStudio/7.0 (это число может изменяться в зависимости от версии, которую вы используете)~/Library/Logs/VisualStudio/7.0 (this number may change depending on the version you are using)

Эту папку можно также открыть с помощью «"Справка"-> открыть каталог журналов».This folder can also be opened via "Help -> Open Log Directory".

Xamarin StudioXamarin Studio

~/Library/Logs/XamarinStudio-6.0 (это число может изменяться в зависимости от версии, которую вы используете)~/Library/Logs/XamarinStudio-6.0 (this number may change depending on the version you are using)

Эту папку можно также открыть с помощью «"Справка"-> открыть каталог журналов».This folder can also be opened via "Help -> Open Log Directory".

«Универсальный» установщик XamarinXamarin "Universal" installer

~/Library/Logs/XamarinInstaller/Universal

Это журналы из XamarinInstaller.dmg установщика.These are the logs from the XamarinInstaller.dmg installer.

Узел сборки XamarinXamarin Build Host

~/Library/Logs/Xamarin-[MAJOR.MINOR]

Выходные данные подробного сборкиVerbose build output

  1. Включить вывод диагностики MSBuild.Enable diagnostic MSBuild output.

  2. Для приложений iOS, следует также включить mtouch подробного вывода , добавив -v -v -v -v под свойства проекта > сборка iOS > Общие (вкладка) > Дополнительные параметры > Дополнительные аргументы mtouch.For iOS apps, also enable verbose mtouch output by adding -v -v -v -v under Project Properties > iOS Build > General (tab) > Additional Options > Additional mtouch arguments.

  3. Выполните очистку и перестройте проект.Clean and rebuild the project.

  4. Скопируйте и вставьте выходные данные построения в интегрированной среде разработки в текстовый файл.Copy and paste the build output from the IDE into a text file.

    • Visual Studio (Windows): Представление > выходные данные > Показать выходные данные из: СборкиVisual Studio (Windows): View > Output > Show output from: Build
    • Visual Studio для Mac: Вид > панели > ошибки > выходных данных сборки (вкладка ")Visual Studio for Mac: View > Pads > Errors > Build Output (tab)

Отладочный журналы для приложений Xamarin.Android и Xamarin.iOSDebug logs for Xamarin.Android and Xamarin.iOS apps

Visual Studio для MacVisual Studio for Mac

Вид > панели > выходные данные приложенияView > Pads > Application Output

(Обратите внимание, что данный элемент меню будет отображаться только в том случае, после запуска приложения.)(Note that this menu item will only appear after the app has been launched.)

Visual StudioVisual Studio

Представление > выходные данные > Показать выходные данные из: ОтладкаView > Output > Show output from: Debug

Android adb logcat журналыAndroid adb logcat logs

После выполнения команды adb команды, снова подключить android_logcat.txt файл с рабочего стола.After running the adb command, attach back the android_logcat.txt file from your Desktop. Эти инструкции предполагают, что у вас есть только одно устройство.These instructions assume you have only one device attached.

См. также Android журнал отладки страницы.See also the Android Debug Log page.

Visual StudioVisual Studio

  1. Сервис > Android > запустить Командная строка Android AdbTools > Android > Start Android Adb Command Prompt
  2. Очистка журнала: adb logcat -cClean the log: adb logcat -c
  3. Воспроизведите проблему.Reproduce the issue.
  4. Выходные данные журнала: adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"Output the log: adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt"

Visual Studio для MacVisual Studio for Mac

  1. Сервис > открыть командную строку пакета SDK для AndroidTools > Open Android SDK Command Prompt
  2. Очистка журнала: adb logcat -cClean the log: adb logcat -c
  3. Воспроизведите проблему.Reproduce the issue.
  4. Выходные данные журнала: adb logcat -vtime -d > ~/Desktop/android_logcat.txtOutput the log: adb logcat -vtime -d > ~/Desktop/android_logcat.txt

симулятор iOS входе (Mac)iOS simulator logs (on Mac)

  • Чтобы открыть журнал системы, выберите Отладка > Открыть журнал системы... в приложении симулятора iOS.To access the system log, select Debug > Open System Log... in the iOS Simulator app.

  • Чтобы просмотреть отчеты о сбоях в симуляторе, откройте Console.app и перейдите к ~/Library/Logs > DiagnosticReports.To view crash reports from the simulator, open Console.app and navigate to ~/Library/Logs > DiagnosticReports.

устройство iOS входе (Mac)iOS device logs (on Mac)

Visual Studio для MacVisual Studio for Mac

Вид > панели > журнал устройств iOSView > Pads > iOS Device Log

XcodeXcode

Окно > устройства > ${DeviceName}Window > Devices > ${DeviceName}

Отчеты о сбоях можно найти в разделе Просмотр журналов устройства кнопки.Crash reports are available under the View Device Logs button. Системный журнал на наличие устройства отображается в нижней части окна в разделе стрелки.The system log for the device appears at the bottom of the window under the disclosure arrow.

Xcode 5Xcode 5

Окно > Организатор > устройств (вкладка) > ${DeviceName}Window > Organizer > Devices (tab) > ${DeviceName}