Создание приложения Xamarin.Forms одной страницыCreate a Single Page Xamarin.Forms Application

Скачать пример Скачать примерDownload Sample Download the sample

В этом кратком руководстве вы узнаете, как:In this quickstart, you will learn how to:

  • Создание кросс платформенные приложения Xamarin.Forms.Create a cross-platform Xamarin.Forms application.
  • Определение пользовательского интерфейса для страницы с использованием расширяемого языка разметки приложений (XAML).Define the user interface for a page using eXtensible Application Markup Language (XAML).
  • Взаимодействие с элементами пользовательского интерфейса XAML из кода.Interact with XAML user interface elements from code.

Кратком руководстве показано, как создать кроссплатформенное приложение Xamarin.Forms, что дает возможность ввести примечание и сохранить их в хранилище устройства.The quickstart walks through how to create a cross-platform Xamarin.Forms application, which enables you to enter a note and persist it to device storage. Ниже показано итоговое приложение:The final application is shown below:

Предварительные требованияPrerequisites

  • (Последний выпуск), 2019 г. Visual Studio с разработки мобильных приложений на .NET установленной рабочей нагрузкой.Visual Studio 2019 (latest release), with the Mobile development with .NET workload installed.
  • Знание C#.Knowledge of C#.
  • (необязательно) Связанном компьютере Mac, чтобы создать приложение на iOS.(optional) A paired Mac to build the application on iOS.

Дополнительные сведения об этих требованиях см. в разделе Установка Xamarin.For more information about these prerequisites, see Installing Xamarin. Сведения о подключении Visual Studio 2019 к узлу сборки Mac см. в статье Связывание с Mac при разработке для Xamarin.iOS.For information about connecting Visual Studio 2019 to a Mac build host, see Pair to Mac for Xamarin.iOS development.

Начало работы с Visual Studio 2019 г.Get started with Visual Studio 2019

  1. Запустите Visual Studio 2019 г и в окне «Пуск» щелкните создайте новый проект для создания нового проекта:Launch Visual Studio 2019, and in the start window click Create a new project to create a new project:

  2. В создайте новый проект выберите Mobile в тип проекта раскрывающийся список, выберите мобильное приложение (Xamarin.Forms шаблон) и нажмите кнопку Далее кнопки:In the Create a new project window, select Mobile in the Project type drop down, select the Mobile App (Xamarin.Forms template), and click the Next button:

  3. В настроить новый проект окне имя_проекта для заметки, выберите подходящее расположение для проекта и нажмите кнопку создать кнопки:In the Configure your new project window, set the Project name to Notes, choose a suitable location for the project, and click the Create button:

    Важно!

    Фрагменты кода на C# и XAML из этого краткого руководства предполагают, что решение называется Notes.The C# and XAML snippets in this quickstart requires that the solution is named Notes. Выбор другого имени приведет к ошибкам сборки при копировании кода из этого краткого руководства в решение.Using a different name will result in build errors when you copy code from this quickstart into the solution.

  4. В новое кроссплатформенное приложение диалоговое окно, нажмите кнопку пустое приложениеи нажмите кнопку ОК кнопки:In the New Cross Platform App dialog, click Blank App, and click the OK button:

    Дополнительные сведения о создаваемой библиотеке .NET Standard см. в разделе Структура приложения Xamarin.Forms статьи Краткое руководство по Xamarin.Forms глубокое погружение в обработку.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  5. В обозревателе решений дважды щелкните файл MainPage.xaml в проекте Notes, чтобы открыть его:In Solution Explorer, in the Notes project, double-click MainPage.xaml to open it:

  6. Удалите из MainPage.xaml весь шаблонный код и замените его приведенным ниже.In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Этот код декларативно определяет пользовательский интерфейс для страницы, которая состоит из Label для отображения текста, Editor для ввода текста, а также два Button экземпляров, которые направляют приложения, чтобы сохранить или удалить файл.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Два экземпляра Button располагаются по горизонтали в Grid, а Label, Editor и Grid — по вертикали в StackLayout.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Дополнительные сведения о создании пользовательского интерфейса см. в разделе пользовательский интерфейс в подробный обзор быстрого запуска Xamarin.Forms.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в файле MainPage.xaml, нажав клавиши CTRL+S, и закройте файл.Save the changes to MainPage.xaml by pressing CTRL+S, and close the file.

  7. В обозревателе решений в проекте Notes разверните узел MainPage.xaml и дважды щелкните файл MainPage.xaml.cs, чтобы открыть его:In Solution Explorer, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  8. Удалите из MainPage.xaml.cs весь шаблонный код и замените его приведенным ниже.In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Этот код определяет поле _fileName, которое ссылается на файл с именем notes.txt, где будут храниться данные с заметками в локальной папке данных для приложения.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. При выполнении конструктора страниц файл считывается, если он существует, и отображается в Editor.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. При нажатии кнопки Сохранить Button выполняется обработчик событий OnSaveButtonClicked, который сохраняет содержимое Editor в файле.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. При нажатии кнопки Удалить Button выполняется обработчик событий OnDeleteButtonClicked, который удаляет файл при условии, что он существует, и весь текст из Editor.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Дополнительные сведения о взаимодействия с пользователем, см. в разделе взаимодействие с пользователем в подробный обзор быстрого запуска Xamarin.Forms.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в файле MainPage.xaml.cs, нажав клавиши CTRL+S, и закройте файл.Save the changes to MainPage.xaml.cs by pressing CTRL+S, and close the file.

Сборка примера из краткого руководстваBuilding the quickstart

  1. В Visual Studio выберите элемент меню Сборка > Построить решение (или нажмите клавишу F6).In Visual Studio, select the Build > Build Solution menu item (or press F6). Выполняется сборка решения, а в строке состояния Visual Studio отображается сообщение об успешном выполнении:The solution will build and a success message will appear in the Visual Studio status bar:

    При наличии ошибок повторите предыдущие шаги и исправьте все ошибки, пока сборка решения не будет проходить успешно.If there are errors, repeat the previous steps and correct any mistakes until the solution builds successfully.

  2. На панели инструментов Visual Studio нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения), чтобы запустить приложение в выбранном эмуляторе Android.In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen Android emulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

    Примечание

    Следующие шаги следует выполнить, только если у вас есть связанный компьютер Mac, отвечающий требованиям к системе для разработки приложений Xamarin.Forms.The following steps should only be carried out if you have a paired Mac that meets the system requirements for Xamarin.Forms development.

  3. На панели инструментов Visual Studio щелкните правой кнопкой мыши проект Notes.iOS, а затем выберите команду Назначить запускаемым проектом.In the Visual Studio toolbar, right-click on the Notes.iOS project, and select Set as StartUp Project.

  4. На панели инструментов Visual Studio нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения), чтобы запустить приложение в выбранном удаленном эмуляторе для iOS.In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen iOS remote simulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Предварительные требованияPrerequisites

  • Visual Studio 2017 с разработки мобильных приложений на .NET установленной рабочей нагрузкой.Visual Studio 2017, with the Mobile development with .NET workload installed.
  • Знание C#.Knowledge of C#.
  • (необязательно) Связанном компьютере Mac, чтобы создать приложение на iOS.(optional) A paired Mac to build the application on iOS.

Дополнительные сведения об этих требованиях см. в разделе Установка Xamarin.For more information about these prerequisites, see Installing Xamarin. Сведения о подключении Visual Studio 2019 к узлу сборки Mac см. в статье Связывание с Mac при разработке для Xamarin.iOS.For information about connecting Visual Studio 2019 to a Mac build host, see Pair to Mac for Xamarin.iOS development.

Начало работы с Visual Studio 2017Get started with Visual Studio 2017

  1. Запустите Visual Studio 2017, а на начальной странице щелкните создать проект... для создания нового проекта:Launch Visual Studio 2017, and on the start page click Create new project... to create a new project:

  2. В диалоговом окне Новый проект щелкните Кроссплатформенный, выберите шаблон Мобильное приложение (Xamarin.Forms) , присвойте параметру "Имя" значение Notes, выберите подходящее расположение для проекта и нажмите кнопку ОК:In the New Project dialog, click Cross-Platform, select the Mobile App (Xamarin.Forms) template, set the Name to Notes, choose a suitable location for the project and click the OK button:

    Важно!

    Фрагменты кода на C# и XAML из этого краткого руководства предполагают, что решение называется Notes.The C# and XAML snippets in this quickstart requires that the solution is named Notes. Выбор другого имени приведет к ошибкам сборки при копировании кода из этого краткого руководства в решение.Using a different name will result in build errors when you copy code from this quickstart into the solution.

  3. В диалоговом окне Новое кроссплатформенное приложение щелкните Пустое приложение, выберите .NET Standard в качестве стратегии совместного использования кода, а затем нажмите кнопку OK:In the New Cross Platform App dialog, click Blank App, select .NET Standard as the Code Sharing Strategy, and click the OK button:

    Дополнительные сведения о создаваемой библиотеке .NET Standard см. в разделе Структура приложения Xamarin.Forms статьи Краткое руководство по Xamarin.Forms глубокое погружение в обработку.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  4. В обозревателе решений дважды щелкните файл MainPage.xaml в проекте Notes, чтобы открыть его:In Solution Explorer, in the Notes project, double-click MainPage.xaml to open it:

  5. Удалите из MainPage.xaml весь шаблонный код и замените его приведенным ниже.In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Этот код декларативно определяет пользовательский интерфейс для страницы, которая состоит из Label для отображения текста, Editor для ввода текста, а также два Button экземпляров, которые направляют приложения, чтобы сохранить или удалить файл.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Два экземпляра Button располагаются по горизонтали в Grid, а Label, Editor и Grid — по вертикали в StackLayout.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Дополнительные сведения о создании пользовательского интерфейса см. в разделе пользовательский интерфейс в подробный обзор быстрого запуска Xamarin.Forms.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в файле MainPage.xaml, нажав клавиши CTRL+S, и закройте файл.Save the changes to MainPage.xaml by pressing CTRL+S, and close the file.

  6. В обозревателе решений в проекте Notes разверните узел MainPage.xaml и дважды щелкните файл MainPage.xaml.cs, чтобы открыть его:In Solution Explorer, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  7. Удалите из MainPage.xaml.cs весь шаблонный код и замените его приведенным ниже.In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Этот код определяет поле _fileName, которое ссылается на файл с именем notes.txt, где будут храниться данные с заметками в локальной папке данных для приложения.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. При выполнении конструктора страниц файл считывается, если он существует, и отображается в Editor.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. При нажатии кнопки Сохранить Button выполняется обработчик событий OnSaveButtonClicked, который сохраняет содержимое Editor в файле.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. При нажатии кнопки Удалить Button выполняется обработчик событий OnDeleteButtonClicked, который удаляет файл при условии, что он существует, и весь текст из Editor.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Дополнительные сведения о взаимодействия с пользователем, см. в разделе взаимодействие с пользователем в подробный обзор быстрого запуска Xamarin.Forms.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в файле MainPage.xaml.cs, нажав клавиши CTRL+S, и закройте файл.Save the changes to MainPage.xaml.cs by pressing CTRL+S, and close the file.

Сборка примера из краткого руководстваBuilding the quickstart

  1. В Visual Studio выберите элемент меню Сборка > Построить решение (или нажмите клавишу F6).In Visual Studio, select the Build > Build Solution menu item (or press F6). Выполняется сборка решения, а в строке состояния Visual Studio отображается сообщение об успешном выполнении:The solution will build and a success message will appear in the Visual Studio status bar:

    При наличии ошибок повторите предыдущие шаги и исправьте все ошибки, пока сборка решения не будет проходить успешно.If there are errors, repeat the previous steps and correct any mistakes until the solution builds successfully.

  2. На панели инструментов Visual Studio нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения), чтобы запустить приложение в выбранном эмуляторе Android.In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen Android emulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

    Примечание

    Следующие шаги следует выполнить, только если у вас есть связанный компьютер Mac, отвечающий требованиям к системе для разработки приложений Xamarin.Forms.The following steps should only be carried out if you have a paired Mac that meets the system requirements for Xamarin.Forms development.

  3. На панели инструментов Visual Studio щелкните правой кнопкой мыши проект Notes.iOS, а затем выберите команду Назначить запускаемым проектом.In the Visual Studio toolbar, right-click on the Notes.iOS project, and select Set as StartUp Project.

  4. На панели инструментов Visual Studio нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения), чтобы запустить приложение в выбранном удаленном эмуляторе для iOS.In the Visual Studio toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application in your chosen iOS remote simulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Предварительные требованияPrerequisites

  • Visual Studio для Mac (последний выпуск), iOS и установленной поддержки платформы Android.Visual Studio for Mac (latest release), with iOS and Android platform support installed.
  • Xcode (последний выпуск).Xcode (latest release).
  • Знание C#.Knowledge of C#.

Дополнительные сведения об этих требованиях см. в разделе Установка Xamarin.For more information about these prerequisites, see Installing Xamarin.

Начало работы с Visual Studio для MacGet started with Visual Studio for Mac

  1. Запустите Visual Studio для Mac и в окне «Пуск» щелкните New для создания нового проекта:Launch Visual Studio for Mac, and in the start window click New to create a new project:

  2. В диалоговом окне Выберите шаблон из нового проекта щелкните Многоплатформенность > Приложение и выберите шаблон Приложение с пустыми формами, а затем нажмите кнопку Далее:In the Choose a template for your new project dialog, click Multiplatform > App, select the Blank Forms App template, and click the Next button:

  3. В диалоговом окне Настройка приложения с пустыми формами присвойте новому приложению имя Notes, убедитесь, что переключатель установлен в положение Использовать .NET Standard и нажмите кнопку Далее:In the Configure your Blank Forms app dialog, name the new app Notes, ensure that the Use .NET Standard radio button is selected, and click the Next button:

  4. В диалоговом окне Настроить новое приложение с пустыми формами сохраните для проекта и решения имя Notes, выберите подходящее расположение для проекта и нажмите кнопку Создать для создания проекта:In the Configure your new Blank Forms app dialog, leave the Solution and Project names set to Notes, choose a suitable location for the project, and click the Create button to create the project:

    Важно!

    Фрагменты кода на C# и XAML из этого краткого руководства предполагают, что решение и проект называются Notes.The C# and XAML snippets in this quickstart requires that the solution and project are both named Notes. Выбор другого имени приведет к ошибкам сборки при копировании кода из этого краткого руководства в проект.Using a different name will result in build errors when you copy code from this quickstart into the project.

    Дополнительные сведения о создаваемой библиотеке .NET Standard см. в разделе Структура приложения Xamarin.Forms статьи Краткое руководство по Xamarin.Forms глубокое погружение в обработку.For more information about the .NET Standard library that gets created, see Anatomy of a Xamarin.Forms application in the Xamarin.Forms Quickstart Deep Dive.

  5. В панели решения дважды щелкните файл MainPage.xaml в проекте Notes, чтобы открыть его:In the Solution Pad, in the Notes project, double-click MainPage.xaml to open it:

  6. Удалите из MainPage.xaml весь шаблонный код и замените его приведенным ниже.In MainPage.xaml, remove all of the template code and replace it with the following code:

    <?xml version="1.0" encoding="utf-8"?>
    <ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
                 xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
                 x:Class="Notes.MainPage">
        <StackLayout Margin="10,35,10,10">
            <Label Text="Notes"
                   HorizontalOptions="Center"
                   FontAttributes="Bold" />
            <Editor x:Name="editor"
                    Placeholder="Enter your note"
                    HeightRequest="100" />
            <Grid>
                <Grid.ColumnDefinitions>
                    <ColumnDefinition Width="*" />
                    <ColumnDefinition Width="*" />
                </Grid.ColumnDefinitions>
                <Button Text="Save"
                        Clicked="OnSaveButtonClicked" />
                <Button Grid.Column="1"
                        Text="Delete"
                        Clicked="OnDeleteButtonClicked"/>
            </Grid>
        </StackLayout>
    </ContentPage>
    

    Этот код декларативно определяет пользовательский интерфейс для страницы, которая состоит из Label для отображения текста, Editor для ввода текста, а также два Button экземпляров, которые направляют приложения, чтобы сохранить или удалить файл.This code declaratively defines the user interface for the page, which consists of a Label to display text, an Editor for text input, and two Button instances that direct the application to save or delete a file. Два экземпляра Button располагаются по горизонтали в Grid, а Label, Editor и Grid — по вертикали в StackLayout.The two Button instances are horizontally laid out in a Grid, with the Label, Editor, and Grid being vertically laid out in a StackLayout. Дополнительные сведения о создании пользовательского интерфейса см. в разделе пользовательский интерфейс в подробный обзор быстрого запуска Xamarin.Forms.For more information about creating the user interface, see User interface in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в MainPage.xaml, выбрав Файл > Сохранить или нажав клавиши ⌘+S, и закройте файл.Save the changes to MainPage.xaml by choosing File > Save (or by pressing ⌘ + S), and close the file.

  7. В панели решений в проекте Notes разверните узел MainPage.xaml и дважды щелкните файл MainPage.xaml.cs, чтобы открыть его:In the Solution Pad, in the Notes project, expand MainPage.xaml and double-click MainPage.xaml.cs to open it:

  8. Удалите из MainPage.xaml.cs весь шаблонный код и замените его приведенным ниже.In MainPage.xaml.cs, remove all of the template code and replace it with the following code:

    using System;
    using System.IO;
    using Xamarin.Forms;
    
    namespace Notes
    {
        public partial class MainPage : ContentPage
        {
            string _fileName = Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "notes.txt");
    
            public MainPage()
            {
                InitializeComponent();
    
                if (File.Exists(_fileName))
                {
                    editor.Text = File.ReadAllText(_fileName);
                }
            }
    
            void OnSaveButtonClicked(object sender, EventArgs e)
            {
                File.WriteAllText(_fileName, editor.Text);
            }
    
            void OnDeleteButtonClicked(object sender, EventArgs e)
            {
                if (File.Exists(_fileName))
                {
                    File.Delete(_fileName);
                }
                editor.Text = string.Empty;
            }
        }
    }
    

    Этот код определяет поле _fileName, которое ссылается на файл с именем notes.txt, где будут храниться данные с заметками в локальной папке данных для приложения.This code defines a _fileName field, which references a file named notes.txt that will store note data in the local application data folder for the application. При выполнении конструктора страниц файл считывается, если он существует, и отображается в Editor.When the page constructor is executed the file is read, if it exists, and displayed in the Editor. При нажатии кнопки Сохранить Button выполняется обработчик событий OnSaveButtonClicked, который сохраняет содержимое Editor в файле.When the Save Button is pressed the OnSaveButtonClicked event handler is executed, which saves the content of the Editor to the file. При нажатии кнопки Удалить Button выполняется обработчик событий OnDeleteButtonClicked, который удаляет файл при условии, что он существует, и весь текст из Editor.When the Delete Button is pressed the OnDeleteButtonClicked event handler is executed, which deletes the file, provided that it exists, and removes any text from the Editor. Дополнительные сведения о взаимодействия с пользователем, см. в разделе взаимодействие с пользователем в подробный обзор быстрого запуска Xamarin.Forms.For more information about user interaction, see Responding to user interaction in the Xamarin.Forms Quickstart Deep Dive.

    Сохраните изменения в MainPage.xaml.cs, выбрав Файл > Сохранить (или нажав клавиши ⌘ + S), а затем закройте файл.Save the changes to MainPage.xaml.cs by choosing File > Save (or by pressing ⌘ + S), and close the file.

Сборка примера из краткого руководстваBuilding the quickstart

  1. В Visual Studio для Mac выберите элемент меню Сборка > Собрать все (или нажмите клавиши ⌘+B).In Visual Studio for Mac, select the Build > Build All menu item (or press ⌘ + B). Выполняется сборка проектов, а на панели инструментов Visual Studio для Mac отображается сообщение об успешном выполнении:The projects will build and a success message will appear in the Visual Studio for Mac toolbar.

    При наличии ошибок повторите предыдущие шаги и исправьте все ошибки, пока сборка проектов не будет проходить успешно.If there are errors, repeat the previous steps and correct any mistakes until the projects build successfully.

  2. В панели решениявыберите Notes.iOS проекта, щелкните правой кнопкой мыши и выберите Назначить запускаемым проектом:In the Solution Pad, select the Notes.iOS project, right-click, and select Set As Startup Project:

  3. На панели инструментов Visual Studio для Mac нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения) для запуска приложения в выбранном симуляторе iOS:In the Visual Studio for Mac toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application inside your chosen iOS Simulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

  4. В панели решениявыберите Notes.Droid проекта, щелкните правой кнопкой мыши и выберите Назначить запускаемым проектом:In the Solution Pad, select the Notes.Droid project, right-click, and select Set As Startup Project:

  5. На панели инструментов Visual Studio для Mac нажмите клавишу Запустить (треугольная кнопка, похожая на кнопку воспроизведения) для запуска приложения в выбранном эмуляторе Android:In the Visual Studio for Mac toolbar, press the Start button (the triangular button that resembles a Play button) to launch the application inside your chosen Android emulator:

    Введите примечание и нажмите кнопку Сохранить.Enter a note and press the Save button.

    Дополнительные сведения о том, как запустить приложение на каждой платформе, см. в разделе запуска приложения на каждой платформе в подробный обзор быстрого запуска Xamarin.Forms.For more information about how the application is launched on each platform, see Launching the application on each platform in the Xamarin.Forms Quickstart Deep Dive.

Следующие шагиNext steps

В этом кратком руководстве вы узнали, как:In this quickstart, you learned how to:

  • Создание кросс платформенные приложения Xamarin.Forms.Create a cross-platform Xamarin.Forms application.
  • Определение пользовательского интерфейса для страницы с использованием расширяемого языка разметки приложений (XAML).Define the user interface for a page using eXtensible Application Markup Language (XAML).
  • Взаимодействие с элементами пользовательского интерфейса XAML из кода.Interact with XAML user interface elements from code.

Чтобы включить это одностраничное приложение в одностраничное приложение, перейдите к следующему руководству.To turn this single page application into a multi-page application, continue to the next quickstart.