Analysera prestandaproblem i användargränssnittet

Problem

Azure Databricks användar gränssnittet verkar vara långsamt.

Orsak

Prestanda problem i användar gränssnittet inträffar vanligt vis på grund av nätverks fördröjningen eller en databas fråga tar längre tid än förväntat.

För att felsöka den här typen av problem måste du samla in nätverks loggar och analysera dem för att se vilken nätverks trafik som påverkas.

I de flesta fall behöver du hjälp med Databricks-support för att identifiera och lösa problem med Databricks-funktioner i användar gränssnittet, men du kan också analysera loggarna själv med ett verktyg som t. ex. G Suite-verktygslådan har analyser. Med det här verktyget kan du analysera loggarna och identifiera det exakta API: et och den tid det tar för varje begäran.

Fel söknings procedur

Det här är proceduren för Google Chrome. Andra webbläsare finns i G Suite-verktygslådan har analys.

  1. Öppna Google Chrome och gå till sidan där problemet uppstår.
  2. I meny raden Chrome väljer du visa > developer > utvecklarverktyg.
  3. I panelen längst ned på skärmen väljer du fliken nätverk .
  4. Titta efter en rund Record -knapp i det övre vänstra hörnet på fliken nätverk och se till att den är röd. Om det är grått, klickar du på det en gång för att starta inspelningen.
  5. Markera kryss rutan bredvid bevara logg.
  6. Klicka på Rensa för att ta bort alla befintliga loggar från fliken nätverk .
  7. Återskapa problemet när nätverks begär Anden registreras.
  8. När du har återskapat och loggat problemet högerklickar du någonstans i rutnätet med nätverks begär Anden för att öppna en snabb meny, väljer Spara alla som har innehålloch spara filen på din dator.
  9. Analysera filen med verktyget har Analyzer. Om den här analysen inte löser problemet öppnar du ett support ärende och laddar upp filen har eller kopplar den till e-postmeddelandet så att Databricks kan analysera den.

Exempel på utdata från har Analyzer

ingen alternativ text