ActiveSync-klienter kan inte ansluta eller synkroniseras är fördröjd i en Exchange Server-miljö

Ursprungligt KB-nummer:   4456227, 4337638

Symptom

I Exchange Server 2016- och Exchange Server 2013-miljöer kan Inte Exchange ActiveSync-klienter ansluta eller uppleva fördröjningar när användare synkroniserar sina mobila enheter. Förutom de här problemen slutar alla funktioner i CAS-rollen att fungera. Det här problemet inträffar efter att Exchange ActiveSync-programpoolen har körs en tid, vanligtvis i flera veckor. Du kan dessutom uppleva följande:

  • Händelse-ID 4227 loggas i systemloggen i loggboken.
  • Exchange ActiveSync-programpoolen tar upp många minnen.
  • .NET CLR Minnes/% Tid i GC-räknare för w3wp-instansen som motsvarar Exchange ActiveSync-programpoolen är ovanligt hög.
  • TCP-portarna tar ut sig på grund av det stora antalet förfrågningar i Exchange ActiveSync.
  • I W3SVC_W3WP/Aktiva begäranden för instansen MSExchangeSyncAppPool visas en stigande värde över flera dagar eller veckor.
  • Kommandot netstat -anob kan visa många anslutningar i ett CLOSE_WAIT tillstånd.

Orsak

Det här är ett känt problem som uppstår när Exchange ActiveSync Ping-kommandon blir tillgängliga i programpoolen.

Lösning

För att komma runt det här problemet för Exchange Server 2013 bör du periodiskt bläddra i Exchange ActiveSync-programpoolen för alla servrar för att släppa de strandade kommandona. Mer information om hur du konfigurerar en programpool för att <recycling> papperskorgen automatiskt ska återanvändas med jämna mellanrum finns i avsnittet Inställningar för papperskorgen för en programpool på webbplatsen Microsoft Docs.

Lösning

Du kan lösa problemet med Exchange Server 2016 genom att installera kumulativ uppdatering 11 för Exchange Server 2016 eller en senare kumulativ uppdatering för Exchange Server 2016.

Status

Microsoft har bekräftat att det är ett problem i de Microsoft-produkter som listas i Gäller för.

Referenser

Läs mer om terminologin som Microsoft använder för att beskriva programuppdateringar.