ActiveSync-klienter kan inte ansluta eller synkroniseringen fördröjs i en Exchange Server miljö

Ursprungligt KB-nummer: 4456227, 4337638

Symptom

I en Exchange Server 2016- eller Exchange Server 2013-miljö kan Exchange ActiveSync klienter inte ansluta eller så uppstår fördröjningar när användarna synkroniserar sina mobila enheter. Förutom dessa problem slutar alla funktioner i CAS-rollen att fungera. Det här problemet uppstår efter att Exchange ActiveSync programpoolen har körts under en viss tid, vanligtvis i flera veckor. Dessutom kan du uppleva följande beteende:

  • Händelse-ID 4227 loggas i systemloggen för Loggboken.
  • Programpoolen Exchange ActiveSync förbrukar många minnen.
  • .NET CLR-minne/% Tid i GC-räknaren för w3wp-instansen som motsvarar den Exchange ActiveSync programpoolen är ovanligt hög.
  • TCP-portöverbelastning uppstår på grund av det stora antalet begäranden i Exchange ActiveSync.
  • Räknaren W3SVC_W3WP/Aktiva begäranden för MSExchangeSyncAppPool-instansen visar ett stadigt ökande värde under flera dagar eller veckor.
  • Kommandot netstat -anob kan visa många anslutningar i ett CLOSE_WAIT tillstånd.

Orsak

Det här är ett känt problem som uppstår när Exchange ActiveSync Ping-kommandon blir strandsatta i programpoolen.

Lösning

För Exchange Server 2013 bör du regelbundet växla Exchange ActiveSync programpool så att alla servrar kan släppa de strandade kommandona. Mer information om hur du konfigurerar en programpool så att den återanvänds automatiskt med jämna mellanrum finns i Återanvändningsinställningar för en programpoolsåtervinning<>.

Åtgärd

För Exchange Server 2016 kan du lösa problemet genom att installera kumulativ uppdatering 11 för Exchange Server 2016 eller en senare kumulativ uppdatering för Exchange Server 2016.

Status

Microsoft har bekräftat att detta är ett problem i De Microsoft-produkter som anges i Gäller för.

Referenser

Läs mer om den terminologi som Microsoft använder för att beskriva programuppdateringar.