EAS-enheter synkroniseras fortfarande när ett konto har inaktiverats eller ett lösenord har ändrats

Ursprungligt KB-nummer: 2612821

Symptom

EAS-enheter fortsätter att synkroniseras när deras konto har inaktiverats. Enheter ansluter också med ett gammalt lösenord när lösenordet har ändrats.

Orsak

När en EAS-enhet är inställd på att synkronisera objekt när de tas emot (direkt push) kan alla ändringar som görs av användarens konto i Active Directory ta 8 till 24 timmar innan enheten känner igen ändringarna.

När du använder Direct Push upprätthåller enheterna en öppen anslutning till servern. Ändringar som görs när anslutningen har upprättats börjar inte gälla omedelbart.

Lösning 1 – Återställa Internet Information Services (IIS)

  1. På de klientåtkomstservrar som enheten ansluter till väljer du Start, kör, skriver CMD och trycker sedan på RETUR.
  2. Skriv iisreset och tryck på RETUR.

Detta startar om IIS-tjänster. Du kan också använda snapin-modulen Services.msc för att starta om IIS Admin-tjänsten manuellt.

Lösning 2 – Återanvänd programpoolen som används av ActiveSync

  1. Välj Start, välj Administrationsverktyg, välj IIS-hanteraren (Internet Information Services).
  2. Expandera servernamnet.
  3. Välj Programpooler.
  4. Högerklicka på MSExchangeSyncAppPool och välj Återanvänd.

Obs!

I Exchange 2003 delar EAS samma programpool med Outlook Web Access.

Lösning 3 – Konfigurera enheten att använda ett manuellt synkroniseringsläge

Beroende på enhetstyp ändrar du synkroniseringsinställningarna för att använda en manuell synkronisering och väntar sedan några minuter på att anslutningen ska återställas. Vid nästa manuella synkroniseringsförsök upprättas en ny anslutning.

Lösning 4 – Stäng av enheten

Stäng av enheten och vänta en stund och aktivera den igen.

Mer information

Mer information, inklusive andra tjänster som påverkas i det här scenariot, finns i Metodtips för Exchange för ej betrodd postlåda.