Fel i Access: Data i Urklipp är skadade, så Microsoft Access kan inte klistra in det
Anteckning
Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.
Ursprungligt KB-nummer: 2221635
Symptom
När du utför en kopierings-/inklistringsåtgärd från en Microsoft Excel till Microsoft Access får du följande felmeddelande:
Data i Urklipp är skadade, så Microsoft Access kan inte klistra in dem. Det kan finnas ett fel i Urklipp eller så finns det kanske inte tillräckligt med ledigt minne. Försök igen.
Orsak
Det finns flera scenarier som kan leda till det här felet. Microsoft är medvetna om problemet i de senaste versionerna av Microsoft Access.
Scenario 1
Det här problemet uppstår när följande två villkor är sanna:
- Ett av värdena på den första raden med data innehåller ett decimaltecken
- Du kopierar mer än en rad med data
Scenario 2
Namnet Excel ett enkelt citattecken eller ett apostroftecken.
Lösning
Använd någon av följande lösningar:
Metod 1
I Microsoft Access väljer du listrinspilen på ikonen Klistra in och väljer sedan Klistra in special. Välj sedan antingen Text eller CSV.
Metod 2
Kontrollera att det inte finns några decimaler på den första raden i Excel data som du kopierar.
Metod 3
Kopiera och klistra in en rad i taget.
Mer information
Problemet uppstår inte i Microsoft Access 2003.
Steg för reproducerning
Skapa en ny tom databas i Access.
Skapa en ny tabell i tabelldesignvyn.
Lägg till följande fält:
Namn: Fält1
Datatyp: Tal
Fältstorlek: Double
Spara tabellen som Tabell1.
Öppna Tabell1 i databladsvyn.
Skapa Microsoft Excel nytt kalkylblad i Microsoft Excel kalkylblad.
Lägg till följande värden i följande celler:
A1: 83,9
A2: 3020
I Excel väljer du A1 och A2 och klickar sedan på ikonen Kopiera.
I Access väljer du Fält1 och klickar sedan på ikonen Klistra in.
Resultat
Du får någon av dessa versioner av felet:
- Data i Urklipp är skadade så det Microsoft Office det inte går att klistra in dem i Access. Det kan finnas ett fel i Urklipp eller så finns det kanske inte tillräckligt med ledigt minne. Försök igen.
- Data i Urklipp är skadade, så Microsoft Access kan inte klistra in dem. Det kan finnas ett fel i Urklipp eller så finns det kanske inte tillräckligt med ledigt minne. Försök igen.
Anteckning
Det här är en FAST som skapats direkt från Microsoft Support-organisationen. Den information som finns här ges som svar på nya problem. Materialet kan innehålla typografiska fel och kan revideras när som helst utan föregående meddelande. Andra överväganden finns i Användningsvillkor.