Meddelandet "Ett fel har uppstått" visas när du läser in en Access-webbapp i Internet Explorer

Anteckning

Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.

Symptom

När du försöker läsa in en Microsoft Access-webbapp i Internet Explorer kanske programmet inte läses in helt och sedan visas felmeddelandet "Det har uppstått ett fel. Något gick fel. Felmeddelandet Försök igen senare.

Skärmbild av felmeddelandet när programmet kanske inte läses in helt.

Anteckning

Felets "TEKNISK INFORMATION" innehåller inte något värde för korrelations-ID:t.

Orsak

Internet Explorer har en tidsgränsgräns för servern för att data ska kunna returneras via Registernyckeln ReceiveTimeout. Det värde som anges för den här time out-tiden kan ha ändrats till ett värde som är mindre än vad som krävs för att servern ska kunna svara på Access-appbegäran.

Lösning

Du kan lösa problemet genom att ändra standardinställningen för time out för Internet Explorer genom att följa de här stegen:

Viktigt

Det här avsnittet, metoden eller uppgiften innehåller steg som beskriver hur du ändrar registret. Det kan uppstå allvarliga problem om du gör detta felaktigt. Följ därför instruktionerna noga, och säkerhetskopiera registret innan du gör några ändringar i det. Då kan du återställa registret om det uppstår problem. Mer information finns i Backa upp och återställa registret i Windows.

  1. Starta Registereditorn.

  2. Leta upp följande undernyckel:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. I den här undernyckeln lägger du till en ReceiveTimeout DWORD-post som har värdet ( <number of seconds> ) * 1000. Om du till exempel vill att time out-varaktigheten ska vara 5 minuter anger du värdet för posten till ReceiveTimeout 300000 ( <300> *1000).

  4. Starta om datorn.

Anteckning

Den här inställningen blir den nya globala tidsgränsen som gäller för både Internet Explorer och WinINet-program.