Office 2013 kan inte checka in filer när LAN inte har internetåtkomst eller över vissa VPN
Den här artikeln är skriven av Rath, Support Escalation Engineer.
I fall där VPN orsakar problemet har vi hittat ett problem i Windows-kod (113100710844135) och korrigeringen är ut från tredjeparts-VPN-klient stoppar Internetanslutningen i Windows 7 SP1 eller Windows Server 2008 R2 SP1. Vi har bekräftat att Palo Networks Global Protect Client och Enper VPN fungerar med den här korrigeringen.
Kunderna använder VPN-lösningar från tredje part på Windows 7. Om kunder migrerar till Office 2013 från en äldre version av Office kan funktioner gå förlorade i Office när de är anslutna via VPN. Office 2013 var beroende av NLA (Information om nätverksplats) och vissa VPN-lösningar fungerar inte korrekt med NLA. Specifikt, om VPN-programvaran inte definierar en standardgateway. I det här fallet rapporterar NLA alltid att klienten inte är ansluten till Internet. Det här påverkar Office2013 eftersom det är beroende av Internetanslutningen för vissa funktioner. Det finns till exempel ingen hjälpfil på datorn och all hjälp finns på Internet. Om en kund trycker på F1 i ett Office 2013-program får de alltid ett felmeddelande om att de inte är anslutna till Internet när de är anslutna via VPN.
Symptom
Användare som saknar fullständig internetanslutning kanske inte kan checka in filer från Office 2013-klienten även om det finns bra anslutning mellan Office-klienten och SharePoint-servern.
Orsak
Det gjordes en designändring mellan Office 2010 och 2013, där 2013 nu kräver en Internetanslutning för vissa aktiviteter. Vissa kunder har redan klagar på det här problemet och produktgruppen har informerats om designbegränsningarna. (men det finns ingen snabbkorrigering just nu på gång, men det kan hända att det inte ser ut att vara en betydande ändring.
Roten till problemet verkar vara att Office 2013 är beroende av NLA (information om nätverksplats). NLA använder sondender för att fastställa om nätverksanslutningen har "Internetanslutning". Det finns två sätt att göra det på.
- Den tar en DNS-sonde för
dns.msftncsi.com. Den förväntar sig ett specifikt svar. Svaret måste vara131.107.255.255. Om det är det är det rätt DNS-sonde. - Den försöker ansluta till
https://www.msftncsi.comoch försöka hämta filen ncsi.txt. I filen måste texten vara "Microsoft NCSI".
Om båda ovanstående villkor uppfylls markeras anslutningen som har Internetanslutning, om inte anslutningen är markerad har ingen Internetanslutning och Office funktioner fungerar inte.
Lösning
Det går att konfigurera en lokal NCIS-server (statusindikator för nätverksanslutning) på nätverket som svarar på Office-klienters förfrågningar och gör att Office fungerar.
I inläggen nedan finns relaterad information och vägbeskrivningar: