Felmeddelande: "Klassen är inte registrerad" när du uppdaterar PowerPivot data

Symptom

Följande felmeddelanden visas när du försöker uppdatera data i en PowerPivot som har redigerats på en annan dator:

Leverantören <Provider name> är inte registrerad.
Följande systemfel inträffade: Klass har inte registrerats En anslutning kunde inte upprättas till datakällan med DataSourceID för <data source id> ', Namn på <data source name> . Ett fel uppstod vid bearbetningen av <table name> . Leverantören <Provider name> är inte registrerad.
Åtgärden har avbrutits.

Anteckning

Felet kan upprepas för varje anslutning som inte fungerar.

Orsak

Det här problemet uppstår vanligtvis i följande fall:

  • Du försöker uppdatera data med mest aktuella data från serverservern med hjälp av alternativet Uppdatera allamenyn Uppdatera.
  • Du försöker importera data med hjälp av en av anslutningarna under alternativet Befintlig anslutning på fliken Design.

Detta är avsiktligt. Det inträffar när den leverantör som har definierats för dataanslutningen för PowerPivot data inte finns i ditt system.

Lösning

Lös problemet genom att använda någon av följande metoder.

Procedur 1: Konfigurera den misslyckade anslutningen för att använda en annan och kompatibel leverantör i systemet

Gör så här:

  1. I Power Pivot-fönstret väljer du fliken Design i menyfliksområdets meny.
  2. Välj Befintliga anslutningar.
  3. I listan över tillgängliga anslutningar väljer du den anslutning som inte fungerar och väljer sedan Redigera.
  4. I fönstret Redigera anslutning väljer du Avancerat.
  5. I området Ange avancerade egenskaper ändrar du providervärdet till en annan och kompatibel leverantör och uppdaterar sedan data.

Om anslutningen till exempel är konfigurerad att använda SQLNCLI10 (SQL Native Client 10 Provider), och SQL Native Client inte är installerat på datorn, ändrar du providern till SQLOLEDB och uppdaterar sedan data i arbetsboken.

Procedur 2: Installera leverantören

  1. Identifiera den leverantör som används för anslutningen som inte fungerar. Det gör du genom att använda informationen i felmeddelandet eller anvisningarna som beskrivs i Procedur 1 för att identifiera leverantören.
  2. Installera leverantören på ditt system med hjälp av installationsmedia eller genom att hämta leverantören från Internet.

Mer information

Du kan även få ett liknande felmeddelande när du använder ett 32-bitarssystem för att arbeta med en arbetsbok som utvecklats i ett 64-bitarssystem. Och det finns ingen 32-bitarsleverantör som är tillgänglig för en eller flera av de anslutningar som definierats i arbetsboken, eller så är 32-bitarsleverantören inte installerad på systemet, eller tvärtom.

Behöver du fortfarande hjälp? Gå till Microsoft Community.