PRB: Felmeddelande: 0x80004005: Allmänt fel Det går inte att öppna registernyckeln

Anteckning

Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.

Symptom

När du öppnar en sida som ansluter till en Access-databas kan du få följande felmeddelande i webbläsaren:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

Orsak

Det konto som används för att komma åt sidan har inte åtkomst till den HKEY_LOCAL_MACHINE\SOFTWARE\ODBC registernyckeln.

Lösning

Viktigt

Det här avsnittet, metoden eller uppgiften innehåller steg som beskriver hur du ändrar registret. Det kan uppstå allvarliga problem om du gör detta felaktigt. Följ därför instruktionerna noga, och säkerhetskopiera registret innan du gör några ändringar i det. Då kan du återställa registret om det uppstår problem. Om du vill ha mer information om hur du både kan backa och återställa registret kan du klicka på följande artikelnummer och läsa artikeln i Microsoft Knowledge Base: 322756 Hur du både kan göra och återställa registret i Windows

  1. Starta Registereditorn (Regedt32.exe).

  2. Välj följande nyckel i registret:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

  3. Klicka på Behörigheter på menyn Säkerhet.

  4. Skriv de behörigheter som krävs för det konto som öppnar webbsidan.

  5. Avsluta Registereditorn.

Status

Detta är avsiktligt.