"Programmet kan inte startas. Kontakta programleverantören när du kör Office 365-datorinstallationen
Anteckning
Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.
Problem
När du försöker köra ett Microsoft Office 365 ClickOnce-program, till exempel Office 365-datorinstallationen eller Office 365 Desktop Readiness Tool, får du följande felmeddelande:
Programmet kan inte startas. Kontakta programleverantören.
När du klickar på Information visas ett detaljerat felmeddelande som ser ut ungefär så här:
ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of https://<NameOfDomain>/ClickOnceConnector/Office365DesktopSetup.application resulted in exception. Following failure messages were detected:
+ Unable to install this application because an application with the same identity is already installed. To install this application, either modify the manifest version for this application or uninstall the preexisting application.
Orsak
Det här problemet inträffar om programmet cachelagrades i ClickOnce-programmets cache. Programmet måste tas bort från cachen innan du kan köra det.
Lösning
Gör så här för att rensa ClickOnce-programcachen:
- Klicka på Start och Kör, skriv cmd och klicka sedan på OK.
- Skriv följande kommando och tryck sedan på Retur: rundll32him CleanOnlineAppCache
Gör så här för att kontrollera om problemet är åtgärdat:
- Om problemet är åtgärdat är du klar med de här stegen.
- Gå till eller kontakta support om problemet https://go.microsoft.com/fwlink/?linkid=2003907 inte är åtgärdat.
Mer information
Mer information finns i ClickOnce-referens för ohanterad API.
Behöver du fortfarande hjälp? Gå till https://go.microsoft.com/fwlink/?linkid=2003907 webbplatsen.