Du kan inte tilldela en federerad domän till en användare i administrationscentret för Microsoft 365

Anteckning

Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.

Problem

Du skapar en ny användare i administrationscentret för Microsoft 365 i Office 365. Men när du försöker tilldela en federerad domän till den nya användaren visas inte den federerade domänen i användarens lista över domäner.

Följande är ett exempelscenario om vad som händer när du upplever det här problemet:

  • I Office 365-portalen aktiveras enkel inloggning (SSO) och Active Directory-synkronisering.
  • När du visar egenskaperna för domänen på sidan med domänegenskaper visas domäntypen som Federerad eller Enkel inloggning. Till exempel adatum.com den federerade domänen.
  • När du skapar en ny användare ser du att standarddomänen som tillhandahålls av Office 365 visas som det första alternativet i listrutan. Standarddomänen är till exempel contoso.onmicrosoft.com.
  • När du klickar i listrutan för att visa listan över domäner visas inte den federerade domänen. Exempel: adatum.com inte finns med i listan.

Orsak

Det här beteendet är enligt design i Office 365. Det går inte att skapa externa användare via portalen. Alla externa användare måste skapas lokalt och måste synkroniseras med hjälp av Microsoft Azure Active Directory-synkroniseringsverktyget.

Lösning

Du kan komma runt problemet genom att skapa ett matchande användarkonto i den lokala AD DS-miljön (Active Directory Domain Services), konfigurera användarkontots huvudnamn (UPN) på rätt sätt och sedan synkronisera kontot och Azure Active Directory med hjälp av katalogsynkronisering. Gör så här:

  1. Skaffa den primära SMTP-adressen för Office 365-användarkontot. Gör så här:

    1. Logga in på Office 365-portalen https://portal.office.com () som global administratör.
    2. Klicka på Admin och klicka sedan på Exchange för att öppna administrationscentret för Exchange.
    3. Leta reda på användarkontot och dubbelklicka på det.
    4. I det vänstra navigeringsfönstret klickar du på E-postadress och anteckna sedan användarkontos primära SMTP-adress.
  2. Starta Active Directory - användare och datorer och skapa sedan ett användarkonto i den lokala domänen som matchar Office 365-användarkontot. Mer information om hur du gör detta finns i Skapa ett användarkonto i Active Directory - användare och datorer.

  3. Kontrollera att UPN för användarkontot har uppdaterats till det federerade domännamnet. Mer information om hur du gör detta finns i Felsöka Active Directory-användarkonton som pilottestas som Office 365 SSO-aktiverade användar-ID.

  4. Använd ADSI-gränssnitt (Active Directory Service Interfaces) om du vill redigera attributet proxyAddresses för användarobjektet så att det matchar den primära SMTP-adress som du antecknade i steg 1D. Gör så här:

    Anteckning

    Mer information om hur du installerar ADSI-redigering finns i Installera ADSI-redigering.

    1. Klicka på Start, klicka Kör, skriv ADSIEdit.msc och klicka sedan på OK.

    2. Högerklicka på ADSI-redigering, välj Anslut till och klicka sedan på OK för att läsa in domänpartitionen.

    3. Leta reda på det användarobjekt som du vill ändra i navigeringsfönstret, högerklicka på det och klicka sedan på Egenskaper.

    4. Klicka på attributet proxyAddresses i listan Attribut och klicka sedan på Redigera.

    5. I fältet Värde som ska läggas till anger du lämplig SMTP-adress och klickar sedan på Lägg till.

      Anteckning

      Det primära SMTP-adressvärdet för användarobjektet bör läggas till i förberedelsen av en versal "SMTP:"-designator för att adressvärdet ska vara rätt formaterat för proxyAddressesattribute. Till exempel är " " ett accepterat värde och " " inte ett SMTP:username@contoso.com username@contoso.com accepterat värde.

    6. Klicka på OK två gånger och avsluta SEDAN ADSI-redigering.

    Mer information om hur du använder ADSI-redigering för att redigera Active Directory-attribut finns på följande Microsoft TechNet-webbplats: Använda ADSI-redigering

  5. Tvinga katalogsynkronisering.

Mer information

Mer information finns i Felsöka problem med användarnamn som uppstår för externa användare när de loggar in på Office 365, Azure eller Intune.

Behöver du fortfarande hjälp? Gå till Microsoft Community.