"Det går inte att ta bort den här domänen" när du försöker ta bort en domän från Office 365

Anteckning

Office 365 ProPlus byter namn till Microsoft 365-appar för företag. Mer information om den här ändringen finns i det här blogginlägget.

Problem

När du försöker ta bort en domän från Microsoft Office 365 med hjälp av Windows PowerShell får du följande felmeddelande:

Remove-MsolDomain : Unable to remove this domain. Use Get-MsolUser -DomainName<domain name> to retrieve a list of objects that are blocking removal.
At line:1 char:18
+ Remove-MsolDomain <<<< -DomainName <DomainName>
+ CategoryInfo : OperationStopped: (:) [Remove-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

Orsak

Det här problemet uppstår om ett eller flera av följande villkor är sanna:

  • Användarkonton eller grupper är kopplade till domänen.
  • Proxyservern som motsvarar domänen för alla e-postlicensierade användare och för alla e-postaktiverade grupper tas inte bort. Office 365 blockerar borttagningen av en domän tills proxy proxyn som motsvarar domänen tas bort.
  • Domänen använder adresser i Skype för företag – Online (tidigare Lync Online) SIP-adresser (Session Initiation Protocol).

Lösning

Använd administrationscentret för Microsoft 365 för att ta bort domänen. Domänhanteraren i Office 365 hjälper administratörer att ta bort beroenden som blockerar domänborttagning utan att behöva använda Windows PowerShell.

Mer information om hur du tar bort en domän i administrationscentret för Microsoft 365 finns i Ta bort en domän.

Felsöka domänborttagning med Windows PowerShell

Anteckning

Följande steg kräver att administratörer använder Windows PowerShell.

Steg 1: Kontrollera om användarnamnen innehåller domännamnet

Anteckning

Du kan också skapa en användarvy och sedan ange domänen till den domän som du försöker ta bort. Den här vyn använder du för att anteckna användarnamnen och sedan ändra användarnamnen så att domänen inte ingår i användarnamnet.

Gör så här för att kontrollera om användarnamn innehåller domännamnet:

  1. Anslut till Microsoft Azure Active Directory med hjälp av Azure Active Directory-modulen för Windows PowerShell. Det gör du genom att öppna Azure Active Directory-modulerna för Windows PowerShell, skriva in följande cmdlet och sedan trycka på Retur.
    Connect-MsolService
    
    Ange dina autentiseringsuppgifter som administratör när du uppmanas att ange dem.
  2. Kör följande cmdlet:
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName  
    
    Kör till exempel följande, där platshållaren contoso.com den domän som är i fråga:
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
    
  3. Undersök resultatet och ändra sedan användarens huvudnamn (UPN) så att domänen inte används. UPN är samma som användarnamnet och användar-ID-egenskapen. Du kan använda Office 365-portalen eller Windows PowerShell för att ändra UPN. Målet är att inga resultat ska returneras.

Steg 2: Kontrollera e-postadresser

Anteckning

  • Det här steget gäller endast om du har en prenumeration som innehåller Exchange Online.
  • Om du kör verktyget Azure Active Directory-synkronisering kan du uppdatera e-postadresser från den lokala miljön.

Kontrollera e-postadresserna genom att följa de här stegen:

  1. Anslut till Exchange Online med fjärr-PowerShell. Mer information om hur du gör detta finns i Ansluta till Exchange Online med Remote PowerShell.

  2. Hitta alla användare och grupper som använder den domän som du försöker ta bort. Det gör du genom att köra följande cmdlet. (I den här cmdleten contoso.com den domän som är i fråga).

    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
    
  3. Observera värdet för egenskapen EmailAddresses och RecipientTypeproperty i utdata. Resultatet kan till exempel se ut ungefär så här:

    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com,   smtp:john@contoso.onmicrosoft.com}
    
  4. Gör något av följande, efter behov:

    • Om RecipientType är inställt på UserMailbox kan du använda parametern Set-Mailboxcmdlet tillsammans med parametern EmailAddresses för att ändra adresserna smtp, SMTP och SIP. Mer information om den här cmdleten finns i Set-Mailbox.

      Du kan också ta bort användaren eller licensen. Vi rekommenderar dock inte att du gör det här.

      Anteckning

      Om det här är den sista administratörsanvändaren skapar du en ny global administratör, loggar in och tar sedan bort den problemanvändaren.

    • Om RecipientType är inställt på MailUniversalDistributionGroupor MailUniversalSecurityGroup kan du använda cmdleten Set-DistributionGroup tillsammans med parametern EmailAddresses för att ändra smtp- och SMTP-adresserna. Mer information om denna cmdlet finns i Set-Distribution Group.

      Eller så kan du ta bort gruppen. Vi rekommenderar dock inte att du gör det här. Om du inte kan ta bort gruppen följer du stegen i Felet "Du har inte tillräcklig behörighet" när du försöker ta bort eller göra en ändring i en distributionsgrupp i Office 365.

    • Om RecipientType är inställd på DynamicDistributionGroup kan du använda cmdleten Set-DynamicDistributionGroup-cmdleten tillsammans med parametern EmailAddresses för att ändra smtp- och SMTP-adresserna. Mer information om denna cmdlet finns i Set-DynamicDistributionGroup.

      Eller så kan du ta bort gruppen. Vi rekommenderar dock inte att du gör det här. Om du inte kan ta bort gruppen följer du stegen i Felet "Du har inte tillräcklig behörighet" när du försöker ta bort eller göra en ändring i en distributionsgrupp i Office 365.

Mer information

Mer information finns i Du får ett felmeddelande när du försöker ta bort en domän från Office 365.

Behöver du fortfarande hjälp? Gå till Microsoft Community.