Varningsmeddelandet "Du arbetar i en delad domän (hybrid)topologi" när du konfigurerar en Office 365-samtalskö i administrationscentret för Skype för företag

Symptom

När du har angett en Office 365-samtalskö i administrationscentret för Skype för företag och du lägger till en distributionsgrupp, så anropas inte representanter eller användare. När du ändrar samtalskön kan du dessutom få följande varningsmeddelande:

Varning! Du arbetar i en topologi med delad domän (hybrid).

För närvarande stöds det här programmet endast för endast onlineklienter.

Du kan fortsätta med konfigurationen på egen risk.

Orsak

Det här problemet uppstår eftersom klientorganisationen är konfigurerad med en delad domän som för närvarande inte stöds för organisations automatiska dirigeringar (OrgAA) eller samtalsköer.

Men om du följer vägledning i avsnittet "Lösning" kanske samtalskön fungerar om alla användare som är definierade som agenter arbetar i Office 365 och har rätt licens.

Lösning

Följ de här anvisningarna för att komma runt det här problemet:

  1. Kontrollera att den lokala distributionen för Skype för företag och Office 365 är korrekt konfigurerad för hybridröst.

  2. Aktivera Edge-servern för att ta emot samtal som dirigeras sipfed.resources.lync.com (en del av en typisk hybridkonfiguration).

  3. Konfigurera en ny värd i din lokala konfiguration som möjliggör kommunikation till Azure-tjänster som fungerar som en del av infrastrukturen för OrgAA och samtalskö. Det gör du genom att köra följande cmdlet i Remote PowerShell:

    New-CSHostingProvider -Identity SFBOnlineResources -ProxyFqdn "sipfed.resources.lync.com" -Enabled $true -EnabledSharedAddressSpace $true -HostsOCSUsers $true -VerificationLevel AlwaysVerifiable -IsLocal $false
    
  4. Kontrollera att den domän som har angetts för samtalskön är ombudens sip-domän. Kontrollera också att alla representanter i kön finns i samma sip-domän. Ange inte "contoso.mail.onmicrosoft.com" eller "onmicrosoft.com". Om domänen valdes felaktigt när du skapade samtalskön måste du skapa om samtalskön eller OrgAA genom att använda rätt domän.

Mer information

Om du vill kontrollera vilka agenter som är tillgängliga för att ta emot samtal bland agenter som har definierats i distributionslistan för en samtalskö kör du följande cmdlet i Remote PowerShell:

Get-CsHuntGroup

Om representanterna inte finns med i listan följer du de här stegen:

  1. Kontrollera att representanterna är licensierade för Skype för företag och Cloud PBX.

  2. Kontrollera att representanterna är Enterprise Voice-aktiverade. Om de har tilldelats en licens för PSTN-samtal är de redan aktiverade för Enterprise Voice. Om de bara har en Cloud PBX-licens måste du manuellt aktivera dem för Enterprise Voice. För att avgöra om det är nödvändigt att aktivera användaren för Enterprise Voice kör du följande skript från Remote PowerShell:

    Get-CsOnlineUser -Identity <UPN or SIP Address> | Select SipAddress, EnterpriseVoiceEnable, HostedVoiceMail
    Set-CsUser -Identity <UPN or SIP Address> -EnterpriseVoiceEnable $True -HostedVoiceMail $True
    

Mer information finns i följande TechNet-ämnen: