Du kan inte logga in på Skype för företag – Online eftersom certifikatet inte kan köpas eller valideras

Problem

När en Office 365-användare försöker logga in på Skype för företag – Online (tidigare Lync Online) med Lync 2010 eller Lync 2013 får användaren följande felmeddelande:

There was a problem acquiring a personal certificate required to sign in. If the problem continues, please contact your support team.

Om du försöker logga in i Lync efter ett nätverksavbrott eller ett avbrott i Skype för företag – Online får du följande felmeddelande:

Cannot sign into Lync. There was a problem verifying the certificate from the server.

Orsak

Det här problemet kan uppstå om ett eller flera av följande villkor är sanna:

  • Programvaran är in föråldrad.

    • Lync-klienten är inte uppdaterad.
    • Microsoft Online Services Sign-In är in date.
  • Certifikaten kan inte inhämtas eller valideras.

    • Det personliga certifikatet för Skype för företag – Online eller de cachelagrade autentiseringsuppgifterna är skadade eller inte är uppdaterade.
    • En del av certifikatskedjan är inte betrodd och certifikatkedja misslyckas med verifieringen.

Lösning

Upplösning för Lync 2013

Ta bort inloggningsinformationen

Under inloggningsprocessen cachelagras dina autentiseringsuppgifter och annan information om anslutningen till Skype för företag – Online i Lync 2013. Om du har problem med att logga in på Skype för företag – Online klickar du på Ta bort mina inloggningsuppgifter. Då tas alla sparade lösenord, certifikat och anslutningsinställningar för användarkontot bort automatiskt från Lync 2013.

Skärmbild av inloggningssidan i Lync 2013

Upplösning för Lync 2010

  1. Uppdatera Lync-klienten till den senaste versionen som finns på sidan Nedladdningar i Office 365-portalen.
  2. Uppdatera Microsoft Online Services-Sign-In till den senaste versionen.
  3. Rensa cachelagrade certifikat, autentiseringsuppgifter och anslutningar.

Ytterligare felsökningssteg för Lync 2013 och Lync 2010

Anteckning

Följ stegen i det här avsnittet noggrant. Det kan uppstå allvarliga problem om du gör felaktiga ändringar i registret. Innan du ändrar det bör du först säkerhetskopiera registret för återställning om problem skulle uppstå.

Om anvisningarna tidigare i den här artikeln inte löser problemet kan du prova följande metoder, efter behov:

  • När Lync ansluter till en viss klientserver cachelagras den slutpunkten så att inloggningsprocessen kan bli snabbare i framtiden. Ibland kan slutpunkten ändras men inloggningen kan misslyckas. Gör så här om du vill ta bort slutpunktscachen:

    1. Leta reda på den lokala programdatamappen:
      • Windows Vista, Windows 7 och Windows 8 (utom Windows 8 RT):

        %LOCALAPPDATA%\Microsoft\Communicator<sip_address@contoso.com>\

    • Windows XP:

      %USERPROFILE%\Local Settings\Application Data\Microsoft\Communicator<sip_address@contoso.com>\

    1. Ta bort mappen som är kopplad till din inloggningsadress.
    2. Starta om Lync och försök sedan att logga in på Skype för företag – Online.
  • Om du använder Lync 2010 tar du bort det personliga certifikatet för Skype för företag – Online och laddar sedan ned ett nytt. När användaren klickar på Spara lösenord i Lync 2010 sparar den här åtgärden även certifikatet i Windows Certificate Manager.

    Så här tar du bort ett personligt certifikat:

    1. Ta bort certifikatet i Windows Certificate Manager. Gör så här:
      1. Öppna Windows Certificate Manager. Det gör du genom att trycka på Windows + R, skriva certmgr.msc och sedan klicka på OK.
      2. Expandera Personligt och expandera sedan Certifikat.
      3. Sortera efter kolumnen Utfärdat av och leta sedan efter ett certifikat som har utfärdats av Communications Server.
      4. Kontrollera att certifikatet finns och att det inte har gått ut.
      5. Ta bort certifikatet och försök logga in på Skype för företag – Online. Om du inte kan logga in på Skype för företag – Online går du till steg 2.
    2. Om du kör Windows 7 tar du bort användarens sparade autentiseringsuppgifter i Windows Credential Manager. Gör så här:
      1. Öppna Kontrollpanelen och klicka sedan på Autentiseringshanteraren.

      2. Leta reda på autentiseringsuppgifterna som används för att ansluta till Skype för företag – Online.

      3. Expandera autentiseringsuppgifterna och välj sedan Ta bort från valv.

      4. Försök att logga in på Skype för företag – Online igen och skriv sedan in den nya uppsättningen autentiseringsuppgifter.

        Anteckning

        De här stegen är inte nödvändiga i Lync 2013 eftersom de steg som nämndes tidigare om att ta bort inloggningsinformation tar bort certifikaten automatiskt.

  • Rensa DNS-cachen. Gör så här:

    1. Tryck på Windows + R, skriv följande kommando och tryck sedan på Retur:

      Ipconfig /flushdns

  • Varning Om du ändrar i registret på fel sätt med Registereditorn eller någon annan metod kan det orsaka allvarliga problem. De här problemen kan kräva att du installerar om operativsystemet. Microsoft kan inte garantera att dessa problem kan lösas. Ändra registret på egen risk.

    Kontrollera följande registernyckel på de berörda datorerna:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\MachineGuid

    Om värdet för MachineGuid innehåller braces runt GUID (till exempel {c1cbd94c-0d35-414c-89ef-dd092b984883}) tar du sedan bort kparenteserna, startar om Lync och försöker sedan att logga in igen.

Lösning för administratörer av Skype för företag – Online: Validera certifikatkedja

Slutanvändarna kan få ett felmeddelande om att certifikatet inte kan verifieras och det sker vanligtvis eftersom ett av certifikaten i kedjan inte är betrodd och inte kan verifieras. Detta inträffar vanligtvis för kunder som använder enkel inloggning i Office 365 eller för kunder som har Lync-hybriddistributioner.

Mer information om certifikatverifiering med Lync finns i Lync Mobile-användare kan inte logga in efter att de uppdaterat till klientversion 5.4.

Anteckning

Även om den här artikeln är skriven för mobila enheter gäller samma begrepp för Lync-klienter.

Mer information

Om problemet kvarstår när du har utför de här felsökningsstegen kontaktar du den tekniska supporten för Microsoft Office 365 eller Microsoft Office 365-communityforumen. I vissa fall kan användarkontot för Active Directory Domain Services vara ofullständigt eller skadat. Därför kan inte Skype för företag – Online generera ett personligt certifikat. Det här kanske inte påverkar alla klientorganisationens konton eftersom effekten beror på serverns status när användarkontot skapades.

För att begränsa problemet ska du avgöra om problemet uppstår för flera användarkonton på samma dator. Försök sedan logga in på Skype för företag – Online från samma dator med flera användarkonton. Den här processen anger om problemet är relaterat till konfigurationen av datorn eller ett problem med Skype för företag – Online-användarkontot.

Löstes problemet?

  • Kontrollera om problemet är åtgärdat.
  • Vi uppskattar din feedback. Skicka ett e-postmeddelande till oss om du vill lämna feedback eller rapportera problem med den här lösningen.

Behöver du fortfarande hjälp? Gå till Microsoft Community.