Felet "MAPI unavailable" i Skype för företag 2016-klienten
Symptom
I vissa situationer kanske MAPI-anslutningen till Exchange Server inte är tillgänglig för Skype för företag 2016-klienter. Det här problemet uppstår i följande scenarier:
- Du har en ny installation av Office 2016 eller så skapar du en ny Outlook 2016-profil.
- Du uppgraderar en befintlig Office 2013-installation till Office 2016 och skapar sedan en ny Outlook 2016 Exchange Server-profil.
Det här problemet kan uppstå för office 365 Exchange Online- eller lokala Exchange-användare. När det här problemet uppstår är MAPI-anslutningen inte tillgänglig för Skype för företag 2016-klienter. Dessutom kan du uppleva följande symptom:
Funktionen Konfigurationsinformation för Skype för företag (håll ned Ctrl-tangenten och högerklicka på systemfältet i Skype för företag 2016) visar statusen "MAPI unavailable" enligt bilden.
Om du klickar på fliken
på Visa fler i Outlook får du följande felmeddelande:
Din Outlook-profil är inte korrekt konfigurerad. Kontakta supportteamet med den här informationen.
Ombudsfunktionen kan brytas. Du kan till exempel inte schemalägga ett möte åt någon annan. När du försöker skapa onlinemötet får du följande felmeddelande:
Du har inte behörighet att schemalägga onlinemöten åt ägaren av det här kontot. Kontakta kontoinnehavaren för att få ombudsbehörigheter i Lync.
Orsak
Det här problemet uppstår eftersom Skype för företag 2016 använder egenskapen PR_PROFILE_USER för att få ledig/upptagen-information. Egenskapen ingår dock inte i funktionen Tillförlitliga profiler i Microsoft Outlook 2016.
Lösning
Lös problemet genom att använda någon av följande metoder, beroende på vilken typ av Office-installation du har. Se avsnittet "Mer information" för att avgöra om Office-installationen är MSI-baserad eller Klicka-och-kör.
MSI-baserade versioner av Skype för företag 2016
Lös problemet genom att installera uppdateringen från 5 juli 2016 (KB3115268) för Skype för företag 2016.
Klicka-och-kör-versioner av Skype för företag 2016
Aktuell kanal (CC): Åtgärdat i version 16.0.7167.2040 och senare
First Release Deferred Channel (FRDC): Åtgärdat i version 16.0.6965.2078 och senare
Uppskjuten kanal (DC): Åtgärdat i version 16.0.6965.2092 och senare
Mer information om C2R-kanalutgivningar finns i Uppdateringskanaler för Office 365-klienten.
Lösning
Viktigt
Följ stegen i det här avsnittet noggrant. Det kan uppstå allvarliga problem om du gör felaktiga ändringar i registret. Innan du ändrar det bör du först säkerhetskopiera registret för att kunna återställa det om problem skulle uppstå.
Du kan kringgå problemet i en Klicka-och-kör-version av Skype för företag 2016 genom att använda lösningen i det här avsnittet.
Anteckning
Endast själva lösningen stöds av Outlook-teamet. De preliminära stegen i den första proceduren stöds inte. Den här proceduren innehåller information som krävs för att lösa problemet. De här anvisningarna ger också en metod för att verifiera att lösningen har distribuerats korrekt och för att backa ut ändringarna om det behövs.
Preliminära steg (stöds inte)
Viktigt
Följande procedur stöds inte av Outlook-teamet och kan orsaka andra problem i Outlook. Använd den här proceduren på egen risk. Vi rekommenderar inte att du använder den här proceduren. Men vi tar med den här eftersom den publicerades tidigare, och du kan behöva använda de här stegen för att ta bort MAPI PR_PROFILE_USER-egenskapen (eller registernyckeln) när korrigeringar släpps för alla Klicka-och-kör-produktkanaler.
Starta Registereditorn.
Windows 10
Skriv regedit.exe på Start-skärmen och tryck eller klicka sedan på regedit i sökresultatet.
Windows 8.1 och Windows 8
Svep in från höger för att öppna snabbknapparna, välj Sök och skriv regedit.exe i sökrutan.
Windows 7 och Windows Vista
Klicka på Start, skriv regedit i rutan Starta sökning och tryck sedan på Retur. Om du uppmanas att ange ett administratörslösenord eller att bekräfta skriver du lösenordet eller klickar på Tillåt.
Leta rätt på följande registerundernycklar:
HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Profiles
Leta upp och expandera namnet på din Outlook-profil under den här undernyckeln.
Anteckning
Som standard är profilnamnet "Outlook". Din profil kan dock ha ett annat namn om du har skapat den manuellt.
Under profilen letar du reda på och expanderar tangenten 9375CFF041311d3B88A00104B2A6676.
Under nyckeln 9375CFF0413111d3B88A00104B2A6676 visas en undermapp för varje konto som finns i din profil. Markera den första undermappen (00000001) och granska sedan data för det binära värdet Kontonamn genom att dubbelklicka på värdet. Upprepa proceduren tills du hittar värdet för Kontonamn som innehåller din SMTP-adress.
Leta upp det binära värdet för Service UID under undernyckeln \0000000x som innehåller din SMTP-adress.
Anteckning
Det här värdet representerar ett GUID (till exempel c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7c 7e).
Leta reda på undermappen i profilen som matchar det GUID-värde som du hittade i steg 6 (till exempel \c3d19a7b801bc44a960ae5b63bf97c7e).
Under undernyckeln från steg 7 undersöker du det binära värdet 01023d0d.
Anteckning
Det här värdet representerar ett GUID (till exempel 5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0d 16 94 58).
Leta reda på undermappen i din profil som matchar GUID-värdet från steg 8 (till exempel \5fcfd5f1ba5c6f45b357cc5e0d169458).
På den här platsen skapar du ett strängvärde som heter 001e6603, enligt bilden.
Hitta användarens tidigare Exchange-domännamn (DN).
Håll ned Ctrl medan du högerklickar på systemikonen i Outlook. Välj sedan Testa Automatisk konfiguration av e-post.
I dialogrutan som öppnas avmarkerar du kryssrutorna Use Guess Smart och Secure Guessmart Authentication och klickar sedan på Testa.
När testet är klart väljer du fliken XML och letar sedan upp värdet för Tidigare DN enligt bilden.
Kopiera den äldre DN-informationen. Även om hela den taggade posten markeras i den här skärmbilden så ligger värdet som du vill kopiera allt mellan <LegacyDN> taggarna. I det här exemplet är det /o=Contoso /ou=Exchange Administrative Group (RÅDIBOHF23SPDLT)/cn=Recipients/cn=4ef0d05da334258afda34a7ce08a430-TestDir1.
I registret fyller du i värdedatafältet med hjälp av den tidigare DN-information som du just kopierade, enligt bilden. Klicka sedan på OK.
Lösning (stöds)
Hämta MFCMapi-verktyget från följande CodePlex-webbplats:
Starta verktyget på den aktuella användarens dator.
Klicka på Profil och sedan på Visa profiler.
Dubbelklicka på den aktuella användarens profil. I det här fallet finns det bara standardprofilen som heter "Outlook". Om användaren har flera profiler väljer du den som representerar det primära användarkontot som har det här problemet.
Leta reda på den tjänst som har visningsnamnet "Microsoft Exchange" i tabellen Tjänster som öppnas och dubbelklicka sedan på den tjänsten för att öppna den.
I tabellen Leverantörer som öppnas. leta upp och välj den leverantör som har SMTP-adressen för den aktuella användaren som inte har några poster för "PR_PROVIDER_DISPLAY".
I verktyget MFCMapi kontrollerar du i fönstret Leverantörer att användarens SMTP-adressleverantör är markerad. Leta sedan efter den egenskap som heter PR_PROFILE_USER. Om den här egenskapen finns går du till steg 10. Om den här egenskapen inte finns klickar du på Ytterligare egenskaper på egenskapsmenyn och sedan på knappen Lägg till.
I dialogrutan Egenskapstagg skriver du in PR_PROFILE_USER.
Anteckning
MFCMapi omvandlar den namngivna egenskapstaggen till rätt värden enligt bilden.
Klicka på OK. Klicka sedan på OK i fönstret Ytterligare egenskaper.
Kör Testa automatisk upptäckt från proceduren Preliminära steg för att få den aktuella användarens äldre Exchange DN (LegDN). Kopiera den här informationen till Urklipp.
I fönstret Leverantörer högerklickar du på egenskapen PR_PROFILE_USER och klickar sedan på Redigera.
Klistra in användarens LegDN-information i ansi-textrutan och klicka sedan på OK.
Anteckning
MFCMapi kan nu visa två poster för PR_PROFILE_USER. Det här är ett känt visningsproblem som kan ignoreras.
Valfritt: Använd metoden som beskrivs i Lösning 1 om du vill undersöka det nya registervärdet som skapades av MFCMapi och kontrollera att det finns i rätt Outlook-profil för den aktuella användaren.
Stäng alla MFCMapi-fönster och registereditorn och testa sedan MAPI-anslutning. Logga också ut helt från Skype och kontrollera att programmet inte är igång.
Logga in på Skype igen, vänta några minuter och kontrollera sedan Skype-konfigurationen. MAPI-status bör nu visas som OK.
Anteckning
Det kan ta lite tid innan ändringen verkställs. Du kanske måste logga ut från Outlook och Skype för företag och sedan logga in igen för att se ändringen.
Mer information
Så här tar du reda på om Office-installationen är Klicka-och-kör- eller MSI-baserad:
- Starta ett Office 2016-program.
- På menyn Arkiv väljer du Konto.
- För Klicka-och-kör-installationer av Office 2016 visas alternativet Uppdateringsalternativ. Alternativet Uppdateringsalternativ visas inte för MSI-baserade installationer.
Office 2016 Klicka-och-kör-installation | MSI-baserad Office 2016 |
---|---|
![]() |
![]() |
Ansvarsfriskrivning för information från tredje part
De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.
Behöver du fortfarande hjälp? Gå till Microsoft Community.