Hanteringsservrarna och deras hanterade enheter är nedtonade i Operations Manager-konsolen
Den här artikeln åtgärdar ett problem där vissa Operations Manager-roller är nedtonade i operationskonsolen och händelse 623 är inloggad på de berörda datorerna.
Ursprunglig produktversion: Microsoft System Center 2012 Operations Manager
Ursprungligt KB-nummer: 975057
Symptom
I en Microsoft System Center Operations Manager-miljö kan en eller flera hanteringsservrar som är värd för följande roller, tillsammans med de hanteringsservrarnas hanterade enheter, visas nedtonade eller nedtonade i operationskonsolen:
- Hanteringsserver
- Gatewayserver
- Agent
Dessutom loggas en händelse som liknar följande i Operations Manager-loggen på dessa datorer:
Händelsekälla: ESE
Händelsekategori: Transaktionshanteraren
Händelse-ID: 623
Beskrivning: HealthService (<PID>) Versionsarkivet ("<instance><name>") har nått sin maximala storlek på <value> MB. Det är troligt att en långvariga transaktion förhindrar rensning av versionsarkivet och orsakar att den byggs upp i storlek. Uppdateringar kommer att avvisas tills den långvariga transaktionen har genomförts helt eller återställts. Möjlig långvariga transaktion:
SessionId: <value>
Sessionssammanhang: <value>
Session-context ThreadId: <value>.
Rensning: <value>
Anteckning
Händelsen kan rapportera problemet med andra Operations Manager-processer, beroende på vilken roll som påverkas.
Orsak
Det här problemet uppstår vanligtvis i en stor Operations Manager-miljö där en hanteringsserver eller en agentdator hanterar många arbetsflöden. Den här situationen kan uppstå på grund av någon av följande orsaker:
- Många hanteringspaket installeras.
- En hanteringsserver eller agent fungerar som proxy för många enheter.
Operations Manager-Hälsotjänst lagrar poster för transaktioner som inte är slutförda i något som kallas version store. Med versionsbutiken kan Extensible Storage Engine (ESE) spåra och hantera aktuella transaktioner. Versionsbutiken har en lista över åtgärder som utförs av aktiva transaktioner som underhålls av HealthService-tjänsten. Den här listan är en minneslista med ändringar som görs i HealthService-lagringsdatabasen. Det finns en standardstorlek som optimeras för en vanlig installation av varje Operations Manager-roll. Standardstorleken kan dock vara otillräcklig för vissa Operations Manager-miljöer.
Lösning
Viktigt
Det här avsnittet, metoden eller uppgiften innehåller steg som beskriver hur du ändrar registret. Det kan uppstå allvarliga problem om du gör detta felaktigt. Följ därför instruktionerna noga, och säkerhetskopiera registret innan du gör några ändringar i det. Då kan du återställa registret om det uppstår problem. Mer information om hur du säkerhetskopierar och återställer registret finns i Hur du säkerhetskopierar och återställer registret i Windows.
Lös problemet genom att använda följande registerinställning på de datorer där rollerna är värd:
- Undernyckel:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters - Typ: REG_DWORD
- Namn: Max för versionsarkiv för beständig lagring
- Värde: Antal 16-kilobytesidor
- Bas: Decimal
Standardstorleken för versionsarkivet beror på operationshanterarens roll och definieras som antalet 16-kilobytesidor som ska allokeras i minnet. Standardvärdena är följande:
- Agent (operativsystem för arbetsstationer): 640 (10 megabyte)
- Agent (serveroperativsystemet): 1920 (30 megabyte)
- Hanteringsserver: 5120 (80 MB)
Om du upplever det här problemet rekommenderar vi att du ställer in versionsbutikens storlek till dubbelt så stor som standard. Om du till exempel anger storleken på versionsarkivet på en dator med rollen Management Server anger du 1 0240 (decimal) för registervärdet .
Starta om HealthService-tjänsten när du har tillämpat registerändringen.
Anteckning
- En större version måste tilldelas ytterligare minne.
- Om HealthService kör många arbetsflöden måste registervärdet anges ännu större än den rekommenderade storleken.
- För andra problem där vissa av dessa symptom är liknande, se Felsöka tillstånd för grå agent System Center Operations Manager.