AutoPilot cihazı içeri aktarma ve kaydı sorunlarını giderme

Geçerli olduğu yer:

  • Windows 11
  • Windows 10

Cihazları Intune'a içeri aktarma ve kaydetme sırasında ortaya çıkabilir sorunlar hakkında bilgi için aşağıdaki bölümlere bakın.

Kendi 0x80180014 veya önceden sağlama modunu kullanarak yeniden kayıt işlemi sırasında hata koduyla ilgili hata kodu

İlk AutoPilot dağıtımının ardından, hedeflenen AutoPilot kendi kendine dağıtım modu veya önceden sağlama modu profiline sahip cihazlar AutoPilot'u kullanarak otomatik olarak yeniden kayded kullanılamaz. Cihazı yeniden parça parça parça etmeye çalışsanız, hata 0x80180014 kodu döndürülür:

Kayıt durumu sayfası 0x80180014 kendi kendine dağıtım modunu veya önceden sağlama modunu kullanan cihazlarda hata kodunu gösterir.

Önceden sağlama sayfasında, kendi 0x80180014 veya ön sağlama modunu kullanan cihazlarda hata kodu görüntülenir.

ETW günlükleri aşağıdaki hatayı gösterebilir:

MDM Enroll: Server Returned Fault/Code/Subcode/Value=(DeviceNotSupported) Fault/Reason/Text=(Enrollment blocked for AP device by SDM One Time Limit Check)

Neden A

Microsoft Endpoint Manager AutoPilot Windows modu (Genel Önizleme) ve Ön Sağlama modu (eski adıyla beyaz önizleme) deneyiminde değiştirildi. Cihazı yeniden kullanmak için, Intune tarafından oluşturulan cihaz kaydını silmeniz gerekir.

Bu değişiklik, kendi kendine dağıtım veya önceden sağlama modunu kullanan tüm AutoPilot dağıtımlarını etkiler. Bu değişiklik, yeniden kullanılan, sıfırlama yapılan veya bir profili yeniden sunarken cihazları etkiler.

Çözüm A

Cihazı AutoPilot aracılığıyla yeniden yapmak için:

  1. Intune'da cihaz kaydını silin. Belirli adımlar için bkz. Cihaz silme Endpoint Manager.
  2. AutoPilot dağıtım profilini yeniden dağıtma.

Neden B

Windows MDM kaydı, Intune kiracınız içinde devre dışı bırakılır.

Çözüm B

Bu sorunu tek başına Intune ortamında düzeltmek için şu adımları izleyin:

  1. Microsoft Endpoint Manager merkezinde DevicesEnrollment > kısıtlamaları'ni seçin ve ardından bir cihaz türü kısıtlaması seçin.
  2. Platform ayarları'nın yanındaki PropertiesEdit'i > seçin. Ardından, Bu (MDM) Windows İzin Ver'i seçin.
  3. Gözden Geçir'i ve ardından Kaydet'i seçin.

Cihaz içeri aktarma sorunları

Cihaz karması hatası dönüştürülemedi

Açıklama

  • CSV'yi seçdikten sonra İçeri Aktar seçeneği hiçbir şey yapmadı
  • Ağ izlemesinde hata gövdesi "[DEVICEHASH]' metni beklenen 'Edm.Binary' türüne dönüştürülemedi" hatasını ile bir 400 hatası görüntülenir

Neden

Bu hata, cihaz karmanın yanlış biçimlendirilmiş olduğunu gösterir. Toplanan karmanın bozuk olduğu her şey bu hataya neden olabilir. Karmanın kendisinin (geçerli olsa bile) kod çözme işlemi başarısız olması olasıdır.

Açıklama

Cihaz karması Base64'tir. Cihaz düzeyinde,paded olmayan Base64 olarak kodlanmış ama AutoPilot'un tuş takımı Base64 olmasını bekler. Yük genellikle doldurma gerektirmez ve işlem çalışır. Bununla birlikte, bazen yük temiz bir şekilde kaplamaz ve doldurma gerekir. Bu durumda, yukarıda görüntülenen hatayı alırsınız. PowerShell'in Base64 kod çözücüsü de base64'ü beklemededir, dolayısıyla karmanın düzgün biçimde biçimde güzel güzel olduğunu doğrulamak için bu kod çözücüsü kullanabiliriz.

Karmanın sonundaki "A" karakterleri etkin bir şekilde boş verilerdir. Base64'te her karakter 6 bit, Base64'te A ise 0'a eşit 6 bittir. Sonunda A'ların silinmesi veya ekli olması, yükün gerçek verilerini değiştirmez.

Çözüm

Bu sorunu çözmek için, karmayı değiştirmemiz, sonra PowerShell karmanın kodunu çözmeyi başarana kadar yeni değeri testmiz gerekir. Sonuç büyük ölçüde uygun değil, bu sorun değil. Yalnızca "64 tabanı karakter dizisi veya dizesi için geçersiz uzunluk" hatasının atulmaması için aramamız var.

base64'ü test etmek için aşağıdaki PowerShell'i kullanabilirsiniz:

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("DEVICE HASH"))

Buna örnek olarak (bu bir cihaz karması değil, ancak yanlış hizalanmamış Base64'tir, dolayısıyla test etmek için iyidir):

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("Q29udG9zbwAAA"))

Şimdi doldurma kuralları için. Doldurma karakteri "=" karakteridir. Doldurma karakteri karmanın yalnızca sonunda ve en fazla iki doldurma karakteri olabilir. Temel mantık burada ve şekildedir.

  • Karma kodunu çözme başarısız olur mu?
  • Evet: Son iki karakter "=" mı?
    • Evet: Her iki "=" karakterini de tek bir "A" karakteriyle değiştirin, sonra yeniden deneyin
    • Hayır: Sonuna başka bir "=" karakteri ekleyin, sonra yeniden deneyin
  • Hayır: Bu karma geçerlidir

Yukarıdaki bir önceki örnek karmanın mantığını döngüye almak için aşağıdaki permütasyonları elde ediyoruz:

  • Q29udG9zbwAAA
  • Q29udG9zbwAAA=
  • Q29udG9zbwAAA==
  • Q29udG9zbwAAA
  • Q29udG9zbwAAA=
  • Q29udG9zbwAAA== (Bu dosyada geçerli doldurma var)

Toplanan karmayı bu yeni paded karma ile değiştirin ve içeri aktarmayı yeniden deneyin.

Intune kayıt sorunları

Intune kayıt sorunlarıyla ilgili yardım için bu bilgi bankası makalesine bakın. Sık karşılaşılan sorunlar şunlardır: "

  • yanlış veya eksik lisansların kullanıcıya atandığı.
  • kullanıcıya kayıtlı çok fazla cihaz var.

Hata kodu 80180018 "Bir sorun oluştu" başlıklı bir hata sayfasında bildiriliyor. Bu hata, MDM kaydın başarısız olduğu anlamına gelir.

AutoPilot Sıfırlama işlemi hemen Başarısız Oldu hatasıyla başarısız olursa. Neden ve el ile sıfırlama olduğunu görmek için lütfen bir yönetici hesabıyla oturum açın ve daha fazla yardım için AutoPilot Sıfırlama Sorunlarını Giderme'ye bakın.

Windows AutoPilot - bilinen sorunlar
E-Windows 10'de MDM hatalarını tanılama