Visual Studio 2005’teki GeliştirmelerImprovements in Visual Studio 2005

Microsoft tarafındanby Microsoft

Visual Studio 2005, Web uygulama geliştiricileri, Web projelerinde yapılan iyileştirmeler ve geliştirmelerin uzun bir listesini sağlar.Visual Studio 2005 provides Web application developers with a long list of improvements and enhancements to Web projects.

Visual Studio 2005, Web uygulama geliştiricileri, Web projelerinde yapılan iyileştirmeler ve geliştirmelerin uzun bir listesini sağlar.Visual Studio 2005 provides Web application developers with a long list of improvements and enhancements to Web projects. Visual Studio .NET 2002 ve 2003 kadar güçlü, Web projeleri ele şekilde birçok şikayet vardı.As powerful as Visual Studio .NET 2002 and 2003 are, there were many complaints in the way that Web projects were handled. Visual Studio 2005, bu şikayetleri gidermek için önemli sayıda yeni özellik ekler.Visual Studio 2005 adds a significant number of new features in order to address these complaints. Visual Studio .NET 2003 web uygulamalarının derlemesini ele alış şeklini tercih edenler için Web Uygulama Projeleribölümüne bakın.For those who prefer the way that Visual Studio .NET 2003 handled compilation of Web applications, see Web Application Projects.

Bu modülde, Web proje oluşturma, yönetimi ve geliştirme deki geliştirmeleri iyi kaplar.In this module, well cover improvements in Web project creation, management, and development. Daha sonraki bir modülde, Web projeleri oluşturma ve dağıtma daki gelişmeleri iyi bir şekilde kapsar.In a later module, well cover improvements in building Web projects and deploying them.

FrontPage Sunucu UzantılarıFrontPage Server Extensions

Visual Studio .NET 2002 ve 2003, Web projeleri oluşturmak veya oluşturmak için kutunun üzerinde FrontPage Server Uzantıları gerekti.Visual Studio .NET 2002 and 2003 required FrontPage Server Extensions on the box in order to create or build Web projects. Geliştiricilerin iki farklı erişim modu (FrontPage Server Uzantıları veya Dosya erişim modu) arasında bir seçim vardı, her ikisi de IIS, vb uygulama kökü ayarı gibi görevleri gerçekleştirmek için FrontPage Server Uzantıları kullanılır.Developers did have a choice between two different access modes (FrontPage Server Extensions or File access mode), both used FrontPage Server Extensions to perform tasks such as setting the application root in IIS, etc.

Visual Studio 2005, yerel projeler için FrontPage Sunucu Uzantılarına olan güveni ortadan kaldırır.Visual Studio 2005 removes the reliance on FrontPage Server Extensions for local projects. Visual Studio 2005 artık FrontPage Server Uzantılarını kullanmak yerine doğrudan IIS metatabanına erişebiliyor.Visual Studio 2005 now accesses the IIS metabase directly instead of using the FrontPage Server Extensions. Visual Studio 2005 ayrıca FrontPage Server Uzantıları gerektirmeden uzaktan proje erişimi ne olanak sağlar FTP için destek ekler.Visual Studio 2005 also adds support for FTP which allows for remote project access without requiring FrontPage Server Extensions.

Projelerinde FrontPage Server Uzantılarını kullanmak isteyen geliştiriciler için seçenek hala kullanılabilir.For those developers who want to use FrontPage Server Extensions in their projects, the option is still available. Ancak, ASP.NET geliştirici topluluğundan gelen güçlü geri bildirimlere dayanarak, bu bir gereklilik değildir.However, based upon strong feedback from the ASP.NET developer community, it is not a requirement.

Note

FrontPage Sunucu Uzantıları hala uzak proje oluşturma, açılış, vb için gereklidir.FrontPage Server Extensions are still required for remote project creation, opening, etc.

ASP.NET Geliştirme SunucusuASP.NET Development Server

Visual Studio 2005, ASP.NET Development Server adlı yeni bir Web sunucusuyla birlikte çalışıyor.Visual Studio 2005 ships with a new Web server called ASP.NET Development Server. (Bu Web sunucusu daha önce Cassini olarak biliniyordu.)(This Web server was previously known as Cassini.)

ASP.NET Geliştirme Sunucusu'nun çeşitli avantajları vardır.There are several benefits of the ASP.NET Development Server.

  • Artık Yönetici olmayanların bir Web sunucusuna karşı hata ayıklama geliştirmesi ve hata ayıklama ları artık mümkündür.It is now possible for non-Administrators to develop and debug against a Web server.
  • ASP.NET Geliştirme Sunucusu, sanal dizinleri dosya sistemindeki herhangi bir konuma dinamik olarak eşleyerek esnek proje konumları sağlar.The ASP.NET Development Server dynamically maps virtual directories to any location in the file system allowing for flexible project locations.
  • Windows XP Professional'da zaten IIS kullanan kullanıcılar artık IIS'deki Varsayılan Web Sitelerinin dosya veya klasör yapısını etkilemeyecek yeni Web uygulamaları oluşturabilecektir.Users on Windows XP Professional who are already using IIS will now be able to create new Web applications that will not affect the file or folder structure of their Default Web Site in IIS.

ASP.NET Geliştirme Sunucusu'ndan yararlanmak için özel bir yapılandırma gerekmez.No special configuration is required to take advantage of the ASP.NET Development Server. Dosya sisteminde barındırılan bir Web projesi debugged veya göz atıldığında, Visual Studio 2005 otomatik olarak isteği hizmet için rasgele bir bağlantı noktasında ASP.NET Geliştirme Sunucusu bir örnek başlatacak.When a Web project that is hosted on the file system is debugged or browsed, Visual Studio 2005 will automatically start an instance of the ASP.NET Development Server on a random port to service the request.

Daha fazla bilgi daha sonra bu modülde ASP.NET Geliştirme Sunucusu'nda ele alınacaktır.More information will be covered on the ASP.NET Development Server later in this module.

Geliştirilmiş Dosya YönetimiImproved File Management

Visual Studio 2002 ve 2003'te, bir proje dosyası (VB.NET için vbproj ve C#için .csproj) Web uygulamasındaki tüm dosyalarda bilgi depolatılır.In Visual Studio 2002 and 2003, a project file (.vbproj for VB.NET and .csproj for C#) stored information on all files in the Web application. Çözüm Gezgini ekranı proje dosyasındaki dosya bilgilerine dayanır.The Solution Explorer display is based upon the file information in the project file. Bu nedenle, Solution Explorer genellikle dış düzenleyicilerin kullanıldığı durumlarda yanlış bilgiler görüntüler.Because of this, the Solution Explorer would often display inaccurate information in cases where external editors were used. Visual Studio 2002 ve 2003 genellikle dosya değişikliklerinin üzerine yazar veya dosyaların en son sürümünü görüntülemez.Visual Studio 2002 and 2003 would often overwrite file changes or not display the most recent version of files.

Visual Studio 2005 proje dosyasını ortadan kaldırıyor.Visual Studio 2005 does away with the project file. Bunun yerine, dosya ve klasör bilgilerini doğrudan diskten okur ve projenizdeki dosyaların doğru bir şekilde görüntülenmesini sağlar.Instead, it reads the file and folder information directly from the disk, resulting in an accurate display of the files in your project. Visual Studio 2002 ve 2003'teki Başvurular klasörü Web uygulamanızda gerçek bir klasörü temsil etmediğinden, Visual Studio 2005 de Çözüm Gezgini'nden Başvurular klasörünü kaldırır.Because the References folder in Visual Studio 2002 and 2003 does not represent an actual folder in your Web application, Visual Studio 2005 also removes the References folder from Solution Explorer. Visual Studio 2005'te projenizin referanslarına erişmek için proje için Özellik sayfalarını kullanmanız gerekir.To access the references for your project in Visual Studio 2005, you should use the Property pages for the project.

Web Projeleri OluşturmaCreating Web Projects

Web geliştiricileri Visual Studio 2005 proje oluşturma için birçok yeni seçenek var.Web developers have many new options available for project creation in Visual Studio 2005. Web siteleri artık dosya sisteminin herhangi bir yerinde oluşturulabilir ve daha sonra yeni ASP.NET Geliştirme Sunucusu kullanılarak debugged veya göz atılabilir.Web sites can now be created anywhere in the file system and can then be debugged or browsed using the new ASP.NET Development Server. Geliştiriciler ftp kullanarak yeni Web siteleri de oluşturabilir.Developers can also create new Web sites using FTP.

Visual Studio 2005'te Web projeleri oluşturmanın video walkthrough'ünü görüntülemek için buraya tıklayın.Click here to view a video walkthrough of creating Web projects in Visual Studio 2005.

Tam Ekran Video AçOpen Full-Screen Video

Dosya Sistemi ProjeleriFile System Projects

Video izbinde gördüğünüz gibi, dosya sisteminde yerel makinede veya dosya paylaşımı yoluyla uzak bir konumda Web siteleri oluşturmayı seçebilirsiniz.As you saw in the video walkthrough, you can choose to create Web sites on the file system either on the local machine or on a remote location via a file share. Dosya sisteminde oluşturulan web sitelerine ASP.NET Geliştirme Sunucusu kullanılarak göz lenir ve debugged.Web sites that are created on the file system are browsed and debugged using the ASP.NET Development Server.

Note

ASP.NET Geliştirme Sunucusu müşteriler için bazı karışıklığa neden olabilir.The ASP.NET Development Server may cause some confusion for customers. IISs dizin yapısında (c:/inetpub/wwwroot) dosya sisteminde bir Web projesi oluşturulursa, Visual Studio 2005'ten başlatıldığında Web sitesine ASP.NET Geliştirme Sunucusu üzerinden göz atılır.If a Web project is created on the file system in IISs directory structure (i.e. c:/inetpub/wwwroot), the Web site will still be browsed via the ASP.NET Development Server when launched from within Visual Studio 2005. Bu nedenle, herhangi bir IIS yapılandırması (yani kimlik doğrulama yöntemleri) geçerli değildir.Therefore, any IIS configuration (i.e. authentication methods) is not applicable.

Varsayılan web projesi, yalnızca default.aspx sayfası, default.cs dosyası ve app/_Data klasörü ekleyerek ek yükün çoğunu da kaldırır.The default web project also removes a lot of the overhead by only includes a Default.aspx page, default.cs file, and an App/_Data folder. Web.config ve özel klasörler (yani app/_code) gerektiğinde eklenir.The web.config and special folders (i.e. app/_code) are added as they are needed. Web projeniz yalnızca ihtiyacınız olan dosya ve klasörleri içerir.Your web project only includes the files and folders that you need.

HTTP ProjeleriHTTP Projects

HTTP projeleri, yerel bir IIS Web sitesinde veya uzak bir Web sitesinde oluşturulan projeler olabilir.HTTP projects can either be projects that are created on a local IIS Web site or on a remote Web site. Varsayılan proje http://localhostkonumu.The default project location is http://localhost. Gözat düğmesini tıklattığınızda, iki HTTP seçeneği vardır: Yerel IIS ve Uzak Site.If you click the Browse button, there are two HTTP options: Local IIS and Remote Site. Bu iki seçenekteki temel fark, web sitesi bilgilerinin Konum Seç iletişim kutusunda görüntülenme yöntemi ve dosyaların Web sunucusuna nasıl kopyalandığıdır.The main difference in these two options is the method in which the web site information is displayed in the Choose Location dialog and in how the files are copied to the Web server.

Yerel IIS seçeneği, yerel makinedeki metatabandaki site bilgilerini okur ve dosyalar dosya sistemi kullanılarak kopyalanır.The Local IIS option reads the site information from the metabase on the local machine and files are copied using the file system. Uzak Site seçeneği FrontPage Server Uzantıları kullanır ve site bilgileri ve dosyaları HTTP ve FrontPage Server Extensions RPC çağrıları kullanılarak kopyalanır.The Remote Site option uses the FrontPage Server Extensions and the site information and files are copied using HTTP and FrontPage Server Extensions RPC calls.

Note

vs##//_tmp.htm dosyası ve get/_aspx/_ver.aspx artık sürüm bilgilerini belirlemek için kullanılmaz.The vs###/_tmp.htm file and get/_aspx/_ver.aspx are no longer used to determine version information.

Varsayılan HTTP seçeneği Yerel IIS'dir.The default HTTP option is Local IIS. Bu seçenek, hangi sitelerin kullanılabilip içerik oluşturulabilmek için hangi konumda olduğunu belirlemek için IIS Metabase'i okur.This option reads the IIS Metabase to determine which sites are available and the location in which to create content. Ağaç görünümünde seçerek farklı bir klasör veya sanal dizin seçebilirsiniz.You can select a different folder or virtual directory by selecting it in the tree view. Ayrıca yeni bir sanal dizin oluşturabilir, klasörleri uygulama olarak işaretleyebilir ve varolan sanal dizinleri bu iletişim kutusundan silebilirsiniz.You can also create a new virtual directory, mark folders as applications, as well as delete existing virtual directories from this dialog box.

Konum Seç İletişim Kutusu

Şekil 1: Konum Seç iletişim kutusuFigure 1: The Choose Location Dialog

Visual Studio'nun önceki sürümlerinden farklı olarak, Güvenli Soketler Katmanı Nı Kullan onay kutusunu kontrol ederseniz ve SSL sertifikası göz attığınız URL ile eşleşmiyorsa, size devam etmek isteyip istemediğiniz konusunda size bir Güvenlik Uyarısı iletişim kutusu sunulur.Unlike in earlier versions of Visual Studio, if you check the Use Secure Sockets Layer checkbox and the SSL certificate does not match the URL you are browsing, you will be presented with a Security Alert dialog asking you if you would like to proceed. Visual Studio .NET 2003'ün kullanımı, sertifika eşleşen bir sertifika değilse, proje oluşturma başarısız olur.Using Visual Studio .NET 2003, if the certificate was not a matching one, creating the project would fail.

SSL Sertifikası ile ilgili güvenlik uyarısı

Şekil 2: SSL Sertifikasına İlişkin Güvenlik UyarısıFigure 2: Security Alert Regarding SSL Certificate

Ev Sahibi Üstenler hakkında notNote on Host Headers

Belirli bir IP'ye bağlı bir sitede bir Web uygulaması oluşturuyorsanız, ana bilgisayar üstbilginin yapılandırıldığından emin olmanız gerekir.If you are creating a Web application on a site bound to a specific IP, you will need to ensure that a host header is configured. Aksi takdirde, Visual Studio http://localhostsiteyi ,, ancak sitenin IDE içinden tsıçrıldığında veya debugged olduğunda IP adresi doğru şekilde çözülmez.Otherwise, Visual Studio will create the site at http://localhost, but the IP address will not resolve correctly when the site is browsed or debugged from within the IDE.

Uzak Site seçeneğini belirlerseniz, iletişim kutusu yeni Web sitesinin hedef URL'sini girmenize olanak sağlayacak şekilde değişir.If you select the Remote Site option, the dialog changes to allow you to enter the destination URL for the new Web site. Bu URL, FrontPage Sunucu Uzantıları etkinleştirilmiş bir sunucuda olmalıdır.This URL must be on a server that has the FrontPage Server Extensions enabled. FrontPage Sunucu Uzantılarını kullanarak yerel Web sunucunuzla çalışmak istiyorsanız, Uzak Site seçeneğini kullanabilir ve yerel bir URL belirtebilirsiniz.If you want to work with your local Web server using the FrontPage Server Extensions, you can use the Remote Site option and specify a local URL.

Uzak Sunucuda Web Sitesi Oluşturma

Şekil 3: Uzak Sunucuda Web Sitesi OluşturmaFigure 3: Creating a Web Site on a Remote Server

SSL üzerinden uzak bir sitede uygulama oluştururken, SSL sertifikası eşleşmiyorsa, onay iletişim kutusu Yerel IIS seçeneğini kullanırken görüntülenen iletişim kutusundan biraz farklıdır.When creating an application on a remote site via SSL, if the SSL certificate does not match, the confirmation dialog is slightly different than the dialog displayed when using the Local IIS option.

Uzak Site Güvenlik Uyarısı

Şekil 4: Uzak Site Güvenlik UyarısıFigure 4: The Remote Site Security Alert

FTPFTP

Visual Studio 2005 FTP üzerinden Web siteleri oluşturma seçeneğini sunar.Visual Studio 2005 introduces the option to create Web sites via FTP. Bu seçeneği kullandığınızda, IDE dosyaları kullanıcılar geçici klasöründe yerel olarak oluşturur ve dosyaları FTP konumuna taşımak için FTP kullanır.When you use this option, the IDE creates the files locally in the users temp folder and then uses FTP to move the files to the FTP location.

Note

Geçici klasör konumu c:/Belgeler ve<>Ayarlar/ Kullanıcı /Yerel Ayarlar/Geçici/VWDWebÖnbellek/<Sunucu>/<uygulama adıdır>The temp folder location is c:/Documents and Settings/<User>/Local Settings/Temp/VWDWebCache/<Server>/<application name>

FTP seçeneğini kullanırken, size konum seç iletişim kutusu sunulur.When using the FTP option, you will be presented with a Choose Location dialog. Bu iletişim kutusuna gerekli FTP bağlantı bilgilerini aşağıda gösterildiği gibi girersiniz.You enter the required FTP connection information into this dialog as shown below.

FTP için Konum Seç İletişim Kutusu

Şekil 5: FTP için Konum Seç İletişim KutusuFigure 5: The Choose Location Dialog for FTP

Laboratuvar: FTP sitesini kurulum ve proje oluşturmaLab: Setup FTP site and create a project

Aşağıdaki adımlar, ftp sitesini, kullanıcının yalnızca FTP üzerinden yükleyebileceği bir konuma sahip olması için yapılandırır.The following steps configure the FTP site so that a user has a location that only they can upload to via FTP.

FTP Hizmetini YükleyinInstall the FTP Service

  1. Programları Kaldır'ı Aç, Windows Bileşenleri Ekle/Kaldır'ı seçinOpen Add Remove Programs, select Add/Remove Windows Components
  2. Internet Information Services 'i (Windows 2003'te Uygulama Sunucusu) seçin ve Ayrıntılar'ıtıklatın.Select Internet Information Services (Application Server on Windows 2003) and click Details.
  3. Dosya Aktarım Protokolü (FTP) Hizmetini denetleyin ve Tamam'ıtıklatın.Check File Transfer Protocol (FTP) Service and click OK.
  4. FTP hizmetini yüklemek için İleri'yi tıklatın.Click Next to install the FTP service.

İçerik için Yeni Bir Klasör OluşturmaCreate a New Folder for Content

  1. Windows Gezgini'nde, c:/inetpub/wwwroot içinde User1 adında yeni bir klasör oluşturun.In Windows Explorer, create a new folder called User1 inside of c:/inetpub/wwwroot.

Klasörleri ve izinleri klasörlerde yapılandırın.Configure folders and permissions on folders.

  1. İdari Araçlar'dan Internet Bilgi Hizmetleri'ni açın.Open the Internet Information Services snap-in from Administrative Tools. Artık bilgisayar adı düğümü altında bir FTP Siteleri klasörüne sahip olacak.You will now have an FTP Sites folder under the computer name node.
  2. FTP SiteleriniGenişletin.Expand FTP Sites.
  3. Varsayılan FTP Sitesinisağ tıklatın, Yeni'yiseçin , sonra Sanal Dizin, sonra İleri'yitıklatın.Right-click the Default FTP Site, select New, then Virtual Directory, then click Next.
  4. Sanal dizin adı için User1'i girin ve İleri'yitıklatın.Enter User1 for the virtual directory name and click Next.
  5. Yol için c:/inetpub/wwwroot/User1'i girin ve İleri'yitıklatın.Enter c:/inetpub/wwwroot/User1 for the path and click Next.
  6. Sihirbazı tamamlamak için İleri ve Sonra Bitir'i tıklatın.Click Next and then Finish to complete the wizard.
  7. Varsayılan FTP Sitesi altında User1 sanal dizinine sağ tıklayın ve Özellikler'iseçin.Right-click the User1 virtual directory under Default FTP Site and select Properties.
  8. Yaz onay kutusunu işaretleyin ve iletişim kutusunu kapatmak için Tamam'ı tıklatın.Check the Write checkbox and click OK to close the dialog.
  9. Varsayılan FTP Sitesini sağ tıklatın ve Özellikler'iseçin.Right-click Default FTP Site and select Properties.
  10. Güvenlik Hesapları sekmesinde, Anonim Bağlantılara İzin Ver'inişaretlerini kaldırın.On the Security Accounts tab, uncheck Allow Anonymous Connections.
  11. Devam etmek isteyip istemediğinisoran iletişim kutusunda Evet'i tıklatın.Click Yes in the dialog asking if you want to continue.
  12. İletişim kutusunu kapatmak için Tamam'ı tıklatın.Click OK to close the dialog.
  13. Varsayılan Web Sitesini Web Siteleri düğümü altında genişletin.Expand the Default Web Site under the Web Sites node.
  14. User1 dizinine sağ tıklayın ve Özellikler'i seçinRight-click the User1 directory and select Properties
  15. Uygulama Ayarları bölümünde, klasörü uygulama olarak işaretlemek için Oluştur'u tıklatın.In the Application Settings section, click Create to mark the folder as an application.
  16. İletişim kutusunu kapatmak için Tamam'ı tıklatın.Click OK to close the dialog.
  17. Internet Bilgi Hizmetleri'ni kapatın.Close the Internet Information Services snap-in.

Web projesi oluşturmaCreate web project

  1. Açık Görsel Studio 2005.Open Visual Studio 2005.
  2. Dosya menüsünden Yeni Web Sitesi'niseçin.From the File menu, select New Web Site.
  3. Konum açılır düşüşünde FTP'yiseçin.In the Location dropdown, select FTP.
  4. Gözat’a tıklayın.Click Browse.
  5. Sunucu metin kutusuna localhost girin.Enter localhost in the Server textbox.
  6. Dizin metin kutusuna User1'i girin.Enter User1 in the Directory textbox.
  7. 'a tıklayın.Click Open. FTP konumu Yeni Web Sitesi iletişim kutusuna girilir.The FTP location will be entered into the New Web Site dialog.
  8. Tamam'a tıklayın.Click OK.
  9. FTP Oturum Açma iletişim kutusunda Anonim oturum açma nın işaretlerini kaldırın, kimlik bilgilerinizi girin ve Tamam'ıtıklatın.Uncheck Anonymous log on in the FTP Log On dialog, enter your credentials, and click OK.
  10. Projenin URL'si nedir?What is the URL for the project? (Projenin URL'si Çözüm Gezgini'nde görüntülenir.)(The URL for the project will be displayed in Solution Explorer.)
  11. Yapı menüsünden Web Sitesi Oluştur veya Çözüm Oluştur'useçin. Build Web SiteFrom the Build menu, select Build Web Site or Build Solution.
  12. Solution Explorer'da Default.aspx'e sağ tıklayın ve Tarayıcıda Görüntüle'yiseçin.Right-click on Default.aspx in Solution Explorer and select View in Browser.
  13. Web Sitesi URL Gerekli iletişim http://localhost/user1 kutusunda, URL için girin ve Tamam'ıtıklatın.In the Web Site URL Required dialog, enter http://localhost/user1 for the URL and click OK.

Note

Tür /_Default yüklenemediğini belirten bir hata alırsanız, önceki bir sürüm yerine Web sitenizde 2.0'ASP.NET çalıştırdığınızdan emin olun.If you get a error indicating an inability to load the type /_Default, make sure that you are running ASP.NET 2.0 on your Web site and not an earlier version. Bunu Internet Bilgi Hizmetleri'ndeki ASP.NET sekmesinden yapabilirsiniz.You can do that from the ASP.NET tab in Internet Information Services.

Web Projeleri AçmaOpening Web Projects

Web projelerini açmak, proje oluşturmaya benzer.Opening Web projects is similar to creating projects. Aşağıdaki bölümlerde IDE içinde çalışırken dikkat edilebis alanlar aforme.The following sections call out areas to keep an eye out for while working within the IDE. Ayrıca HTTP ve FTP kullanarak Web projeleri ile çalışmayı kapsar.It also covers working with Web projects using HTTP and FTP.

Bir Web projesi açmak için Dosya menüsünden Web Sitesini Aç'ı seçin.To open a Web project, select Open Web Site from the File menu. Daha önce kapsanan aynı Konum Seç iletişim kutusunda sizden istenir ve kullanabileceğiniz aynı dört seçenek vardır: Dosya Sistemi, Yerel IIS, FTP ve Uzak Site.You will be prompted with the same Choose Location dialog covered previously and you have the same four options available to you: File System, Local IIS, FTP, and Remote Site.

Dosya SistemiFile System

Bu modülde daha önce belirtildiği gibi, Visual Studio artık bir proje dosyası kullanmaz.As indicated previously in this module, Visual Studio no longer uses a project file. Bu nedenle, dosya sisteminden bir Web sitesi açmayı seçerseniz, seçtiğiniz klasör başlangıçta Visual Studio'da bir Web projesi olarak oluşturulmasa bile istediğiniz klasörü seçme seçeneğiniz vardır.Therefore, if you choose to open a Web site from the file system, you actually have the option of choosing any folder that you wish, even if the folder you choose was not created as a Web project initially in Visual Studio. Örneğin, Belgelerim klasörünü Bir Web sitesi olarak açmayı seçebilirsiniz ve Visual Studio bu klasörü mutlu bir şekilde açar ve dosyalarınızı aşağıda gösterildiği gibi görüntüler.For example, you can choose to open the My Documents folder as a Web site and Visual Studio will happily open it and display your files as shown below.

Web Sitesi Olarak Açılan Belgelerim

Şekil 6: Web Sitesi Olarak Açılan BelgelerimFigure 6: My Documents Opened As a Web Site

Visual Studio yalnızca gerektiğinde ek dosya ve klasörler oluşturduğundan, açtığınız konuma ek dosya veya klasör eklenmez.Because Visual Studio only creates additional files and folders when necessary, no additional files or folders are added to the location you open. Bu mimarinin bir yan etkisi, dosya sisteminde Web sitelerini iç içe geçmenizi engellemesidir.A side-effect of this architecture is that it prevents you from nesting Web sites on the file system. Örneğin, aşağıdaki dizin yapısını göz önünde bulundurun.For example, consider the following directory structure.

C:/MyWebSite'de Web projesiWeb project at C:/MyWebSite

C:/MyWebSite/Nested'de başka bir web projesiAnother web project at C:/MyWebSite/Nested

Web sitesini c:/MyWebSite adresinde açtığınızda, İç Içe klasör bu uygulamanın bir alt klasörü olarak görünür.When you open the Web site at c:/MyWebSite, the Nested folder will appear as a sub-folder of that application.

HTTPHTTP

WEB sitelerini HTTP üzerinden açarken ayarlar IIS metatabanından (Yerel IIS) veya FrontPage Server Uzantıları (Uzak Site) kullanılarak okunur. İç içe web uygulamaları varsa, bunlar da onları bir uygulama olarak tanımlayan bir simgeyle görüntülenir.When opening Web sites via HTTP, settings are read either from the IIS metabase (Local IIS) or using FrontPage Server Extensions (Remote Site.) If there are nested web applications, these are displayed as well with an icon identifying them as an application. FrontPage'deki web uygulamalarıyla çalışmaya aşinaysanız, Visual Studio 2005'teki davranış benzerdir.If you are familiar with working with web applications in FrontPage, the behavior in Visual Studio 2005 is similar.

Visual Studio, Şu anda IDE içinde açılan uygulamanın altında iç içe olan uygulamalar için bir simge gösterse de, içeriklerini görmek için genişletmenize izin vermez.Even though Visual Studio will display an icon for applications that are nested beneath the application that is currently opened within the IDE, it will not allow you to expand them to see their content. Ancak, bunları açmak için onlara çift tıklayabilirsiniz.You can, however, double-click on them to open them. Bunu yaptığınızda, web uygulamasını açmanızı (ve şu anda açık olan çözümü değiştirmenizi) veya Web uygulamasını geçerli çözümünüzün yerine eklemenizi isteyen bir iletişim kutusu sunulur.When you do, you will be presented with a dialog prompting you to either open the web application (and replace the currently open solution) or add the Web application to your current solution.

İç içe geçen bir uygulama simgesini çift tıklatma nız size bu iletişim kutusunu sunar

Şekil 7: İç içe geçen bir uygulama simgesine çift tıklayarak bu iletişim kutusunu sunarFigure 7: Double-clicking a nested application icon presents you with this dialog

FTP SitesiFTP Site

FTP ile bir siteyi açtığınızda, dosyaların tümü geçici klasörünüze yerel olarak kopyalanır.When you open a site via FTP, the files are all copied locally to your temp folder. Yerel depolama konumu için tam yol proje için Özellikler bölmesinde görüntülenir ve aşağıdaki biçim kullanılarak oluşturulur.The full path for the local storage location is displayed in the Properties pane for the project and is created using the following format.

C:/Belgeler ve<Ayarlar/ Kullanıcı>/Yerel Ayarlar/Geçici/VWDWebÖnbellek/<Sunucu>/<uygulama adı>C:/Documents and Settings/<User>/Local Settings/Temp/VWDWebCache/<Server>/<application name>

FTP kullanırken Visual Studio'nun projenizin temel URL'sini belirterek aşağıda gösterildiği gibi göz atabilmeniz gerekir.When using FTP, Visual Studio will need to specify the base URL for your project so that you can browse it as shown below. Temel URL belirtmezseniz, Visual Studio web sitesindeki bir sayfaya ilk kez göz atmagirişiminde sizden bunu ister.If you do not specify a base URL, Visual Studio will ask you for it the first time you attempt to browse a page in the Web site.

FTP Siteleri için Temel URL belirtme

Şekil 8: FTP Siteleri için Temel URL belirtmeFigure 8: Specifying a Base URL for FTP Sites

Derlemede GeliştirmelerImprovements in Compilation

Visual Studio 2005'teki Web uygulamalarıyla çalışmak önceki sürümlere göre belirgin derecede daha hızlıdır.Working with Web applications in Visual Studio 2005 is noticeably faster than previous versions. Bunun nedeni derleme mimarisindeki değişikliklerdir.This is due in no small part to the changes in compilation architecture.

Visual Studio 2002 ve 2003'te, Web uygulamaları /bin klasöründe bulunan tek bir birincil derleme de derlenmiştir.In Visual Studio 2002 and 2003, Web applications were compiled into one primary assembly residing in the /bin folder. Visual Studio 2005'te bir App/_Code klasörü eklendi.In Visual Studio 2005, an App/_Code folder was added. Sınıflar ve Diğer Kullanıcı Arabirimi kodu App/_Code klasörüne eklenir.Classes and other non-UI code are added to the App/_Code folder. Visual Studio projeyi oluşturduğunda, App/_Code klasöründeki tüm dosyalar tek bir App/_Code.dll dosyasında derlenir.When Visual Studio builds the project, all files in the App/_Code folder are compiled into a single App/_Code.dll file. Bu değişikliğin sonucu, sonraki yapılar önceki sürümlere göre çok daha hızlı olmasıdır.The result of this change is that subsequent builds are much faster than in previous versions.

Note

MSBuild komut satırı yardımcı programı, web uygulamaları ASP.NET oluşturmak için de kullanılabilir.The MSBuild command line utility can also be used to build ASP.NET Web applications. Bu alet modül 9'da ele alınacaktır.That tool will be covered in module 9.

Başka bir derleme geliştirme, Yapı menüsündeki yeni Yapı Sayfası seçeneğidir.Another compilation enhancement is the new Build Page option on the Build menu. Bu özellik, değişikliklerin daha hızlı derlenebilmeleri için bir geliştiricinin yalnızca geçerli sayfayı (elbette ve bağımlılıklarla birlikte) yeniden oluşturmasına olanak tanır.This feature allows a developer to rebuild only the current page (along with, of course, and dependencies) so that changes can be compiled more quickly. C# IntelliSense, vb güncelleme amacıyla arka plan derleme sunmuyor çünkü intelliSense sadece tek bir sayfa yı kalarak hızlı bir şekilde güncellenmesine olanak sağlayacak, çünkü bu özellikten son derece yararlanacaktır.Because C# does not offer background compilation for purposes of updating IntelliSense, etc., they will benefit immensely from this feature because it will allow for IntelliSense to be updated quickly by simply rebuilding a single page.

Projenin Yapı özellikleri, başlangıç sayfası yürütülmeden önce oluşan yapı türünü yapılandırmanıza olanak sağlar.The Build properties for a project allow you to configure the type of build that occurs before the startup page is executed. Geliştiriciler, Visual Studio'nun kod değişikliklerinden sonra uygulamaları daha hızlı bir şekilde hata ayıklamaya başlayabilmeleri için geçerli sayfayı oluşturmayı seçebilir.Developers can choose to only build the current page so that Visual Studio can start debugging applications more quickly after code changes.

Yapı Sayfası Başlatma Eylemi

Şekil 9: Yapı Sayfası Başlatma EylemiFigure 9: The Build Page Start Action

Visual Studio ve ASP.NET mimarisi için başka büyük geliştirme edit ve devam alanında.Another great enhancement to Visual Studio and the ASP.NET architecture is in the area of edit and continue. Visual Studio 2005'te, geliştiriciler bir projeyi hata ayıklamaya başlayabilir ve hata ayıklayıcıyı ayırmadan projede kod değişiklikleri yapabilir.In Visual Studio 2005, developers can start debugging a project and make code changes on the project without detaching the debugger. Aslında, kelimenin tam anlamıyla bir proje hata ayıklama başlayabilir, yeni bir sınıf eklemek, bu sınıfa kod eklemek, bu sınıfın yeni bir örnek oluşturur ve sınıfın bir yöntem yürütmek sayfanıza kod eklemek, tüm hata ayıklayıcı ayırmadan.In fact, you can literally start debugging a project, add a new class, add code to that class, add code to your page that creates a new instance of that class and execute a method of the class, all without detaching the debugger. Yeni kodu yürütmek tarayıcıyı yenilemek kadar kolaydır!Executing the new code is literally as easy as refreshing the browser!

Visual Studio 2005'te yapılan editin video walkthrough'ını görmek ve devam etmek için buraya tıklayın.Click here to see a video walkthrough of the edit and continue feature in Visual Studio 2005.

Tam Ekran Video AçOpen Full-Screen Video

ASP.NET 2.0 ve Visual Studio 2005'teki sağlam ve devam işlevselliği, ASP.NET uygulamaları için mimari bir değişiklikten kaynaklanmaktadır.The robust edit and continue functionality in ASP.NET 2.0 and Visual Studio 2005 is due to an architectural change for ASP.NET applications. 1.xASP.NET Visual Studio 2002/2003'te oluşturulan uygulamalar /bin klasöründe depolanan bir birincil derleme de derlenmiştir.In ASP.NET 1.x, applications created in Visual Studio 2002/2003 were compiled into a primary assembly that was stored in the /bin folder. Uygulama için tüm sınıflar, sayfalar, vb bu bir DLL içine derlenmiştir.All classes, pages, etc. for the application were compiled into that one DLL. Daha sonra çalışma zamanında, ASP.NET tüm denetimleri, işaretlemeyi ve ASP.NET kodu sayfalar içinde derler ve bu DL'leri ASP.NET geçici klasörüne kopyalar.Then at runtime, ASP.NET would compile all of the controls, markup, and ASP.NET code within pages and copy those DLLs into the ASP.NET temporary folder.

Visual Studio 2005'te ASP.NET 2.0 kullanılarak, yukarıda ana hatolan iki derleme modeli (biri Visual Studio için, diğeri çalışma zamanında ASP.NET için) ortak bir derleme modelinde birleştirilmiştir.In Visual Studio 2005 using ASP.NET 2.0, the two compilation models outline above (one for Visual Studio and one for ASP.NET at runtime) have been merged into one common compilation model. Bu, tüm derleme sorunlarının artık çalışma zamanı yerine geliştirme aşamasında yakalandığı anlamına gelir.That means that all compilation issues are now caught during the development stage instead of at runtime. Ayrıca, kullanıcı denetimleri ve ana sayfalar gibi özellikler için tasarımcı ve IntelliSense desteğine de olanak tanır.It also allows for designer and IntelliSense support for features such as user controls and master pages.

Kullanıcı denetimleri için tasarımcı desteğinin video walkthrough görmek için buraya tıklayın.Click here to see a video walkthrough of designer support for user controls.

Tam Ekran Video AçOpen Full-Screen Video

Note

Bir kullanıcı denetimi bir sayfadan @Register kaldırıldığında, kullanıcı denetimi Web sitesinden silinirse ayrıştırıcı hatalarını önlemek için yönerge biçimlendirmede kalır ve el ile kaldırılmalıdır.When a user control is removed from a page, the @Register directive remains in the markup and should be removed manually in order to avoid parser errors if the user control is deleted from the Web site.

Visual Studio derleme modelindeki bir diğer gelişme de Web Sitesini Yayımla özelliğidir.Another improvement in the Visual Studio compilation model is the Publish Web Site feature. Yayımlama özelliği Web sitesini önceden derlediği için, geliştiriciler isteğe bağlı olarak hiçbir şey derlemek zorunda kalmamanın ek performansından yararlanabilir.Because the Publish feature precompiles the Web site, developers can enjoy the added performance of not having to compile anything on demand. Ayrıca, kaynak kodunun dağıtılması gerekmesin diye App/_Code klasöründeki tüm kaynak kodlarını dll olarak önceden derler.It also precompiles all source code in the App/_Code folder into a DLL so that no source code has to be deployed.

Web Sitesi Yayımla İletişim

Şekil 10: Web Sitesi Yayınla Iletişim KutusuFigure 10: The Publish Web Site Dialog

Note

aspnet/_compile.exe yardımcı programı, ASP.NET bir Web uygulamasını önceden derlemek için de kullanılabilir.The aspnet/_compile.exe utility can also be used to pre-compile an ASP.NET Web application. Bu alet modül 9'da ele alınacaktır.That tool will be covered in module 9.

Bir Web sitesi yayımladığınızda, önceden derlenmiş dosyalar aşağıda gösterildiği gibi Geçici ASP.NET Dosyaları klasöründe depolanır.When you Publish a Web site, the precompiled files are stored in the Temporary ASP.NET Files folder as shown below. .derlenmiş dosya uzantısı olan dosyalar, belirli DL'ler için bağımlılıkları tanımlayan XML dosyalarıdır.Files with a .compiled file extension are XML files that define dependencies for particular DLLs. Herhangi bir Webform veya kullanıcı denetimleri App / Web/ ile başlayan rasgele DLs içine derlenir.Any Webform or user controls are compiled into random DLLs that begin with App/Web/.

Önceden derlenmiş bu siteyi güncellenebilir onay kutusu olarak bırakırsanız, Webformlarınızın ve kullanıcı denetimlerinizin içindeki biçimlendirme, dağıtımdan sonra değişiklik yapmanıza olanak tanıyan bir DLL'ye önceden derlenmez.If you leave the Allow this precompiled site to be updatable checkbox checked, markup inside of your Webforms and user controls will not be pre-compiled into a DLL allowing you to make changes after deployment. Dağıtılan içeriğe izin verilmemesi için işaretlemeyi kilitlemeyi tercih ederseniz, bu kutunun işaretini kaldırın.If you would prefer to lock down the markup so that changes to the deployed content are not allowed, uncheck this box.

Sabit adlandırma ve tek sayfa derlemelerini kullan onay kutusu, her sayfanın sabit adlandırılmış bir derlemede derlenmesine olanak sağlayacak toplu toplu derlemeyi devre dışı bırakmanızı sağlar.The Use fixed naming and single page assemblies checkbox allows you to disable batch compilation so that each page is compiled into a fixed-named assembly. Bu kutuyu işaretsiz bırakmak toplu toplu derlemeden yararlanmanızı sağlar.Leaving this box unchecked allows you to take advantage of batch compilation.

Önceden derlenmiş derlemeler onay kutusunda güçlü adlandırmayı etkinleştir, önceden derlenmiş derlemelerinizi güçlü bir şekilde adlandırmanızı sağlar.The Enable strong naming on precompiled assemblies checkbox allows you to strong-name your precompiled assemblies.

Note

1.xASP.NET, güçlü adlandırılmış derlemelerin Küresel Derleme Önbelleğine (GAC) yüklenmesi gerekiyordu.In ASP.NET 1.x, strong-named assemblies had to be installed into the Global Assembly Cache (GAC). 2.0ASP.NET, GAC'ye güçlü adlandırılmış derlemeler yüklemeniz gerekmez.In ASP.NET 2.0, you are not required to install strong-named assemblies into the GAC.

Bir ASP.NET Uygulamaları Önceden Derlenmiş Dosyalar

Şekil 11: Bir ASP.NET Uygulamaları Önceden Derlenmiş DosyalarFigure 11: An ASP.NET Applications Pre-Compiled Files

Note

Yukarıdaki uygulamada, hiçbir web.config dosyası vardı.In the application above, there was no web.config file. Olsaydı, Web sitesi yayınlama işleminden sonra PrecompiledApp.config olarak adlandırılacaktı.If there had been, it would have been called PrecompiledApp.config after the Publish Web site process.

Dağıtımdaki GeliştirmelerImprovements in Deployment

Visual Studio 2002 ve 2003'te olduğu gibi Visual Studio 2005, Copy Project özelliği ni sunuyor.As with Visual Studio 2002 and 2003, Visual Studio 2005 offers a Copy Project feature. Ancak, özellik Visual Studio 2005 yılında güçlendirilmiş ve şimdi Copy Web Sitesi denir.However, the feature has been beefed up in Visual Studio 2005 and is now called Copy Web Site.

Web Sitesini Kopyala iletişim kutusu sol çerçeveye ve sağ çerçeveye bölünür.The Copy Web Site dialog is split into a left frame and a right frame. Sol çerçeveye Kaynak Web Sitesi, sağ çerçeveye uzak web sitesi denir.The left frame is called the Source Web Site and the right frame is called the Remote Web Site. Bazı geliştiricilerin kafasını karıştırabilecek bir şey, doğru çerçevede görüntülenen sitenin mutlaka uzak bir site olmamasıdır.One thing that may confuse some developers is that the site displayed in the right frame is not necessarily a remote site. Yerel dosya sisteminde veya IIS'nin yerel örneğinde bir site olabilir.It could be a site on the local file system or on the local instance of IIS. Ayrıca, iletişim kutusu uzak Web sitesinden kaynak Web sitesine yayımlamanızı sağladığından, sol çerçevede görüntülenen site mutlaka kaynak Web sitesi değildir.Additionally, the site displayed in the left frame is not necessarily the source Web site because the dialog allows you to publish from the remote Web site to the source Web site.

Bir projeyi uzak bir Web sitesine kopyalıyorsanız, bu sitenin üzerinde FrontPage Server Uzantıları yüklü olmalıdır.If you are copying a project to a remote Web site, that site must have the FrontPage Server Extensions installed on it. Değilse, FTP kullanarak bağlanmanız gerekir.If it does not, you will need to connect using FTP. Diğer taraftan, bir projeyi yerel IIS örneğine kopyalıyorsanız, FrontPage Sunucu Uzantıları gerekmez.On the other hand, if you are copying a project to the local IIS instance, FrontPage Server Extensions are not required.

Note

Yerel IIS örneğinde yeni bir Web sitesi oluşturmaya çalışırsanız ve FrontPage 2002 Sunucu Uzantıları yüklenirse, Web sitesi oluşturmanın Bir SharePoint sunucusunda desteklenmediğini belirten bir hata iletisi alırsınız.If you try to create a new Web site on the local IIS instance and the FrontPage 2002 Server Extensions are installed, you will get an error message telling you that creating Web sites is not supported on a SharePoint server. Bu durumda, FrontPage 2000 Sunucu Uzantılarını yükleme veya FrontPage Sunucu Uzantılarını kaldırma seçeneğiniz vardır.In that case, you have the option of installing the FrontPage 2000 Server Extensions or removing the FrontPage Server Extensions.

Web Sitesini Kopyala özelliğinin video bölümü için buraya tıklayın.Click here for a video walkthrough of the Copy Web Site feature.

Tam Ekran Video AçOpen Full-Screen Video

Hata Ayıklamada GeliştirmelerImprovements in Debugging

Visual Studio 2005'te hata ayıklamada dört önemli gelişme vardır.There are four key improvements in debugging in Visual Studio 2005.

  • Yönetici olmayan biri olarak yerel olarak hata ayıklama kutudan çıkmak mümkündür.Debugging locally as a non-administrator is possible out of the box.
  • Derleme öğesi için Hata Ayıklama özniteliği artık varsayılan olarak yanlıştır.The Debug attribute for the Compilation element is now false by default.
  • Uzaktan hata ayıklama kurulumu ve yapılandırması eskisinden daha kolaydır.Remote debugging setup and configuration is easier than before.
  • Artık FTP konumu üzerinden açılan bir Web sitesini hata ayıklayabilirsiniz.You can now debug a Web site opened via an FTP location.

Yönetici Olmayan Olarak Hata AyıklamaDebugging as a Non-Administrator

ASP.NET Geliştirme Sunucusu'nun eklenmesi, yönetici olmayanların ASP.NET uygulamaları kolayca kutudan çıkarmalarına olanak tanır.The addition of the ASP.NET Development Server allows non-administrators to easily debug ASP.NET applications right out of the box. Yerel dosya sisteminde çalışan bir ASP.NET uygulaması debugged olduğunda, Visual Studio oturum açmış kullanıcı bağlamında ASP.NET Geliştirme Sunucusu başlattı.When an ASP.NET application running on the local file system is debugged, Visual Studio launches the ASP.NET Development Server under the context of the logged-on user. Bu kullanıcı daha sonra herhangi bir ek yapılandırma olmadan bu uygulamayı hata ayıklama olabilir.That user can then debug that application without any additional configuration.

Hata Ayıklama Varsayılan Olarak FalseDebug is False by Default

1.xASP.NETde, web.config dosyasının derleme öğesindeki hata ayıklama özniteliği varsayılan olarak doğru olarak ayarlanmıştır.In ASP.NET 1.x, the debug attribute in the compilation element of the web.config file was set to true by default. Geliştiricilerin bir uygulamayı üretime dağıtmadan önce bu özniteliği yanlış olarak ayarlamaları her zaman önerilmiştir, ancak çoğu geliştirici hata ayıklama özniteliğini doğru bırakmanın sonuçlarını tam olarak anlamadığından, yalnızca olduğu gibi bıraktılar.It has always been recommended that developers set this attribute to false before deploying an application to production, but because most developers don't fully understand the consequences of leaving the debug attribute set to true, they simply left it as-is.

Hata ayıklama özniteliğinin doğru olarak ayarlanmasındaki en ciddi sorun, ASP.NETs toplu derleme modelini devre dışı bırakmasın.The most severe problem with having the debug attribute set to true is that it disables ASP.NETs batch compilation model. Bu nedenle, her sayfa ayrı bir DLL içine derlenir.Therefore, each page is compiled into a separate DLL. Bir Web uygulaması binlerce sayfadan oluşuyorsa (hiçbir şekilde duyulmamış değil), bu uygulama tarafından birkaç bin küçük LL'nin oluşturulacağı anlamına gelir.If a Web application consists of thousands of pages (not unheard of by any means), that means several thousand small DLLs will be created by that application. Bu DL'ler boyutu küçük olsa da, bellekte belirli bir konuma yüklenmez.While these DLLs are small in size, they are not loaded into any particular location in memory. Bu nedenle, sistem belleğinde parçalanmaya neden olur lar ve OutOfMemoryException oluşumlarına katkıda bulunabilirler.Therefore, they cause fragmentation in system memory and can contribute to OutOfMemoryException occurrences.

2.0ASP.NET hata ayıklama özniteliği varsayılan olarak false olarak ayarlanır.In ASP.NET 2.0, the debug attribute is set to false by default. Daha önce de gördüğünüz gibi, bir geliştirici Visual Studio 2005'te bir ASP.NET uygulamasını bozduğunda, hata ayıklama etkin leştirilmiş bir web.config dosyası eklemeleri istenir.As you have already seen, when a developer debugs an ASP.NET application in Visual Studio 2005, they are prompted to add a web.config file with debugging enabled. Bunu yapmak, ASP.NET 1.x'te bulunan aynı sakıncalara neden olur, ancak şimdi geliştirici, uygulamayı üretime taşımadan önce özniteliğin yanlışa sıfırlandığı konusunda açıkça uyarılır.Doing so incurs the same drawbacks that were present in ASP.NET 1.x, but now the developer is clearly warned that the attribute should be reset to false before moving the application to production.

Uzaktan Hata Ayıklama Kurulumu ve YapılandırmasıRemote Debugging Setup and Configuration

Visual Studio 2002/2003'te uzaktan hata ayıklama Makine Hata Ayıklama Yöneticisi (mdm.exe) ve vs7jit.exe sürecine dayanıyordu.In Visual Studio 2002/2003, remote debugging relied on the Machine Debug Manager (mdm.exe) and the vs7jit.exe process. Bu nedenle, uzaktan hata ayıklama sorunları sorun giderme genellikle müşteriler için bir kara kutu oldu ve genellikle PSS için çok daha iyi değildi.Because of that, troubleshooting remote debugging problems was often a black box for customers and it was often not much better for PSS.

Visual Studio 2005 mdm.exe ve vs7jit.exe süreçlerine olan güveni ortadan kaldırır.Visual Studio 2005 removes the reliance on the mdm.exe and vs7jit.exe processes. Bunun yerine, şimdi Uzaktan Hata Ayıklama Monitörü hizmetini kullanır (msvsmon.exe.)Instead, it now uses the Remote Debug Monitor service (msvsmon.exe.)

Visual Studio 2005'te hata ayıklama gereksinimi oldukça basittir.The requirement for debugging in Visual Studio 2005 remotely is quite simple. Hata ayıklama dan önce uzak sunucuda msvsmon.exe çalıştırmak gerekir.You need to run msvsmon.exe on the remote server prior to debugging. Uzaktan Hata Ayıklama Monitörünü Visual Studio CD'sinden yükleyebilir veya Web sunucusuna hiçbir şey yüklemeden msvsmon.exe'yi bir paylaşımdan çalıştırabilirsiniz.You can install the Remote Debug Monitor from the Visual Studio CD or you can simply run msvsmon.exe from a share without installing anything at all on the Web server.

msvsmon.exe çalıştırdığınızda, uzak hata ayıklama için bloke olan bağlantı noktaları hakkında şikayet olasıdır.When you run msvsmon.exe, it is likely that it will complain about ports being blocked for remote debugging. Neyse ki, aşağıda gösterildiği gibi uyarı iletişim kutusundaki bağlantı noktalarını kolayca kaldırabilirsiniz.Fortunately, you can easily unblock the ports from right within the warning dialog as shown below.

Windows Güvenlik Duvarı'nın Uzaktan Hata Ayıklama'yı Engellediğini Bildiren Bildirim

Şekil 12: Windows Güvenlik Duvarı'nın Uzaktan Hata Ayıklama'yı EngellediğiniN BildirilmesiFigure 12: Notification that Windows Firewall is Blocking Remote Debugging

Hata ayıklama için gerekli bağlantı noktalarını kaldırdıktan sonra, aşağıda gösterildiği gibi Uzaktan Hata Ayıklama Monitörü'nün de liğini görürsünüz.Once you have unblocked the ports necessary for debugging, you will see the Remote Debugging Monitor as shown below. Bu arabirimden bağlantıları izleyebilir ve hata ayıklama izinlerini kolayca değiştirebilirsiniz.From this interface, you can monitor connections and change debugging permissions easily.

Uzaktan Hata Ayıklama Monitörü

Şekil 13: Uzaktan Hata Ayıklama MonitörüFigure 13: The Remote Debugging Monitor

FTP üzerinden açılan bir Web uygulamasını uzaktan hata ayıklamak da mümkündür.It is also possible to remotely debug a Web application opened via FTP. Adımlar, daha önce kapsananlarla aynıdır.The steps are the same as those previously covered. Ancak, ftp projesinde daha önce belirtildiği gibi göz atmak için bir temel URL belirtmeniz gerekir.However, you will need to specify a base URL for browsing the FTP project as outlined earlier in this module.

Laboratuvar 2Lab 2

Visual Studio 2005 ile Uzaktan Hata AyıklamaRemote Debugging with Visual Studio 2005

Bu laboratuvar Visual Studio 2005 ile uzaktan hata ayıklama size yol verecektir.This lab will walk you through remote debugging with Visual Studio 2005.

Bu laboratuvarın video bölümü için buraya tıklayın.Click here for a video walkthrough of this lab.

Tam Ekran Video AçOpen Full-Screen Video

Bu laboratuvar, biri Visual Studio 2005'i, diğeri de IIS 5 veya daha büyük çalışan iki makineye sahip olmayı gerektirir.This lab requires you to have two machines, one running Visual Studio 2005 and the other running IIS 5 or greater.

  1. Visual Studio 2005'i açın ve uzak sunucuda yeni bir Web sitesi oluşturun.Open Visual Studio 2005 and create a new Web site on the remote server.

Note

Web sitesini uzak bir IIS örneğinde veya FTP aracılığıyla oluşturabilirsiniz.You can create the Web site on a remote IIS instance or via FTP.

  1. Uzak Web sunucusundan, bir UNC yolunu kullanarak geliştirme makinesinde msvsmon.exe'yi bulun ve çalıştırın.From the remote Web server, locate msvsmon.exe on the development machine using a UNC path and execute it.
    msvsmon.exe için varsayılan konum //server/c$/Program Files/Microsoft Visual Studio 8/Common7/IDE/Remote Debugger/x86'dır.The default location for msvsmon.exe is //server/c$/Program Files/Microsoft Visual Studio 8/Common7/IDE/Remote Debugger/x86.
  2. Uzaktan hata ayıklama için bağlantı noktalarının engelini kaldırması istenirse, bunu yapın.If prompted to unblock ports for remote debugging, do so.
  3. Geliştirme makinesinden Default.aspx için kodu niçin açın ve Sayfa/_Load yönteminde bir kesme noktası ayarlayın.From the development machine, open the code-behind for Default.aspx and set a breakpoint in the Page/_Load method.
  4. Geliştirme makinesinden hata ayıklamaya başlayın.Start debugging from the development machine.

Beklendiği gibi kırılma noktasına ulaşmalısın.You should hit the breakpoint as expected.

ASP.NET Geliştirme SunucusuASP.NET Development Server

Daha önce de tartıştığımız gibi, Visual Studio 2005 ASP.NET Development Server adlı bir Web sunucusu ile gemi.As we've already discussed, Visual Studio 2005 ships with a Web server called the ASP.NET Development Server. (ASP.NET Geliştirme Sunucusu bazen Cassini olarak adlandırılır.) Bu Web sunucusu, dosya sisteminde çalışan Web uygulamalarına göz atmak ve hata ayıklamak için kullanışlı bir araçtır.(The ASP.NET Development Server is sometimes referred to as Cassini.) This Web server is a convenient means to browse and debug Web applications running on the file system.

ASP.NET Geliştirme Sunucusu kısıtlı bir Web sunucusudur.The ASP.NET Development Server is a restricted Web server. Uzaktan bağlantılara izin vermez, Web sunucusunu başlatan kullanıcı dışında herhangi bir kullanıcıdan gelen isteklere izin vermez.It does not allow remote connections, it does not allow any requests from any user other than the user who started the Web server. Ayrıca ASP sayfaları sunma özelliğine de sahip değildir.It also does not have the capability of serving ASP pages. Yalnızca ASP.NET kaynakları ve HTML kaynakları (resimler, CSS dosyaları, vb. dahil) sunulmaktadır.Only ASP.NET resources and HTML resources (including images, CSS files, etc.) are served.

ASP.NET Geliştirme Sunucusu komut satırı üzerinden c:/Windows/Microsoft.NET/Framework/v2.0./////*adresinde bulunan WebDev.WebServer.exe dosyasını çalıştırarak başlatılabilir.The ASP.NET Development Server can be launched via the command line by running the WebDev.WebServer.exe file located at c:/Windows/Microsoft.NET/Framework/v2.0./////*. Aşağıdaki iletişim kutusu, kullanılabilir parametreleri görüntüler.The following dialog displays the parameters that are available.

Şekil 14Figure 14

Note

ASP.NET Geliştirme Sunucusu komut satırı üzerinden açıkça başlatıldığında desteklenmez.The ASP.NET Development Server is not supported when launched explicitly via the command line.