ExpressRoute üzerinden BFD yapılandırınConfigure BFD over ExpressRoute

ExpressRoute, hem özel hem de Microsoft eşlemesi üzerinden çift yönlü Iletme algılamayı (BFD) destekler.ExpressRoute supports Bidirectional Forwarding Detection (BFD) both over private and Microsoft peering. ExpressRoute üzerinde BFD 'yi etkinleştirerek, Microsoft Enterprise Edge (MSEE) cihazları ile ExpressRoute devresini (CE/PE) sonlandıran yönlendiriciler arasında bağlantı hatası algılamayı yönlendirebilirsiniz.By enabling BFD over ExpressRoute, you can expedite link failure detection between Microsoft Enterprise edge (MSEE) devices and the routers on which you terminate the ExpressRoute circuit (CE/PE). (Yönetilen Katman 3 bağlantısı hizmetiyle gittiyse) müşteri Edge'i yönlendirme cihazları veya iş ortağı uç yönlendirme cihazları üzerinden ExpressRoute sonlandırabilirsiniz.You can terminate ExpressRoute over Customer Edge routing devices or Partner Edge routing devices (if you went with managed Layer 3 connection service). Bu belge ihtiyacını BFD ve ExpressRoute üzerinden BFD etkinleştirme konusunda size kılavuzluk eder.This document walks you through the need for BFD, and how to enable BFD over ExpressRoute.

BFD gereksiniminiNeed for BFD

ExpressRoute bağlantı hattı üzerinden BFD etkinleştirme avantajı Aşağıdaki diyagramda gösterilmiştir: 1The following diagram shows the benefit of enabling BFD over ExpressRoute circuit: 1

Yönetilen Katman 3 bağlantılarını veya ExpressRoute bağlantı hattı Katman 2 bağlantıları ya da etkinleştirebilirsiniz.You can enable ExpressRoute circuit either by Layer 2 connections or managed Layer 3 connections. ExpressRoute bağlantı yolunda bir veya daha fazla katman 2 cihazlar varsa her iki durumda da, üstteki BGP ile bağlantı hataları algılama yolu sorumluluğunu arasındadır.In either case, if there are one or more Layer-2 devices in the ExpressRoute connection path, responsibility of detecting any link failures in the path lies with the overlying BGP.

MSEE cihazlarda BGP keepalive ve durma süresini genellikle 60-180 saniye sırasıyla yapılandırılır.On the MSEE devices, BGP keepalive and hold-time are typically configured as 60 and 180 seconds respectively. Bu nedenle, en fazla götürecek bir bağlantı hatası algılamak için üç dakika bağlantı hatası ve alternatif bağlantı trafiğini geçin.Therefore, following a link failure it would take up to three minutes to detect any link failure and switch traffic to alternate connection.

Müşteri sınır eşleme cihazı daha düşük BGP keepalive ve durma süresini yapılandırarak BGP zamanlayıcılar kontrol edebilirsiniz.You can control the BGP timers by configuring lower BGP keepalive and hold-time on the customer edge peering device. İki eşleme cihazlar arasında BGP zamanlayıcılar eşleşirse, eşler arasında BGP oturumu alt zamanlayıcı değeri kullanırsınız.If the BGP timers are mismatched between the two peering devices, the BGP session between the peers would use the lower timer value. BGP keepalive üç saniye ve onlarca saniye sırasına göre Durma süresini olabildiğince düşük olarak ayarlanabilir.The BGP keepalive can be set as low as three seconds, and the hold-time in the order of tens of seconds. Ancak, protokol işlem yoğun olduğundan BGP zamanlayıcıları kararlılığı daha az tercih edilir.However, setting BGP timers aggressively is less preferable because the protocol is process intensive.

Bu senaryoda BFD yardımcı olabilir.In this scenario, BFD can help. BFD subsecond zaman aralığındaki düşük ek yük bağlantı hatası algılama sağlar.BFD provides low-overhead link failure detection in a subsecond time interval.

BFD etkinleştirmeEnabling BFD

Varsayılan olarak tüm yeni oluşturulan ExpressRoute özel eşlemesi arabirimlerde Msee'ler altında BFD yapılandırılır.BFD is configured by default under all the newly created ExpressRoute private peering interfaces on the MSEEs. Bu nedenle BFD 'yi etkinleştirmek için, her ikisi de her ikisi de (hem birincil hem de ikincil cihazlarınızda) BFD 'yi yapılandırmanız gerekir.Therefore, to enable BFD, you need to just configure BFD on your CEs/PEs (both on your primary and secondary devices). BFD 'nin yapılandırması iki adımlı bir işlemdir: arabirimdeki BFD 'yi yapılandırmanız ve ardından BGP oturumuna bağlamanız gerekir.Configuring BFD is two-step process: you need to configure the BFD on the interface and then link it to the BGP session.

Örnek bir CE/PE (Cisco IOS XE kullanılarak) yapılandırma aşağıda gösterilmiştir.An example CE/PE (using Cisco IOS XE) configuration is shown below.

interface TenGigabitEthernet2/0/0.150
  description private peering to Azure
  encapsulation dot1Q 15 second-dot1q 150
  ip vrf forwarding 15
  ip address 192.168.15.17 255.255.255.252
  bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
  address-family ipv4 vrf 15
    network 10.1.15.0 mask 255.255.255.128
    neighbor 192.168.15.18 remote-as 12076
    neighbor 192.168.15.18 fall-over bfd
    neighbor 192.168.15.18 activate
    neighbor 192.168.15.18 soft-reconfiguration inbound
  exit-address-family

Not

Bir mevcut özel eşdüzey hizmet sağlama altında BFD etkinleştirmek için; eşleme sıfırlamak gerekir.To enable BFD under an already existing private peering; you need to reset the peering. Bkz. ExpressRoute eşayarlarını sıfırlamaSee Reset ExpressRoute peerings

BFD Zamanlayıcı anlaşmasıBFD Timer Negotiation

BFD eşleri arasında iki eş daha yavaş aktarım hızını belirler.Between BFD peers, the slower of the two peers determine the transmission rate. Msee BFD aktarım/alma aralıkları 300 milisaniye olarak ayarlanır.MSEEs BFD transmission/receive intervals are set to 300 milliseconds. Belirli senaryolarda aralığı 750 milisaniye olarak daha yüksek bir değer ayarlanabilir.In certain scenarios, the interval may be set at a higher value of 750 milliseconds. Yüksek değerler yapılandırarak, daha uzun olacak şekilde Bu aralıklar zorunlu kılabilirsiniz; Ancak, daha kısa değil.By configuring higher values, you can force these intervals to be longer; but, not shorter.

Not

Coğrafi olarak yedekli ExpressRoute devreleri yapılandırdıysanız veya yedekleme olarak siteden siteye IPSec VPN bağlantısı kullanıyorsanız; BFD 'nin etkinleştirilmesi ExpressRoute bağlantı hatasından sonra hızlı bir şekilde yük devretmeye yardımcı olur.If you have configured Geo-redundant ExpressRoute circuits or use Site-to-Site IPSec VPN connectivity as backup; enabling BFD would help failover quicker following an ExpressRoute connectivity failure.

Sonraki AdımlarNext Steps

Daha fazla bilgi veya Yardım için aşağıdaki bağlantıları kontrol edin:For more information or help, check out the following links: