Sık Azure Front Door sorunları giderme

Bu makalede, uygulama yapılandırmanız için karşılaşabilirsiniz yaygın yönlendirme sorunlarının nasıl Azure Front Door açıklanmıştır.

Ek hata ayıklama HTTP üst bilgileri

Ek hata ayıklama FRONT DOOR http yanıt üst bilgileri geri dönmek için istekte bulundurabilirsiniz. Diğer ayrıntılar için isteğe bağlı yanıt üst bilgilerine bakın.

Birkaç saniye sonra Azure Front Door 503 yanıtı

Belirti

  • Arka ucunıza gönderilen normal istekler Azure Front Door başarılı oluyor. Bu Azure Front Door 503 hata yanıtıyla sonuçlandı.
  • Hatanın başarısız Azure Front Door genellikle yaklaşık 30 saniye sonra gösterir.
  • günlüğünde aralıklı 503 ErrorInfo: OriginInvalidResponse hataları.

Nedeni

Bu sorunun nedeni şu üç durumdan biri olabilir:

  • Kaynağınız, istekten isteği almak için yapılandırılan zaman aşımı süresinden (varsayılan değer 30 saniyedir) daha uzun Azure Front Door.
  • İstekten yanıt göndermek için gereken süre Azure Front Door zaman aşımı değerinden uzun sürer.
  • İstemci ile bir byte aralık isteği gönderdi Accept-Encoding header (sıkıştırma etkin).

Sorun giderme adımları

  • İsteği doğrudan arka ucunıza gönderin (Azure Front Door). Arka ucun genellikle ne kadar süreyle yanıt vermesi olduğunu görme.

  • İsteği Azure Front Door gönder ve 503 yanıtı alıp almamaya bakın. Yoksa, sorun bir zaman aşımı sorunu olabilir. Desteğe başvurun.

  • Bu bağlantıdan Azure Front Door 503 hata yanıtı koduyla sonuçlandısa uç nokta için Kaynak yanıt zaman aşımını (saniye olarak) yapılandırabilirsiniz. Varsayılan zaman aşımını 4 dakikaya (240 saniye) kadar uzatabilirsiniz. Bu ayar, Uç Nokta yöneticisine gidip Uç noktayı düzenle seçerek yalıtabilirsiniz.

    Uç nokta yöneticisinden uç noktayı düzenle seçeneğinin ekran görüntüsü.

    Ardından Uç nokta özelliklerini seçerek Kaynak yanıt zaman aşımını yapılandırabilirsiniz:

    Uç nokta özelliklerini ve Kaynak yanıtı zaman aşımı alanını seçme ekran görüntüsü.

  • Zaman aşımı sorunu çözmezse Fiddler veya tarayıcınızın geliştirici aracı gibi bir araç kullanarak istemcinin Accept-Encoding üst bilgileriyle byte aralık istekleri göndererek kaynağın farklı içerik uzunluklarında yanıt vermesini s gerektirmektedir. Yanıt evet ise, Kaynak/Kaynak/Azure Front Door sıkıştırmayı devre dışı bırakarak veya bir Kural Kümesi kuralı oluşturarak accept-encoding byte aralığı isteklerinin isteğinden kaldırılır.

    Kural Kümesinde kodlamayı kabul etme kuralının ekran görüntüsü.

Özel etki alanına gönderilen istekler 400 durum kodu geri döner

Belirti

  • Bir örnek Azure Front Door ama etki alanına veya ön uç ana bilgisayarlarına yönelik bir istek HTTP 400 durum kodu döndürecek.
  • Yapılandırmış olduğunu ön uç ana bilgisayar ile özel etki alanı için bir DNS eşlemesi oluşturamadınız. Ancak, özel etki alanı ana bilgisayar adına istek göndermek bir HTTP 400 durum kodu döndürür. Yapılandırmış olduğu arka end'e yönlendirecek gibi görünmüyor.

Nedeni

Ön uç ana bilgisayarı olarak eklenen özel etki alanı için bir yönlendirme kuralı yapılandırmadısanız sorun oluşur. Bu ön uç ana bilgisayarı için açıkça bir yönlendirme kuralı eklenmiştir. Bu, Azure Front Door alt etki alanı (*.azurefd.net) altında ön uç ana bilgisayarı için zaten bir yönlendirme kuralı yapılandırılmış olsa bile bu azurefd.net.

Sorun giderme adımları

Trafiği seçilen kaynak grubuna yönlendirmesi için özel etki alanı için bir yönlendirme kuralı ekleyin.

Azure Front Door HTTP'yi HTTPS'ye yönlendirmez

Belirti

Azure Front Door HTTP'yi HTTPS'ye yönlendiren bir yönlendirme kuralı vardır, ancak etki alanına erişim yine de protokol olarak HTTP'yi sürdürür.

Nedeni

Bu davranış, Azure Front Door için yönlendirme kurallarını doğru yapılandırmadısanız Azure Front Door. Temel olarak, geçerli yapılandırmanız belirli değil ve çakışan kurallara sahip olabilir.

Sorun giderme adımları

Ön uç ana bilgisayar adına yapılan istek 411 durum kodu döndürür

Belirti

Azure Front Door Standard/Premium örneği oluşturduktan sonra bir ön uç ana bilgisayarı, en az bir çıkış noktası olan bir kaynak grubu ve ön uç ana bilgisayarını kaynak grubuna bağlayan bir yönlendirme kuralı yapılandırmış olduktan sonra. HTTP 411 durum kodu döndürüldü diye yapılandırılmış ön uç ana bilgisayarlarına bir istek geldiğinde içeriğiniz kullanılamıyor gibi görünüyor.

Bu isteklere verilen yanıtlar, yanıt gövdesinde açıklayıcı bir deyim içeren bir HTML hata sayfası da içerebilir. Örneğin: HTTP Error 411. The request must be chunked or have a content length.

Nedeni

Bu belirtilerin birkaç olası nedeni vardır. Bunun genel nedeni, HTTP isteğinizin tam olarak RFC uyumlu olmasıdır.

Bir veya üst bilgisi (örneğin, kullanarak) olmadan gönderilen bir istek, bir yetersizlik POST Content-Length Transfer-Encoding curl -X POST https://example-front-door.domain.com örneğidir. Bu istek, RFC 7230'da ayarlanmış gereksinimleri karşılamaz. Azure Front Door HTTP 411 yanıtıyla engellenmiş olur.

Bu davranış, uygulamanın Web Uygulaması Güvenlik Duvarı (WAF) işlevinden Azure Front Door. Şu anda bu davranışı devre dışı bırakmanın hiçbir yolu yoktur. WAF işlevselliği kullanımda değilse bile tüm HTTP isteklerinin gereksinimleri karşılaması gerekir.

Sorun giderme adımları

  • İsteklerinizi, gerekli RFC'lerde ayarlanmış gereksinimlerle uyumlu olduğunu doğrulayın.

  • İsteğinize yanıt olarak döndürülen tüm HTML ileti gövdelerini not edin. İleti gövdesi genellikle isteğinizin tam olarak nasıl yetersiz olduğunu açıklar.

Sonraki adımlar