Senaryo: Azure HDInsight 'ta bağlantı sıfırlandıktan sonra depolama özel durumu

Bu makalede, Azure HDInsight kümeleriyle etkileşim kurarken sorun giderme adımları ve olası çözümleri açıklanmaktadır.

Sorun

Yeni Apache HBase tablosu oluşturulamıyor.

Nedeni

Bir tablo kesme işlemi sırasında, bir depolama bağlantı sorunu oluştu. Tablo girdisi HBase meta veri tablosu 'nda silindi. Yalnızca bir blob dosyası silindi.

/hbase/data/default/ThatTableDepolama alanında oturmuş bir klasör blobu yoktu. Bu sürücü, yukarıdaki blob dosyasının varlığını buldu ve /hbase/data/default/ThatTable üst klasörlerin var olduğunu varsaydığı için adlı blob oluşturmaya izin vermiyor, bu nedenle tablo oluşturma başarısız olur.

Çözüm

  1. Apache ambarı kullanıcı arabiriminden, etkin HMaster ' ı yeniden başlatın. Bu, iki bekleme modundan birinin etkin hale gelmesine izin verir ve yeni etkin HMaster, meta veri tablosu bilgilerini yeniden yükler. Bu nedenle, already-deleted tabloyu HMaster Kullanıcı arabiriminde görmezsiniz.

  2. Artık blob dosyasını Cloud Explorer gibi kullanıcı arabirimi araçlarından veya gibi çalışan bir komutla bulabilirsiniz hdfs dfs -ls /xxxxxx/yyyyy . hdfs dfs -rmr /xxxxx/yyyyBu blobu silmek için ' i çalıştırın. Örneğin, hdfs dfs -rmr /hbase/data/default/ThatTable/ThatFile.

Artık HBase 'de aynı ada sahip yeni bir tablo oluşturabilirsiniz.

Sonraki adımlar

Sorununuzu görmüyorsanız veya sorununuzu çözemediyseniz, daha fazla destek için aşağıdaki kanallardan birini ziyaret edin:

  • Azure topluluk desteğiaracılığıyla Azure uzmanlarından yanıt alın.

  • @AzureSupportMüşteri deneyimini iyileştirmek için resmi Microsoft Azure hesabına bağlanın. Azure Community 'yi doğru kaynaklara bağlama: yanıtlar, destek ve uzmanlar.

  • Daha fazla yardıma ihtiyacınız varsa Azure Portalbir destek isteği gönderebilirsiniz. Menü çubuğundan destek ' i seçin veya Yardım + Destek hub 'ını açın. Daha ayrıntılı bilgi için Azure destek isteği oluşturmakonusunu inceleyin. Abonelik yönetimi ve faturalandırma desteği 'ne erişim Microsoft Azure aboneliğinize dahildir ve Azure destek planlarındanbiri aracılığıyla teknik destek sağlanır.