Visual Studio'da C++ kodlama tercihlerinizi ayarlayınSet your C++ coding preferences in Visual Studio

Visual Studio'yı kişiselleştirerek C++ kodlama deneyiminizi daha kullanışlı, üretken ve keyifli hale getirebilirsiniz.You can make your C++ coding experience more convenient, productive, and pleasurable by personalizing Visual Studio. Şunları yapabilirsiniz:You can:

  • Menüleri ve araç çubuklarını özelleştirin.Customize the menus and toolbars.
  • Pencere düzenini düzenleyin.Arrange the window layout.
  • Renk temalarını ayarlayın.Set color themes.
  • ClangFormat'ın çeşitli stilleri de dahil olmak üzere C++ biçimlendirme kurallarını belirtin.Specify C++ formatting rules, including several styles of ClangFormat.
  • Özel klavye kısayolları oluşturun.Create custom keyboard shortcuts.

Tercihlerinizi birden çok makine de senkronize edebilir, birden çok tercih kümesi oluşturabilir ve depolayabilir ve bunları takım arkadaşlarıyla paylaşabilirsiniz.You can synchronize your preferences across multiple machines, and create and store multiple sets of preferences and share them with teammates. Visual Studio Marketplace'ten uzantılar yükleyerek davranışı özelleştirmek için ek seçenekler sunabilirsiniz.You can install extensions from the Visual Studio Marketplace, giving you additional options for customizing behavior. Daha fazla bilgi için Visual Studio IDE'yi Kişiselleştir'ebakın.For more information, see Personalize the Visual Studio IDE.

Pencere düzenini düzenlemeArrange window layout

Visual Studio penceresinde, alan ana menüye, araç çubuğuna, kod düzenleyicisine (veya belge penceresine) ve araç pencerelerine (Çözüm Gezgini ve Hata Listesi gibi) ayrılır.Within the Visual Studio window, the space is divided into the main menu, the toolbar, the code editor (or document window), and tool windows (such as Solution Explorer and Error List). Bazı pencereler aynı konumda birbiriyle çakışıyor.Some windows overlap each other in the same position. Örneğin, Çözüm Gezgini, Sınıf Görünümü, Kaynak Görünümü ve Kaynak Denetim Gezgini'nin tümü aynı varsayılan konumu paylaşır.For example, Solution Explorer, Class View, Resource View, and Source Control Explorer all share the same default position. Çerçevenin altındaki sekmeleri seçerek aralarında geçiş yapabilirsiniz.You switch among them by selecting the tabs at the bottom of the frame. Bu pencerelerden iki veya daha fazlasını aynı anda görünür hale getirmek için, bunlardan birini başlık çubuğuna göre yeni bir konuma sürüklemeleri gereken bir yer.To make two or more of these windows visible at the same time, just drag one of them by its title bar to a new position. Visual Studio ana pencere kenarlıklarından birine sabitleyebilir veya yüzdürebilirsiniz.You can dock it against one of the Visual Studio main window borders, or you can float it.

Aşağıdaki ekran görüntüsü, Team Explorer penceresinin varsayılan konumundan kod düzenleyicisinin sol tarafındaki yeni, sabitlenmiş bir konuma sürüklendiğini gösterir.The following screenshot shows the Team Explorer window being dragged from its default position to a new, docked position on the left side of the code editor. Mavi gölgeli alan, fare düğmesi bırakıldığında pencerenin nereye yerleştirileceğini gösterir.The blue shaded area shows where the window will be placed when the mouse button is released.

Düzen değişikliği vurgulanmış Visual Studio Team Explorer penceresinin ekran görüntüsü

Belge penceresinde, her açık dosya sekmeli bir çerçeveiçinde bulunur.In the document window, each open file is contained in a tabbed frame. Bu sekmeleri, alet pencereleri gibi yüzdürebilir veya kilitleyebilirsiniz.You can float or lock these tabs, just like tool windows. Daha fazla bilgi için Visual Studio'daki pencere düzenlerini özelleştir'ebakın.For more information, see Customize window layouts in Visual Studio.

Tüm araç pencerelerini gizlemek ve Kod Düzenleyicisi penceresini en üst düzeye çıkarmak için, tam ekran modunudeğiştirmek için Alt + Shift + Enter tuşuna basın.To hide all the tool windows and maximize the Code Editor window, press Alt + Shift + Enter to toggle full-screen mode.

C++ kodlama stillerini ve biçimlendirmeyi ayarlamaSet C++ coding styles and formatting

Girinti ve ayraç pozisyonları gibi birçok ayrı kod biçimlendirme seçeneği belirtebilirsiniz.You can specify many individual code formatting options, such as indentation and brace positions. Bunu yapmak için Araçlar > Seçenekleri > Metin > Düzenleyicisi C/C++ > Biçimlendirme 'ne gidin (veya Ctrl + Q yazın ve "Biçimlendirme"yi arayın).To do so, go to Tools > Options > Text Editor > C/C++ > Formatting (or type Ctrl + Q and search for "Formatting"). Alternatif olarak, ClangFormat stillerinden birini (veya kendi özel ClangFormat stilinizi) belirtebilirsiniz.Alternatively, you can specify one of the ClangFormat styles (or your own custom ClangFormat style).

ClangFormat seçeneklerinin ekran görüntüsü

Tüm biçimlendirme seçenekleri hakkında daha fazla bilgi için Seçenekler, Metin Düzenleyicisi, C/C++, Biçimlendirme'yebakın.For more information about all the formatting options, see Options, Text Editor, C/C++, Formatting.

Renk tesini ayarlamaSet the color theme

Açık veya koyu arka plan ayarlamak için Ctrl + Q yazın ve "Renk Teması"nı arayın.To set a light or dark background, type Ctrl + Q and search for "Color Theme". Ayrıca Araçlar > Seçenekleri > Ortamıgiderek bu bulabilirsiniz , ve Renk Temaseçerek .You can also find these by going to Tools > Options > Environment, and choosing Color Theme.

Renk temalarının ekran görüntüsü

Örneğin, karanlık tema şunlardır:For example, here's the dark theme:

Koyu renk teonu ile Visual Studio ekran görüntüsü

Kod renklendirmeyi özelleştirmeCustomize code colorization

Visual Studio 2019'da, önceden tanımlanmış üç renk düzeniarasından seçim yapabilirsiniz.In Visual Studio 2019, you can choose from three predefined color schemes. Bunlar, kod öğelerinin düzenleyicide nasıl renklendirilebildiğini belirtir.These specify how code elements are colorized in the editor. Bir tema seçmek için Araçlar > Seçenekleri > Metin Düzenleyicisi > C/C++ > Görünümü'negidin ve Renk Düzeni'niseçin:To choose a theme, go to Tools > Options > Text Editor > C/C++ > View, and choose Color Scheme:

Gelişmiş vurgulanmış C++ Renk Düzeni seçeneklerinin ekran görüntüsü

Visual Studio 2017adı verilen renk düzeninde çoğu kod öğesi sadece siyahtır.In the color scheme called Visual Studio 2017, most code elements are simply black. Geliştirilmiş renk düzeninde işlevler, yerel değişkenler, makrolar ve diğer öğeler renklendirilir.In the Enhanced color scheme, functions, local variables, macros, and other elements are colorized. Gelişmiş (Globals vs. Üyeler) şemasında, genel işlevler ve değişkenler sınıf üyeleriyle kontrast olacak şekilde renklenir.In the Enhanced (Globals vs. Members) scheme, global functions and variables are colorized to contrast with class members. Varsayılan mod Geliştirilmiştirve şuna benzer:The default mode is Enhanced, and it looks like this:

Geliştirilmiş renk düzeninin ekran görüntüsü

Hangi tema veya renk düzeni etkin olursa olsun, yazı tipini ve renkleri tek tek kod öğeleri için özelleştirebilirsiniz.Regardless of which theme or color scheme is active, you can customize the font and colors for individual code elements. Bunu yapmak için Araçlar > Seçenekleri > Çevre > Yazı Tipleri ve Renkleri 'ne gidin (veya Ctrl + Q yazın ve "Yazı Tipleri"ni arayın).To do this, go to Tools > Options > Environment > Fonts and Colors (or type Ctrl + Q and search for "Fonts"). C++ seçeneklerini görene kadar görüntü öğeleri listesini aşağı kaydırın.Scroll down the list of display items until you see the C++ options.

C++ yazı tipi ve renk seçeneklerinin ekran görüntüsü

Burada ayarladığınız renkler, renk düzenleri için tanımlanan değerleri geçersiz kılar.Colors that you set here override the values defined for the color schemes. Renk düzeni için varsayılan renklere geri dönmek istiyorsanız, rengi Varsayılanolarak geri ayarlayın.If you want to go back to the default colors for the color scheme, set a color back to Default.

Araç çubuklarını özelleştirmeCustomize the toolbars

Araç çubukları, menüleri veya klavye kısayollarını kullanmak yerine komutları tek bir tıklamayla vermek için kullanışlı bir yol sağlar.The toolbars provide a convenient way to issue commands with a single click, rather than by using the menus or keyboard shortcuts. Visual Studio standart bir araç çubuğu kümesi içerir.Visual Studio includes a standard set of toolbars. Standart C++ geliştirme için en kullanışlı araç çubukları büyük olasılıkla Standart, Metin Düzenleyicisi, Oluşturma, Hata Ayıklama, Kaynak Denetimi ve Dosyaları Karşılaştır'dır.For standard C++ development, the most useful toolbars are probably Standard, Text Editor, Build, Debug, Source Control, and Compare Files. Windows geliştirme için, İletişim Düzenleyicisi ve Görüntü Düzenleyicisi iletişim kutuları düzenlemek ve simgeleri düzenlemek için yararlıdır.For Windows development, the Dialog Editor and Image Editor are useful for laying out dialog boxes and editing icons.

Hangi komutu temsil ettiğine görmek için araç çubuğundaki simgelerin üzerine tıklayın:Hover over the icons in the toolbar to see which command it represents:

Araç çubuğu simgelerinin ekran görüntüsü, komut bilgileri örneği havada mevcuttur

Aşağı oku seçerek komutlar ekleyebilir veya kaldırabilir veya özel bir araç çubuğu oluşturabilirsiniz.You can add or remove commands, or create a custom toolbar, by selecting the down-arrow. Araç çubuğunu yeni bir konuma taşımak için, soldaki noktalı çubuğun yanında sürükleyin.To move the toolbar to a new location, drag it by the dotted bar on the left.

Aşağı ok ve noktalı çubuğu vurgulanmış araç çubuğunun ekran görüntüsü..

Daha fazla bilgi için bkz: Visual Studio'da menüleri ve araç çubuklarını özelleştirin.For more information, see How to: Customize menus and toolbars in Visual Studio.

Satır numaralarını gösterme veya gizlemeShow or hide line numbers

Satır numaralarının düzenleyici pencerelerinin solunda gösterip göstermediğini belirtebilirsiniz.You can specify whether line numbers show on the left of the editor windows. Seçenekler'de, C/C++ altında Genel'iseçin.In Options, under C/C++, select General. Ayarlar bölümünde, tercihinize bağlı olarak Satır numaralarınıseçin veya temizleyin.In the Settings section, select or clear Line numbers, depending on your preference.

Satır numaraları vurgulanmış genel seçeneklerin ekran görüntüsü

Klavye kısayolları oluşturmaCreate keyboard shortcuts

Visual Studio'daki birçok komutta klavye kısayolları, Ctrl, Alt ve Shift tuşları ile tuş kombinasyonları vardır.Many commands in Visual Studio have keyboard shortcuts, key combinations with the Ctrl, Alt, and Shift keys. Bu klavye kısayollarını değiştirebilir veya Visual Studio'da kendi klavyelerinizi oluşturabilirsiniz.You can modify these keyboard shortcuts or create new ones of your own in Visual Studio. Araçlar > Seçenekleri > Ortam > Klavyesine gidin (veya Ctrl + Q yazın ve "kısayollar" için arama yapın).Go to Tools > Options > Environment > Keyboard (or type Ctrl + Q and search for "shortcuts"). Daha fazla bilgi için Visual Studio'da klavye kısayollarını tanımla ve özelleştir'e bakın.For more information, see Identify and customize keyboard shortcuts in Visual Studio.