Mac için Visual Studio kullanarak macOS 'ta kapsamlı bir .NET Core çözümü oluşturunBuild a complete .NET Core solution on macOS using Visual Studio for Mac

Mac için Visual Studio .NET Core uygulamaları geliştirmek için tam özellikli bir tümleşik geliştirme ortamı (IDE) sağlar.Visual Studio for Mac provides a full-featured Integrated Development Environment (IDE) for developing .NET Core applications. Bu makalede, yeniden kullanılabilir bir kitaplık ve birim testi içeren bir .NET Core çözümü oluşturma işlemi adım adım açıklanmaktadır.This article walks you through building a .NET Core solution that includes a reusable library and unit testing.

Bu öğreticide, bir arama sözcüğünü ve kullanıcıdan bir metin dizesini kabul eden bir uygulama oluşturma, bir sınıf kitaplığındaki yöntemi kullanarak arama sözcüğünün dize içinde görünme sayısını saymakta ve sonucu kullanıcıya döndürmekte olduğunuz gösterilmektedir.This tutorial shows you how to create an application that accepts a search word and a string of text from the user, counts the number of times the search word appears in the string using a method in a class library, and returns the result to the user. Çözüm, birim testi kavramlarına giriş olarak sınıf kitaplığı için birim testi de içerir.The solution also includes unit testing for the class library as an introduction to unit testing concepts. Öğreticide bir bütün örnekle devam etmek isterseniz, örnek çözümüindirin.If you prefer to proceed through the tutorial with a complete sample, download the sample solution. İndirme yönergeleri için bkz. örnekler ve öğreticiler.For download instructions, see Samples and Tutorials.

Not

Geri bildiriminiz çok değerli.Your feedback is highly valued. Mac için Visual Studio üzerinde geliştirme ekibine geri bildirimde bulunmak için kullanabileceğiniz iki yol vardır:There are two ways you can provide feedback to the development team on Visual Studio for Mac:

  • Mac için Visual Studio, menüden sorun bildirmek > Yardım ' ı veya bir hata raporu dosyalayarak bir pencere açan hoş geldiniz ekranından sorun bildir ' i seçin.In Visual Studio for Mac, select Help > Report a Problem from the menu or Report a Problem from the Welcome screen, which opens a window for filing a bug report. Geri bildiriminizi Geliştirici Topluluğu portalında izleyebilirsiniz.You can track your feedback in the Developer Community portal.
  • Bir öneride bulunmak için, yardım > menüden bir öneri sağlayın ya da size Mac için Visual Studio Geliştirici topluluğu Web sayfasınagötüren hoş geldiniz ekranından bir öneri sağlayın .To make a suggestion, select Help > Provide a Suggestion from the menu or Provide a Suggestion from the Welcome screen, which takes you to the Visual Studio for Mac Developer Community webpage.

PrerequisitesPrerequisites

Önkoşullar hakkında daha fazla bilgi için bkz. .NET Core Dependencies ve gereksinimleri.For more information on prerequisites, see the .NET Core dependencies and requirements. Mac için Visual Studio 2019 ' nin tüm sistem gereksinimleri için bkz. Mac Için Visual studio 2019 ürün ailesi sistem gereksinimleri.For the full system requirements of Visual Studio 2019 for Mac, see Visual Studio 2019 for Mac Product Family System Requirements.

Kitaplık oluşturmaBuilding a library

  1. Başlangıç penceresinde Yeni proje' yi seçin.On the start window, select New Project. .NET Core düğümü altındaki Yeni proje iletişim kutusunda .NET Standard kitaplığı şablonunu seçin.In the New Project dialog under the .NET Core node, select the .NET Standard Library template. Bu komut, .NET Core 'un yanı sıra .NET Standardsürüm 2,1 ' i destekleyen diğer .NET uygulamaları hedefleyen bir .NET Standard kitaplığı oluşturur.This command creates a .NET Standard library that targets .NET Core as well as any other .NET implementation that supports version 2.1 of the .NET Standard. .NET Core SDK yüklü birden çok sürümü varsa, kitaplığınız için .NET Standard farklı sürümlerini seçebilirsiniz.If you have multiple versions of the .NET Core SDK installed, you can choose different versions of .NET Standard for your library. ".NET Standard 2,1" öğesini seçin ve İleri ' yiseçin.Choose ".NET Standard 2.1" and select Next.

    Yeni proje iletişim kutusunu Mac için Visual Studio Visual Studio for Mac New project dialog

  2. Projeyi "TextUtils" ("metin yardımcı programları" için kısa bir ad) ve "WordCounter" çözümünü adlandırın.Name the project "TextUtils" (a short name for "Text Utilities") and the solution "WordCounter". Çözüm dizini içinde bir proje dizini oluşturma onay işaretli kalsın.Leave Create a project directory within the solution directory checked. Seçin oluşturma.Select Create.

    Yeni Mac için Visual Studio proje iletişim seçenekleriniVisual Studio for Mac New project dialog options

  3. Çözüm panelinde, Class1.csşablonu tarafından sunulan sınıf dosyasını açığa çıkarmak için TextUtils düğümünü genişletin.In the Solution pad, expand the TextUtils node to reveal the class file provided by the template, Class1.cs. CTRL-dosyaya tıklayın, bağlam menüsünden Yeniden Adlandır ' ı seçin ve dosyayı WORDCOUNT.csolarak yeniden adlandırın.Ctrl-click the file, select Rename from the context menu, and rename the file to WordCount.cs. Dosyasını açın ve içeriğini şu kodla değiştirin:Open the file and replace the contents with the following code:

    using System;
    using System.Linq;
    
    namespace TextUtils
    {
        public static class WordCount
        {
            public static int GetWordCount(string searchWord, string inputString)
            {
                // Null check these variables and determine if they have values.
                if (string.IsNullOrEmpty(searchWord) || string.IsNullOrEmpty(inputString))
                {
                    return 0;
                }
    
                // Convert the string into an array of words.
                var source = inputString.Split(new char[] { '.', '?', '!', ' ', ';', ':', ',' },
                                               StringSplitOptions.RemoveEmptyEntries);
    
                // Create the query. Use ToLowerInvariant to match uppercase/lowercase strings.   
                var matchQuery = from word in source
                                 where word.ToLowerInvariant() == searchWord.ToLowerInvariant()
                                 select word;
    
                // Count the matches, which executes the query. Return the result.
                return matchQuery.Count();
            }
        }
    }
    
  4. Üç farklı yöntemden birini kullanarak dosyayı kaydedin :+sklavye kısayolunu kullanın, menüden Dosya > Kaydet ' i seçin veya dosya sekmesine CTRL tuşunu basılı tutarak bağlam menüsünden Kaydet ' i seçin.Save the file by using any of three different methods: use the keyboard shortcut +s, select File > Save from the menu, or ctrl-click on the file's tab and select Save from the contextual menu. Aşağıdaki görüntüde IDE penceresi gösterilmektedir:The following image shows the IDE window:

    sınıf kitaplığı dosyası ve yöntemi ile Mac için Visual Studio IDE penceresi Visual Studio for Mac IDE window with class library file and method

  5. Hatalar panelini açmak için IDE penceresinin altındaki kenar boşluğunda bulunan hataları seçin.Select Errors in the margin at the bottom of the IDE window to open the Errors panel. Derleme çıkışı düğmesini seçin.Select the Build Output button.

    Hatalar düğmesini gösteren Visual Studio Mac IDE 'nin alt kenar Bottom margin of the Visual Studio Mac IDE showing the Errors button

  6. Menüden derleme > Oluştur ' u seçin.Select Build > Build All from the menu.

    Çözüm oluşturulur.The solution builds. Yapı çıktı paneli, yapılandırmanın başarılı olduğunu gösterir.The build output panel shows that the build is successful.

    Hata bölmesinin Visual Studio Mac derleme çıkış bölmesi oluşturma başarılı iletisiVisual Studio Mac Build output pane of the Errors panel with Build successful message

Test projesi oluşturmaCreating a test project

Birim testleri geliştirme ve yayımlama sırasında otomatik yazılım testi sağlar.Unit tests provide automated software testing during your development and publishing. Bu öğreticide kullandığınız test çerçevesi, xUnit test projesi aşağıdaki adımlarda çözüme eklendiğinde otomatik olarak yüklenen xUnit 'dir (sürüm 2.4.0 veya üzeri).The testing framework that you use in this tutorial is xUnit (version 2.4.0 or later), which is installed automatically when the xUnit test project is added to the solution in the following steps:

  1. Çözüm kenar çubuğunda, WordCounter çözüme CTRL tuşunu basılı ve Ekle > Yeni Proje Ekle' yi seçin.In the Solution sidebar, ctrl-click the WordCounter solution and select Add > Add New Project.

  2. Yeni proje iletişim kutusunda, .NET Core düğümünden testler ' i seçin.In the New Project dialog, select Tests from the .NET Core node. Ardından İleri' ye tıklayarak xUnit test projesini seçin.Select the xUnit Test Project followed by Next.

    Visual Studio Mac yeni proje iletişim kutusu xUnit test projesi oluşturuluyorVisual Studio Mac New Project dialog creating xUnit test project

  3. .NET Core SDK birden çok sürümüne sahipseniz, bu proje için sürümü seçmeniz gerekir.If you have multiple versions of the .NET Core SDK, you'll need to select the version for this project. .NET Core 3,1' u seçin.Select .NET Core 3.1. "TestLibrary" adlı yeni projeyi adlandırın ve Oluştur' u seçin.Name the new project "TestLibrary" and select Create.

    Visual Studio Mac proje adı sağlayan yeni proje iletişim kutusuVisual Studio Mac New Project dialog providing project name

  4. Test kitaplığının WordCount sınıfıyla çalışması için, TextUtils projesine bir başvuru ekleyin.In order for the test library to work with the WordCount class, add a reference to the TextUtils project. Çözüm kenar çubuğunda, Testlibraryaltında bulunan Bağımlılıklar ' a CTRL tuşuna tıklayın.In the Solution sidebar, ctrl-click Dependencies under TestLibrary. Bağlam menüsünden başvuruları Düzenle ' yi seçin.Select Edit References from the context menu.

  5. Başvuruları Düzenle iletişim kutusunda, Projeler sekmesinde Textutils projesini seçin. Tamam' ı seçin.In the Edit References dialog, select the TextUtils project on the Projects tab. Select OK.

    Visual Studio Mac başvuruları düzenleme iletişim kutusuVisual Studio Mac Edit References dialog

  6. Testlibrary projesinde, UnitTest1.cs dosyasını TextUtilsTests.csolarak yeniden adlandırın.In the TestLibrary project, rename the UnitTest1.cs file to TextUtilsTests.cs.

  7. Dosyasını açın ve kodu şu kodla değiştirin:Open the file and replace the code with the following code:

    using Xunit;
    using TextUtils;
    using System.Diagnostics;
    
    namespace TestLibrary
    {
        public class TextUtils_GetWordCountShould
        {
            [Fact]
            public void IgnoreCasing()
            {
                var wordCount = WordCount.GetWordCount("Jack", "Jack jack");
    
                Assert.NotEqual(2, wordCount);
            }
        }
    }
    

    Aşağıdaki görüntüde birim test kodu yerine IDE gösterilmektedir.The following image shows the IDE with the unit test code in place. Assert.NotEqual bildirimine dikkat edin.Pay attention to the Assert.NotEqual statement.

    IDE ana penceresinde Ilk birim testi Mac için Visual Studio Visual Studio for Mac Initial unit test in the IDE main window

    Test mantığının doğru olduğundan emin olmak için yeni bir testin başarısız olması önemlidir.It's important to make a new test fail once to confirm its testing logic is correct. Yöntemi "jak" (büyük harf) ve "jak" ve "jak" (büyük ve küçük harf) ile bir dize ile geçer.The method passes in the name "Jack" (uppercase) and a string with "Jack" and "jack" (uppercase and lowercase). GetWordCount yöntemi düzgün çalışıyorsa, Arama sözcüğünün iki örneğinin sayısını döndürür.If the GetWordCount method is working properly, it returns a count of two instances of the search word. Bu testi amaç doğrultusunda başarısız kılmak için, önce "jak" Arama sözcüğünün iki örneğinin GetWordCount yöntemi tarafından döndürülmeyeceğini belirten testi uygulamalısınız.In order to fail this test on purpose, you first implement the test asserting that two instances of the search word "Jack" aren't returned by the GetWordCount method. Testi amaç üzerinde başarısız kılmak için sonraki adıma geçin.Continue to the next step to fail the test on purpose.

  8. Ekranın sağ tarafındaki birim testleri panelini açın.Open the Unit Tests panel on the right side of the screen. Menüden > testlerini görüntüle ' yi seçin.Select View > Tests from the menu.

    Mac için Visual Studio birim testleri paneliVisual Studio for Mac Unit Tests panel

  9. Paneli açık tutmak için Yerleştir simgesine tıklayın.Click the Dock icon to keep the panel open. (Aşağıdaki görüntüde vurgulanır.)(Highlighted in the following image.)

    Mac için Visual Studio birim testleri bölmesi yerleştirme simgesiVisual Studio for Mac Unit Tests panel dock icon

  10. Tümünü Çalıştır düğmesine tıklayın.Click the Run All button.

    Test başarısız olur ve doğru sonuç olur.The test fails, which is the correct result. Test yöntemi, GetWordCount yöntemine sunulan "jak jakı" dizesinden inputString, "jak" öğesinin iki örneğinin döndürülmeyeceğini onaylar.The test method asserts that two instances of the inputString, "Jack," aren't returned from the string "Jack jack" provided to the GetWordCount method. Sözcük büyük harfleri GetWordCount yönteminde bir şekilde yayıldığından, iki örnek döndürülür.Since word casing was factored out in the GetWordCount method, two instances are returned. 2 ' nin 2 ' ye eşit olmadığı onay başarısız olur.The assertion that 2 is not equal to 2 fails. Bu sonuç doğru sonuçadaydır ve testimizin mantığı iyidir.This result is the correct outcome, and the logic of our test is good.

    Mac için Visual Studio test hatası görüntülemeVisual Studio for Mac test failure display

  11. IgnoreCasing test yöntemini Assert.Equal``Assert.NotEqual değiştirerek değiştirin.Modify the IgnoreCasing test method by changing Assert.NotEqual to Assert.Equal. Ctrl+sklavye kısayolunu kullanarak dosyayı kaydedin, menüden > Kaydet ' i veya dosyanın sekmesine CTRL tuşunu basılı tutarak bağlam menüsünden Kaydet ' i seçin.Save the file by using the keyboard shortcut Ctrl+s, File > Save from the menu, or ctrl-clicking on the file's tab and selecting Save from the context menu.

    searchWord "jak" inputString "jak jakı" GetWordCountgeçirilmiş iki örnek döndürdüğünü düşünüyorsunuz.You expect that the searchWord "Jack" returns two instances with inputString "Jack jack" passed into GetWordCount. Ekranın alt kısmındaki test sonuçları panelinde, birim testleri panelinde Testleri Çalıştır düğmesine veya Testleri yeniden çalıştır düğmesine tıklayarak testi yeniden çalıştırın.Run the test again by clicking the Run Tests button in the Unit Tests panel or the Rerun Tests button in the Test Results panel at the bottom of the screen. Test başarılı olur.The test passes. "Jak jakı" dizesinde iki "jak" örneği vardır (büyük/küçük harf yok sayılıyor) ve test onaylaması true.There are two instances of "Jack" in the string "Jack jack" (ignoring casing), and the test assertion is true.

    Mac için Visual Studio Testleri görüntü geçişiVisual Studio for Mac tests pass display

  12. Tek tek dönüş değerlerini bir Fact test etmek yalnızca birim testinde yapabileceklerinizin başlangıcıdır.Testing individual return values with a Fact is only the beginning of what you can do with unit testing. Başka bir güçlü teknik, Theorykullanarak birkaç değeri aynı anda test etmenizi sağlar.Another powerful technique allows you to test several values at once using a Theory. TextUtils_GetWordCountShould Sınıfınıza aşağıdaki yöntemi ekleyin.Add the following method to your TextUtils_GetWordCountShould class. Bu yöntemi ekledikten sonra sınıfında iki yöntem vardır:You have two methods in the class after you add this method:

    [Theory]
    [InlineData(0, "Ting", "Does not appear in the string.")]
    [InlineData(1, "Ting", "Ting appears once.")]
    [InlineData(2, "Ting", "Ting appears twice with Ting.")]
    public void CountInstancesCorrectly(int count,
                                        string searchWord,
                                        string inputString)
    {
        Assert.NotEqual(count, WordCount.GetWordCount(searchWord,
                                                   inputString));
    }
    

    CountInstancesCorrectly, GetWordCount yönteminin doğru şekilde sayımlarını denetler.The CountInstancesCorrectly checks that the GetWordCount method counts correctly. InlineData bir sayı, bir arama sözcüğü ve denetlenecek bir giriş dizesi sağlar.The InlineData provides a count, a search word, and an input string to check. Test yöntemi her veri satırı için bir kez çalışır.The test method runs once for each line of data. , Verilerdeki sayımların doğru olduğunu ve değerlerin GetWordCount yöntemi tarafından döndürülen sayılarla eşleştiğini bildiğiniz durumlarda bile, önce bir hatayı Assert.NotEqualkullanarak bir kez daha deneyin.Note once again that you're asserting a failure first by using Assert.NotEqual, even when you know that the counts in the data are correct and that the values match the counts returned by the GetWordCount method. Başarısız olma adımını gerçekleştirmek, ilk başta bir zaman kaybı gibi görünebilir, ancak testin mantığını başarısız olarak denetlemek öncelikle testlerin mantığına ilişkin önemli bir denetim olur.Performing the step of failing the test on purpose might seem like a waste of time at first, but checking the logic of the test by failing it first is an important check on the logic of your tests. Başarısız olması beklendiğinde geçen bir test yöntemi boyunca aldığınızda testin mantığındaki bir hata buldunuz.When you come across a test method that passes when you expect it to fail, you've found a bug in the logic of the test. Her test yöntemi oluşturduğunuzda bu adımı ele alma çabasına değecektir.It's worth the effort to take this step every time you create a test method.

  13. Dosyayı kaydedin ve testleri yeniden çalıştırın.Save the file and run the tests again. Büyük/küçük harf testi geçer, ancak üç sayma testi başarısız olur.The casing test passes but the three count tests fail. Bu sonuç, tam olarak ne olmasını beklediğiniz şeydir.This outcome is exactly what you expect to happen.

    beklenen test hatası Mac için Visual StudioVisual Studio for Mac expected test failure

  14. CountInstancesCorrectly test yöntemini Assert.Equal``Assert.NotEqual değiştirerek değiştirin.Modify the CountInstancesCorrectly test method by changing Assert.NotEqual to Assert.Equal. Dosyayı kaydedin.Save the file. Testleri yeniden çalıştırın.Run the tests again. Tüm testler geçer.All tests pass.

    beklenen test geçişleri Mac için Visual StudioVisual Studio for Mac expected test passes

Konsol uygulaması eklemeAdding a console app

  1. Çözüm kenar çubuğunda WordCounter çözüme CTRL tuşunu basılı olarak tıklayın.In the Solution sidebar, ctrl-click the WordCounter solution. .NET Core > uygulama şablonlarından şablonu seçerek yeni bir konsol uygulama projesi ekleyin.Add a new Console Application project by selecting the template from the .NET Core > App templates. İleri’yi seçin.Select Next. Projeyi Wordcounterappolarak adlandırın.Name the project WordCounterApp. Projeyi çözümde oluşturmak için Oluştur ' u seçin.Select Create to create the project in the solution.

  2. Çözümler kenar çubuğunda, CTRL + yeni wordcounterapp projesinin Bağımlılıklar düğümüne tıklayın.In the Solutions sidebar, ctrl-click the Dependencies node of the new WordCounterApp project. Başvuruları Düzenle iletişim kutusunda, textutils ' i denetleyip Tamam' ı seçin.In the Edit References dialog, check TextUtils and select OK.

  3. Program.cs dosyasını açın.Open the Program.cs file. Kodu şu kodla değiştirin:Replace the code with the following code:

    using System;
    using TextUtils;
    
    namespace WordCounterApp
    {
        class Program
        {
            static void Main(string[] args)
            {
                Console.WriteLine("Enter a search word:");
                var searchWord = Console.ReadLine();
                Console.WriteLine("Provide a string to search:");
                var inputString = Console.ReadLine();
    
                var wordCount = WordCount.GetWordCount(searchWord, inputString);
    
                var pluralChar = "s";
                if (wordCount == 1)
                {
                    pluralChar = string.Empty;
                }
    
                Console.WriteLine($"The search word {searchWord} appears " +
                                  $"{wordCount} time{pluralChar}.");
            }
        }
    }
    
  4. WordCounterApp projeye CTRL tuşunu basılı ve bağlam menüsünden projeyi Çalıştır ' ı seçin.Ctrl-click on the WordCounterApp project and select Run project from the context menu. Uygulamayı çalıştırdığınızda, konsol penceresindeki istemlerin sözcük ve giriş dizesi için değerler sağlayın.When you run the app, provide values for the search word and input string at the prompts in the console window. Uygulama, Arama sözcüğünün dizede kaç kez göründüğünü gösterir.The app indicates the number of times the search word appears in the string.

    uygulamanızı çalıştıran](./media/using-on-mac-vs-full-solution/visual-studio-mac-console-window.png) ![Mac için Visual Studio konsol penceresiVisual Studio for Mac console window showing your app running

  5. Araştırılacak son özellik Mac için Visual Studio hata ayıklaması yapılır.The last feature to explore is debugging with Visual Studio for Mac. Console.WriteLine bildiriminde bir kesme noktası ayarlayın: 23. satırın sol kenar boşluğunda seçim yapın ve kod satırının yanında kırmızı bir daire görünür.Set a breakpoint on the Console.WriteLine statement: Select in the left margin of line 23, and you see a red circle appear next to the line of code. Alternatif olarak, kod satırında herhangi bir yeri seçin ve menüden kesme noktası aç > Çalıştır ' ı seçin.Alternatively, select anywhere on the line of code and select Run > Toggle Breakpoint from the menu.

    Mac için Visual Studio kesme noktası ayarlandıVisual Studio for Mac breakpoint set

  6. WordCounterApp projesine CTRL tuşuna tıklayın.ctrl-click the WordCounterApp project. Bağlam menüsünden hata ayıklamayı Başlat ' ı seçin.Select Start Debugging Project from the context menu. Uygulama çalıştığında, "Cat" sözcüğünü ve "kedi olan köpek, ancak Cat kaçışın." ifadesini girin.When the app runs, enter the search word "cat" and "The dog chased the cat, but the cat escaped." Aranacak dizenin.for the string to search. Console.WriteLine ifadeye ulaşıldığında, deyimin yürütülmesi için program yürütme durur.When the Console.WriteLine statement is reached, program execution halts before the statement is executed. Yereller sekmesinde searchWord, inputString, wordCountve pluralChar değerlerini görebilirsiniz.In the Locals tab, you can see the searchWord, inputString, wordCount, and pluralChar values.

    Mac için Visual Studio hata ayıklayıcı program yürütme durduVisual Studio for Mac debugger program execution stopped

  7. Komut bölmesinde, "WORDCOUNT = 999;" yazın ve ENTER tuşuna basın.In the Immediate pane, type "wordCount = 999;" and press Enter. Bu komut, hata ayıklama sırasında değişken değerlerini değiştirmenizi gösteren wordCount değişkenine 999 olmayan bir değer atar.This command assigns a nonsense value of 999 to the wordCount variable showing that you can replace variable values while debugging.

    , komut penceresindeki değerleri değiştirme Mac için Visual StudioVisual Studio for Mac changing values in the immediate window

  8. Araç çubuğunda devam okuna tıklayın.In the toolbar, click the continue arrow. Konsol penceresinde çıkışa bakın.Look at the output in the console window. Uygulamada hata ayıklarken ayarladığınız 999 yanlış değerini raporlar.It reports the incorrect value of 999 that you set when you were debugging the app.

    araç çubuğunda Mac için Visual Studio devam düğmesineVisual Studio for Mac continue button in the toolbar

    Mac için Visual Studio konsol penceresi çıkışıVisual Studio for Mac console window output

Birim testi projenizi kullanarak kodda hata ayıklamak için aynı işlemi kullanabilirsiniz.You can use the same process to debug code using your unit test project. WordCount uygulama projesini başlatmak yerine, test Kitaplığı projesine CTRL tuşunu basılı ve bağlam menüsünde proje hata ayıklamayı Başlat ' ı seçin.Instead of starting the WordCount app project, ctrl-click the Test Library project, and select Start Debugging Project from the context menu. Mac için Visual Studio, test projenizi ekli hata ayıklayıcı ile başlatır.Visual Studio for Mac starts your test project with the debugger attached. Yürütme, test projesine eklediğiniz herhangi bir kesme noktasında veya temeldeki kitaplık kodunda durur.Execution will stop at any breakpoint you've added to the test project, or the underlying library code.

Ayrıca bkz.See also