Office 365'ta RPS'de GeçersizShellID hatası

Özgün KB numarası:   3090768

Belirtiler

Betik uzun süre çalışıyorsa veya Microsoft Office 365'de Uzak PowerShell'de (RPS) yönetim cmdlet'ini çalıştırıyorsanız, aralıklı olarak aşağıdakine benzer bir hata iletisi alırsınız:

Uzak komutun verileri iş tutulamadı ve şu hata iletisiyle başarısız oldu:
[ClientAccessServer=Server1,BackEndServer=Server2,RequestId=<>,TimeStamp=DateTime] [FailureCategory=WSMan-InvalidShellID] ShellId veya Windows Uzak Kabuk isteği <> , çünkü kabuk sunucuda bulunamadı. Bunun olası nedenleri: Belirtilen ShellId yanlıştır veya kabuk artık sunucuda yoktur. Doğru ShellId'yi sağlama veya yeni bir kabuk oluşturma ve işlemi yeniden deneme. Daha fazla bilgi için Yardım about_Remote_Troubleshooting bakın.

+ CategoryInfo : OperationStopped: (mail.contoso.com:String) [], PSRemotingTransportException

+ TamErrorId : JobFailure

+ PSCompgisayarAdı: posta. contoso.com

Neden

Bu sorun, aşağıdaki koşullar doğruysa ortaya çıkar:

  • Çok bölgeli bir ortamda posta hesabı etkin kullanıcıyla (MEU) ilişkilendirilmiş bir hesap kullanıyorsanız.
  • Bağlantılar, kullanıcının bölgesinden farklı bir bölge üzerinden yönlendirildi.

Bu hata, bir arka uç sunucusu yükseltilecek döndürmeden kaldırıldığı zaman oluşabilir. Buna ek olarak, bu sorun seyrek ortaya çıkar.

Çözüm

Senaryo 1 - Bir betiğin uzun çalışıyor olduğu veya otomatik iş akışının durduğu zaman

Bu senaryoda, devam eden bir sunucu döndürmeden kaldırılırsa betiği otomatik olarak yeniden bağlanmak için yeniden bağlamanız gerekir. Bunu yapmak için betikte hataları yakalamak için uygun hata işlemeyi kullanın. Sonra yeniden bağlanıp işlemleri yeniden başlatın.

Senaryo 2 - RPS'de bir yönetim cmdlet'ini çalıştırma

Bu senaryoda, cmdlet'i yeniden çalıştırmalısiniz. Farklı bir arka uç sunucusuyla bağlantı kurmalı ve sonra cmdlet başarılı bir şekilde çalıştır olmalıdır.

Not

Çok bölgeli bir Exchange Online dağıtımında, posta kutusu etkinleştirilmiş yönetim hesaplarını kullanmanızı öneririz. Böylece RPS bağlantıları geçerli ortamdan yapılır. Yönetim hesabı bir MEU ile ilişkilendirilmişse, bağlantılar diğer bölge üzerinden yönlendirilebilirsiniz. Bu davranış bağlantıda gecikmeye neden olabilir veya hataları tetikler.

Microsoft, bu sorunu araştırmak için bir Fiddler izlemesi gerekli olabilir. Bu gerekli olursa, bir destek mühendisi bu bilgileri güvenli bir şekilde yakalamak ve karşıya yüklemek için bir Destek Tanılama Paketi gönderir. Bu bilgileri Fiddler izlemesinde yakalamak için, IEConfig parametresi ayarlanmış bir PowerShell ProxyAccessType oturum seçeneği ekle o gerekir. Örneğin:

Import-PSSession (New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://mail.contoso.com/powershell -Credential (Get-Credential) -Authentication Basic -AllowRedirection -SessionOption (New-PSSessionOption -ProxyAccessType IEConfig))

Daha fazla bilgi

Hata işleme hakkında daha fazla bilgi için bkz. Hafta Sonu Komut Dosyası: Dene, Yakala, Son olarak PowerShell hata işlemesi için blokları kullanma.