Etkin olmayan posta kutusu şirket içi Active Directory hesabına otomatik olarak yeniden bağlanmaz

Özgün KB numarası:   4337973

Belirtiler

Şirket içi Active Directory hesabınız Azure AD Bağlan kapsamına geri getirilirse, etkin olmayan posta kutunuz Exchange Online'te otomatik olarak yeniden Exchange Online. Ayrıca, posta kutusunda yeni sağlanan bir posta Exchange Online.

Not

Özel Microsoft Office 365/ITAR müşterileri için, Microsoft Yönetilen Hizmetler Hizmet Sağlama Sağlayıcısı (MMSSPP) birlikte çalışma aşamasında özel ortamdan müşterinin şirket içi msExchMailboxGUID Active Directory'sinde geri ExchangeGUID yazar. Posta hesabıyla yeni sağlanan bir posta Exchange Online, posta özelliği etkin kullanıcı oluşturulur.

Neden

Posta kutusu nesneleri Azure AD Posta Kutusu'nun Bağlan, Azure AD Geri Dönüşüm Kutusu'na 30 gün boyunca kalır. Hesap Geri Dönüşüm Kutusu'na temizlir olduğunda, şirket içi AD hesabını etkin olmayan bir posta kutusuyla yeniden bağlanmak için ek adımlar atabilirsiniz.

Çözüm

Bu sorunu çözmek için aşağıdaki işlemleri kullanın.

Özgün posta kutusundan içeriği aktarma

New-MailboxRestoreRequest cmdlet'ini kullanarak etkin olmayan posta kutusundan yeni sağlanan posta kutusuna içeriği geri yükleme. Böylece yeni posta kutusunu kullanmaya ve özgün içeriği kopyalamaya devam edersiniz.

Etkin olmayan özgün posta kutusunu yeniden bağlama

Not

Bu işlem, yeni bir şirket içi AD hesabına bağlanıyorsa, yumuşak silinmiş posta kutuları için de çalışır. Parametrenin SoftDeletedMailbox yerini alacak parametre InactiveMailboxOnly kullanılmalıdır.

  1. Exchange Online PowerShell'den etkin olmayan posta kutusu özniteliklerini almak Exchange Online çalıştırın:

    $InactiveMailbox = Get-Mailbox -InactiveMailboxOnly -Identity <identity of inactive mailbox>
    
  2. Etkin olmayan posta kutusunu geçici olarak bir bulut hesabıyla ilişkilendirmek için aşağıdaki komutu çalıştırın:

    New-Mailbox -InactiveMailbox $InactiveMailbox.DistinguishedName -Name "<name of inactive mailbox>" -DisplayName "<DisplayName of inactive mailbox>" -MicrosoftOnlineServicesID <alias@*.onmicrosoft.com> -Password (ConvertTo-SecureString -String <PasswordString> -AsPlainText -Force) -ResetPasswordOnNextLogon $true
    
  3. Bağlan PowerShell Azure Active Directory'ne sahip oldu ve özniteliği almak için aşağıdaki komutu ObjectGUID çalıştırın:

     Get-ADUser -Identity <ADUser> -Properties "ObjectGUID"
    
  4. Varsayılan ImmutableID olarak şirket içi özniteliği olan parametre ObjectGUID değerini alın. ObjectGUIDE-postada ImmutableID aşağıdaki komutu kullanarak Windows PowerShell:

    [system.convert]::ToBase64String(([GUID]"<ObjectGUID>").tobytearray())
    
  5. Azure ImmutableID AD'de parametreyi ayarlayın:

    Set-MsolUser -UserPrincipalName <UPN> -ImmutableId <ImmutableId>
    
  6. Azure AD eşitlemeyi Bağlan çalıştırın. Bu işlem, özgün Azure AD hesabını Azure AD projelerinin kapsamına Bağlan.

  7. Posta kutusu nesnesini denetleyin ve birincil SMTP adresinin geçici kullanıcı asıl adı (UPN) değerinden doğru birincil adrese güncelleştirilmiş olduğunu doğrulayın.

    Not

    Yeni posta kutusu Mahkeme Tutma için etkinleştirilmedi. Ayrıca, aşağıdaki uyarı iletisini de alırsınız:
    UYARI: Etkin olmayan posta kutusu kurtarıldı. Geçerli bir lisans elde edilene kadar verileri korumak için Tek Öğe Kurtarma'ya 30 gün boyunca izin sağladık. Ayrıca 30 gün boyunca Bekletme bekletmeyi de etkinleştirdikten sonra kullanabiliriz. Bu posta kutusu için geçerli bir lisans atandıktan sonra, bu ayarları devre dışı bırakmayı ve verileri korumak için bunun yerine Mahkeme In-Place'i kullanmayı tercih edebilirsiniz.

  8. Yeni Exchange Server posta kutusuna posta kutusu lisansını ve uygun tutma ayarlarını uygulama.

Daha fazla bilgi

Çözüm bölümündeki adımlar, Çözüm bölümünde etkin olmayan posta kutusunu geri yükleme bölümünde verilen bulut posta kutusu yönergelerinden Office 365.

Yine de yardım mı gerekiyor? Microsoft Community web sitesine gidin.